Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Enabling "Monitor Power Saver" features HOWTO
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
BarryMead
n00b
n00b


Joined: 26 Jun 2004
Posts: 5

PostPosted: Sat Jun 26, 2004 8:36 am    Post subject: Enabling "Monitor Power Saver" features HOWTO Reply with quote

Many distros already have "Monitor Power Saver" features enabled by default. Gentoo linux does not. So this it how you do it.

1. Edit the /etc/modules.autoload.d/kernel-2.X file (where X is 4 or 6) and add the line:
apm
This will cause the Automatic Power Management kernel module to load at boot time. Alternatively (if you didn't use genkernel) you can enable APM in the kernel config and have it permanently compiled into your kernel.

2. emerge apmd

3. rc-update add apmd default

4. edit the file /etc/conf.d/apmd and remove the "proxy-timeout 30" clause from the line in that file. (This option does not work at least in the 2.4 kernel it does not work. I haven't tried the 2.6 kernel)

5. Edit the /etc/X11/XF86Config file and add the line:
Option "DPMS"
in the device section right below the Driver "nvidia" line. Note your video card's driver may be different.

6. Reboot and watch the bootup text for the loading of the "apm" kernel module and the "apmd" daemon.

7. Assuming yor window manger is KDE go into the "K" button, "Settings" selector, "Control Center" selector. Expand the "Power Control" plus sign and select "Display Power Control".

8. Check the check box marked "Enable Display Power Management".

9. Slide the Sliders for "Standby", "Suspend", or "Power Off" to the desired times and click the "Apply" button.
:D
That's It! You now have automatic power down control for your monitor.


Last edited by BarryMead on Sat Jun 26, 2004 11:22 am; edited 2 times in total
Back to top
View user's profile Send private message
Shan
Guru
Guru


Joined: 04 Nov 2003
Posts: 558
Location: /dev/null

PostPosted: Sat Jun 26, 2004 10:28 am    Post subject: Reply with quote

What about those of us not using KDE? Are Gnome, [Flux|Black|Open]box, enlightenment and FVWM (and any others I've missed) left in the dark?

Not meaning to pick at you but I'm curious if this is a KDE only thing or not.
_________________
{ NO -U } { STRIP }
{ TINY }
Back to top
View user's profile Send private message
jbpros
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2004
Posts: 133
Location: Brussels, Belgium

PostPosted: Sat Jun 26, 2004 10:58 am    Post subject: Reply with quote

Maybe you should add the word "howto" in your post's subject, a good keyword for people seraching the forums :D
Back to top
View user's profile Send private message
scoon
l33t
l33t


Joined: 23 Aug 2003
Posts: 747
Location: Philadelphia, PA

PostPosted: Sat Jun 26, 2004 11:43 am    Post subject: Reply with quote

Shan wrote:
What about those of us not using KDE? Are Gnome, [Flux|Black|Open]box, enlightenment and FVWM (and any others I've missed) left in the dark?

Not meaning to pick at you but I'm curious if this is a KDE only thing or not.


Hey there,

I run openbox and NO, we are not left in the dark. Open up a shell and type: xscreensaver-demo and click the Advanced tab.

scoon
_________________
Hope this helps........
Back to top
View user's profile Send private message
stahlsau
Guru
Guru


Joined: 09 Jan 2004
Posts: 582
Location: WildWestwoods

PostPosted: Sat Jun 26, 2004 12:17 pm    Post subject: Reply with quote

Quote:
Hey there,

I run openbox and NO, we are not left in the dark. Open up a shell and type: xscreensaver-demo and click the Advanced tab.

scoon

well, this relies on having xscreensaver installed.
But you can configure monitor-powersaving in your xfree86config or xorg.conf. Just search the forums for "monitor power saving", there is at least one thread about howto realize that.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18159

PostPosted: Sat Jun 26, 2004 5:22 pm    Post subject: Reply with quote

Moved from Installing Gentoo.
_________________
Those who know what's best for us must rise and save us from ourselves.
Back to top
View user's profile Send private message
vdboor
Guru
Guru


Joined: 03 Dec 2003
Posts: 592
Location: The Netherlands

PostPosted: Sat Jun 26, 2004 8:26 pm    Post subject: Reply with quote

Shan wrote:
What about those of us not using KDE? Are Gnome, [Flux|Black|Open]box, enlightenment and FVWM (and any others I've missed) left in the dark?

Not meaning to pick at you but I'm curious if this is a KDE only thing or not.


Add this to your serverflags section of your X11 config (XF86Config / xorg.conf):

Code:
   Option      "standby time"  "15"     # DPMS (enabled per screen/monitor)
   Option      "suspend time"  "20"
   Option      "off time"      "30"   


;)
_________________
The best way to accelerate a windows server is by 9.81M/S²
Linux user #311670 and Yet Another Perl Programmer

[ screenies | Coding on KMess ]
Back to top
View user's profile Send private message
Monkeywrench
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: Florida

PostPosted: Sat Jun 26, 2004 8:41 pm    Post subject: Reply with quote

It seems like this all only works in X? Even without X, the backlight is still on, right? :oops:
_________________
Folding@home -Join the Linux team (163)!
Back to top
View user's profile Send private message
BlindSpy
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 263

PostPosted: Sun Jun 27, 2004 6:25 am    Post subject: Reply with quote

Monkeywrench wrote:
It seems like this all only works in X? Even without X, the backlight is still on, right? :oops:


thats how it is for me.
_________________
Symlinks to:
xorg.conf
Back to top
View user's profile Send private message
amittp
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2002
Posts: 123
Location: USA

PostPosted: Sun Jun 27, 2004 2:03 pm    Post subject: Reply with quote

The standby time and offtimes are written in Camel notations unlime shown with space before. (unless there is change in xorg which I dunno )
Code:

Section "ServerFlags"

    Option "StandbyTime" "15"
    Option "SuspendTime" "20"
    Option "OffTime" "30"
    Option "Dont Zoom"


EndSection


AND dpms goes here.

Code:

Section "Device"
    Identifier  "9180SE"
    Driver      "nvidia"
    Option      "DigitalVibrance" "150"
    Option      "CursorShadow"  "on"
    Option      "NoLogo"        "on"
    Option      "NvAgp"         "3"
    Option      "RenderAccel"   "on"
    Option      "IgnoreDisplayDevices" "DFP, TV"
    Option      "ConnectedMonitor"      "CRT"
    Option      "DPMS"


    #VideoRam    65536
    # Insert Clocks lines here if appropriate
EndSection

_________________
Believe in yourself
Back to top
View user's profile Send private message
Shan
Guru
Guru


Joined: 04 Nov 2003
Posts: 558
Location: /dev/null

PostPosted: Sun Jun 27, 2004 11:31 pm    Post subject: Reply with quote

Stupid question, whats "no zoom" do? Presumably it "doesn't zoom" but I've never had a case of it zooming before 0.o
_________________
{ NO -U } { STRIP }
{ TINY }
Back to top
View user's profile Send private message
Monkeywrench
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: Florida

PostPosted: Mon Jun 28, 2004 6:27 am    Post subject: Reply with quote

Shan wrote:
Stupid question, whats "no zoom" do? Presumably it "doesn't zoom" but I've never had a case of it zooming before 0.o


Code:
# Uncomment this to disable the <Crtl><Alt><KP_+>/<KP_-> mode switching
# sequences.  This allows clients to receive these key events.

#    Option "Dont Zoom"


from /etc/X11/xorg.conf

The key sequence changes my resolution.
_________________
Folding@home -Join the Linux team (163)!
Back to top
View user's profile Send private message
Shan
Guru
Guru


Joined: 04 Nov 2003
Posts: 558
Location: /dev/null

PostPosted: Mon Jun 28, 2004 8:01 am    Post subject: Reply with quote

Monkeywrench wrote:
Shan wrote:
Stupid question, whats "no zoom" do? Presumably it "doesn't zoom" but I've never had a case of it zooming before 0.o


Code:
# Uncomment this to disable the <Crtl><Alt><KP_+>/<KP_-> mode switching
# sequences.  This allows clients to receive these key events.

#    Option "Dont Zoom"


from /etc/X11/xorg.conf

The key sequence changes my resolution.



Oooooooh, so its not really 'zooming' just resolution changing eh? I was a naughty boy when I upgraded to X.Org, I just renamed my XF86Config file and tweaked it a bit, so I didn't get some of the new commenting. Guess this'll teach me :-D
_________________
{ NO -U } { STRIP }
{ TINY }
Back to top
View user's profile Send private message
WackyDoo
n00b
n00b


Joined: 16 Mar 2004
Posts: 44
Location: Ottawa

PostPosted: Mon Jun 28, 2004 1:34 pm    Post subject: Reply with quote

Shan wrote:
What about those of us not using KDE? Are Gnome, [Flux|Black|Open]box, enlightenment and FVWM (and any others I've missed) left in the dark?

Not meaning to pick at you but I'm curious if this is a KDE only thing or not.


You can always use the xset program if your window manager/desktop environment doesn't allow you to manipulated these settings. Do a
Code:
man xset
and look for the DPMS settings. You still need the DPMS option to be enabled in your XFree or Xorg configuration file.
Back to top
View user's profile Send private message
Monkeywrench
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: Florida

PostPosted: Mon Jun 28, 2004 8:38 pm    Post subject: Reply with quote

Shan wrote:
Monkeywrench wrote:
Shan wrote:
Stupid question, whats "no zoom" do? Presumably it "doesn't zoom" but I've never had a case of it zooming before 0.o


Code:
# Uncomment this to disable the <Crtl><Alt><KP_+>/<KP_-> mode switching
# sequences.  This allows clients to receive these key events.

#    Option "Dont Zoom"


from /etc/X11/xorg.conf

The key sequence changes my resolution.



Oooooooh, so its not really 'zooming' just resolution changing eh? I was a naughty boy when I upgraded to X.Org, I just renamed my XF86Config file and tweaked it a bit, so I didn't get some of the new commenting. Guess this'll teach me :-D

Erm... I'm pretty positive that it's in the XF86Config file as well.. :oops:
_________________
Folding@home -Join the Linux team (163)!
Back to top
View user's profile Send private message
Shan
Guru
Guru


Joined: 04 Nov 2003
Posts: 558
Location: /dev/null

PostPosted: Mon Jun 28, 2004 9:51 pm    Post subject: Reply with quote

Monkeywrench wrote:
Shan wrote:
Monkeywrench wrote:
Shan wrote:
Stupid question, whats "no zoom" do? Presumably it "doesn't zoom" but I've never had a case of it zooming before 0.o


Code:
# Uncomment this to disable the <Crtl><Alt><KP_+>/<KP_-> mode switching
# sequences.  This allows clients to receive these key events.

#    Option "Dont Zoom"


from /etc/X11/xorg.conf

The key sequence changes my resolution.



Oooooooh, so its not really 'zooming' just resolution changing eh? I was a naughty boy when I upgraded to X.Org, I just renamed my XF86Config file and tweaked it a bit, so I didn't get some of the new commenting. Guess this'll teach me :-D

Erm... I'm pretty positive that it's in the XF86Config file as well.. :oops:


Mine had the Nozoom option commented out, but it didn't have any accompanying comment text explaining what it did. This was off of an XFree build I did about 2 months ago. Things could have changed between then and a week or so ago when I changed over to X.Org
_________________
{ NO -U } { STRIP }
{ TINY }
Back to top
View user's profile Send private message
Vidar
Apprentice
Apprentice


Joined: 09 Apr 2003
Posts: 239
Location: Washington, USA

PostPosted: Mon Jun 28, 2004 10:05 pm    Post subject: Reply with quote

I'm stuck... Is this not suppsed to work with acpi?

My kernel dmesg:
Quote:
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: overridden by ACPI.


edit: which of course leads to apmd not starting saying apm support isn't in kernel.

And the important part of my xorg log:
Quote:
(==) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "StandbyTime" "10"
(**) Option "SuspendTime" "12"
(**) Option "OffTime" "15"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)


The obvious solution would be to dump acpi, but is that really the only way?
_________________
"Vidar, Odin's mighty son, he will come to slay the wolf
The sword runs into the heart of Hverdrungs son
So he avenges his father" -- Amon Amarth - Burning Creation
Back to top
View user's profile Send private message
Monkeywrench
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: Florida

PostPosted: Tue Jun 29, 2004 8:07 am    Post subject: Reply with quote

vidar: as far as I know, ACPI is newer and superior to APM. Do you have both enabled? If so, I'd probably disable APM :oops:
_________________
Folding@home -Join the Linux team (163)!
Back to top
View user's profile Send private message
Vidar
Apprentice
Apprentice


Joined: 09 Apr 2003
Posts: 239
Location: Washington, USA

PostPosted: Tue Jun 29, 2004 8:15 am    Post subject: Reply with quote

Yeah, it seems to work anyway. The original post and my xorg log seems to suggest that it specificially wants apm though. Pretty spiffy though... my monitor used to really heat up.
_________________
"Vidar, Odin's mighty son, he will come to slay the wolf
The sword runs into the heart of Hverdrungs son
So he avenges his father" -- Amon Amarth - Burning Creation
Back to top
View user's profile Send private message
DaveAtFraud
n00b
n00b


Joined: 20 Jun 2004
Posts: 13
Location: Parker, Colorado USA

PostPosted: Fri Jul 09, 2004 12:55 pm    Post subject: Data Point Reply with quote

I finally got the monitor for my box to power down automagically through xscreensaver. The system is a dual Athlon so APM is unusable and I can only use ACPI. It seems that for ACPI you just need to have the Option = "DPMS" lines in XF86config. The "(WW) Open APM failed (/dev/apm_bios) (No such file or directory)" complaint is still there (correctly) but the monitor now powers down.

BTW, it appears that the Option = "DPMS" can be given to both the monitor and the video card sections of XF86config. I'd guess that having it in both allows the system to actually use DPMS to power down the monitor rather than just no longer sending a video signal but that's way below the level I want to try to figure out how this all works.
_________________
When buying and selling are controlled by legislation, the first things bought and sold are the legislators.
-- P.J. O'Rourke
Back to top
View user's profile Send private message
dmitrio
Tux's lil' helper
Tux's lil' helper


Joined: 10 Dec 2002
Posts: 115
Location: Pago Pago

PostPosted: Wed Jul 21, 2004 12:06 pm    Post subject: :. copied to gentoo-wiki.com Reply with quote

I have copied this HOWTO, with permission of BarryMead, amittp and scoon to gentoo-wiki.com
http://gentoo-wiki.com/HOWTO_Enabling_Monitor_Power_Saver
If you see anything that should be added or changed, feel free to do so.

Thank you for a great HOWTO.
_________________

... Leaving ground, destination is unknown,
into the darkness and far away from home,
Will your dream come true and what will you find,
when fate is your guide ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum