Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Lokalisatie met Qwerty toetsenbord
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
jo_vermeulen
n00b
n00b


Joined: 21 Aug 2003
Posts: 64

PostPosted: Sun Jun 27, 2004 4:15 pm    Post subject: Lokalisatie met Qwerty toetsenbord Reply with quote

Hallo,

Ik ben een Belg, maar gebruik een Qwerty-toetsenbord omdat dat handiger is bij het programmeren, bij een Azerty keyboard kan ik moeilijk aan tekens als # @ [] {} ' " enz.. Nu wil ik natuurlijk wel leestekens kunnen gebruiken (bv. trema ("), accent circonflex (^), accent aigu ('), accent grave (`), ...

Ik heb geprobeerd de Gentoo lokalisatie gids te volgen. Zij zetten hun LANG variabele echter op nl_BE@euro of nl_NL@euro. Nu wil ik graag UTF8 gebruiken, dus staat mijn LANG variabele op nl_BE.UTF8.

Als Keymap heb ik al "nl" en "us_intl" geprobeerd, maar die blijken ook niet te werken. Als ik nu bv. een dubbele quote typ ("), dan verschijnt die meteen, terwijl die met internationale qwerty pas verschijnt na twee keer, wat je de mogelijkheid geeft om eerst bv. een 'e' te typen en dan de quotes, waardoor het een trema wordt.

Iemand een idee hoe ik dit kan oplossen?

Groetjes,
_________________
Jo Vermeulen
Student Computer Science at the tUL
email: jo@lumumba.luc.ac.be
www: http://lumumba.luc.ac.be/jo
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Mon Jun 28, 2004 5:07 pm    Post subject: Reply with quote

Zulke vragen heb ik hier ook al eens gesteld. Je kan zelf een keymap maken, maar ok ik heb het probleem nog niet helemaal opgelost. Ik geloof wel dat er iemand mee bezig is. Als je misschien even wacht is er een mini-howto klaar.
Back to top
View user's profile Send private message
toMeloos
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jul 2003
Posts: 101
Location: The Netherlands

PostPosted: Thu Jul 01, 2004 8:38 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic.php?t=184053

voila. daar staat al een hoop in over lokalisatie. keymap dingen ben ik nog niet aan toe gekomen....
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Thu Jul 08, 2004 9:15 pm    Post subject: Reply with quote

Het was eerst niet mijn bedoeling van zelf een mini-howto te schrijven, maar heb er nu toch een gemaakt :? : https://forums.gentoo.org/viewtopic.php?t=195564

Ik hoop dat dit mensen zoals jij kan helpen.
Nu ik eraan denk: er zijn er eigenlijk veel te weinig. Meer Vlamingen zouden moeten gaan werken met qwerty vind ik! Veel handiger! In de eerste plaats heb je sowieso al altijd standaard ondersteuning wegens QWERTY en US (meestal al de symbolen die op je toetsen staan). De rest heb je hier nu ook mee.
Back to top
View user's profile Send private message
bertvv
n00b
n00b


Joined: 15 Jun 2003
Posts: 46
Location: Pamel, Flanders

PostPosted: Tue Jul 20, 2004 8:26 am    Post subject: Reply with quote

Ik gebruik de en_US (V.S. Engels met ISO9995-3) toetsenbordindeling. Deze indeling is bij uitstek geschikt voor internationaal gebruik. De meeste lettertekens die gebruikt worden in Westeuropese talen zijn zo gemakkelijk beschikbaar, i.h.b. als je een toetsenbord met Windows-toetsen hebt. Toegang tot accenttekens krijg je met de rechter-windowstoets (RWIN). Bijvoorbeeld: het teken é krijg je met toetsenbordcombinatie RWIN+' e; ö met RWIN+" o, enz. Ik vind dit een stuk aangenamer werken dan de "deadkeys" van us_intl.

De rechter-alt-toets doet dan iets gelijkaardigs als de Alt-Gr op Azerty-toetsenborden. ALT+o geeft ø, ALT+s wordt ß, enz. Je kan evt. de Scroll-lock toets gebruiken om aan te geven dat de alternatieve groep is ingeschakeld met
Code:
setxkbmap -option grp_led:scroll


Het euro-teken zit er niet in, maar die kan je krijgen door in je ~/.Xmodmap bestand de volgende lijn toe te voegen:
Code:
keycode 26 = e E EuroSign

Opmerking hierbij: Als je KDE gebruikt en toetsenbordindelingen zijn ingeschakeld, dan wordt deze instelling gewist bij het overgaan naar een andere indeling. Door het volgende in je ~/.bashrc te zetten wordt dit opgelost:
Code:
# Euro sign support
xmodmap -e 'keycode 26 = e E EuroSign'

_________________
If Bill Gates had a penny for each time Windows crashed...
Wait a minute! He does!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum