Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nVidia and keyboard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Brennos
n00b
n00b


Joined: 25 Jun 2004
Posts: 43
Location: Belgium

PostPosted: Tue Jun 29, 2004 12:02 pm    Post subject: nVidia and keyboard Reply with quote

I have Gentoo running on my G4 at last (kernel 2.6.7) and I was configuring Xorg. Ran the automatic configure and started X, all I got was a black screen. I searched the forum and found out I had to install nvidia-kernel and nvidia-glx because I have a GeForce 2 MX.
Tried to emerge those 2, alas they're masked. I forced them to install (by entering the full path) which gave me the error that I should enable MTRR in Processor Type and Features. This beats me, I can't find it!

My second problem is, I loaded the us keymap (in i386), it works very good, but I can't get a tilde. I'm using a standard qwerty USB keyboard which came with the computer. Instead of a ~ I get a <.
Beats me again ...
Back to top
View user's profile Send private message
JudgeNik
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2004
Posts: 86
Location: Bolzano, Italy

PostPosted: Tue Jun 29, 2004 1:25 pm    Post subject: Reply with quote

Guessing PPC would be similar to the x86 way of skipping masks
Code:
ACCEPT_KEYWORDS="~PPC" emerge -av nvidia-kernel


Another thing if you would rather avoid the hassle nvidia drivers can cause go into xorg.conf and hit ctrl-w and type "nv"

you should see something like:

Code:
Driver   "nvidia"


to use the generic nvidia opensource drivers change that to:

Code:
Driver    "nv"


I hope this works on PPC aswell.
_________________
See the famous Niko Roberts at http://www.nikoroberts.com
Back to top
View user's profile Send private message
Brennos
n00b
n00b


Joined: 25 Jun 2004
Posts: 43
Location: Belgium

PostPosted: Tue Jun 29, 2004 1:54 pm    Post subject: Reply with quote

Thx, that worked great! I'm typing this with Konquerer! Gentoo rules!
Except for the tilde thing, I can't figure out what could be wrong ...
Back to top
View user's profile Send private message
jaspal kallar
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 194
Location: Sweden

PostPosted: Tue Jun 29, 2004 3:28 pm    Post subject: Reply with quote

Code:
Section "InputDevice"
  Driver       "Keyboard"
  Identifier   "Keyboard[0]"
  Option       "MapName" "Standard Keyboard [ pc104 ]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "se"
  #Option       "XkbModel" "pc104"
  Option       "XkbModel" "pc105"
  Option       "XkbRules" "xfree86"
EndSection


Try changing perhaps in your xorg.conf to the above "XkbModel" i.e change to
Code:
Option       "XkbModel" "pc105"
Back to top
View user's profile Send private message
Brennos
n00b
n00b


Joined: 25 Jun 2004
Posts: 43
Location: Belgium

PostPosted: Sat Jul 03, 2004 12:33 pm    Post subject: Reply with quote

I tried both, pc104 and pc105, none of them is working ...
Back to top
View user's profile Send private message
pindar
Apprentice
Apprentice


Joined: 30 Apr 2004
Posts: 220

PostPosted: Sat Jul 03, 2004 3:27 pm    Post subject: Reply with quote

Re the keyboard problem: given that you're located in Belgium, I assume you have a European keyboard. In my case, with the PC 104 enabled, the tilde is on the key situated beneath the escape-key: unshifted, it gives `, with shift, ~. If you want to change that, you'll have to modify the keymap. It's not hard, but takes several steps. HTH
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum