Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iBook problems video and / or sleeping
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
kingmoffa
n00b
n00b


Joined: 08 Dec 2003
Posts: 22
Location: Lowestoft , England.

PostPosted: Tue Jun 29, 2004 8:36 pm    Post subject: iBook problems video and / or sleeping Reply with quote

Hello all,

Been having some problems with my iBook (G3 900).


I have been using the new xorg X-server (i think) rather than xfree. As it takes sooooo long to compile, I would like to stick with this. I have a working x config


Most of the kernels I try (all 2.6), give me problems with video. I have a radeon 7500 and have tried using the xfree radeon module. Usually X starts but the display becomes destored and looks like it is bleeding color. (Nice effect if it was a screensave!). It locks up the keyboard and mouse, and not having another machine at home I cannot get in via SSH (if it is still running).

However, I have a come across a bitkeeper kernel (i think) where I have sorted the video , but the iBook will not sleep. Pressing the power button , closing the lid or waiting until it shutsdown via pbbuttons just locks the machine up. And in addition dmsg is full of:

evbug.c: Event. Dev: adb2:2.c4/input, Type: 1, Code: 15, Value: 0
evbug.c: Event. Dev: adb2:2.c4/input, Type: 0, Code: 0, Value: 0
evbug.c: Event. Dev: adb2:2.c4/input, Type: 1, Code: 28, Value: 1
evbug.c: Event. Dev: adb2:2.c4/input, Type: 0, Code: 0, Value: 0

with nothing else in there at all (it must have overwritten everything else).

If anyone could shed light on the above , or point me in the right direction for a suitable 2.6 kernel I would be grateful.
Back to top
View user's profile Send private message
servobf
Apprentice
Apprentice


Joined: 03 Jun 2004
Posts: 160

PostPosted: Wed Jun 30, 2004 4:17 am    Post subject: pbbuttonsd Reply with quote

Have you emerged pbbuttonsd? I think that even though the kernel suports sleep and what-not, it still needs to know when to do it. I had it working right before I emerged a new kernel... :-)

good luck!

~Michael
Back to top
View user's profile Send private message
Immortal Q
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 241
Location: Silicone Valley

PostPosted: Wed Jun 30, 2004 4:46 am    Post subject: Reply with quote

The evbug.c is caused by a parameter in your kernel config - look though your .config and make sure all DEBUG options are off. This will allow you to get something useful out of dmesg (and /var/log/messages, if applicable).
_________________
Osmos.org
Now with 20% fewer rabid primates.
Back to top
View user's profile Send private message
woolsherpahat
Guru
Guru


Joined: 09 Mar 2004
Posts: 347

PostPosted: Wed Jun 30, 2004 7:21 am    Post subject: Reply with quote

I believe the exact option your looking to turn off is event debugging.
Back to top
View user's profile Send private message
kingmoffa
n00b
n00b


Joined: 08 Dec 2003
Posts: 22
Location: Lowestoft , England.

PostPosted: Wed Jun 30, 2004 9:19 am    Post subject: Reply with quote

Yeah pbbuttonsd is emerged and added to default run level. I set it up using powerprefs.

About the debug option in the kernel, seems like a good idea. Will post some more feedback later.
Back to top
View user's profile Send private message
servobf
Apprentice
Apprentice


Joined: 03 Jun 2004
Posts: 160

PostPosted: Wed Jun 30, 2004 3:13 pm    Post subject: pbbuttonsd...one more possibility Reply with quote

One thing I forgot to mention...pbbuttonsd, even if loaded to start initially, may not, if there are problems. I had mine set to start, but it wouldn't because of my alsa setup - pbbuttonsd wanted /dev/mixer, but alsa only made /dev/sound/mixer. If the debugging thing doesn't work, try starting pbbuttonsd manually, and see if it will start.
Back to top
View user's profile Send private message
kingmoffa
n00b
n00b


Joined: 08 Dec 2003
Posts: 22
Location: Lowestoft , England.

PostPosted: Mon Jul 05, 2004 3:30 pm    Post subject: Reply with quote

please excuse the stupidity,

but does anyone know exactly what kernel config options to turn off to stop the horrible debug messages above??

I have tried make menuconfig and not found anything, and searching my .config for debug or event yields little result. (i have not found an appropriate option to turn off).

Thanks
Back to top
View user's profile Send private message
Immortal Q
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 241
Location: Silicone Valley

PostPosted: Mon Jul 05, 2004 7:13 pm    Post subject: Reply with quote

I keep browsing these forums when I'm in OSX. Bah. Anyway - if you do "make menuconfig", I believe you can find the relevant option(s) under Device Drivers -> Input Devices. Usually right next to "event interface", another option I usually skip.
_________________
Osmos.org
Now with 20% fewer rabid primates.
Back to top
View user's profile Send private message
kambroff
n00b
n00b


Joined: 06 Jul 2004
Posts: 6
Location: Cameron Park, CA

PostPosted: Thu Jul 08, 2004 4:40 pm    Post subject: Reply with quote

The correct kernel option for event debugging is ...

Code:
# CONFIG_INPUT_EVBUG is not set


If you use menuconfig, it is under
Device Drivers => Input Device Support => Event Debugging <>
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum