Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installing java
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Brennos
n00b
n00b


Joined: 25 Jun 2004
Posts: 43
Location: Belgium

PostPosted: Tue Jul 06, 2004 9:15 am    Post subject: installing java Reply with quote

I downloaded j2re-1_4_2_04-linux-i586.bin, put it in /usr/portage/distfiles and tried to emerged. What failed with this error:

>>> Unpacking source...
/usr/sbin/ebuild.sh: line 50: ./install.sfx: cannot execute binary file

!!! ERROR: dev-java/sun-jre-bin-1.4.2.04 failed.
!!! Function src_unpack, Line 50, Exitcode 126
!!! (no error message)

Can somebody help me with this?
Back to top
View user's profile Send private message
ralph
Advocate
Advocate


Joined: 02 Mar 2003
Posts: 2001
Location: Hamburg

PostPosted: Tue Jul 06, 2004 9:21 am    Post subject: Reply with quote

You tried to install a java version that is compiled for x86, so it won't run on ppc.

emerge ibm-jre-bin should give you a ppc java version, or, if you also want a java browser plugin, emerge blackdown-jre.
_________________
The computer can't tell you the emotional story. It can give you the exact mathematical design, but what's missing is the eyebrows.
- Frank Zappa
Back to top
View user's profile Send private message
Brennos
n00b
n00b


Joined: 25 Jun 2004
Posts: 43
Location: Belgium

PostPosted: Tue Jul 06, 2004 9:23 am    Post subject: Reply with quote

I read a thread on this forum about installing sun-jre-bin.
I have blackdown-jre installed, but it doesn't install the java command on my computer which I very much need.
Back to top
View user's profile Send private message
SeJo
Retired Dev
Retired Dev


Joined: 08 Oct 2002
Posts: 298
Location: Belgium

PostPosted: Tue Jul 06, 2004 9:34 am    Post subject: Reply with quote

brennos,


you need to use java-config and set your configuration ok
then env-update
logout
login again and your settings should be ok.


btw mind that blackdown is till 1.3, and no 1.4.

If you need java 1.4 you must install the ibm one.

greetings
_________________
"I am not bound to please thee with my answers."
Back to top
View user's profile Send private message
Brennos
n00b
n00b


Joined: 25 Jun 2004
Posts: 43
Location: Belgium

PostPosted: Tue Jul 06, 2004 9:35 am    Post subject: Reply with quote

Thanks! I emerged IBM-jdk and everything is working (except Java 3D but I'll figure that one out myself)
Back to top
View user's profile Send private message
Hydraulix
Guru
Guru


Joined: 12 Dec 2003
Posts: 447
Location: Baltimore, Maryland

PostPosted: Tue Jul 06, 2004 9:35 am    Post subject: Reply with quote

It looks like the ibm-jdk package won't download from any Gentoo server. I'll post up the error when I get off work.
_________________
It is the fate of operating systems to become free.
- Neal Stephenson

If only You and Dead people can read hex, how many people can read hex?
Back to top
View user's profile Send private message
panyo
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2004
Posts: 86

PostPosted: Sat Jul 10, 2004 12:00 am    Post subject: Reply with quote

SeJo wrote:
brennos,


you need to use java-config and set your configuration ok
then env-update
logout
login again and your settings should be ok.


btw mind that blackdown is till 1.3, and no 1.4.

If you need java 1.4 you must install the ibm one.

greetings

I could not find ibm-jdk-bin-1.4.2.
For blackdown 1.3, e-build also did not work because the download sites failed. I searched
and put one of the sites I found into the ebuild file and ran

Code:
 ebuild /usr/portage/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r10.ebuild digest


Emerged fine, but no plugin. What exactly do I need to set with java-config?
Back to top
View user's profile Send private message
SeJo
Retired Dev
Retired Dev


Joined: 08 Oct 2002
Posts: 298
Location: Belgium

PostPosted: Mon Jul 12, 2004 9:01 am    Post subject: Reply with quote

IBM-jdk-1.4.2 is in the rsync tree, and should be in order.

javaconfig, the explination is in the ppc documentation (installguide or faq).
but it should be like this:
Code:

$ java-config --set-system-vm=ibm-jdk-bin-1.4.2

greetings,


SeJo
_________________
"I am not bound to please thee with my answers."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum