Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg on G5 PowerMac?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
deffjammer
n00b
n00b


Joined: 20 Nov 2003
Posts: 11
Location: Minneapolis, MN

PostPosted: Tue Jul 06, 2004 8:29 pm    Post subject: Xorg on G5 PowerMac? Reply with quote

Has anyone had success running xorg-x11 on a G5 with the ATI Radeon 9800 Pro Card? I've been using xfree-4.3.0-r5 with the fbdev driver (all defaults from Xeasyconf) with some success, but I can't seem to get a similiar configuration to work with xorg.

Thanks
D
Back to top
View user's profile Send private message
woolsherpahat
Guru
Guru


Joined: 09 Mar 2004
Posts: 347

PostPosted: Wed Jul 07, 2004 6:57 am    Post subject: Reply with quote

Aren't XFree and Xorg almost the same thing? You should just be able to transfer over the configuration files and use the same 3D acceleration drivers as far as I know.

What exactly are you having problems with? xorg.conf? DRI?
Back to top
View user's profile Send private message
jaspal kallar
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 194
Location: Sweden

PostPosted: Wed Jul 07, 2004 12:16 pm    Post subject: Reply with quote

I have the radeon 9600 pro on my G5. My xorg.con file

Code:
Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail"
  Option       "RandR" "on"
EndSection

Section "Module"
  Load         "type1"
  Load         "speedo"
  Load         "freetype"
  Load         "dbe"
  Load         "extmod"
  Load         "glx"
  Load         "v4l"
EndSection

Section "InputDevice"
  Driver       "Keyboard"
  Identifier   "Keyboard[0]"
  Option       "MapName" "Standard Keyboard [ pc104 ]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "se"
  #Option       "XkbModel" "pc104"
  Option       "XkbModel" "pc105"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "ButtonNumber" "5"
  #Option       "Device" "/dev/mouse"
  Option       "Device" "/dev/input/mice"
  Option       "InputFashion" "Mouse"
  Option       "Name" "Autodetection"
  Option       "Protocol" "imps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
  Option       "Resolution" "400"
EndSection

Section "Monitor"
  Option       "CalcAlgorithm" "CheckDesktopGeometry"
  DisplaySize  495 310
  HorizSync    30-90
  Identifier   "Monitor[0]"
  ModelName    "1600X1200@60HZ"
  Option       "DPMS"
  VendorName   "--> LCD"
  VertRefresh  50-70
  UseModes     "Modes[0]"
EndSection

Section "Modes"
 Identifier   "Modes[0]"
  #Modeline "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
# Modeline "1280x800_60.00"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
 # Modeline "1280x800" 67.26 1280 1312 1560 1592 800 817 824 841
 Modeline "1920x1200"  193.16  1920 2048 2256 2592  1200 1201 1204 1242 -HSync +Vsync
 #Modeline "1920x1200"  193.16  1920 2048 2256 2592  1200 1201 1204 1242
# Modeline "1920x1200" 155.0 1920 1984 2016 2144 1200 1203 1206 1212
EndSection



Section "Screen"
  DefaultDepth 24
#  DefaultDepth 8
  SubSection   "Display"
    Depth      24
    #Depth       8
    Modes      "1920x1200"
 #   Modes      "1920x1200_old"
#    Modes       "1280x800_60.00"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "Unknown"
#  BusID        "240:16:0"
  #Driver       "nv"
  Driver       "ati"
  Identifier   "Device[0]"
  Option       "dpms"
  Option       "UseFBDev"
  #Option        "FlatPanel"
  #Option "CrtcNumber" "0"
  #Option "CrtcNumber" "1"
  #Option       "NvAGP" "1"
  #Option  "MonitorLayout" "TMDS, TMDS"
  Screen       0
  VendorName   "Unknown"
EndSection


Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection
Back to top
View user's profile Send private message
deffjammer
n00b
n00b


Joined: 20 Nov 2003
Posts: 11
Location: Minneapolis, MN

PostPosted: Wed Jul 07, 2004 3:46 pm    Post subject: Reply with quote

Thank you very much. I was using the wrong font path's, the xorg.conf you posted worked for me as well.
Back to top
View user's profile Send private message
asv
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2003
Posts: 138
Location: State College, PA United States

PostPosted: Wed Jul 07, 2004 6:34 pm    Post subject: Re: Xorg on G5 PowerMac? Reply with quote

deffjammer wrote:
Has anyone had success running xorg-x11 on a G5 with the ATI Radeon 9800 Pro Card? I've been using xfree-4.3.0-r5 with the fbdev driver (all defaults from Xeasyconf) with some success, but I can't seem to get a similiar configuration to work with xorg.

Thanks
D


Are you using ppc64?
Back to top
View user's profile Send private message
deffjammer
n00b
n00b


Joined: 20 Nov 2003
Posts: 11
Location: Minneapolis, MN

PostPosted: Thu Jul 08, 2004 2:33 pm    Post subject: Reply with quote

Right now I'm using a 64 bit kernel with 32 bit user environment. Now that I know I can get Xorg working I'm in the process of upgrading everything to a 64 bit.
Back to top
View user's profile Send private message
jaspal kallar
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 194
Location: Sweden

PostPosted: Thu Jul 08, 2004 3:04 pm    Post subject: Reply with quote

If going to ppc64 perhaps keep tabs on the url's below since it mentions some X issuses on ppc64 gentoo.

http://gentoo-ppc64.blogspot.com/
http://dev.gentoo.org/~tgall/
Back to top
View user's profile Send private message
asv
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2003
Posts: 138
Location: State College, PA United States

PostPosted: Thu Jul 08, 2004 3:11 pm    Post subject: also on irc Reply with quote

I would reccommend checking out #gentoo-ppc64 on freenode.net too. Tgall has helped me out a bunch.

jaspal kallar wrote:
If going to ppc64 perhaps keep tabs on the url's below since it mentions some X issuses on ppc64 gentoo.

http://gentoo-ppc64.blogspot.com/
http://dev.gentoo.org/~tgall/
Back to top
View user's profile Send private message
dschaefer
n00b
n00b


Joined: 08 Jul 2004
Posts: 2
Location: Ottawa, Canada

PostPosted: Thu Jul 08, 2004 7:31 pm    Post subject: Reply with quote

Just to confirm, does anyone have direct rendering working on a G5 radeon?
Back to top
View user's profile Send private message
ppc64
n00b
n00b


Joined: 24 Jun 2004
Posts: 11
Location: Va

PostPosted: Sat Jul 10, 2004 12:33 am    Post subject: Reply with quote

No dice, here!

I'm using a radeon 9800 pro SE in a G5 DP 1.8 with a Studio Display 17 Flat Panel. I've been struggling with acceleration for a couple of weeks. I get 24depth color with 2.6 kernels but only 8 with 2.4 kernels. AGPGART tells me the uninorth controller is NOT supported, even though its built in to the kernel.(?)

It looks like the problem with 2.6 kernels and acceleration is that there is no driver support currently. : (
Back to top
View user's profile Send private message
jaspal kallar
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 194
Location: Sweden

PostPosted: Sat Jul 10, 2004 2:36 pm    Post subject: Reply with quote

I have a radeon 9600 pro with dual 1.8 G5 and i use kernel
Code:
uname -a
Linux linux 2.6.7-r0 #14 SMP Wed Jun 23 23:42:15 CEST 2004 ppc PPC970, altivec supported PowerMac7,2 GNU/Linux


my lsmod states:
Code:

Module                  Size  Used by
.
.
.
ip_tables              22400  4 ipt_LOG,ipt_limit,ipt_state,iptable_filter
eth1394                22024  0
uninorth_agp            6656  0
agpgart                32016  1 uninorth_agp
ohci1394               36868  0
ieee1394              425744  2 eth1394,ohci1394
usblp                  13312  0
joydev                 10560  0


I'm using the 64 bit kernel sources with 32 bit userland and xorg-x11.

I have no idea if the above helps since I'm quite a newbie when it comes to such things. For example
Quote:
just to confirm, does anyone have direct rendering working on a G5 radeon


Does this mean 3D acceleration (which I gather is not possible on ppc) ?
Back to top
View user's profile Send private message
gohmdoree
Guru
Guru


Joined: 12 Oct 2004
Posts: 533

PostPosted: Mon Mar 14, 2005 11:15 am    Post subject: Reply with quote

lucky guy...

i will get a quad g5 one day. =)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum