Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Festival tips: more understandable and books to audiobooks
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Dr_Smack
n00b
n00b


Joined: 15 Jul 2004
Posts: 18

PostPosted: Wed Jul 21, 2004 4:48 pm    Post subject: Reply with quote

Well, I'm remerging with very tame CFLAGS now to see if that makes a difference.
I'm running:

2.6.7-gentoo-r10
perl-5.8.4
speech-tools 1.2.3
festival 1.4.3-r1

all on a Celeron 600. I'll edit this post when it finishes with my results (I'm not holding out much hope).

*EDIT* Nope, didn't change a thing.

*EDIT #2* I've now tried installing and running this on 3 different computers and have had the same results (see previous post) on all 3.
Back to top
View user's profile Send private message
chrisashton84
Apprentice
Apprentice


Joined: 12 Aug 2003
Posts: 192
Location: Peoria, IL (home) Urbana, IL (school)

PostPosted: Wed Jul 21, 2004 11:11 pm    Post subject: Reply with quote

I currently get the same error as ootneg and floam.
Back to top
View user's profile Send private message
ootneg
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jul 2003
Posts: 82

PostPosted: Thu Jul 22, 2004 4:48 am    Post subject: Reply with quote

I recompiled (even unmerged before the new emerge) with no optomizations in my CFLAGS. This made no difference. I replaced both speech-tools and festival this way.

Well . . . Back to the old drawing board.
Back to top
View user's profile Send private message
Chaosite
Guru
Guru


Joined: 13 Dec 2003
Posts: 540
Location: Right over here.

PostPosted: Thu Jul 22, 2004 9:04 am    Post subject: Reply with quote

Hey, this works great for me!

Thanks!
Back to top
View user's profile Send private message
tridy
n00b
n00b


Joined: 23 May 2004
Posts: 41
Location: Australia

PostPosted: Thu Jul 22, 2004 6:07 pm    Post subject: Reply with quote

getting the same error;

festival> (SayText "help")
Cannot open file /tmp/est_13432_00000/utt.wav as tokenstream
Wave load: can't open file "/tmp/est_13432_00000/utt.wav"
Cannot load wavefile: /tmp/est_13432_00000/utt.wav
#<Utterance 0x2a96652850>

there seems to be a problem with speech-tools package, don't know if the problem is during compiling or the actual package but all(or lots of) the scripts/binaries are pointing to PORTAGE_TMPDIR.

for example /usr/lib/speech-tools/bin/tilt_synthesis
includes
extend LD_LIBRARY_PATH "/home/tmp/portage/portage/speech-tools-1.2.3/work/speech_tools/lib:"

I don't know where this should be pointing, there is about 90 similar examples in /usr/lib/speech-tools. I'm hoping this might help someone figure this out. I'm not certain where to go from here.
Back to top
View user's profile Send private message
Rafje
Tux's lil' helper
Tux's lil' helper


Joined: 19 May 2004
Posts: 109
Location: .be

PostPosted: Thu Jul 22, 2004 7:22 pm    Post subject: Reply with quote

tridy wrote:
/usr/lib/speech-tools/bin/tilt_synthesis includes extend LD_LIBRARY_PATH "/home/tmp/portage/portage/speech-tools-1.2.3/work/speech_tools/lib:"


Hmm. My /usr/lib/speech-tools/bin/tilt_synthesis does not point to a temporary directory:
Code:
pistache bin # pwd
/usr/lib/speech-tools/bin
pistache bin # cat tilt_analysis | grep LIBR 
extend LD_LIBRARY_PATH "/usr/lib/speech-tools/lib:"
but I have the same "Cannot load wavefile" error as reported above.

So that appears not to be the key issue...
Back to top
View user's profile Send private message
Rafje
Tux's lil' helper
Tux's lil' helper


Joined: 19 May 2004
Posts: 109
Location: .be

PostPosted: Thu Jul 22, 2004 7:34 pm    Post subject: Reply with quote

Bingo!

I noticed that I could select voice_us1_mbrola, voice_us2_mbrola and voice_us3_mbrola even before I had emerged mbrola. But when I did select one of those mbrola voices and let festival say something, I got the same "Cannot load wavefile" error.

So, I emerged mbrola, after which the voice_us?_mbrola voices worked. And lo and behold, the voice_cmu_us_slt_arctic_hts magically worked as well. Yay!

So my suggestion is to emerge mbrola and see if it does the trick for you too.

Cheers
Back to top
View user's profile Send private message
Dr_Smack
n00b
n00b


Joined: 15 Jul 2004
Posts: 18

PostPosted: Thu Jul 22, 2004 8:26 pm    Post subject: Reply with quote

Rafje wrote:
Bingo!

I noticed that I could select voice_us1_mbrola, voice_us2_mbrola and voice_us3_mbrola even before I had emerged mbrola. But when I did select one of those mbrola voices and let festival say something, I got the same "Cannot load wavefile" error.

So, I emerged mbrola, after which the voice_us?_mbrola voices worked. And lo and behold, the voice_cmu_us_slt_arctic_hts magically worked as well. Yay!

So my suggestion is to emerge mbrola and see if it does the trick for you too.

Cheers


I emerged mbrola (which emerged successfully), but the cmu_.... still didn't work. The mbrola voices did, just not the cmu stuff.

*EDIT* Just for completeness, I tried this method on 3 different machines, all with the same result.
Back to top
View user's profile Send private message
ootneg
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jul 2003
Posts: 82

PostPosted: Fri Jul 23, 2004 3:20 am    Post subject: Reply with quote

Rafje wrote:
Bingo!

I noticed that I could select voice_us1_mbrola, voice_us2_mbrola and voice_us3_mbrola even before I had emerged mbrola. But when I did select one of those mbrola voices and let festival say something, I got the same "Cannot load wavefile" error.

So, I emerged mbrola, after which the voice_us?_mbrola voices worked. And lo and behold, the voice_cmu_us_slt_arctic_hts magically worked as well. Yay!

So my suggestion is to emerge mbrola and see if it does the trick for you too.

Cheers


I have had mbrola installed from nearly the beginning of my playing with this program. It hasn't helped me with getting cmu_us_slt_arctic_hts to work. Just to be sure, I reinstalled mbrola, but with no change in performance.
Back to top
View user's profile Send private message
tridy
n00b
n00b


Joined: 23 May 2004
Posts: 41
Location: Australia

PostPosted: Fri Jul 23, 2004 5:35 am    Post subject: Reply with quote

I emerged mbrola

but with no change.....mmmm.

will have a look at the other error, if Rafje has things pointing to the correct place in speech-tools and mbrola, I'm thinking if I can get things pointing in the right direction it might work.

Dr_Smack and ootneg does your /usr/lib/speech-tools/bin/tilt_analysis and other files in /usr/lib/speech-tools/bin point to the wrong place.
i.e.
extend LD_LIBRARY_PATH "/home/tmp/portage/portage/speech-tools-1.2.3/work/speech_tools/lib:"
exec /home/tmp/portage/portage/speech-tools-1.2.3/work/speech_tools/main/tilt_analysis "$@"

I going blindly here, I don't know if this is the problem but it does seem to be an error. Might be a portage problem? i'm running portage-2.0.50-r9.
Back to top
View user's profile Send private message
tridy
n00b
n00b


Joined: 23 May 2004
Posts: 41
Location: Australia

PostPosted: Fri Jul 23, 2004 3:54 pm    Post subject: Reply with quote

fixed LD_LIBRARY_PATH problem by updating /usr/portage/app-accessibility/speech-tools. The problem i described seemed to be a known problem.

But I'm still getting

Cannot open file /tmp/est_16977_00000/utt.wav as tokenstream

Rafje was correct.
Back to top
View user's profile Send private message
ootneg
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jul 2003
Posts: 82

PostPosted: Sat Jul 24, 2004 12:05 am    Post subject: Reply with quote

Quote:
# cat tilt_analysis | grep LIBR
extend LD_LIBRARY_PATH "/usr/lib/speech-tools/lib:"

Mine has been the same as Rafje's. I did not need to make this change.
Back to top
View user's profile Send private message
Dr_Smack
n00b
n00b


Joined: 15 Jul 2004
Posts: 18

PostPosted: Sat Jul 24, 2004 2:52 am    Post subject: Reply with quote

tridy wrote:

Dr_Smack and ootneg does your /usr/lib/speech-tools/bin/tilt_analysis and other files in /usr/lib/speech-tools/bin point to the wrong place.
i.e.
extend LD_LIBRARY_PATH "/home/tmp/portage/portage/speech-tools-1.2.3/work/speech_tools/lib:"
exec /home/tmp/portage/portage/speech-tools-1.2.3/work/speech_tools/main/tilt_analysis "$@"

All of mine were correct. I just did:
Code:
grep LIBR *
grep exec *

Then... just to be sure:
Code:
grep tmp *

All from the /u/l/s-t/bin/ directory. Nothing was pointing to /tmp/....
Back to top
View user's profile Send private message
chrisashton84
Apprentice
Apprentice


Joined: 12 Aug 2003
Posts: 192
Location: Peoria, IL (home) Urbana, IL (school)

PostPosted: Tue Jul 27, 2004 7:10 am    Post subject: Reply with quote

Here's my guess, it's just a guess, but I think the wav isn't being created. Since this apparently uses a different engine, has the engine been installed correctly? I can't tell for sure on mine where it should be. Any help here?
Back to top
View user's profile Send private message
Calchan
Developer
Developer


Joined: 15 Aug 2002
Posts: 50
Location: Cannes, France

PostPosted: Tue Aug 03, 2004 9:49 am    Post subject: Reply with quote

I had the same problem. I tried a few things, including recompiling the hts_engine executable, but it didn't work. At least, now, I have an über-optimized hts_engine. Enough with suspense, the solution to our problem is:
Code:
emerge sox

Have fun with your new voices.
Back to top
View user's profile Send private message
tomthewombat
Apprentice
Apprentice


Joined: 29 Mar 2003
Posts: 244
Location: NY State

PostPosted: Tue Aug 17, 2004 12:13 am    Post subject: Reply with quote

yeah, the perl script runs sox thought a system() call. would be nice if its left some error messages or a log somewhere when that fails.
_________________
http://www.wombatorium.net
Back to top
View user's profile Send private message
gazoombo
n00b
n00b


Joined: 22 Feb 2004
Posts: 56
Location: GR. MI. USA

PostPosted: Tue Aug 17, 2004 10:21 pm    Post subject: Reply with quote

Works for me. ...kinda...
The voices sound fantastic and nothing is broken but I get strange errors mentioning segfaults every time I run festival with the cmu_* voices.
Code:
mike@gemini ~ $ cat talking.txt | festival --tts
sh: line 1:  4142 Segmentation fault      /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//hts_engine -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_dyn.win -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_acc.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_dyn.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_acc.win -td /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-dur.inf -tm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-mcep.inf -tf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-lf0.inf -md /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//duration.pdf -mm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep.pdf -mf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0.pdf -a 0.420000 -r 0.000000 -fs 1.000000 -fm 0.000000 -om /tmp/est_04135_00000/tmp.mcep -of /tmp/est_04135_00000/tmp.f0 -or /tmp/est_04135_00000/tmp.raw -u 0.500000 -l 0.000000 -b 0.300000 /tmp/est_04135_00000/tmp.lab >/dev/null
sh: line 1:  4151 Segmentation fault      /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//hts_engine -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_dyn.win -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_acc.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_dyn.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_acc.win -td /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-dur.inf -tm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-mcep.inf -tf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-lf0.inf -md /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//duration.pdf -mm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep.pdf -mf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0.pdf -a 0.420000 -r 0.000000 -fs 1.000000 -fm 0.000000 -om /tmp/est_04135_00002/tmp.mcep -of /tmp/est_04135_00002/tmp.f0 -or /tmp/est_04135_00002/tmp.raw -u 0.500000 -l 0.000000 -b 0.300000 /tmp/est_04135_00002/tmp.lab >/dev/null
sh: line 1:  4159 Segmentation fault      /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//hts_engine -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_dyn.win -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_acc.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_dyn.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_acc.win -td /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-dur.inf -tm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-mcep.inf -tf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-lf0.inf -md /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//duration.pdf -mm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep.pdf -mf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0.pdf -a 0.420000 -r 0.000000 -fs 1.000000 -fm 0.000000 -om /tmp/est_04135_00004/tmp.mcep -of /tmp/est_04135_00004/tmp.f0 -or /tmp/est_04135_00004/tmp.raw -u 0.500000 -l 0.000000 -b 0.300000 /tmp/est_04135_00004/tmp.lab >/dev/null

_________________
Hoping to install Gentoo 2007.0 soon and rejoin the Linux world
My Ol' Box:
Abit NF7-S (nForce2 Chipset)
Athlon XP 2500+ Barton
512MB RAM (which may be in need of replacement)
NVIDIA GeForce3
Back to top
View user's profile Send private message
Dr_Smack
n00b
n00b


Joined: 15 Jul 2004
Posts: 18

PostPosted: Wed Aug 18, 2004 7:37 pm    Post subject: Reply with quote

gazoombo wrote:
Works for me. ...kinda...
The voices sound fantastic and nothing is broken but I get strange errors mentioning segfaults every time I run festival with the cmu_* voices.
{snip}

I get the segfaults as well.
Back to top
View user's profile Send private message
tridy
n00b
n00b


Joined: 23 May 2004
Posts: 41
Location: Australia

PostPosted: Thu Aug 19, 2004 1:57 am    Post subject: emerge sox worked Reply with quote

emerge sox gets it working for me

thanks :)

talks a bit fast though, will have to get it to slow down!
Back to top
View user's profile Send private message
crazycat
l33t
l33t


Joined: 26 Aug 2003
Posts: 838
Location: Hamburg, Germany

PostPosted: Tue Aug 24, 2004 3:51 am    Post subject: Reply with quote

Works awesome here on amd64. Thanks for the tipp, i had to replace hts_engine with amd64 compiled one.
saytext works pretty good :D - i tried some dumb things with this f*** word and laughed alot. But i got the following error:
Code:

#text2wave
/usr/bin/text2wave: line 2: /tmp/portage/festival-1.4.3-r1/work/festival/bin/festival: No such file or directory
/usr/bin/text2wave: line 2: exec: /tmp/portage/festival-1.4.3-r1/work/festival/bin/festival: cannot execute: No such file or directory

I assume theese are some configuration problems but man text2wave did nothing. Do you also know a good frontend for festival?

EDIT: I found out it's a script - and fixed it .
Back to top
View user's profile Send private message
kpoman
Apprentice
Apprentice


Joined: 15 May 2003
Posts: 209
Location: Buenos Aires, Argentina

PostPosted: Thu Sep 02, 2004 2:33 am    Post subject: Reply with quote

hello again!
i am trying to make this thing work but am also getting the segfault:
Code:

root@zobiak /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts # text2wave /home/kpoman/mytext
sh: line 1:  2170 Segmentation fault      /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//hts_engine -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_dyn.win -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_acc.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_dyn.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_acc.win -td/usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-dur.inf -tm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-mcep.inf -tf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-lf0.inf -md /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//duration.pdf -mm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep.pdf -mf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0.pdf -a 0.420000 -r 0.000000 -fs 1.000000 -fm 0.000000 -om /tmp/est_02164_00000/tmp.mcep -of /tmp/est_02164_00000/tmp.f0 -or /tmp/est_02164_00000/tmp.raw -u 0.500000 -l 0.000000 -b 0.300000 /tmp/est_02164_00000/tmp.lab >/dev/null
Cannot open file /tmp/est_02164_00000/utt.wav as tokenstream
Wave load: can't open file "/tmp/est_02164_00000/utt.wav"
Cannot load wavefile: /tmp/est_02164_00000/utt.wav

root@zobiak /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts #       

...


i compiled from sources the hts_engine just in case that was the problem i was having, but no luck !
i tried also compiling sox, but that did not help. i am able to switch to an mbrola voice, and then if i switch to the arctic one, it works (it complains and segfaults though, but i hear the new voice and it sounds cool !):
Code:

root@zobiak /usr/lib/festival/voices/english # festival
Festival Speech Synthesis System 1.4.3:release Jan 2003
Copyright (C) University of Edinburgh, 1996-2003. All rights reserved.
For details type `(festival_warranty)'
festival>  (voice_us1_mbrola)
us1_mbrola
festival>  (SayText "Good morning, welcome to Festival")
#<Utterance 0x407301f8>
festival>  (voice_cmu_us_slt_arctic_hts)
cmu_us_slt_arctic_hts
festival>  (SayText "Good morning, welcome to Festival")
sh: line 1:  6973 Segmentation fault      /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//hts_engine -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_dyn.win -dm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep_acc.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_dyn.win -df /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0_acc.win -td/usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-dur.inf -tm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-mcep.inf -tf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//tree-lf0.inf -md /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//duration.pdf -mm /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//mcep.pdf -mf /usr/lib/festival/voices/english/cmu_us_slt_arctic_hts/hts//lf0.pdf -a 0.420000 -r 0.000000 -fs 1.000000 -fm 0.000000 -om /tmp/est_06952_00001/tmp.mcep -of /tmp/est_06952_00001/tmp.f0 -or /tmp/est_06952_00001/tmp.raw -u 0.500000 -l 0.000000 -b 0.300000 /tmp/est_06952_00001/tmp.lab >/dev/null
#<Utterance 0x40783438>
festival>  (voice_us1_mbrola)
us1_mbrola
festival>  (SayText "Good morning, welcome to Festival")
#<Utterance 0x40948958>
festival>           

do someone know what is going on here ? help much appreciated! i would really like havin my audiobooks :) thanks !
_________________
please, help me, pity on me :'(
Back to top
View user's profile Send private message
Heiga Zen
n00b
n00b


Joined: 13 Sep 2004
Posts: 4
Location: Japan

PostPosted: Mon Sep 13, 2004 5:17 pm    Post subject: Thank you very much Reply with quote

Hi, my name is Heiga Zen.
I am maintaining and developping HMM-based speech synthesis toolkit.

Today I visited this forum for the first time.
I was very surprised :D
I'd like to commit to this forum.
If you are interested in developping HMM-based speech synthesis system,
please join our hts-users mailing list.

Next version of festival (2.0?) will include HTS as a module.
Curret HTS voices requires sox, and perl.
I think it causes a lot of problems for you.
I'm very sorry :cry:
But next version does not require them.
Festival 1.95beta has been released already.
(http://www.festvox.org/festival/index.html)
(HTS voices are included initially)
I recommend you to try to use it.
Please give me your feedback.

Thank you very much

P.S. Our web server crushed from July 6th to 21st.
I'm sorry for your inconvienience :cry:
Back to top
View user's profile Send private message
tridy
n00b
n00b


Joined: 23 May 2004
Posts: 41
Location: Australia

PostPosted: Sat Sep 18, 2004 7:52 am    Post subject: Reply with quote

Quote:
Festival 1.95beta has been released already.
(http://www.festvox.org/festival/index.html)
(HTS voices are included initially)
I recommend you to try to use it.
Please give me your feedback.


I tried compiling speech_tools-1.2.95-beta for festival-1.95-beta with gcc-3.3.4-r1.

I did
Code:
./configure

and
Code:
make(gmake)


but it seems to go in a loop

Code:

./config.status
creating config/config
Check system type
Remake modincludes.inc
        NATIVE_AUDIO
                ok
        EDITLINE
                config/modules/editline.mak
        SIOD
                siod/siod.mak
        WAGON
                stats/wagon/wagon.mak
        SCFG
                grammar/scfg/scfg.mak
        WFST
                grammar/wfst/wfst.mak
        OLS
                stats/ols.mak
        RXP
                rxp/rxp.mak
        LINUX16_AUDIO
                config/modules/linux16_audio.mak
./config.status
creating config/config
Check system type
Remake modincludes.inc
        NATIVE_AUDIO
                ok
        EDITLINE
                config/modules/editline.mak
        SIOD
                siod/siod.mak
        WAGON
                stats/wagon/wagon.mak
        SCFG
                grammar/scfg/scfg.mak
        WFST
                grammar/wfst/wfst.mak
        OLS
                stats/ols.mak
        RXP
                rxp/rxp.mak
        LINUX16_AUDIO
                config/modules/linux16_audio.mak


am I doing anything wrong?
Back to top
View user's profile Send private message
lisa
Retired Dev
Retired Dev


Joined: 01 Jun 2003
Posts: 273
Location: York, UK again! Horray!

PostPosted: Sat Sep 18, 2004 7:45 pm    Post subject: Re: Festival tips: more understandable and books to audiobo Reply with quote

fireboy1919 wrote:
Check if you have ispell with emerge (emerge -s ispell). Check if you have Lingua::Ispell by using CPAN. To do this, type
Code:
perl -MCPAN -e shell

as root, and then (after configuring it if you haven't done it before), type
Code:
install Lingua::Ispell

at the cpan prompt. Typing exit will exit the CPAN shell.



NOOOOOOOOOOOOOOOOOOOOOOOO!!!!!!!!!!!!!!!!!!!

Use
Code:
g-cpan.pl Lingua::Ispell

_________________
Distcc guide
Visit my website
I maintain Distcc, Ccache, Memcached, and some others (i think)
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Sun Sep 19, 2004 8:04 pm    Post subject: Re: Thank you very much Reply with quote

Heiga Zen wrote:
Hi, my name is Heiga Zen.
I am maintaining and developping HMM-based speech synthesis toolkit.


Thank you very much for this fine piece of software.

One tip I would like to share with fellow users is to compile their own hts_engine:

Code:
-rwxr-xr-x  1 root root  37K Sep 19 15:43 hts_engine
-rwxr-xr-x  1 4426 4420 1.6M Dec 26  2003 hts_engine.old

_________________
Hello.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum