Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NVidia & modprobe
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
InAt!QuE
Apprentice
Apprentice


Joined: 02 Jan 2004
Posts: 257
Location: The Netherlands

PostPosted: Mon Jul 12, 2004 2:52 pm    Post subject: NVidia & modprobe Reply with quote

Dag allemaal,

Kheb een vraagje over nvidia.
Ik ben bezig met een gentoo install 2004.1 en wil er een dekstop environment opzetten.

Ik heb emerge xfree gedaan en ben wat met de configs aan et rommelen. Maar nu staat er in de doc. ( http://www.gentoo.org/doc/nl/desktop.xml#doc_chap2 ) over et configureren van de vga kaart het volgende

Code:
# emerge nvidia-glx
# emerge nvidia-kernel
# nano -w /etc/X11/XF86Config
(Verander "nv" in "nvidia" in het 'Device section')
# modprobe nvidia


Nu heb ik stap 1 , 2 en 3 gedaan maar zodra ik modprobe nvidia intik krijg ik het volgende

Code:
# modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/2.6.7-gentoo-r9/video/nvidia.ko): Invalid module format


Kan iemand mij verder helpen?? Oftewel wat doe ik fout?

Wat is de betere manier om een desktop omgeving bij gentoo te zetten en welke is aan te raden?

Bij voorbaat dank.

Groeten
_________________
...Unix, MS-DOS, and Windows NT (also known as the Good, the Bad, and the Ugly).
Back to top
View user's profile Send private message
oiper
Guru
Guru


Joined: 01 May 2003
Posts: 316
Location: Alabama, US

PostPosted: Mon Jul 12, 2004 4:33 pm    Post subject: well Reply with quote

VERTALING STAAT ONDERAAN HET BERICHT

which kernel verison and which nvidia-kernel versions are you using?

if you are using 2.6.x, I'd try using at least nvidia-kernel-1.0.5336-r4.

Make SURE you emerge -C any other versions that are installed. B/c emerging another nvidia-kernel version does not usually remove the previous version. Just take note of any "Protected" "Omitted" versions it lists during the emerge, and then emerge -C any old versions.

ie. if you have nvidia-kernel-1.0.4496-r3 installed
Code:

emerge nvidia-kernel/nvidia-kernel-1.0.4496-r3 -C
emerge /usr/portage/media-video/nvidia-kernel-1.0.5336-r4.ebuild


I had the same problem b/c of using older versions, and THEN had the same problem b/c emerge was simply adding more installs for this ebuild instead of Upgrading it. Also install the corresponding nvidia-glx package.

TRANSLATION/VERTALING (van garo):

Welke kernel-versie en welke versie van "nvidia-kernel" gebruik je ?

Als je een 2.6 kernel gebruikt dan raad ik nvidia-kernel-1.0.5336-r4 of hoger aan.

Denk er ZEKER aan om al andere geinstalleerde versies te wissen (met "emerge -C". Als je een nieuwe versie van de nvidia kernel gebruikt wordt de vorige meestal niet automatisch gewist. Let gewoon op de "Protected" & "Omitted" versies tijdens de emerge en wis de oude versies.

vb: Als je nvidia-kernel-1.0.4496-r3 hebt geinstalleerd:
Code:
emerge nvidia-kernel/nvidia-kernel-1.0.4496-r3 -C
emerge /usr/portage/media-video/nvidia-kernel-1.0.5336-r4.ebuild


Ik had het zelfde probleem met een oude nvidia-kernel, en na het mergen mergen van een nieuwe versie had ik nog steeds problemen omdat emerge nieuwe versies was aan het installeren zonder de oude te wissen. Installeer ook de "nvidia-glx" ebuild van de zelfde versie.
_________________
www.bearscanfly.org - Because hiking is cool
Back to top
View user's profile Send private message
garo
Bodhisattva
Bodhisattva


Joined: 15 Jul 2002
Posts: 860
Location: Edegem,BELGIUM

PostPosted: Mon Jul 12, 2004 6:18 pm    Post subject: Reply with quote

Ik had ook dit probleem, de oudere nvidia-kernel's werken niet meer met nieuwere kernels. Ik dacht dat het opgelost was door nvidia-kernel-1.0.6106 te gebruiken. (Mischien moest er ook nog iets anders gebeuren, meld het maar als het niet werkt).
Gebruik dus zeker geen nvidia-kernel uit de 1.0.4xxx reeks, die werken niet.
En liever ook geen uit de 1.0.5xxx, die werken traag.
_________________
My favorite links this month:
- Surf Random
- Web-based SSH
- Stop Spam
Back to top
View user's profile Send private message
sgaap
l33t
l33t


Joined: 16 Aug 2002
Posts: 754
Location: Enschede, The Netherlands

PostPosted: Mon Jul 12, 2004 9:29 pm    Post subject: Reply with quote

Ik had hetzelfde probleem, maar naar de driver dir gaan en gewoon de driver insmodden werkte wel, geen id: misschien een te oude versie van modutils oid
_________________
In "old" Europe we already have a word for "pre-emptive strikes" mr Bush: its called "war"
Back to top
View user's profile Send private message
RobDin
n00b
n00b


Joined: 08 Aug 2004
Posts: 32
Location: Netherlands, Zaandam

PostPosted: Sun Aug 08, 2004 3:17 pm    Post subject: Reply with quote

Ik had hetzelfde probleem, bij mij was dat pas opgelost nadat ik het volgende had gedaan:

ACCEPT_KEYWORDS="~x86" emerge nvidia-kernel nvidia-glx

Hierdoor gaat emerge de 6106 versie van de nvidia drivers installeren. Na het toevoegen van de driver in modules.autoload en een reboot werkte alles perfect.
_________________
RobDin

Save the whales, collect the whole set

« Zo niet, Dan toch »
Back to top
View user's profile Send private message
Bastaard
n00b
n00b


Joined: 07 Aug 2004
Posts: 34

PostPosted: Mon Aug 09, 2004 10:50 am    Post subject: Reply with quote

zelfde probleem hier.

opgelost door de driver van de nvidia site te downloaden en dan gewoon zelf bouwen. Werkt ook :)

/me is lui :D
_________________
- live in your world, die in mine -
Back to top
View user's profile Send private message
Marcski
n00b
n00b


Joined: 28 Jul 2004
Posts: 17

PostPosted: Mon Aug 09, 2004 12:45 pm    Post subject: Reply with quote

RobDin wrote:
Ik had hetzelfde probleem, bij mij was dat pas opgelost nadat ik het volgende had gedaan:

ACCEPT_KEYWORDS="~x86" emerge nvidia-kernel nvidia-glx

Hierdoor gaat emerge de 6106 versie van de nvidia drivers installeren. Na het toevoegen van de driver in modules.autoload en een reboot werkte alles perfect.


Dat is idd de juiste manier.
Het beste is een /etc/portage/package.keywords aan te maken met:
Code:

media-video/nvidia-kernel ~x86
media-video/nvidia-glx ~x86
x11-base/opengl-update ~x86


anders worden bij de volgende "emerge world" de 4496 drivers weer teruggezet
Back to top
View user's profile Send private message
Traffixxx
n00b
n00b


Joined: 27 Mar 2004
Posts: 46

PostPosted: Wed Aug 11, 2004 11:08 am    Post subject: Reply with quote

bash-2.05b$ glxinfo
name of display: :0.0
Error: API mismatch: the NVIDIA kernel module is version 1.0.6111, but
this library is version 1.0.4496. Please be sure that your kernel
module and all NVIDIA driver files have the same driver version.
NV: could not get NV card info (Invalid argument)
Error: glXCreateContext failed

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x21 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x22 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x29 24 tc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x2a 24 tc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2e 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 2 1 Ncon
0x2f 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 2 1 Ncon
0x30 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 4 1 Ncon
0x31 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 4 1 Ncon
0x32 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 2 1 Ncon
0x33 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 2 1 Ncon
0x34 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 4 1 Ncon
0x35 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 4 1 Ncon
0x36 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x37 24 dc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x38 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x39 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x3a 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x3b 24 dc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x3c 24 dc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x3d 24 dc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x3e 24 dc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x3f 24 dc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x40 24 dc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x41 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 2 1 Ncon
0x42 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 2 1 Ncon
0x43 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 4 1 Ncon
0x44 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 4 1 Ncon
0x45 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 2 1 Ncon
0x46 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 2 1 Ncon
0x47 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 4 1 Ncon
0x48 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 4 1 Ncon


glxgears geeft hetzelfde probleem
als ik et speel dan zijn er blokjes en de 3d is ni zo geniaal :s


hahah en nu werkt mijn driver ni meer
http://users.pandora.be/IconProjects/log
Back to top
View user's profile Send private message
Marcski
n00b
n00b


Joined: 28 Jul 2004
Posts: 17

PostPosted: Wed Aug 11, 2004 12:12 pm    Post subject: Reply with quote

je kernel en glx versie moeten hetzelfde zijn...
Probeer dit es:
Code:

ACCEPT_KEYWORDS="~x86" emerge nvidia-glx opengl-update
Back to top
View user's profile Send private message
RobDin
n00b
n00b


Joined: 08 Aug 2004
Posts: 32
Location: Netherlands, Zaandam

PostPosted: Wed Aug 11, 2004 2:27 pm    Post subject: Reply with quote

Marcski schreef:
Quote:

Het beste is een /etc/portage/package.keywords aan te maken met:

Code:

media-video/nvidia-kernel ~x86
media-video/nvidia-glx ~x86
x11-base/opengl-update ~x86


anders worden bij de volgende "emerge world" de 4496 drivers weer teruggezet


Bedankt voor de tip ;), ik was al op zoek naar zoiets. Ik vreesde al dat ik voortaan na iedere world update m'n nvidia drivers opnieuw zou moeten compilen(en mischien in de toekomst nog meer masked software).

thnx Marcski!
_________________
RobDin

Save the whales, collect the whole set

« Zo niet, Dan toch »
Back to top
View user's profile Send private message
Traffixxx
n00b
n00b


Joined: 27 Mar 2004
Posts: 46

PostPosted: Sat Aug 14, 2004 10:03 pm    Post subject: Reply with quote

Marcski wrote:
je kernel en glx versie moeten hetzelfde zijn...
Probeer dit es:
Code:

ACCEPT_KEYWORDS="~x86" emerge nvidia-glx opengl-update


werkte perfect thx
alleen moest ik iets moven mor da stond in de emerge dus :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum