Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error on boot: can't mount root partition
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
kingLatency
n00b
n00b


Joined: 28 Sep 2002
Posts: 61
Location: Amherst, MA

PostPosted: Wed Jul 14, 2004 1:50 am    Post subject: Error on boot: can't mount root partition Reply with quote

I'm trying to boot my fresh Gentoo system for the first time. My partition map has /dev/hda1 as the map, hda2 as boot, hda3 as swap and hda4 as root. The output of mac-fdisk verifies this. fstab is set up accordingly, as is yaboot.conf. But when I boot the sytem, I get the following error:
Code:
VFS: Cannot open root device "hda4"

What's causing this? Seems like everything should be in order. Any help would be appreciated.
Back to top
View user's profile Send private message
KePSuX
Guru
Guru


Joined: 29 Sep 2003
Posts: 312
Location: Fredericksburg Va

PostPosted: Wed Jul 14, 2004 2:40 am    Post subject: Reply with quote

Do you have devfs support compiled into your kernel? You also need to make sure it is set to mount at bootup in the kernel as well. Other than that double check your fstab syntax for errors.
_________________
http://www.atomicraygunattack.com
Back to top
View user's profile Send private message
kingLatency
n00b
n00b


Joined: 28 Sep 2002
Posts: 61
Location: Amherst, MA

PostPosted: Wed Jul 14, 2004 2:50 am    Post subject: Reply with quote

Actually, wepy got me the solution. It turned out turning on builtin powermac ide support made it work. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum