Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blackdown java-plugin fails in Firefox/Galeon (ran earlier)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Sun Jul 18, 2004 5:37 pm    Post subject: Blackdown java-plugin fails in Firefox/Galeon (ran earlier) Reply with quote

At one time I had java-plugin working but now it will not work in my firefox or galeon so I re-emerge blackdown-jre, but that did not help. Notice the warning I get when I config java
Code:

root@Tony tony #  java-config --list-available-vms
[blackdown-jre-1.3.1] "Blackdown JRE 1.3.1" (/etc/env.d/java/20blackdown-jre-1.3.1)
[blackdown-jdk-1.3.1] "Blackdown JDK 1.3.1" (/etc/env.d/java/20blackdown-jdk-1.3.1)
[ibm-jdk-bin-1.4.2] "IBM JDK 1.4.2" (/etc/env.d/java/20ibm-jdk-bin-1.4.2) *
root@Tony tony # java-config --set-system-vm=blackdown-jre-1.3.1
javac not found
javadoc not found
jar not found
rmic not found
THIS SYSTEM VM IS NOT SUFFICIENT, REQUIRED BINARIES WERE NOT FOUND
System Virtual Machine set
You may want to update your enviroment by running:
        "/usr/sbin/env-update && source /etc/profile"
Back to top
View user's profile Send private message
DiskBreaker
Apprentice
Apprentice


Joined: 07 Oct 2003
Posts: 224

PostPosted: Sun Jul 18, 2004 7:34 pm    Post subject: Reply with quote

AFAIK Firefox 9.0 and higher will only support a JRE 1.4.2 or higher.
(cf. the statement from the official FAQ: http://texturizer.net/firefox/faq.html#q2.2). I haven't gotten the new Firefox versions to work with Blackdown 1.3.1 either.
If anyone has a solution to this I'd really like to know. I'll try if I can get plugger to run appletviewer inside firefox for java applets, but this is not an optimal solution.

On the other hand Konqueror runs fine with IBM's JDK 1.4.2 since it accesses it directly through KJAS, the KDE Java Applet Server.

Oh, and the warning you are getting from java-config is not relevant at all, it just says that it could not find all programs for the development environment like javac etc. Since you emerged a JRE (runtime environment) and not an SDK, you won't have these binaries of course.
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Sun Jul 18, 2004 9:07 pm    Post subject: Reply with quote

Thanks for the info.
Back to top
View user's profile Send private message
tomasino
Apprentice
Apprentice


Joined: 11 Feb 2004
Posts: 154
Location: Italy, Bologna

PostPosted: Sun Jul 18, 2004 9:21 pm    Post subject: Reply with quote

DiskBreaker wrote:
AFAIK Firefox 9.0 and higher will only support a JRE 1.4.2 or higher.


maybe you mean JRE-1.4.1, I was using firefox 0.9 before IBM release the 1.4.2.
Back to top
View user's profile Send private message
DiskBreaker
Apprentice
Apprentice


Joined: 07 Oct 2003
Posts: 224

PostPosted: Sun Jul 18, 2004 11:08 pm    Post subject: Reply with quote

tomasino wrote:
maybe you mean JRE-1.4.1, I was using firefox 0.9 before IBM release the 1.4.2.

Yeah, I guess that's what I meant.

I tried a couple of things with plugger but nothing worked. I also saw that there is mozplugger, a newer branch of plugger so I might try that one as well.

I also found that there is some active development on solving this problem:
http://www.nongnu.org/gcjwebplugin/index.html
The GCJ Web Plugin for Mozilla/Firefox/Galleon uses gcj to display java applets. It requres gcc 3.4 or 3.5 though and I'm still on 3.3 so I haven't tested it yet. This would be a worthwhile alternative though if you don't want to run Konqueror.
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Sat Aug 07, 2004 9:48 pm    Post subject: Reply with quote

Just wondering have there been any success with java and firefox or galeon lately?
Back to top
View user's profile Send private message
Tarzan
n00b
n00b


Joined: 17 Sep 2003
Posts: 23

PostPosted: Sun Aug 29, 2004 6:13 pm    Post subject: Reply with quote

Same problem here. ibm-jdk-bin-1.4.2 and Firefox just can't be installed together.

Is there any way to emerge FF and have IBM's JAVA installed?
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Mon Sep 20, 2004 2:00 am    Post subject: Reply with quote

Any fix for java plug-in working with firefox or galeon yet?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum