Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
stage2 - missing file j2sdk-1_4_1-doc.zip
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
tandj
n00b
n00b


Joined: 22 May 2004
Posts: 25

PostPosted: Mon Jul 26, 2004 7:05 pm    Post subject: stage2 - missing file j2sdk-1_4_1-doc.zip Reply with quote

My system: Mac 7300 w/G3 upgrade, 352M ram, 9G external scsi

I did a stage1 bootstrap install yesterday -- took 16 hours :)

Today I started stage2.
I d/l all the files first with emerge --fetchonly system
Then I start with emerge system

After about an hour it quit saying it could not find j2sdk-1_4_1-doc.zip, and that I should d/l it from sun -- long http address -- and move it to portage/distfiles. Unfortunately, my envoronment at this point is still quite limited -- no ftp, no lynx, no links2.

How do I get this file and proceed?

TIA,
tony
Back to top
View user's profile Send private message
Tyger
n00b
n00b


Joined: 25 Jul 2004
Posts: 30
Location: Germany

PostPosted: Mon Jul 26, 2004 8:19 pm    Post subject: Reply with quote

j2sdk-1_4_1-doc.zip is not critical to your system, it's just a bunch of html-documentation about the java api. emerge your system with "-doc" in your USE-Flags. You can install the documentation always later on.

You could also emerge lynx, I don't think it depends on java, and get the file from the sun-HP. wget or ftp will not help, because you have to navigate through the sun-webpage and accept license terms to get it.

Cya, Ed
_________________
Join the adopt an unanswered question initiative now
Back to top
View user's profile Send private message
tandj
n00b
n00b


Joined: 22 May 2004
Posts: 25

PostPosted: Mon Jul 26, 2004 11:46 pm    Post subject: Reply with quote

thanks tyger. i guess i shouldn't have stuck the doc in USE, but i figured i needed all the help i could get. i removed it, and it seems to be clucking away once again.

best,
tony
Back to top
View user's profile Send private message
Tyger
n00b
n00b


Joined: 25 Jul 2004
Posts: 30
Location: Germany

PostPosted: Tue Jul 27, 2004 8:29 am    Post subject: Reply with quote

The problem is not the USE-Flag, but that the j2sdk-docs can't be retrieved automatically by emerge -f. If you check your emerge -f world output from your post above, you will see there was a warning that packages could not be retrieved.

emerge -p java-sdk-docs will show the package has fetch restrictions and what actions are necessary to get the file.

Cya
_________________
Join the adopt an unanswered question initiative now
Back to top
View user's profile Send private message
tandj
n00b
n00b


Joined: 22 May 2004
Posts: 25

PostPosted: Tue Jul 27, 2004 5:26 pm    Post subject: Reply with quote

ok, although i thought the d/l was being attempted because doc was specified in USE.

it does seem like, if not a flaw, a weakness in the install procedure that the process dies upon encountering this condition. Not that I have any idea what would be a better action. Is there a list of "packages" that need to be d/l interactively in order to respond to licensing requirements? If so, perhaps they could be d/l before doing the emerge system.

Well, just rambling. My thanks again, Tyger.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum