Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xemacs doesn't want to be emerged
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
deep
n00b
n00b


Joined: 04 May 2004
Posts: 9

PostPosted: Mon Jul 26, 2004 8:14 pm    Post subject: xemacs doesn't want to be emerged Reply with quote

Hi all
I'm trying, desperatly, to emerge xemacs but it fails all the time. I get this :

/usr/lib/libc_nonshared.a(elf-init.oS)(.got2+0x0): undefined reference to `__init_array_end'
/usr/lib/libc_nonshared.a(elf-init.oS)(.got2+0x4): undefined reference to `__init_array_start'
/usr/lib/libc_nonshared.a(elf-init.oS)(.got2+0x8): undefined reference to `__fini_array_end'
/usr/lib/libc_nonshared.a(elf-init.oS)(.got2+0xc): undefined reference to `__fini_array_start'
collect2: ld returned 1 exit status
make[1]: *** [temacs] Error 1
make[1]: Leaving directory `/var/tmp/portage/xemacs-21.4.9/work/xemacs-21.4.9/src'
make: *** [src] Erreur 2

!!! ERROR: app-editors/xemacs-21.4.9 failed.
!!! Function src_compile, Line 128, Exitcode 2
!!! (no error message)

Any idea?

Regards.
Back to top
View user's profile Send private message
liryon
n00b
n00b


Joined: 21 Aug 2003
Posts: 21
Location: Boston, MA

PostPosted: Tue Jul 27, 2004 12:58 am    Post subject: Reply with quote

I too had much trouble getting xemacs to install under ppc. I evetually found success with portage version 21.4.12. Its allreayd in portage but its not set up for ppc consumption. (and for some reason other versions which don't compile are set as the defaults). anyways you will need to emerge this ebuild.

Code:
 emerge -a /usr/portage/app-editors/xemacs/xemacs-21.4.12.ebuild


I think when I did this it compained about keywords so you may need to

Code:
 ACCEPT_KEYWORDS="~ppc"


I think when i did it some of the deps were even more unhappy about being installed and i had to add pcc to the keywords manually, hopefully you won't have to do that. But this ebuild works just great for me once i coaxed portage into leting me install it.
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Tue Jul 27, 2004 4:32 am    Post subject: Reply with quote

XEmacs is one particular application I had problem with under Gentoo. It also is my day to day tool (including for reading email), so I gotta have it no matter what. I ended up compiling it from sources, which goes uneventfully except precisely for the error you are getting. The problem is a "magic" for ppc systems which is no longer relevant (it is relevant for GCC 2.95 and below but breaks things under GCC 3.x); in fact, once eliminated the build process works without a hitch. To the point, one needs to patch the configure script as follows:
Code:
--- configure.old       2004-07-27 00:26:00.950039391 -0400
+++ configure   2004-07-27 00:27:49.003474206 -0400
@@ -2990,7 +2990,6 @@
 fi
 
 
-test "$machine$opsys" = "powerpclinux" && start_flags="-T $srcdir/src/ppc.ldscript"
 
 if test "$unexec" = "unexaix.o"; then
   if   test "$dynamic" = "no"; then

(a proper patch would consider the possibility of somebody still using GCC 2.x, but you get the picture).

I am surprised that this patch has not made it into the portage tree, Yellow Dog Linux has it for some time. You could in any case add a patch in this respect to your portage overlay, or if you are lazy (as I am) just compile the damn thing from sources and inject it afterwards. I have notified the XEmacs' developpers (a while ago) so hopefully this will be fixed upstream eventually.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum