Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Radeon Mobility m7 7500 32mb
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
scruff
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2003
Posts: 142
Location: Boston, MA

PostPosted: Fri Jul 30, 2004 3:12 pm    Post subject: Radeon Mobility m7 7500 32mb Reply with quote

I was wondering if someone can tell me the best kernel drivers and relevant xorg entries for this card. I just rebuilt Gentoo on my iBook 900mhz G3 and am having trouble with X. Using the radeon driver randomly locks X and the keyboard. Mouse pad continues to work, but there is no way to get out of X when it locks short of the power button 8O

Here is the section from my xorg.conf:
Code:

Identifier  "Card0"
Option "UseFBDev"
Driver      "radeon"
VendorName  "ATI Technologies Inc"
BoardName   "Radeon Mobility M7 LW"
BusID       "PCI:0:16:0"


And the section of my kernel config:
Code:

#
# Graphics support
#
CONFIG_FB=y
CONFIG_FB_OF=y
CONFIG_FB_RADEON=y
#
# Ftape, the floppy tape device driver
#
CONFIG_AGP=y
CONFIG_AGP_UNINORTH=y
CONFIG_DRM=y
CONFIG_DRM_RADEON=m


I had this problem before and was able to resolve it by using the r128 driver but that is a shitty workaround that results in non-existent 3D performance.

Any advice will be appreciated :)
_________________

AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ @ oc'd to 2.3ghz
DFI Lanparty UltraD nForce4 SLI
2x1gb Geil PC4000
GeForce 7800GT
Sound Blaster Audigy Platinum
200gb Maxtor DiamondMax 10
74gb WD Raptor 10k RPM
Back to top
View user's profile Send private message
killfire
l33t
l33t


Joined: 04 Oct 2003
Posts: 618

PostPosted: Fri Jul 30, 2004 3:23 pm    Post subject: Reply with quote

i had the same problem (un killable x etc.... no keyboard, only mouse)

what you should do, is load the modules at boot, instead of having x load them automatically, as xfree did.


add this to your /etc/modules.autoload.d/kernel-2.6:

agpgart
uninorth-agp
radeon

[EDIT]

misread your original post.

if you dont want to make your kernel again, only use the radeon in the modules.autoload.d/kernel-2.6, as you have uninorth-agp and agpgart compiled in

if that does not work, make them as modules, and then remake your kernel and try again, because with your exact configuration (except i have an 800mh g3) this worked for me

[/EDIT]

and then modprobe them (so you dont have to reboot)

and try starting x


killfire
Back to top
View user's profile Send private message
scruff
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2003
Posts: 142
Location: Boston, MA

PostPosted: Fri Jul 30, 2004 3:27 pm    Post subject: Reply with quote

Ok, I'll give that a try.

Thanks
_________________

AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ @ oc'd to 2.3ghz
DFI Lanparty UltraD nForce4 SLI
2x1gb Geil PC4000
GeForce 7800GT
Sound Blaster Audigy Platinum
200gb Maxtor DiamondMax 10
74gb WD Raptor 10k RPM
Back to top
View user's profile Send private message
scruff
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2003
Posts: 142
Location: Boston, MA

PostPosted: Sat Jul 31, 2004 3:08 am    Post subject: Reply with quote

Well, it was going strong all day so I went to post a reply and guess what... It locks again :roll: Right in the middle of compiling QT and transferring 3gb's of mp3's over NFS. Of course, QT and the transfer are still going. Odd huh? I ssh'd in from my desktop so I can monitor top and see when QT finishes at least.

I am going to try compiling agpgart and uninorth-agp as modules but I honestly doubt that will solve it. 99% of the time the problems arise from using modules so you compile directly in the kernel. If it is the other way around here, this will be the first I've heard of it.

If you have a minute killfire, I wouldn't mind looking over your kernel and xorg configs. Maybe you could tar 'em and email them to me.

Otherwise, anyone have any other suggestions?
_________________

AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ @ oc'd to 2.3ghz
DFI Lanparty UltraD nForce4 SLI
2x1gb Geil PC4000
GeForce 7800GT
Sound Blaster Audigy Platinum
200gb Maxtor DiamondMax 10
74gb WD Raptor 10k RPM
Back to top
View user's profile Send private message
killfire
l33t
l33t


Joined: 04 Oct 2003
Posts: 618

PostPosted: Sat Jul 31, 2004 4:21 pm    Post subject: Reply with quote

i can do better.

i already posted it, when i was working through this the first time (and the only i changed was in modules.autoload.d) so heres a link to the post (its towards the bottom)

https://forums.gentoo.org/viewtopic.php?t=200680&highlight=

hope that helps... and actually, when i was setting up alsa, i had problems when i DID compile it in.... i couldnt change the volume beyond a whisper... so it may not always be a solution to compile in :)

btw, when you ssh'd in, was the X killable? like with a kill -9 pid-of-X....?

because every time mine locked up,, i could ssh, and i could do everything else, but i co uldnt kill X....

for testing purposes, i would suggest in a root console, before you start x, use a "sleep 120 && reboot" so that you dont have to do any hard or ugly reboots... and then if it works, you can switch to that and stop it....


killfire
Back to top
View user's profile Send private message
ronmon
Veteran
Veteran


Joined: 15 Apr 2002
Posts: 1043
Location: Key West, FL

PostPosted: Sun Aug 01, 2004 12:28 pm    Post subject: Reply with quote

You can check these out if you like. I have the exact same iBook:

xorg.conf
2.6.7-gentoo-r11.config
_________________
Ask Questions the Smart Way - by ESR
Back to top
View user's profile Send private message
scruff
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2003
Posts: 142
Location: Boston, MA

PostPosted: Sun Aug 01, 2004 3:40 pm    Post subject: Reply with quote

Thanks guys I'm looking them over. ronmon's configs are little closer to mine so it shouldn't be too hard to figure it out.
_________________

AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ @ oc'd to 2.3ghz
DFI Lanparty UltraD nForce4 SLI
2x1gb Geil PC4000
GeForce 7800GT
Sound Blaster Audigy Platinum
200gb Maxtor DiamondMax 10
74gb WD Raptor 10k RPM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum