Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Nvidia Drivers with Kernel 2.6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
PhotonX
n00b
n00b


Joined: 14 Jul 2004
Posts: 33
Location: Irvine, CA

PostPosted: Sat Jul 31, 2004 8:59 am    Post subject: HOWTO: Nvidia Drivers with Kernel 2.6 Reply with quote

HOWTO: Nvidia Drivers with Kernel 2.6

After helping endless amounts of people with their nvidia drivers and kernel 2.6 i have decided to create a howto, and create it STAT. This guide also fixes errors along the lines of "incorrect module type" with nvidia.ko.
IMPORTANT: You must use xorgconfig instead of Xorg -configure as the latter will cause problems with glx.

Step 1 - Edit your packages.keywords file
Do this by typing the following as root. (su)
Code:

(If /etc/portage does not exist, type the following)
# mkdir /etc/portage/

# <editor> /etc/portage/package.keywords
(most users would "nano -w /etc/portage/package.keywords")



In this file, input the following lines
Code:

media-video/nvidia-kernel ~x86
media-video/nvidia-glx ~x86
x11-base/opengl-update ~x86


Save the file, and close the editor.

Step 2 - Emerging the driver
Execute a
Code:

# emerge nvidia-kernel nvidia-glx opengl-update
# opengl-update nvidia


After all of that, you should be set. Do NOT use ACCEPT_KEYWORDS="~x86" emerge nvidia-kernel nvidia-glx as this will mess up your dependancies sooner or later as shown in https://forums.gentoo.org/viewtopic.php?t=171464 (Thanks, GaMMa)
_________________
g2|PhotonX
Gentoo Enemy Territory Clan :: #gentoo.et @ freenode


Last edited by PhotonX on Sun Aug 01, 2004 6:47 am; edited 1 time in total
Back to top
View user's profile Send private message
mold
n00b
n00b


Joined: 31 Jul 2004
Posts: 52
Location: Essen, Germany

PostPosted: Sat Jul 31, 2004 12:00 pm    Post subject: Reply with quote

One addition: You must run a kernel that is compiled without nVidia Riva framebuffer support, as this would conflict with the nvidia drivers.
Back to top
View user's profile Send private message
thecas
n00b
n00b


Joined: 28 Jul 2004
Posts: 22

PostPosted: Sat Jul 31, 2004 3:11 pm    Post subject: Reply with quote

First of all tnx for the howto, I was just trying to configure a nvidia card.
But after your steps hardware rendering was still "no" in glxinfo. Don't you need to set your xorg.conf/XFree.conf to the "nvidia" driver instead of the "nv" driver?
After i tried this my colors are all messed up (looks like i only have 265 colors) and i get the error "couldn't find RGB GLX visual" in glxinfo

Xorg.0.log glxinfo xorg.conf

Anyone knows what could be wrong?
Back to top
View user's profile Send private message
PhotonX
n00b
n00b


Joined: 14 Jul 2004
Posts: 33
Location: Irvine, CA

PostPosted: Sat Jul 31, 2004 3:16 pm    Post subject: Reply with quote

Yes you must change your driver from nv to nvidia. enable glx as well. make sure your default depth is not 8bit but 16 or 24 bit.
_________________
g2|PhotonX
Gentoo Enemy Territory Clan :: #gentoo.et @ freenode
Back to top
View user's profile Send private message
PhotonX
n00b
n00b


Joined: 14 Jul 2004
Posts: 33
Location: Irvine, CA

PostPosted: Sat Jul 31, 2004 3:18 pm    Post subject: Reply with quote

Specifically, remove the lines that read:
Code:

   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection

_________________
g2|PhotonX
Gentoo Enemy Territory Clan :: #gentoo.et @ freenode
Back to top
View user's profile Send private message
thecas
n00b
n00b


Joined: 28 Jul 2004
Posts: 22

PostPosted: Sat Jul 31, 2004 3:36 pm    Post subject: Reply with quote

tried that allready but no luck
Back to top
View user's profile Send private message
PhotonX
n00b
n00b


Joined: 14 Jul 2004
Posts: 33
Location: Irvine, CA

PostPosted: Sat Jul 31, 2004 4:14 pm    Post subject: Reply with quote

thecas wrote:
tried that allready but no luck


Have you edited your .config for your kernel or compiled a new kernel lately? if so, you must recompile nvidia-kernel.
_________________
g2|PhotonX
Gentoo Enemy Territory Clan :: #gentoo.et @ freenode
Back to top
View user's profile Send private message
PhotonX
n00b
n00b


Joined: 14 Jul 2004
Posts: 33
Location: Irvine, CA

PostPosted: Sun Aug 01, 2004 6:48 am    Post subject: Reply with quote

the problem was found, its an xorg misconfiguration. use xorgconfig instead of Xorg -configure
_________________
g2|PhotonX
Gentoo Enemy Territory Clan :: #gentoo.et @ freenode
Back to top
View user's profile Send private message
drdebian
n00b
n00b


Joined: 07 Apr 2004
Posts: 49

PostPosted: Sun Aug 08, 2004 3:59 pm    Post subject: Reply with quote

Thanks for the howto, works like a charm!
Back to top
View user's profile Send private message
darksage
n00b
n00b


Joined: 16 Jul 2004
Posts: 8

PostPosted: Sun Aug 08, 2004 7:00 pm    Post subject: an Reply with quote

um I have been having a problem all morning and haven't found a fix
I have a fresh install of gentoo using 2.6 and I have a gforce fx5200 128meg
I emerge xorg kde nvidia-kernel nvidia-glx opengl-update, and then walked away....

when I try to use x, I get 4 screens of unresolved symbols??

Required symbol vgaHWLock from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved

any ideas?
Back to top
View user's profile Send private message
imageek
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2002
Posts: 77
Location: Richardson, TX

PostPosted: Thu Aug 12, 2004 3:12 am    Post subject: Reply with quote

my only problem with this howto, is that is seems on my system that /etc/portage/package.keywords is totally ignored :( I have several entries in it and it seems to ignore them all. Any help would be appreciated.

*edit*
DOH! i had a typo.. i had /etc/portage/pakage.keywords instead of /etc/portage/package.keywords
Back to top
View user's profile Send private message
Mekoryuk
Apprentice
Apprentice


Joined: 17 Sep 2003
Posts: 174

PostPosted: Sat Aug 14, 2004 3:21 pm    Post subject: Re: an Reply with quote

darksage wrote:
um I have been having a problem all morning and haven't found a fix
I have a fresh install of gentoo using 2.6 and I have a gforce fx5200 128meg
I emerge xorg kde nvidia-kernel nvidia-glx opengl-update, and then walked away....

when I try to use x, I get 4 screens of unresolved symbols??

Required symbol vgaHWLock from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved

any ideas?


You compiled xorg-x11 with the dlloader use flag enabled, didn't you? :wink: Recompile and leave it out.
Back to top
View user's profile Send private message
marcalj
Apprentice
Apprentice


Joined: 23 Dec 2003
Posts: 193
Location: Barcelona

PostPosted: Tue Sep 14, 2004 9:01 am    Post subject: Reply with quote

Hello, i'ts strange... I installed nvidia drivers with "ACCEPT_KEYWORDS" and use "Xorg -configure" and works for me fine.

I have unresolved symbols problems first, but re-compiled with "-dlloader" all works fine.

It's strange, isn't it?
_________________
AMD 64bits X2
porlaminima.com
Back to top
View user's profile Send private message
roterl
n00b
n00b


Joined: 25 Oct 2003
Posts: 32

PostPosted: Tue Sep 14, 2004 10:47 am    Post subject: Reply with quote

marcalj wrote:
Hello, i'ts strange... I installed nvidia drivers with "ACCEPT_KEYWORDS" and use "Xorg -configure" and works for me fine.

I have unresolved symbols problems first, but re-compiled with "-dlloader" all works fine.

It's strange, isn't it?


using ACCEPT_KEYWORDS will work fine for the first installation, but may, and probably WILL make you problems when you will update the nvidia driver and/or the kernel (look about it here)
Back to top
View user's profile Send private message
Manx
n00b
n00b


Joined: 12 Sep 2004
Posts: 5

PostPosted: Fri Sep 17, 2004 8:56 pm    Post subject: Reply with quote

i cant emerge the nvidia kernel thanks to this problem..

Code:

Your kernel was configured to include rivafb support!
 
The rivafb driver conflicts with the NVIDIA driver, please
reconfigure your kernel and *disable* rivafb support, then
try installing the NVIDIA kernel module again.


how do i disable this ? im not sure how to reconfigure my kernel :(

i just started to use linux like 2 days ago :)
_________________
/Manx
Back to top
View user's profile Send private message
Farkenell
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2003
Posts: 88

PostPosted: Sat Sep 18, 2004 10:26 am    Post subject: Reply with quote

I'm having troubles as well...but I'll get back to that in awhile after I re-emerge xorg 6.7...and update gcc see how it goes...

Manx>
when u compile your kernel with
goto ur kernel directory
cd /usr/src/linux (which is normally a link to the /usr/src/*kernel*
make menuconfig
Device Drivers --->
Graphics Support --->
and then uncheck [*] riva ;)

after that save and exit
2.6 kernel then requires u to : make && make modules_install

then copy the arch/i386/boot/bzImage to /boot (which obviously has to be mounted)

then edit ur /boot/grub/grub.conf so that the option points to the bzImage

Check the FAQs section of the forums to get a better tutorial...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum