Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Apache Problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Circuitsoft
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2004
Posts: 112

PostPosted: Tue Aug 03, 2004 7:17 am    Post subject: Apache Problem Reply with quote

I decided to completely reconfigure Apache, because I couldn't get it to work how I wanted. So. deleted the config file then did a touch apache2.conf. I then added all the AddModule statements I wanted and figured that error messages from Apache would put me to the minimum config. I was wrong. I got a Segmentation Fault when I tried to start it. I'm running Apache 2.0.49-r4 on a 266 Mhz OldWorld G3 with 256 Mb RAM. Here is my config file as it stands now...

Code:
ServerRoot /usr/lib/apache2
ServerName ilar.net
LockFile /etc/apache2/apache2.lock
PidFile /var/run/apache2.pid
ErrorLog logs/error_log
LogLevel warn

LoadModule access_module                 modules/mod_access.so
LoadModule log_config_module             modules/mod_log_config.so
LoadModule mime_magic_module             modules/mod_mime_magic.so
LoadModule mime_module                   modules/mod_mime.so
LoadModule autoindex_module              modules/mod_autoindex.so
LoadModule dir_module                    modules/mod_dir.so
LoadModule speling_module                modules/mod_speling.so
LoadModule userdir_module                modules/mod_userdir.so
LoadModule alias_module                  modules/mod_alias.so
LoadModule dav_module                    modules/mod_dav.so
LoadModule dav_fs_module                 modules/mod_dav_fs.so

<VirtualHost *:80>
        AddType application/x-http-php .php

        <Directory />
                Order Deny,Allow
                Deny from All
        </Directory>

        UserDir /home/*/Website

        <Directory /home/*/Website>
                Options Indexes FollowSymLinks
        </Directory>

        DocumentRoot /home/www/Website
</VirtualHost>


I'm eventually hoping to make http://user.ilar.net work, but I'll settle for fixing this problem now.
Back to top
View user's profile Send private message
Immortal Q
Apprentice
Apprentice


Joined: 14 Sep 2003
Posts: 241
Location: Silicone Valley

PostPosted: Sun Aug 08, 2004 6:09 am    Post subject: Reply with quote

If I were you, I'd start from scratch with the Gentoo ebuilds, then modify the existing .conf files. The gentoo layout has a nice modular approach you can use, or just hack to pieces.
_________________
Osmos.org
Now with 20% fewer rabid primates.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum