Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gcc problems with ppc64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
jgombos
n00b
n00b


Joined: 27 Jul 2004
Posts: 64

PostPosted: Tue Aug 03, 2004 4:44 pm    Post subject: gcc problems with ppc64 Reply with quote

I'm probably going to switch to another distribution, but I thought I'd document the problems with the current bleeding-edge 64 bit stage1 (which is not yet released, but available at http://dev.gentoo.org/~tgall). It crashes about an hour into the bootstrap.sh script.

I appears to me that gcc fails to compile itself, causing emerge to give up, when in reality it's probably not critical that the gcc compiler recompile itself. The workaround is probably to somehow tell emerge that if the gcc installation blows up, it's okay to continue. Anyway, here's my output log:

Code:
checking whether the C compiler ( /var/tmp/portage/libstdc++-v3-3.3.3-r1/work/build/gcc/xgcc -B/var/tmp/portage/libstdc++-v3-3.3.3-r1/work/build/gcc/ -B/usr/powerpc64-unknown-linux-gnu/bin/ -B/usr/powerpc64-unknown-linux-gnu/lib/ -isystem /usr/powerpc64-unknown-linux-gnu/include -O2 -mcpu=G5 -O2 ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
make: *** [configure-target-libiberty] Error 1

!!! ERROR: sys-libs/libstdc++-v3-3.3.3-r1 failed.
!!! Function src_compile, Line 193, Exitcode 2
!!! (no error message)

gnu-g++
--- !targe sym /usr/powerpc64-unknown-linux-gnu/gcc-bin/3.4/powerpc64-unknown-linux-gnu-c++
--- !targe sym /usr/lib/gcc-lib/powerpc64-unknown-linux-gnu/lib64/libgcc_s.so
--- !targe sym /usr/lib/gcc-lib/powerpc64-unknown-linux-gnu/3.4.0/libstdc++.so.6
--- !targe sym /usr/lib/gcc-lib/powerpc64-unknown-linux-gnu/3.4.0/libstdc++.so
--- !targe sym /usr/lib/gcc-lib/powerpc64-unknown-linux-gnu/3.4.0/libgcc_s.so
--- !targe sym /usr/lib/gcc
>>> original instance of package unmerged safely.
>>> sys-devel/gcc-3.4.0-r6 merged.
>>> emerge (2 of 2) sys-libs/libstdc++-v3-3.3.3-r1 to /
>>> md5 src_uri ;-) gcc-3.3.3.tar.bz2


BTW- this install was attempted on a dual G5.

Does anyone have suggestions for how to get up and running with a 64 bit kernel in little time? Customization is not important here, so I'm thinking Debian.


Last edited by jgombos on Tue Aug 03, 2004 4:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
jgombos
n00b
n00b


Joined: 27 Jul 2004
Posts: 64

PostPosted: Tue Aug 03, 2004 4:48 pm    Post subject: Reply with quote

Also, if I press forward with the install, pretended that bootstrap.sh went well, the emerge system command results are below (and this is probably as expected):

Code:
Which of these apply, if any? [none] 
hint to use instead? [none] 
Operating system name? [none] 
Operating system version? [none] 
Build Perl for SOCKS? [n] 
Use the PerlIO abstraction layer? [y] 
Build a threading Perl? [y] 
Use the newer interpreter-based ithreads? [y] 
Use which C compiler? [gcc] 
Checking for GNU cc in disguise and/or its version number...

*** WHOA THERE!!! ***

    Your gcc has not been compiled for the exact release of
    your operating system (Reading specs from /usr/lib/gcc/powerpc64-unknown-linux-gnu/3.4.0/specs versus ).

    In general it is a good idea to keep gcc synchronized with
    the operating system because otherwise serious problems
    may ensue when trying to compile software, like Perl.

    I'm trying to be optimistic here, though, and will continue.
    If later during the configuration and build icky compilation
    problems appear (headerfile conflicts being the most common
    manifestation), I suggest reinstalling the gcc to match
    your operating system release.

Now, how can we feed standard input to your C preprocessor...
Directories to use for library searches? [/usr/local/lib /lib /usr/lib] 
What is the file extension used for shared libraries? [so] 
Try to use long doubles if available? [n] 
Checking for optional libraries...
What libraries to use?
[-lnsl -lndbm -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lbsd] 
What optimizer/debugger flag should be used? [-O2] 
Any additional cc flags? [-fno-strict-aliasing] 
Let me guess what the preprocessor flags are...
Any additional ld flags (NOT including libraries)? [ -L/usr/local/lib] 
Checking your choice of C compiler and flags for coherency...
I've tried to compile and run the following simple program:

#include <stdio.h>
int main() { printf("Ok\n"); return(0); }

I used the command:

   gcc -o try -O2 -fno-strict-aliasing -L/usr/local/lib try.c -lnsl -lndbm -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lbsd
    ./try

and I got the following output:

/usr/lib/gcc/powerpc64-unknown-linux-gnu/3.4.0/../../../../powerpc64-unknown-linux-gnu/bin/ld: cannot find -ldb
collect2: ld returned 1 exit status
I can't compile the test program.
You have a BIG problem.  Shall I abort Configure [y] 
Ok.  Stopping Configure.
Calculating system dependencies    ...done!
>>> emerge (1 of 64) sys-devel/libperl-5.8.2 to /
>>> md5 src_uri ;-) perl-5.8.2.tar.gz
Back to top
View user's profile Send private message
tarzan420
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jul 2003
Posts: 81
Location: Fairbanks AK

PostPosted: Tue Aug 03, 2004 8:31 pm    Post subject: Reply with quote

While those don't seem to the the exact problems that I had trying stage1, i ended up taking tgall's word for it that stage3 was the only one that really works. That's what I used. (IBM iSeries box)

My question is, if you go from stage3, and then reemerge everything once you've got a working system, how different is that from a stage1 install? (other than taking even longer?)

good luck, it seems to work well for me at least.

EDIT:
I see that he's added new stages since I did my installs. Still, if you want to do things quickly with installing gentoo, the obvious solution is to go with stage3.
Back to top
View user's profile Send private message
jgombos
n00b
n00b


Joined: 27 Jul 2004
Posts: 64

PostPosted: Wed Aug 04, 2004 6:37 pm    Post subject: Reply with quote

Thanks for the suggestion tarzan420!!

I had already given up, and burned off debian and yellowdog sets, but the CDs would not boot on my G5. Only the Gentoo CDs would boot, so I was forced to tough-out my gentoo issues. (It worked out for the better- I'm glad I have gentoo working).

Tom Gall's page says stage 3 only works for the 2004.1 stages, and that all stages work for 2004.2. However, at least in my experience, stage 3 worked while stage 1 failed on me for version 2004.2.

For anyone attempting a ppc64 installation of version 2004.2:

I recommend stage 3. Also, yabootconfig failed on me following the handbook (after emerging yaboot-static). It also failed when I used the --chroot switch in the non-chrooted environment (which may not yet be documented but is a necessary way to run it). There were some good yaboot discussions in this forum that helped me get it running manually. In particular, the handbook omits the need for the -b and -o switches. I believe the -o switch is necessary on new world macs, and I think the -b switch was probably just a duplication on my part.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum