Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eth0!! booting [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Tue Aug 10, 2004 2:06 pm    Post subject: eth0!! booting [solved] Reply with quote

*Bringing eth0 up
SIOCSIFADDR: no such device
eth0: uknown interface: No such device
SIOCSIFBRDADDR: No such device
eth0: uknown interface: No such device
SIOCSIFNETMASK: NO such device

Failed to bring eth0 up

ERROR: Problem starting needed services "netmount" was not started.

:(
_________________
ibook 12" G3 800mhz 30gb 384ram


Last edited by soujirou on Tue Aug 10, 2004 3:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
golloza
Guru
Guru


Joined: 14 Mar 2004
Posts: 427

PostPosted: Tue Aug 10, 2004 3:10 pm    Post subject: Reply with quote

Obviously there's no driver for your ethernet device in the kernel.

If you compiled the driver as modules, type in modprobe <drivername>
If you didnt enable it at all, you'll have to change your kernel config and recompile the kernel.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Tue Aug 10, 2004 3:11 pm    Post subject: Reply with quote

how do i get info about what nic card i got ?
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
golloza
Guru
Guru


Joined: 14 Mar 2004
Posts: 427

PostPosted: Tue Aug 10, 2004 3:31 pm    Post subject: Reply with quote

On PC architecture: lspci or cat /proc/pci | grep Ethernet

But I don't know if this works on Macs, too.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Tue Aug 10, 2004 3:40 pm    Post subject: Reply with quote

lspci didnt work but the other thing work..

the only thing i can see that is about NIC is "sun gem" but it says nothing about a ethernet card
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
servobf
Apprentice
Apprentice


Joined: 03 Jun 2004
Posts: 160

PostPosted: Wed Aug 11, 2004 9:20 pm    Post subject: sun gem IS the card Reply with quote

In the kernel config you need to go into devices --> 10/100MB ethernet --> sun Gem card

(I'm going from memory, from work, but it's something like that)

Enable that in the kernel (built in is great, module would probably work, if loaded at boot) and try again. :-)

~Michael
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum