Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eth0 modprobe tulip
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
TurkisH
n00b
n00b


Joined: 15 Aug 2004
Posts: 66
Location: @ /home

PostPosted: Sun Aug 15, 2004 1:26 am    Post subject: eth0 modprobe tulip Reply with quote

hiya,

Ik heb zo juist mijn gentoo installatie succesvol beeindigd, echter na het opstarten werkt mijn internet niet meer. Dit komt waarschijnlijk door het feit dat tijdens de gentoo installatie ik mijn netwerk-kaart werkend kreeg door
Code:

modprobe tulip

Nu zegt hij tijdens het opstarten van mijn geinstalleerde gentoo systeem dat hij mijn eth0 niet kan vinden, nu heb ik geprobeerd nogmaals modprobe tulip te doen, maar dan krijg ik: modprobe: Can't locate module tulip. Hoe krijg ik dit werkend, gezien dit mijn eerste ervaring met linux is heb ik geen flauw idee hoe dit op te lossen.
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Sun Aug 15, 2004 8:22 am    Post subject: Reply with quote

Je bent toevallig niet vergeten de module voor je netwerkkaart (tulip dus) mee te compileren toen je je kernel compileerde?
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
TurkisH
n00b
n00b


Joined: 15 Aug 2004
Posts: 66
Location: @ /home

PostPosted: Sun Aug 15, 2004 10:53 am    Post subject: Reply with quote

theBlackDragon wrote:
Je bent toevallig niet vergeten de module voor je netwerkkaart (tulip dus) mee te compileren toen je je kernel compileerde?


Daar ben ik wel bang voor, hoe kan ik dit rechtbrijen? Aangezien die module ergens op die LiveCD moet staan, kan ik hem dan niet alsnog compileren, en zo ja hoe?
Back to top
View user's profile Send private message
bravecobra
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2002
Posts: 130
Location: Planet Earth (sometimes)

PostPosted: Sun Aug 15, 2004 12:18 pm    Post subject: Reply with quote

ff terug booten met de livecd, terug chrooten en dan de module erbij compileren. Vergeet die trouwens ook niet te laden tijdens het bootprocess.
_________________
Brave Cobra
http://www.bravecobra.com
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Sun Aug 15, 2004 12:45 pm    Post subject: Reply with quote

bravecobra wrote:
ff terug booten met de livecd, terug chrooten en dan de module erbij compileren. Vergeet die trouwens ook niet te laden tijdens het bootprocess.


Waarom terug booten? Hij kan inloggen hé...

Gewoon naar /usr/src/linux gaan make menuconfig (of make xconfig/gconfig als je in X zit) typen. In je kernel configuratie naar Device Drivers :arrow: Networking support :arrow: Ethernet (10 or 100Mbit) :arrow: Tulip family network device support (ik ga er van uit dat je een 2.6 kernel gebruikt)
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
TurkisH
n00b
n00b


Joined: 15 Aug 2004
Posts: 66
Location: @ /home

PostPosted: Sun Aug 15, 2004 12:46 pm    Post subject: Reply with quote

Heb wat verder onderzoek gedaan en wat dingen geprobeerd. Heb
Code:

cd /usr/src/linux
make menuconfig

Hier mijn tulip driver geselecteerd en dit
Code:

make dep && make bzImage modules modules_install

Daarna weer modprobe tulip geprobeerd, maar pakte nog steeds niet. Toen heb ik gezocht naar die module tulip.o
Code:

find / -name tulip.o -print
Gaf:
/usr/src/linux-2.4.26-gentoo-r8/drivers/net/tulip/tulip.o

Dus hij staat er wel, waarom kan ik hem dan niet laden en als ik hem kan laden hoe zet ik hem dan ook in bootsequence?
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Sun Aug 15, 2004 12:49 pm    Post subject: Reply with quote

Ben je make modules_install niet vergeten uitvoeren? Want geïnstalleerde modules moetn in /lib/modules/<kernelversie> staan.
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
TurkisH
n00b
n00b


Joined: 15 Aug 2004
Posts: 66
Location: @ /home

PostPosted: Sun Aug 15, 2004 12:54 pm    Post subject: Reply with quote

theBlackDragon wrote:
Ben je make modules_install niet vergeten uitvoeren? Want geïnstalleerde modules moetn in /lib/modules/<kernelversie> staan.

Wederom bedankt voor je reply, maar hierboven had ik gezegd dat ik na het selecteren van de tulip ik heb gedaan:
Code:

make dep && make bzImage modules modules_install 

Dus volgens mij is dat gedaan :?:
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Sun Aug 15, 2004 2:30 pm    Post subject: Reply with quote

Hmm, lijkt me vreemd, om een of andere reden wordt die module dus niet gecompileerd, je kan proberen make modules_install nog eens apart te runnen ofzo, als dat niets uithaalt zou ik de driver in je kernel inbakken.

hth
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
TurkisH
n00b
n00b


Joined: 15 Aug 2004
Posts: 66
Location: @ /home

PostPosted: Sun Aug 15, 2004 4:23 pm    Post subject: Reply with quote

Heb dat modules_install nogmaals geprobeerd zonder succes. Wat bedoel je met de driver in de kernel inbakken?
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Sun Aug 15, 2004 4:38 pm    Post subject: Reply with quote

Je hebt normaalgezien de keuze je driver als module te compileren of om hem vast in de kernel te compileren. Ik compileer normaalgezien levensnoodzakelijke zaken in de kernel om miserie te vermijden (oops, de module voor m'n toetsenbord is kaput... :wink: )

Ik hoop dat dit iets verduidelijkt heeft...
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
TurkisH
n00b
n00b


Joined: 15 Aug 2004
Posts: 66
Location: @ /home

PostPosted: Sun Aug 15, 2004 5:24 pm    Post subject: Reply with quote

Lol dit verduidelijkt ja, ik ga ermee aan de slag en laat nog wel weten of het gelukt is, bedankt voor al de hulp

en suc6 met je toetsenbord :P
Back to top
View user's profile Send private message
guni
Apprentice
Apprentice


Joined: 18 May 2003
Posts: 193
Location: Belgium lommel

PostPosted: Sun Aug 15, 2004 10:19 pm    Post subject: Reply with quote

TurkisH wrote:
Lol dit verduidelijkt ja, ik ga ermee aan de slag en laat nog wel weten of het gelukt is, bedankt voor al de hulp

en suc6 met je toetsenbord :P


Heb je een laptop of een gewone pc?

ff vraagske (kan belangrijk zijn )
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Mon Aug 16, 2004 8:57 am    Post subject: Reply with quote

guni wrote:
TurkisH wrote:
Lol dit verduidelijkt ja, ik ga ermee aan de slag en laat nog wel weten of het gelukt is, bedankt voor al de hulp

en suc6 met je toetsenbord :P


Heb je een laptop of een gewone pc?

ff vraagske (kan belangrijk zijn )


Voor de duidelijkheid: er mankeert niets met m'n toetsenbord... ;)
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
guni
Apprentice
Apprentice


Joined: 18 May 2003
Posts: 193
Location: Belgium lommel

PostPosted: Mon Aug 16, 2004 12:26 pm    Post subject: Reply with quote

theBlackDragon wrote:
guni wrote:
TurkisH wrote:
Lol dit verduidelijkt ja, ik ga ermee aan de slag en laat nog wel weten of het gelukt is, bedankt voor al de hulp

en suc6 met je toetsenbord :P


Heb je een laptop of een gewone pc?

ff vraagske (kan belangrijk zijn )


Voor de duidelijkheid: er mankeert niets met m'n toetsenbord... ;)

ik had het ook tegen turkish
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Tue Aug 17, 2004 6:18 am    Post subject: Reply with quote

guni wrote:
theBlackDragon wrote:
guni wrote:
TurkisH wrote:
Lol dit verduidelijkt ja, ik ga ermee aan de slag en laat nog wel weten of het gelukt is, bedankt voor al de hulp

en suc6 met je toetsenbord :P


Heb je een laptop of een gewone pc?

ff vraagske (kan belangrijk zijn )


Voor de duidelijkheid: er mankeert niets met m'n toetsenbord... ;)

ik had het ook tegen turkish


Ah oké :wink:

Anyway, ik denk niet dat dat hier uitmaakt, het lijkt me dat zijn module gewoon niet gecompileerd wordt, niet dat hij de verkeerde module compileerd...
Hetgeen ik eigenlijk wel vrij vreemd vind, maar soit.
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
guni
Apprentice
Apprentice


Joined: 18 May 2003
Posts: 193
Location: Belgium lommel

PostPosted: Tue Aug 17, 2004 12:28 pm    Post subject: Reply with quote

Mja twas omdat hij niet vermelde of het om een pcmcia kaartje ging, dus da wou ik ff checken...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum