Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can not boot G5 with 2004.2 LiveCD
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
xyz
n00b
n00b


Joined: 29 Oct 2003
Posts: 67

PostPosted: Tue Aug 17, 2004 1:53 am    Post subject: Can not boot G5 with 2004.2 LiveCD Reply with quote

I tried to boot my G5 DP from 2004.2 livecd (http://www.metadistribution.org/gentoo/). I selected G5-SMP at boot prompt, and it loaded kernel, showed some messages quiclkly, and went to black screen. I had to shut down my computer by power button. I also tried the "video=" parameter at boot prompt, but no avail.
Has some one met the same problem?


Dehua
Back to top
View user's profile Send private message
bad111
n00b
n00b


Joined: 17 Aug 2004
Posts: 13

PostPosted: Tue Aug 17, 2004 5:23 am    Post subject: Reply with quote

Have had the same prob with all of the 2004.2 CDs, but never got around to posting about it. I have no problems booting with the 2004.1 CDs though. My system is a Dual 2ghz - june 04 model.

-bill
Back to top
View user's profile Send private message
Tesseract
n00b
n00b


Joined: 03 Jun 2004
Posts: 21

PostPosted: Thu Aug 19, 2004 4:06 pm    Post subject: Reply with quote

I am also unable to boot from the livecd. I have tried the 2004.2 and 2004.1 minimal livecds, and neither one even makes it to the bootloader. I just get stuck with a grey screen. I assume that the bootloader & kernel would be the same on the full livecd so there's no point trying it.

My system is a Dual 2.5 GHz G5, so I don't suppose much (if any) testing will have been done on this model. :(
Back to top
View user's profile Send private message
bad111
n00b
n00b


Joined: 17 Aug 2004
Posts: 13

PostPosted: Fri Aug 20, 2004 2:36 pm    Post subject: Reply with quote

Sounds as if the new ibook g4's have a similar problem. Maybe all recent macs are having a prob with 2004.2? xyz, how old is your G5 DP? is it a june 04 model as well?
Back to top
View user's profile Send private message
xyz
n00b
n00b


Joined: 29 Oct 2003
Posts: 67

PostPosted: Fri Aug 20, 2004 9:58 pm    Post subject: Reply with quote

[quote="bad111"]Sounds as if the new ibook g4's have a similar problem. Maybe all recent macs are having a prob with 2004.2? xyz, how old is your G5 DP? is it a june 04 model as well?[/quote]

No. I bought it last October.
Back to top
View user's profile Send private message
Tesseract
n00b
n00b


Joined: 03 Jun 2004
Posts: 21

PostPosted: Sat Aug 21, 2004 4:17 pm    Post subject: Reply with quote

Has anybody opened a bug on this topic in bugzilla?
Back to top
View user's profile Send private message
bad111
n00b
n00b


Joined: 17 Aug 2004
Posts: 13

PostPosted: Sun Aug 22, 2004 8:31 pm    Post subject: Reply with quote

video=ofonly makes it freeze with text on the screen, rather than just the black screen! ooohhhh aahhhhhh! hehehehe
Back to top
View user's profile Send private message
Tesseract
n00b
n00b


Joined: 03 Jun 2004
Posts: 21

PostPosted: Sun Aug 22, 2004 9:51 pm    Post subject: Reply with quote

I've opened a bug about my issue. Since you guys seem to be experiencing something a bit different, I guess it should be a separate bug.
Back to top
View user's profile Send private message
Tesseract
n00b
n00b


Joined: 03 Jun 2004
Posts: 21

PostPosted: Mon Aug 23, 2004 5:28 am    Post subject: Reply with quote

Does the text look something like this, bad111?

Code:
... ok
opening display /pci@0,f0000000/ATY,ElanParent@10/ATY,Elan_B@1... ok
copying OF device tree...done
starting cpu /cpus/PowerPC,G5...failed: 00000000
calling quiesce ...
returning 0x01400000 from prom_init
_


If so, then we have the same problem. (My initial problem was that my superdrive was jumpered to slave rather than master -- worked fine for reading CDs in OS X but couldn't boot from it...)
Back to top
View user's profile Send private message
bad111
n00b
n00b


Joined: 17 Aug 2004
Posts: 13

PostPosted: Tue Aug 24, 2004 12:23 am    Post subject: Reply with quote

That text seems familiar, and I remember thinking "g5...failed?" , but I get those same lines when I boot into 2004.1 (Which boots fine). I believe there is more text after that as well.

I'm just going to use the 2004.1 CD and install using the 2004.2 stages, etc, I'm just worried about not being able to get my fans under control .... because during installation they sound like jet engines.
Back to top
View user's profile Send private message
Tesseract
n00b
n00b


Joined: 03 Jun 2004
Posts: 21

PostPosted: Tue Aug 24, 2004 7:20 am    Post subject: Reply with quote

Hmm, it would be nice if I could do the same, but unfortunately I have the same problem with both 2004.2 and 2004.1. I never get anything more than the text I quoted. I wonder if it could possibly be my video card (Radeon 9800XT)?

Thermal management may indeed be an issue. I read that the current G5 fan control module doesn't work properly on newer G5s. There will probably be even more issues with mine since it has the liquid cooling system...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum