Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AltGR again [fixed]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sat Aug 21, 2004 3:25 pm    Post subject: AltGR again [fixed] Reply with quote

yo.. i have checked here at forums about AltGr in X on a G3 ibook.. it works in console mode when i enter "125 = AltGr" in sv-latin1, the showkeys tells me that it is keycode "125" and xev tells me that in X it is 115, but i still dont get it tor work. in the XF86Config-4 file i have tested many things..

nodeadkeys, modeshift and so on..

what the heck is the problem ?
_________________
ibook 12" G3 800mhz 30gb 384ram


Last edited by soujirou on Tue Aug 24, 2004 11:51 am; edited 1 time in total
Back to top
View user's profile Send private message
HighOnBonsai
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 260

PostPosted: Sat Aug 21, 2004 5:27 pm    Post subject: Reply with quote

Hey, soujirou again! ;-)

Have you tried xmodmap and configured the ~/.Xmodmap file?? Via xmodmap you can re-define the keymappings.

Christopher
_________________
Are YOU high - on bonsai?
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sat Aug 21, 2004 6:26 pm    Post subject: Reply with quote

yo yo!! thnx...

hum the only Xmodfile i find was in /usr/share/doc/kbd-1.12-r2/html/dvorak/dvorak.xmodmap
is it that one ?
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
HighOnBonsai
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 260

PostPosted: Sun Aug 22, 2004 8:20 am    Post subject: Reply with quote

I have the following .Xmodmap file in my home directory (recognize the dot before the filename!!):

Code:
keycode 115 = Mode_switch
keycode 24 = q Q at at
keycode 26 = e E EuroSign EuroSign
keycode 94 = less greater bar
keycode 46 = l L at threesuperior
keycode 108 = Delete
keycode 16 = 7 slash braceleft
keycode 17 = 8 parenleft bracketleft
keycode 18 = 9 parenright bracketright
keycode 19 = 0 equal braceright


You can test the settings by
Code:
$ xmodmap ~/.Xmodmap


This settings are working for my PB15" my a german keyboard layout - but I guess they should work - with some exceptions - for your iBook too (just give a try!)

The additional (and under Linux useless) second "Enter" key is mapped to the non-existent "Delete" key (not Backspace) in my configuration.

If you want more information try a:
Code:
 man xmodmap




Christopher
_________________
Are YOU high - on bonsai?
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sun Aug 22, 2004 2:30 pm    Post subject: Reply with quote

hi again.. many thanks,,

i created a .Xmodmap file and i put "keycode 115 = Mode_switch" in it.. is that the line that should get the AltGR button to work in X ?

shouldnt it be like Keycode 115 = AltGr ? i did test that but it didnt work..

1337#xmodmap
xmodmap: up to 2 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x6d)
mod1 Alt_L (0x40), Alt_R (0x71)
mod2 Num_Lock (0x4d)
mod3
mod4
mod5 Scroll_Lock (0x4e)

1337#
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
HighOnBonsai
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 260

PostPosted: Sun Aug 22, 2004 3:47 pm    Post subject: Reply with quote

Have you tried all the settings of my file? I mean just copy and paste it!


Christopher
_________________
Are YOU high - on bonsai?
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sun Aug 22, 2004 4:43 pm    Post subject: Reply with quote

yes i did..

everything went ok when i typed "xmodmap /root/.Xmodmap"


The keyboard has another interesting issue: notice the lack of the AltGr button. The solution is quite simple: through the small xmodmap utility you can find the keycode of every key on the keyboard. Then you can assign a specific function or map to it by writing some lines in a .Xmodmap file stored in your home directory. For example, the keycode of the Apple key is 115, so you can write keycode 115 = Multi_key in the file, and the Apple key then will work as AltGr.

hum if i test "Multi_key" instead of "Mode_switch" it comes nothing.. when using "Mode_switch" it becomes a still only a "2"
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Tue Aug 24, 2004 11:51 am    Post subject: Reply with quote

fixed it by this

http://www.yellowdoglinux.com/support/solutions/ydl_general/keyboard_german.shtml
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum