Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pinnacle PCTV Pro: kernelmodules, overlay en geluid
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
E.T.
n00b
n00b


Joined: 01 Aug 2004
Posts: 52

PostPosted: Tue Aug 24, 2004 2:37 pm    Post subject: Pinnacle PCTV Pro: kernelmodules, overlay en geluid Reply with quote

Hallo,

Ik ben de trotse bezitter van een Pinnacle PCTV Pro tv-kaart (pci). Onder mandrake werkte deze altijd vlot van bij de installatie. Nu ik overgeschakeld ben op gentoo, is dit niet meer het geval. Waarschijnlijk ben ik een of andere module of zo vergeten in de kernel te compileren. Wat zijn nu precies de problemen?

1. Overlay werkt niet. Dit is de methode waarbij het beeld rechtstreeks in het geheugen van je videokaart geschreven wordt (dacht ik toch) om zo de processor te ontlasten. Nu kan ik wel beeld krijgen, doch enkel via grabbing en dat vindt mijn pc niet zo leuk, zeker niet als ik die ondertussen een paar andere zaken laat uitvoeren: het beeld beeft dan veel te veel. (had ik dus niet bij overlay vroeger)
Xawtv runnen in konsole geeft "VIDIOC_OVERLAY(int=1): Ongeldig argument". Zie hieronder voor meer output.

2. Geluid krijg ik er al helemaal niet uit. De oorzaak ligt misschien bij een of andere module die ik vergeten te compileren ben in de kernel. Daarom volgende vraag:

Heeft er iemand enig idee welke modules of kernelonderdelen er nog ontbreken in mijn configuratie? Het (voor dit probleem) relevante gedeelte van mijn .config: zie hieronder, net zoals het relevante deel van dmesg.

Alleszins vreewel merci!



.config:

# I2C support
CONFIG_I2C=y
CONFIG_I2C_CHARDEV=y

# I2C Algorithms
CONFIG_I2C_ALGOBIT=y
# CONFIG_I2C_ALGOPCF is not set

# Multimedia devices
CONFIG_VIDEO_DEV=y

# Video For Linux
# Video Adapters
CONFIG_VIDEO_BT848=y
# CONFIG_VIDEO_BWQCAM is not set
# CONFIG_VIDEO_CQCAM is not set
# CONFIG_VIDEO_CPIA is not set
CONFIG_VIDEO_SAA5246A=m
CONFIG_VIDEO_SAA5249=m
# CONFIG_TUNER_3036 is not set
# CONFIG_VIDEO_STRADIS is not set
# CONFIG_VIDEO_ZORAN is not set
# CONFIG_VIDEO_SAA7134 is not set
# CONFIG_VIDEO_MXB is not set
# CONFIG_VIDEO_DPC is not set
# CONFIG_VIDEO_HEXIUM_ORION is not set
# CONFIG_VIDEO_HEXIUM_GEMINI is not set
# CONFIG_VIDEO_CX88 is not set
# CONFIG_VIDEO_OVCAMCHIP is not set

#
# Radio Adapters
#
# CONFIG_RADIO_GEMTEK_PCI is not set
# CONFIG_RADIO_MAXIRADIO is not set
# CONFIG_RADIO_MAESTRO is not set


dmesg:

Linux version 2.6.7-gentoo-r11 (root@Sylvain) (gcc versie 3.3.3 20040412 (Gentoo Linux 3.3.3-r6, ssp-3.3.2-2, pie-8.7.6)) #2 Mon Aug 2 14:57:04 CEST 2004
Linux video capture interface: v1.00
bttv: driver version 0.9.14 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:02:09.0, irq: 3, latency: 64, mmio: 0xf6afe000
bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012
bttv0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00fffbdf [init]
bttv0: i2c: checking for MSP34xx @ 0x80... found
bttv0: pinnacle/mt: id=2 info="PAL+SECAM / stereo" radio=yes
bttv0: using tuner=33
bttv0: i2c: checking for MSP34xx @ 0x80... found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: registered device radio0
bttv0: PLL: 28636363 => 35468950 .. ok
msp34xx: init: chip=MSP3410G-B11 +nicam +simple +radio
msp3410: daemon started
tvaudio: TV audio decoder + audio/video mux driver
tvaudio: known chips: tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54 (PV951),ta8874z
tuner: chip found at addr 0xc0 i2c-bus bt878 #0 [sw]
tuner: type set to 33 (MT20xx universal) by bt878 #0 [sw]
tuner: microtune: companycode=4d54 part=04 rev=04
tuner: microtune MT2032 found, OK
tda9887: chip found @ 0x86



bash-2.05b$ xawtv > xawtv-error
This is xawtv-3.86, running on Linux/i686 (2.6.7-gentoo-r11)
WARNING: Your X-Server has no DGA support.
WARNING: couldn't find framebuffer base address, try manual
configuration ("v4l-conf -a <addr>")
Warning: Cannot convert string
"-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
Xlib: extension "GLX" missing on display ":0.0".
ioctl: VIDIOC_OVERLAY(int=1): Ongeldig argument
Back to top
View user's profile Send private message
E.T.
n00b
n00b


Joined: 01 Aug 2004
Posts: 52

PostPosted: Tue Aug 24, 2004 7:49 pm    Post subject: Reply with quote

Ondertussen heb ik ondersteuning voor de Conexant bt848 chip bijgecompileerd, zonder resultaat.
Back to top
View user's profile Send private message
E.T.
n00b
n00b


Joined: 01 Aug 2004
Posts: 52

PostPosted: Tue Aug 24, 2004 11:04 pm    Post subject: Re: Pinnacle PCTV Pro: kernelmodules, overlay en geluid Reply with quote

E.T. wrote:
1. Overlay werkt niet.


Dit is al opgelost. Voor de geïnteresseerden: ik heb in XF86Config de lijn "Option "omit xfree86-dga"" uitgecommentarieerd. Ik heb echter nog steeds geen geluid. De output van xawtv staat hieronder. Zouden die warning en die error daar iets mee te maken kunnen hebben?


bash-2.05b$ xawtv
This is xawtv-3.86, running on Linux/i686 (2.6.8-gentoo-r1)
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
Xlib: extension "GLX" missing on display ":0.0".
Back to top
View user's profile Send private message
E.T.
n00b
n00b


Joined: 01 Aug 2004
Posts: 52

PostPosted: Thu Aug 26, 2004 5:44 pm    Post subject: Reply with quote

Geluid is opgelost ondertussen: het kabeltje dat mijn tv-kaart moet verbinden met de lijningang van mijn geluidskaart, zat ergens verkeerd.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum