Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema Com emerge KDE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
skycrow
n00b
n00b


Joined: 20 Jul 2004
Posts: 24

PostPosted: Tue Aug 24, 2004 7:00 pm    Post subject: Problema Com emerge KDE Reply with quote

:D Acabei de instalar o Gentoo , e logo depois tentei dar um "emerge kde" so que quando ele chega num arquivo chamando "pango-1.4.1" ele dá problema não consegue compilar, baixei ele separadamente na versão 1.5.0 instalei..reinicie o sistema e mesm oassim ele continua pedindo este arquivo na versão mais antiga...Aglêm poderia me ajudar? :?:
Back to top
View user's profile Send private message
Gotterdammerung
l33t
l33t


Joined: 11 Feb 2004
Posts: 627
Location: Rio de Janeiro, Brazil

PostPosted: Tue Aug 24, 2004 7:10 pm    Post subject: Reply with quote

como vc já instalou uma versão mais recente, pode tentar fazer um inject do pacote antigo e continuar a compilação:

Code:
emerge --inject "=x11-libs/pango-1.4.1"

_________________
A mind that is stretched by a new experience can never go back to its old dimensions. - Oliver Wendell Holmes
Back to top
View user's profile Send private message
skycrow
n00b
n00b


Joined: 20 Jul 2004
Posts: 24

PostPosted: Sat Aug 28, 2004 5:49 pm    Post subject: Reply with quote

Então graças a dica do nosso amigo ai em cima, e masi algumas configurações adicionas eu consgui instalar o Kde através do Emerge.. 8)
So que eu preciso configurar o X86config para configurar o driver de video, o mouse que é usb so que eu não consigo achar este arquivo de configuração. eu Terei que cria-lo?
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Sat Aug 28, 2004 8:39 pm    Post subject: Reply with quote

skycrow wrote:
So que eu preciso configurar o X86config para configurar o driver de video, o mouse que é usb so que eu não consigo achar este arquivo de configuração. eu Terei que cria-lo?

É o arquivo /etc/X11/xorg.conf para Xorg ou XF86Config para XFree. Se não existir nenhum, crie um.
Back to top
View user's profile Send private message
skycrow
n00b
n00b


Joined: 20 Jul 2004
Posts: 24

PostPosted: Mon Aug 30, 2004 1:17 am    Post subject: Reply with quote

:arrow: Blz Essa era a minha dúvida. tá instalado so preciso descobrir porque as fontes do kde estão bem pequenas...que pena que deu problema nos drivers da Nvidia falando que o kernel(eu usei o genkernel) foi compilado com uma opcão que pode conflitar com o driver, então estou tendo que usar o padrão "nv". eu poderia compilar outro tipo de kernel e escolher em qual eu posso dar boot?
Back to top
View user's profile Send private message
Gotterdammerung
l33t
l33t


Joined: 11 Feb 2004
Posts: 627
Location: Rio de Janeiro, Brazil

PostPosted: Mon Aug 30, 2004 11:37 am    Post subject: Reply with quote

skycrow wrote:
:arrow: Blz Essa era a minha dúvida. tá instalado so preciso descobrir porque as fontes do kde estão bem pequenas...que pena que deu problema nos drivers da Nvidia falando que o kernel(eu usei o genkernel) foi compilado com uma opcão que pode conflitar com o driver, então estou tendo que usar o padrão "nv". eu poderia compilar outro tipo de kernel e escolher em qual eu posso dar boot?


Para vc poder usar os drivers da NVidia, você tem que excluir o driver genérico "nv" do kernel. E caso você queira ter vários kernels instalados na máquina, isso também é possível. Contudo, só para frisar, para usar os drivers da NVidia em um desses kernels, você deverá excluir (ou não incluir) o driver genérico "nv".

Abs!
_________________
A mind that is stretched by a new experience can never go back to its old dimensions. - Oliver Wendell Holmes
Back to top
View user's profile Send private message
skycrow
n00b
n00b


Joined: 20 Jul 2004
Posts: 24

PostPosted: Mon Aug 30, 2004 3:59 pm    Post subject: Reply with quote

:arrow: Fimz um emerge para o nvidia-kernels, configurei e confirmeio se o modulo estava carregado e sendo carregado no iniciar tudo ok. Mas não funciona com o driver da nvidia apenas com o "nv" mesmo. Ai baixei os Drivers direto do site da nvidia, fui rodar e ele me dei a mesnsagem que o meu Kernel foi configurado com para incluir um danado de "RivaFb" e que este módulo pode dar conflito com os drivers da nvidia podendo não funcionar (é o que está acontecendo)heheh. :!: Agora com o comando lsmod eu não vejo este danado carregado, como será que eu posso tirá-lo?
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Mon Aug 30, 2004 6:02 pm    Post subject: Reply with quote

skycrow wrote:
:arrow: Fimz um emerge para o nvidia-kernels, configurei e confirmeio se o modulo estava carregado e sendo carregado no iniciar tudo ok. Mas não funciona com o driver da nvidia apenas com o "nv" mesmo. Ai baixei os Drivers direto do site da nvidia, fui rodar e ele me dei a mesnsagem que o meu Kernel foi configurado com para incluir um danado de "RivaFb" e que este módulo pode dar conflito com os drivers da nvidia podendo não funcionar (é o que está acontecendo)heheh. :!: Agora com o comando lsmod eu não vejo este danado carregado, como será que eu posso tirá-lo?


Se o lsmod nao acusa o rivafb, eh porque tu compilaste ele dentro do kernel (e nao como modulo). Edita teu .config e retira o CONFIG_FB_RIVA (acho que eh esse o vilao).
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
skycrow
n00b
n00b


Joined: 20 Jul 2004
Posts: 24

PostPosted: Tue Aug 31, 2004 3:54 pm    Post subject: Reply with quote

:arrow: Bom editei achei este danado coloquei uam Cerquilha na frente "#" Reinicie mas não deu certo não.... :(
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Tue Aug 31, 2004 4:29 pm    Post subject: Reply with quote

skycrow wrote:
:arrow: Bom editei achei este danado coloquei uam Cerquilha na frente "#" Reinicie mas não deu certo não.... :(


recompilaste o kernel e bootou com a nova imagem?
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
skycrow
n00b
n00b


Joined: 20 Jul 2004
Posts: 24

PostPosted: Tue Aug 31, 2004 6:28 pm    Post subject: Reply with quote

Hummm NãNãninãnão. Eu tinha usado o genkernel. Agora então vou ter uqe fazer de outro modo....não é?
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Tue Aug 31, 2004 7:06 pm    Post subject: Reply with quote

Eh bom dares uma olhada na documentacao
de como compilar o kernel
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Gotterdammerung
l33t
l33t


Joined: 11 Feb 2004
Posts: 627
Location: Rio de Janeiro, Brazil

PostPosted: Tue Aug 31, 2004 8:50 pm    Post subject: Reply with quote

tenta

Code:
genkernel --menuconfig all

_________________
A mind that is stretched by a new experience can never go back to its old dimensions. - Oliver Wendell Holmes
Back to top
View user's profile Send private message
alexandre_parente
n00b
n00b


Joined: 29 Jun 2003
Posts: 37

PostPosted: Thu Sep 02, 2004 7:28 am    Post subject: Reply with quote

skycrow voce vai ter que recompilar o kernel.

Lembre-se de nao apagar o kernel antigo para caso ocorra algum erro voce poder entrar no sistema novamente. crie duas entradas no grub ou lilo , uma para o kernel velho e outra para o novo.

aconselho voce a ler o "guia foca" é em portugues e bem didatico.

Outra documentacao que aborda exatamente o que voce precisa eh essa;
http://www.gentoo.org/doc/en/nvidia-guide.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum