Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Install freenx
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 28, 29, 30  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
SeanHarmer
n00b
n00b


Joined: 29 Aug 2003
Posts: 22
Location: Macclesfield, UK

PostPosted: Tue Feb 15, 2005 12:48 pm    Post subject: Reply with quote

I installed the freenx server and it's dependencies along with nxssh today. The install seemed to go fine but when I try to connect to the freenx server using nxclient the connection fails with this error message in the details box:

Code:
NX> 203 NXSSH running with pid: 25132
nxssh: illegal option -- S
Usage: nxssh [options] host [command]
Options:
  -nx         Use ssh in nx mode. (Only if it is first argument)
  -delkey known_hosts row  Delete the key in known_hosts
  -l username   Log in using this username.
  -n          Redirect input from /dev/null.
  -F config   Config file (default: ~/.ssh/config).
  -A          Enable authentication agent forwarding.
  -a          Disable authentication agent forwarding (default).
  -X          Enable X11 connection forwarding.
  -x          Disable X11 connection forwarding (default).
  -i file     Identity for public key authentication (default: ~/.ssh/identity)
  -t          Tty; allocate a tty even if command is given.
  -T          Do not allocate a tty.
  -v          Verbose; display verbose debugging messages.
              Multiple -v increases verbosity.
  -V          Display version number only.
  -P          Don't allocate a privileged port.
  -q          Quiet; don't display any warning messages.
  -f          Fork into background after authentication.
  -e char     Set escape character; ``none'' = disable (default: ~).
  -c cipher   Select encryption algorithm
  -m macs     Specify MAC algorithms for protocol version 2.
  -p port     Connect to this port.  Server must be on the same port.
  -L listen-port:host:port   Forward local port to remote address
  -R listen-port:host:port   Forward remote port to local address
              These cause nxssh to listen for connections on a port, and
              forward them to the other side by connecting to host:port.
  -D port     Enable dynamic application-level port forwarding.
  -C          Enable compression.
  -N          Do not execute a shell or command.
  -g          Allow remote hosts to connect to forwarded ports.
  -1          Force protocol version 1.
  -2          Force protocol version 2.
  -4          Use IPv4 only.
  -6          Use IPv6 only.
  -o 'option' Process the option as if it was read from a configuration file.
  -s          Invoke command (mandatory) as SSH2 subsystem.
  -b addr     Local IP address.



Any ideas?
_________________
Just because I don't care, it doesn't mean that I don't understand.
- Homer J. Simpson
Back to top
View user's profile Send private message
SilentShadow
n00b
n00b


Joined: 25 Oct 2004
Posts: 36
Location: Italia

PostPosted: Wed Feb 16, 2005 12:04 pm    Post subject: Reply with quote

Hi,

I'have installed freenx and seems to work very well (few test for now)

Anyone can explain me the difference from the free edition against the commercial (nomachine) edition.
I want to test this solution on a commercial enviroment and may be put it in production, but i'm not sure about the license.

another question is that i try to install the nxclient on a client macchine but it has as dependency the nx-x11 packages, why?
I can't install the client without the server?

thanks
Bye Dario

p.s. the home page in the ebuild is wrong, or in under construction, you know another home page for freenx?
Back to top
View user's profile Send private message
SilentShadow
n00b
n00b


Joined: 25 Oct 2004
Posts: 36
Location: Italia

PostPosted: Wed Feb 16, 2005 12:07 pm    Post subject: Reply with quote

hi SeanHarmer

try to emerge the masked nxssh package. you have the wrong (old) version.

my /etc/portage/package.keyword file have this line
Code:

net-misc/nxclient ~x86
net-misc/nx-x11 ~x86
net-misc/nxproxy ~x86
net-misc/nxserver-freenx ~x86
net-misc/nxserver-freenx ~x86
net-misc/nxssh ~x86


and the problem was resolved

bye Dario
Back to top
View user's profile Send private message
onlawn
n00b
n00b


Joined: 25 Oct 2002
Posts: 45

PostPosted: Fri Feb 18, 2005 5:30 pm    Post subject: Reply with quote

I'm getting some off the wall compile warnings,

Code:
cc1plus: warning: command line option "-Wmissing-declarations" is valid for C/ObjC but not for C++
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for C/ObjC but not for C++
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for C/ObjC but not for C++


Not too big a deal, but they are accompanied by the following errors...

Code:
In file included from Control.h:24,
                 from Loop.cpp:69:
Types.h: In member function `void T_data::clear()':
Types.h:95: error: `start' undeclared (first use this function)
Types.h:95: error: (Each undeclared identifier is reported only once for each function it appears in.)
Types.h:95: error: `finish' undeclared (first use this function)
Types.h:95: error: `destroy' undeclared (first use this function)
Types.h:97: error: `deallocate' undeclared (first use this function)
Types.h:99: error: `end_of_storage' undeclared (first use this function)
Types.h: In member function `void T_messages::clear()':
Types.h:129: error: `start' undeclared (first use this function)
Types.h:129: error: `finish' undeclared (first use this function)
Types.h:129: error: `destroy' undeclared (first use this function)
Types.h:131: error: `deallocate' undeclared (first use this function)
Types.h:133: error: `end_of_storage' undeclared (first use this function)
make[4]: *** [Loop.o] Error 1
make[4]: Leaving directory `/opt/gentoo/tmp/portage/nx-x11-1.4.0-r3/work/nxcomp'
make[3]: *** [../../../nxcomp/libXcomp.so] Error 2
make[3]: Leaving directory `/opt/gentoo/tmp/portage/nx-x11-1.4.0-r3/work/nx-X11/lib/X11'


As you can tell, this is happening on compiling nx-x11, which is the first of the dependancies. A few more stats...

Code:
linux06 ~ # gcc-config -l
[1] i686-pc-linux-gnu-3.4.3-20050110 *


The reason I post this is because it seems ambigious from reading this thread whether or not nx/freenx can be built with gcc 3.4.x, this problem exists on a few machines and this is the common thread between them. This error is either a gross problem with the code or a compile error?

Thanks in advance ;)
Back to top
View user's profile Send private message
SilentShadow
n00b
n00b


Joined: 25 Oct 2004
Posts: 36
Location: Italia

PostPosted: Mon Feb 21, 2005 10:23 pm    Post subject: Reply with quote

Hi onlawn,

I only can tell you that the problem persist and that I have resolve it compiling with the 3.3 gcc version.

bye Dario

p.s. use caution with cflags for 3.4 not accepted from 3.3
Back to top
View user's profile Send private message
Shaman
Apprentice
Apprentice


Joined: 12 Sep 2002
Posts: 167
Location: Kingston, ON

PostPosted: Wed Feb 23, 2005 11:50 pm    Post subject: Reply with quote

I don't mean to sound ungrateful, because I appreciate this project. It's helping me to evaluate NX as a product, and give me some access to my home machine.

But, setting up freenx is a nightmare... there are so many little issues.

Is there any freenx 0.2.8 documentation? I've been through a lot of hax0ring and still come up with things that make me want to scream here... outside of adding /usr/NX to every path in the system (which begs the question why it isn't integrated some better way), has anyone made this thing work with just "emerge nxserver-freenx ; add user ; $path/nxclient --wizard"?

It's pretty discouraging when you're just trying to evaluate this technology for future commercial use (I don't mind paying, but I do want to evaluate it).
Back to top
View user's profile Send private message
TerminalAddict
Tux's lil' helper
Tux's lil' helper


Joined: 13 Feb 2003
Posts: 119

PostPosted: Thu Feb 24, 2005 12:16 am    Post subject: Reply with quote

with all this talk about gcc version ...
here's what I have
gcc-config -l
[1] i686-pc-linux-gnu-3.3.5 *
[2] i686-pc-linux-gnu-3.3.5-hardened
[3] i686-pc-linux-gnu-3.3.5-hardenednopie
[4] i686-pc-linux-gnu-3.3.5-hardenednossp

and here's my error
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a .emacs_* tags TAGS make.log MakeOut "#"*
cleaning in ./include...
make[2]: Entering directory `/home/var/tmp/portage/nx-x11-1.4.0-r4/work/nx-X11/include'
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a .emacs_* tags TAGS make.log MakeOut "#"*
cleaning in include/bitmaps...
make[3]: Entering directory `/home/var/tmp/portage/nx-x11-1.4.0-r4/work/nx-X11/include/bitmaps'
make[3]: *** No rule to make target `clean'. Stop.
Back to top
View user's profile Send private message
thebigslide
l33t
l33t


Joined: 23 Dec 2004
Posts: 790
Location: under a car or on top of a keyboard

PostPosted: Thu Feb 24, 2005 8:12 am    Post subject: Reply with quote

That's a broken build. Try doing an emerge sync.
Back to top
View user's profile Send private message
TerminalAddict
Tux's lil' helper
Tux's lil' helper


Joined: 13 Feb 2003
Posts: 119

PostPosted: Thu Feb 24, 2005 11:26 am    Post subject: Reply with quote

done that.
same error
net-misc/nx-x11-1.4.0-r4
Back to top
View user's profile Send private message
ILikeFish
n00b
n00b


Joined: 06 Jan 2004
Posts: 3

PostPosted: Thu Feb 24, 2005 5:43 pm    Post subject: Stumped! Reply with quote

I'm having a lot of trouble getting this working...

/var/log/messages:
Code:

Feb 24 17:38:58 rat sshd[26078]: Accepted publickey for nx from 195.74.141.61 port 12215 ssh2
Feb 24 17:38:58 rat sshd(pam_unix)[26080]: session opened for user nx by (uid=0)
Feb 24 17:38:59 rat sshd[26102]: Accepted keyboard-interactive/pam for jon from 127.0.0.1 port 45124 ssh2
Feb 24 17:38:59 rat sshd(pam_unix)[26105]: session opened for user jon by (uid=0)
Feb 24 17:38:59 rat sshd(pam_unix)[26105]: session closed for user jon
Feb 24 17:38:59 rat sshd(pam_unix)[26080]: session closed for user nx


/tmp/nxserver.log:
Code:

HELLO NXSERVER - Version 1.4.0-02 OS_(GPL)
NX> 105 hello NXCLIENT - Version 1.4.0
NX> 134 Accepted protocol: 1.4.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: jon
NX> 102 Password:
NX> 103 Welcome to: rat user: jon
NX> 105 quit


The windows client just pops up a dialog saying "Error Unknown", then "X local Server error".

Running nxclient in X on localhost just pops up an empty xmessage dialog with nothing but an "Ok" button.

Installed using nxserver-freenx 0.2.8 ebuild.

Any ideas?

Thanks,
jon
Back to top
View user's profile Send private message
Shaman
Apprentice
Apprentice


Joined: 12 Sep 2002
Posts: 167
Location: Kingston, ON

PostPosted: Thu Feb 24, 2005 5:46 pm    Post subject: Reply with quote

One thing I have found is that you don't want to install separate versions of nxproxy or nxclient at all.

Just "emerge nxserver-freenx nxssh" and leave it at that. Its own server, proxy, client are added. PAM seems to work for me, too.
Back to top
View user's profile Send private message
thebigslide
l33t
l33t


Joined: 23 Dec 2004
Posts: 790
Location: under a car or on top of a keyboard

PostPosted: Fri Feb 25, 2005 4:37 am    Post subject: Reply with quote

TerminalAddict wrote:
done that.
same error
net-misc/nx-x11-1.4.0-r4


Have a look at your features and the .ebuild and see why it's trying to make clean. It shouldn't be.
Back to top
View user's profile Send private message
TerminalAddict
Tux's lil' helper
Tux's lil' helper


Joined: 13 Feb 2003
Posts: 119

PostPosted: Sun Feb 27, 2005 10:07 pm    Post subject: Reply with quote

I tried it on my laptop this weekend after doignan emerge -e world

all went perfectly :)
The diferences are my desktop uses 2.4 and devfsd, and has never had a emerge -e world
My Laptop is 100% udev gentoo-dev-sources, and just fiunished an emerge -e world.

I leave my laptop compiling for a day or 2 with emerge -e world, and try again.
Back to top
View user's profile Send private message
FishB8
l33t
l33t


Joined: 17 Mar 2003
Posts: 820

PostPosted: Thu Mar 10, 2005 11:03 pm    Post subject: Reply with quote

Is it possible to configure NX to allow connections as root?
_________________
"...as we enjoy great advantages from the inventions of others, we should be glad of an opportunity to serve others by any invention of ours, and this we should do freely and generously." -Benjamin Franklin
Back to top
View user's profile Send private message
thebigslide
l33t
l33t


Joined: 23 Dec 2004
Posts: 790
Location: under a car or on top of a keyboard

PostPosted: Fri Mar 11, 2005 4:36 am    Post subject: Reply with quote

8O 8O 8O
Hopefully not.
That's what sudo is for.
Back to top
View user's profile Send private message
FishB8
l33t
l33t


Joined: 17 Mar 2003
Posts: 820

PostPosted: Fri Mar 11, 2005 6:21 am    Post subject: Reply with quote

I'm just confused why NX would prevent root connections if I have SSH configured to allow root connections.
_________________
"...as we enjoy great advantages from the inventions of others, we should be glad of an opportunity to serve others by any invention of ours, and this we should do freely and generously." -Benjamin Franklin
Back to top
View user's profile Send private message
thebigslide
l33t
l33t


Joined: 23 Dec 2004
Posts: 790
Location: under a car or on top of a keyboard

PostPosted: Fri Mar 11, 2005 6:39 am    Post subject: Reply with quote

By not connecting you if you're trying to login as root ;-) SSH is just used for authentication. The nx-server itself has full control over the connection still.

Same way xscreensaver won't run as root even though PAM has authenticated you.
Back to top
View user's profile Send private message
FishB8
l33t
l33t


Joined: 17 Mar 2003
Posts: 820

PostPosted: Fri Mar 11, 2005 5:03 pm    Post subject: Reply with quote

I wasn't wonder HOW it didn't let you connect, I was wondering WHY. :wink: It would seem like preventing root connections would be something to set with the SSH daemon, not the NX server.
_________________
"...as we enjoy great advantages from the inventions of others, we should be glad of an opportunity to serve others by any invention of ours, and this we should do freely and generously." -Benjamin Franklin
Back to top
View user's profile Send private message
linuxpyro
Apprentice
Apprentice


Joined: 08 Sep 2004
Posts: 255

PostPosted: Tue Apr 12, 2005 3:51 am    Post subject: Reply with quote

This page helped me get over the authentication errors: http://www.linuxquestions.org/questions/showthread.php?s=&threadid=310583&highlight=freenx
Back to top
View user's profile Send private message
statare
n00b
n00b


Joined: 25 Mar 2005
Posts: 28
Location: Sweden

PostPosted: Tue Apr 12, 2005 11:59 am    Post subject: NXserver really slow Reply with quote

Anyone else who gets 100% cpu usage on the freenx server when connecting and starting a app? I get that right after the nice !machine logo until my desk is finished loading. I have to wait >30sec for the desk to show. 10-20 seconds to start rox-filer and 5-10sec, sometimes!, after resizeing a window. When I start rox, aterm and so on the disk works for ½-1 sec then I see 2 nxagent processes fight over cpu usage for 10-20 sec in top.

I emerged with commercial flag, didnt do any conf at all besides adding /usr/NX/bin to PATH.. it just works! thou with 100% cpu usage. I tried the new 0.3.1 with ebuild bumping from 0.3.0. - https://bugs.gentoo.org/show_bug.cgi?id=84299 I been confing a little with node.conf but no difference.

I have a Cel 733MHz 320Mb RAM and I guess that should be sufficent? Fluxbox as wm if that makes any difference. In the client I use Unix and Custom as Desktop and "Run default X client script on server". It doesnt make any difference if I disable compression by using LAN or max compression with MODEM in the slider, neither if I connect locally or from my windows laptop.

Right now these are the enabled lines in node.conf, but at first I didn't even have one besides the default node.conf.sample
Code:

NX_LOGGING=1
NX_LOGFILE=/var/log/nxserver.log
SESSION_HISTORY=2592000
ENABLE_SSH_AUTHENTICATION="1"
DEFAULT_X_WM=fluxbox


this is my last session output, I had to copy it before I ended the session even thou I have enabled session history in node.conf
Code:

NXAGENT - Version 1.4.0

Copyright (C) 2001, 2004 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Agent running with pid '14701'.
Loop: WARNING! No 'sync' channel in current version. Assuming 'cups' channel.
Warning: No 'sync' channel in current version. Assuming 'cups' channel.
Info: Proxy running in server mode with pid '14706'.
Info: Waiting for connection from '127.0.0.1' on port '5002'.
Info: Accepted connection from '127.0.0.1' on port '4603'.
Info: Connection with remote proxy established.
Info: Handshaking with remote proxy completed.
Info: Synchronizing local and remote caches.
Info: Not using NX delta compression.
Info: Using lan link parameters 16384/20/16/8192.
Info: Using agent parameters 98304/2/1/1.
Info: Using pack method '16m-jpeg-9' with session 'unix-default'.
Info: Not using ZLIB stream compression.
Info: Not using remote ZLIB stream compression.
Info: Not using processor load limit.
Info: Not using persistent cache.
Info: Starting X protocol compression.
Info: Established X client connection.
Info: Not using shared memory support in X server.
Info: Using fast copy area mode in agent.
Info: Using fast get image mode in agent.
Info: Using render cleanup parameters 8/20/23/24/25/26.
Info: Using image cleanup parameters 0/0/0/0.
Info: No window manager has been detected.
Info: Using local device configuration changes.
Info: Using alpha channel in render extension.
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
Info: Entering dispatch loop with exception 0x0.


last output in nxserver.log
Code:

-- NX SERVER START:
HELLO NXSERVER - Version 1.4.0-03 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.4.0
NX> 134 Accepted protocol: 1.4.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: tobias
NX> 102 Password:
Auth method: passdb ssh
NX> 103 Welcome to: mumin user: tobias
NX> 105 listsession --user="tobias" --status="Suspended","Running" --geometry="1024x768x32+render" --type="unix-console"
NX> 127 Sessions list of user 'tobias' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
 ------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: tobias
NX> 105 startsession --session="mumin" --type="unix-default" --cache="8M" --images="32M" --cookie="2b2731af96cc3d862395993a7ba1188d" --link="adsl" --virtualdesktop="1" -$

user=tobias&userip=10.0.0.251&uniqueid=B55E051B0BE8C48CC895285948BF664E& \
display=1002&&session=mumin&type=unix-default&cache=8M&images=32M&cookie=2b2731af96cc3d862395993a$
Password:
NX> 1000 NXNODE - Version 1.4.0-03 OS (GPL)
user=tobias&userip=10.0.0.251&uniqueid=B55E051B0BE8C48CC895285948BF664E&display=1002&& \
session=mumin&type=unix-default&cache=8M&images=32M&cookie=2b2731af96cc3d862395993a$
NX> 700 Session id: mumin-1002-B55E051B0BE8C48CC895285948BF664E
NX> 705 Session display: 1002
NX> 703 Session type: unix-default
NX> 701 Proxy cookie: 2fe3fc8fda3b6b0edf6252a1a9fc669f
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 2b2731af96cc3d862395993a7ba1188d
NX> 704 Session cache: unix-default
NX> 707 SSL tunneling: 1
NX> 710 Session status: running
NX> 1002 Commit
NX> 1006 Session status: running
NX> 105 bye
Bye
NX> 999 Bye
NX> 1009 Session status: terminating
NX> 1006 Session status: closed
NX> 1001 Bye.


I bet its simple, just to make me feel worthless :wink:

MOD EDIT: Code text chopped to improve viewing.
-- Deathwing00
Back to top
View user's profile Send private message
JustinHoMi
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2005
Posts: 97

PostPosted: Wed Apr 27, 2005 8:32 am    Post subject: Reply with quote

Evangelion wrote:
Any news on getting FreeNX to run on AMD64?


I'd b curious to know this myself. I had no luck building it as a 64-bit binary, but after *much* work I was able to cross-compile it as a 32-bit binary. It'll probably be tomorrow before I will be able to test it though.
Back to top
View user's profile Send private message
brazilian_joe
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2003
Posts: 99

PostPosted: Thu Apr 28, 2005 2:52 pm    Post subject: Reply with quote

It looks like the ebuilds do not even state that nx can be compiled for amd64. I added the amd64 keyword to all ebuilds, but now I am hitting an error while building nxcomp. It asks for the -fPIC flag during compilation. I filed a bug for the developers to add the amd64 keyword to the ebuilds.
Back to top
View user's profile Send private message
JoePC
n00b
n00b


Joined: 30 Apr 2003
Posts: 31

PostPosted: Mon May 30, 2005 9:20 pm    Post subject: Reply with quote

When i run nxclient i get this error:
Code:
NX> 203 NXSSH running with pid: 10061
NX> 285 Enabling skip of SSH config files
nxssh: connect to address 127.0.0.1 port 22: Connection refused

Can someone help me?

Thnaks.
Back to top
View user's profile Send private message
brazilian_joe
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2003
Posts: 99

PostPosted: Mon May 30, 2005 9:32 pm    Post subject: Reply with quote

Kalyxo.org looks dead to me. Is the project dead? The nx original stuff (upon which freenx builds) supports amd64, but freens does not, and I can't even file a bug! Anyone has more info on the subject?
Back to top
View user's profile Send private message
phuqmnb
n00b
n00b


Joined: 29 Mar 2005
Posts: 68

PostPosted: Thu Jun 02, 2005 2:03 pm    Post subject: nxserver-freenx issues Reply with quote

I have emerged this:

emerge nxserver-freenx nxssh

That all went fine, and I added the user and changed the password. When I try and connect from my windows machine with the nx client, I get this error:

Quote:

NX> 203 NXSSH running with pid: 3264
NX> 285 Enabling skip of SSH config files
nxssh: connect to address 63.98.138.230 port 22: Connection refused
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 28, 29, 30  Next
Page 9 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum