Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Install freenx
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 28, 29, 30  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
GrimSage
n00b
n00b


Joined: 13 Sep 2004
Posts: 42

PostPosted: Tue Mar 28, 2006 2:05 am    Post subject: Reply with quote

Unable to connect now that I updated to xorg 7

Ok I am no longer able to connect since I updated portage and got the new xorg 7 that because testing rather than package masked.

It start fine, gets to teh !M logo then just quits. Try to reconnect and it cant reconnect.

Anyone else getting this issue?
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Tue Mar 28, 2006 2:26 am    Post subject: Reply with quote

Sync to the latest overlay release and re-emerge nx-comp. :) That should fix it. The issue is with fonts. That is the error that people use to get before I found the issue and corrected it with a patch. I only applied the patch if you had xorg 7, so that patch would not have been applied for you. Recently (a few days ago) I changed it so that the patch would always apply. :) Now this issue shouldn't come up. So, just update the svn overlay and emerge nx-x11. :D Let me know if this works.

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
GrimSage
n00b
n00b


Joined: 13 Sep 2004
Posts: 42

PostPosted: Tue Mar 28, 2006 4:40 am    Post subject: Reply with quote

I unmerged all the nx stuff in your overlay updated it and the re emerged

It worked.

Thank you
Back to top
View user's profile Send private message
GrimSage
n00b
n00b


Joined: 13 Sep 2004
Posts: 42

PostPosted: Tue Mar 28, 2006 10:00 am    Post subject: Reply with quote

t a question. Is there a way to have a disconnect from a freenx session, and then connect from the console? And then disconnect from that session on teh console and connect to it with freenx?
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Tue Mar 28, 2006 2:00 pm    Post subject: Reply with quote

here i am again :), now with the more "exotic" stuff.

I'd like to use windows shares in my NX-Sessions. My Environment is the following:

-Server at home, all needed NX ports accessible from outside
-Client behind a NAT firewall and maybe others (company network)
-Freenx runs insisde a 32 bit vserver on a 64 bit system
-Samba is installed, i am able to mount things in my home network through the commandline like "smbmount //wiindowsclient/sharename /home/user/shares/test -o guest"

Is it possible for freenx to mount remote shares that are behind firewalls?
I guess yes, because i get an error that a connection to 127.0.0.1 could not be established, when i define a resource in the nxclient. The data is routed through the connection between NX-server and client, right?

Then i "only" would have to make shure, that my vserver gets its own loopback adress .. do you guys think thats the way to try it? :)

have a nice day
Christoph
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.


Last edited by mana on Tue Mar 28, 2006 2:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Tue Mar 28, 2006 2:03 pm    Post subject: Reply with quote

hey GrimSage..

well i don't think that is possible so easy .. but honestly i don't know how you could use the NX-Session management from the commandline .. thing is, that maybe all tty's the user uses in the suspended session contain running processes such as KDE or some other that permits the console usage. For what purpose would you need such functionality?
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Tue Mar 28, 2006 8:19 pm    Post subject: Reply with quote

got loopback working .. but .. in the source there lies truth ...

from nxnode in nxserver-freenx-0.5.0.20060311-r1 (SVN)
Code:

#!/bin/bash

# Free implementation of nxserver components
#
# nxnode does accept (for now):
#
#       --startsession
#       --terminate
#       --smbmount
#               (smbmount is not implemented yet)
#
# Copyright (c) 2004 by Fabian Franz.


damn, that means waiting :)
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
GrimSage
n00b
n00b


Joined: 13 Sep 2004
Posts: 42

PostPosted: Tue Mar 28, 2006 11:47 pm    Post subject: Reply with quote

Reason is I like to leave GAIM open so I can get messages from people when I am not there. If I could connect and disconnect to sessions I could do this easily, jsut leave it there and then connect back once I get home and visa versa. I was thinking a possible way would to be able to disconnect from teh session then wen I go home connect to the session using NXClient. THough I am not sure how to disconnect from a session and leave everything still running.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Wed Mar 29, 2006 2:42 am    Post subject: Reply with quote

As far as I know, when you disconnect using NX, it pauses everything. This is how it use to be at least. I have not played around with resuming. I just never really disconnect. :P
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Wed Mar 29, 2006 8:15 am    Post subject: Reply with quote

that _IS_ possible .. resuming works (for me) :) ,.. so you can just suspend your session (applications keep running) go home or wherever you want, start your nxclient and resume the session.

Sometimes we have problems with the internet connection here, that kick my out of my session. I can continue without big problems most of the time.

greets
Christoph
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
BlackB1rd
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2003
Posts: 131
Location: /Europe/Netherlands/Haarlem

PostPosted: Wed Mar 29, 2006 10:56 am    Post subject: Reply with quote

I get this error when compiling the (overlayed, as suggested above) nxagent at the end of emerge nx-x11:

Code:

exports/lib   -lXext -lX11 -lz -lm                  -lXpm -Wl,-rpath-link,/usr/NX/lib -Wl,-rpath-link,../../../nxcompext,-lXrender -Wl,-rpath-link,../../exports/lib
os/libos.a(WaitFor.o): In function `WaitForSomething':
WaitFor.c:(.text+0x495): undefined reference to `_XSelect'
os/libos.a(connection.o): In function `EstablishNewConnections':
connection.c:(.text+0xd30): undefined reference to `_XSelect'
os/libos.a(connection.o): In function `CheckConnections':
connection.c:(.text+0xfd1): undefined reference to `_XSelect'
os/libos.a(utils.o): In function `Popen':
utils.c:(.text+0x1fb9): undefined reference to `_NXUnsetLibraryPath'
hw/nxagent/libnxagent.a(Args.o): In function `nxagentPostProcessArgs':
/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/programs/Xserver/hw/nxagent/Args.c:1465: undefined reference to `_NXEnableCleanImages'
/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/programs/Xserver/hw/nxagent/Args.c:1466: undefined reference to `_NXEnableImageMask'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXContinueOnDisplayError'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXSplitParams'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXEnableCleanAlloc'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXEnableCleanFlush'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXLostSequenceFunction'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXEnableImageFrame'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXColorParams'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXEnableImageSplit'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXImageEnvironmentCached'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXCleanupEnvironmentCached'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXEnableCleanGet'
/usr/NX/lib/libXcompext.so.1: undefined reference to `_NXEnableCleanSend'
collect2: ld returned 1 exit status
make[4]: *** [nxagent] Error 1
make[4]: Target `all' not remade because of errors.


After that, the only files that get installed are:

Code:

prepallstrip:
strip: x86_64-pc-linux-gnu-strip --strip-unneeded
   usr/NX/bin/nxauth
   usr/NX/lib/libXext.so.6.4
   usr/NX/lib/libXcompext.so.1.5.0
   usr/NX/lib/libXrender.so.1.2
>>> Completed installing nx-x11-1.5.0-r8 into /var/tmp/portage/nx-x11-1.5.0-r8/image/

./
./usr/
./usr/NX/
./usr/NX/bin/
./usr/NX/bin/nxauth
./usr/NX/lib/
./usr/NX/lib/libXext.so.6.4
./usr/NX/lib/libXcompext.so.1.5.0
./usr/NX/lib/libXrender.so.1.2
>>> Done.


So there's no nxagent thus it won't work ;) What about this?

Some emerge --info:
Code:

Portage 2.0.54 (default-linux/x86/2005.1/vserver, gcc-3.4.5, glibc-2.4-r1, 2.6.14-vs2.0.1-gentoo x86_64)
=================================================================
System uname: 2.6.14-vs2.0.1-gentoo x86_64 Intel(R) Xeon(TM) CPU 3.00GHz
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -mtune=nocona -O2 -pipe -fomit-frame-pointer -fPIC -m32"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/NX/etc /usr/NX/home /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=nocona -mtune=nocona -O2 -pipe -fomit-frame-pointer -fPIC -m32"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.nedlinux.nl http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://gentoo.nedlinux.nl/gentoo-portage"
USE="x86 apm arts avi bitmap-fonts bzip2 crypt cups dri eds emboss encode expat foomaticdb fortran gdbm gif gpm gstreamer gtk2 imlib ithreads jpeg kde lcms libg++ libwww mad mikmod mng motif mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl spell ssl tcpd tiff truetype truetype-fonts type1-fonts vorbis xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS


(get the same error without -fPICS -m32 CFLAGS)
Back to top
View user's profile Send private message
tja
n00b
n00b


Joined: 17 Jan 2004
Posts: 12

PostPosted: Wed Mar 29, 2006 11:54 am    Post subject: Reply with quote

i found this thread and tried to compile the svn-ebuilds on a testmachine. its a AMD64 but strictly 32 bit gentoo.

Code:
userv nx # emerge --info
Portage 2.0.54 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.3.5-r2, 2.6.15-gentoo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -ftracer -msse2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -ftracer -msse2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/overlay/nx"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X acl alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bzip2 cli crypt ctype cups dba doc dri eds emboss encode esd exif expat fam fastbuild firefox foomaticdb force-cgi-redirect fortran ftp gd gdbm gif glut gnome gpm gstreamer gtk gtk2 gtkhtml idn imlib ipv6 jpeg lcms ldap libg++ libwww mad memlimit mikmod mng motif mp3 mpeg ncurses nls nptl ogg opengl oss pam pcre pdflib perl png posix python qt quicktime readline samba sdl session simplexml smp soap sockets spell spl ssl tcpd tiff tokenizer truetype truetype-fonts type1-fonts udev usb vorbis xml xml2 xmms xsl xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS


complie of nx-x11:

Code:

userv nx # emerge nxserver-freenx
Calculating dependencies ...done!
>>> emerge (1 of 6) net-misc/nx-x11-1.5.0-r8 to /
>>> md5 files   ;-) nx-x11-1.5.0-r8.ebuild
>>> md5 files   ;-) files/digest-nx-x11-1.5.0-r8
>>> md5 files   ;-) files/1.5.0/nx-x11-1.5.0-xorg7-font-fix.patch
>>> md5 files   ;-) files/1.5.0/nx-x11-1.5.0-nxcomp-fix.patch
>>> md5 files   ;-) files/1.5.0/nxdesktop-1.5.0-nxcomp-fix.patch
>>> md5 files   ;-) files/1.5.0/nx-x11-1.5.0-plastik-render-fix.patch
>>> md5 files   ;-) files/1.5.0/nx-x11-windows-linux-resume.patch
>>> md5 files   ;-) files/1.5.0/nxcompext-1.5.0-nxcomp-fix.patch
>>> md5 files   ;-) files/1.5.0/nxviewer-1.5.0-nxcomp-fix.patch
>>> md5 src_uri ;-) nx-X11-1.5.0-21.tar.gz
>>> md5 src_uri ;-) nxagent-1.5.0-112.tar.gz
>>> md5 src_uri ;-) nxauth-1.5.0-1.tar.gz
>>> md5 src_uri ;-) nxcompext-1.5.0-20.tar.gz
>>> Unpacking source...
>>> Unpacking nx-X11-1.5.0-21.tar.gz to /var/tmp/portage/nx-x11-1.5.0-r8/work
>>> Unpacking nxagent-1.5.0-112.tar.gz to /var/tmp/portage/nx-x11-1.5.0-r8/work
>>> Unpacking nxauth-1.5.0-1.tar.gz to /var/tmp/portage/nx-x11-1.5.0-r8/work
>>> Unpacking nxcompext-1.5.0-20.tar.gz to /var/tmp/portage/nx-x11-1.5.0-r8/work
 * Applying nx-x11-windows-linux-resume.patch ...                                             [ ok ]
 * Applying nx-x11-1.5.0-plastik-render-fix.patch ...                                         [ ok ]
 * Applying nx-x11-1.5.0-nxcomp-fix.patch ...                                                 [ ok ]
 * Applying nx-x11-1.5.0-xorg7-font-fix.patch ...                                             [ ok ]
 * Applying nxcompext-1.5.0-nxcomp-fix.patch ...                                              [ ok ]
>>> Source unpacked.

Building XFree86 version 4.3.0 (27 February 2003).

I hope you checked the configuration parameters in ./config/cf
to see if you need to pass BOOTSTRAPCFLAGS.

Wed Mar 29 13:43:19 CEST 2006

cd ./config/imake && make  -f Makefile.ini BOOTSTRAPCFLAGS="" CC="cc" clean
make[1]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
rm -f ccimake imake.o imake
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a tags TAGS make.log \#*
rm -f -r Makefile.proto Makefile Makefile.dep bootstrap
rm -f imakemdep_cpp.h
make[1]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
make  Makefile.boot
make[1]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
cd ./config/imake && make -w -f Makefile.ini BOOTSTRAPCFLAGS="" CC="cc"
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
making imake with BOOTSTRAPCFLAGS= and CROSSCOMPILEFLAGS=-DCROSSCOMPILEDIR="" in config/imake
cc -o ccimake -DCROSSCOMPILEDIR=\"\"  -O -I../../include -I../../imports/x11/include/X11 ccimake.c
if [ -n "" ] ; then \
/cc -E `./ccimake` \
-DCROSSCOMPILE_CPP imakemdep.h > imakemdep_cpp.h; \
else touch imakemdep_cpp.h; fi
cc -c  -O -I../../include -I../../imports/x11/include/X11 `./ccimake` imake.c
cc -o imake  -O -I../../include -I../../imports/x11/include/X11 imake.o
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
rm -f ./config/makedepend/Makefile.proto
./config/imake/imake -I./config/cf  -s ./config/makedepend/Makefile.proto -f ./config/makedepend/Imakefile -DTOPDIR=../.. -DCURDIR=./config/makedepend
cd ./config/makedepend && rm -f -r Makefile Makefile.dep makedepend *.o bootstrap
cd ./config/makedepend && make -f Makefile.proto bootstrap
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/makedepend'
make[2]: Nothing to be done for `bootstrap'.
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/makedepend'
./config/imake/imake -I./config/cf  -s ./config/imake/Makefile.proto -f ./config/imake/Imakefile -DTOPDIR=../.. -DCURDIR=./config/imake -DBootStrap
cd ./config/imake && make -f Makefile.proto bootstrapdepend
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
make[2]: Nothing to be done for `bootstrapdepend'.
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
cd ./config/imake && make -w -f Makefile.ini BOOTSTRAPCFLAGS="" CC="cc" bootstrap
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
+ mkdir bootstrap
mv *.o bootstrap
+ mv imake bootstrap
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
cd ./config/imake && make -f Makefile.proto all
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
gcc -m32 -O3 -ansi -pedantic -Wall -Wpointer-arith -Wundef   -I../../include -I../../exports/include/X11  -I../.. -I../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L               -D_POSIX_SOURCE -D_XOPEN_SOURCE                          -D_BSD_SOURCE -D_SVID_SOURCE                -D_GNU_SOURCE                             -DFUNCPROTO=15 -DNARROWPROTO     -DCPP_PROGRAM="\"/usr/bin/cpp\"" -DHAS_MERGE_CONSTANTS=`if gcc -m32 -fmerge-constants -xc /dev/null -S -o /dev/null 2> /dev/null 1> /dev/null; then echo 1; else echo 0; fi`              -c -o imake.o imake.c
imake.c:972: warning: string length `1094' is greater than the length `509' ISO C89 compilers are required to support
rm -f imake
gcc -m32 -o imake -O3 -ansi -pedantic -Wall -Wpointer-arith -Wundef      imake.o       -Wl,-rpath-link,../../exports/lib
rm -f imake._man
/usr/bin/cpp -undef -traditional  -D__apploaddir__=/usr/X11R6/lib/X11/app-defaults -D__filemansuffix__=5x -D__libmansuffix__=3x -D__miscmansuffix__=7 -D__drivermansuffix__=4 -D__projectroot__=/usr/X11R6 -D__xorgversion__='"Release 6.6" "X Version 11"' -D__vendorversion__="XFree86ManVersionString XFree86" -D__cpp__=/usr/bin/cpp <imake.man | sed -e '/^#  *[0-9][0-9]*  *.*$/d' -e '/^XCOMM$/s//#/' -e '/^XCOMM[^a-zA-Z0-9_]/s/^XCOMM/#/' >imake._man
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
make -w xmakefile
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
rm -f xmakefile
./config/imake/imake -I./config/cf  -s xmakefile -DTOPDIR=. -DCURDIR=.
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
rm -f ./config/imake/Makefile.proto
make[1]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make -f xmakefile  version.def
make[1]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
rm -f ./config/cf/version.def
rm -f ./config/cf/date.def
ln -s ../.././programs/Xserver/hw/xfree86/xf86Version.h ./config/cf/version.def
ln -s ../.././programs/Xserver/hw/xfree86/xf86Date.h ./config/cf/date.def
make[1]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make  Makefile.boot
make[1]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
cd ./config/imake && make -w -f Makefile.ini BOOTSTRAPCFLAGS="" CC="cc"
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
making imake with BOOTSTRAPCFLAGS= and CROSSCOMPILEFLAGS=-DCROSSCOMPILEDIR="" in config/imake
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
rm -f ./config/makedepend/Makefile.proto
./config/imake/imake -I./config/cf  -s ./config/makedepend/Makefile.proto -f ./config/makedepend/Imakefile -DTOPDIR=../.. -DCURDIR=./config/makedepend
cd ./config/makedepend && rm -f -r Makefile Makefile.dep makedepend *.o bootstrap
cd ./config/makedepend && make -f Makefile.proto bootstrap
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/makedepend'
make[2]: Nothing to be done for `bootstrap'.
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/makedepend'
./config/imake/imake -I./config/cf  -s ./config/imake/Makefile.proto -f ./config/imake/Imakefile -DTOPDIR=../.. -DCURDIR=./config/imake -DBootStrap
cd ./config/imake && make -f Makefile.proto bootstrapdepend
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
make[2]: Nothing to be done for `bootstrapdepend'.
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
cd ./config/imake && make -w -f Makefile.ini BOOTSTRAPCFLAGS="" CC="cc" bootstrap
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
make[2]: `bootstrap' is up to date.
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
cd ./config/imake && make -f Makefile.proto all
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config/imake'
+ rm -f xmakefile.bak
+ mv xmakefile xmakefile.bak
make -w xmakefile
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
rm -f xmakefile
./config/imake/imake -I./config/cf  -s xmakefile -DTOPDIR=. -DCURDIR=.
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
rm -f ./config/imake/Makefile.proto
make[1]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make -f xmakefile  VerifyOS
make[1]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'

Building XFree86 version 4.3.0 (27 February 2003).

Building on Linux 2.6.15-gentoo-r1 i686 [ELF] (2.6.15).

Linux Distribution: Unknown
libc version: 6.3.5
binutils version: 21.6

GCC version: 3.4

make[1]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make -f xmakefile  Makefiles
make[1]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
making Makefiles in include...
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/include'
making Makefiles in include/bitmaps...
make[3]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/include'
make[3]: xmakefile: No such file or directory
make[3]: *** No rule to make target `xmakefile'.  Stop.
make[3]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/include'
make[2]: [Makefiles] Error 2 (ignored)
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/include'
making Makefiles in config...
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config'
making Makefiles in config/cf...
make[3]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config'
make[3]: xmakefile: No such file or directory
make[3]: *** No rule to make target `xmakefile'.  Stop.
make[3]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config'
make[2]: [Makefiles] Error 2 (ignored)
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/config'
making Makefiles in lib...
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/lib'
making Makefiles in lib/xtrans...
make[3]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/lib'
make[3]: xmakefile: No such file or directory
make[3]: *** No rule to make target `xmakefile'.  Stop.
make[3]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/lib'
make[2]: [Makefiles] Error 2 (ignored)
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/lib'
making Makefiles in programs...
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/programs'
making Makefiles in programs/Xserver...
make[3]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/programs'
make[3]: xmakefile: No such file or directory
make[3]: *** No rule to make target `xmakefile'.  Stop.
make[3]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/programs'
make[2]: [Makefiles] Error 2 (ignored)
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/programs'
make[1]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make -f xmakefile  BOOTSTRAPSUBDIRS= clean
make[1]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
rm -f -r ./exports/include
rm -f -r ./exports/lib
rm -f -r ./exports/bin
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a .emacs_* tags TAGS make.log MakeOut  "#"*
cleaning in ./include...
make[2]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/include'
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a .emacs_* tags TAGS make.log MakeOut  "#"*
cleaning in include/bitmaps...
make[3]: Entering directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/include/bitmaps'
make[3]: *** No rule to make target `clean'.  Stop.
make[3]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/include/bitmaps'
make[2]: *** [clean] Error 2
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11/include'
make[1]: *** [clean] Error 2
make[1]: Leaving directory `/var/tmp/portage/nx-x11-1.5.0-r8/work/nx-X11'
make: *** [World] Error 2

!!! ERROR: net-misc/nx-x11-1.5.0-r8 failed.
!!! Function src_compile, Line 64, Exitcode 2
!!! unable to build nx-x11
!!! If you need support, post the topmost build error, NOT this status message.


where am i wrong ?
Back to top
View user's profile Send private message
GrinRoth
n00b
n00b


Joined: 31 Mar 2006
Posts: 3

PostPosted: Fri Mar 31, 2006 7:04 am    Post subject: Themes and Icons Reply with quote

Hi,

I managed to install freenx with the ebuilds supplied here a few posts earlier.
Thanks for that, it works blazingly fast and good!

Only 'problem' i encounter is that only the default gtk theme works...
Also my icons are all gone (with the exception of the gnome stock icons) , does somebody knows why this is happening?
And a solution to this maybe?

Thanks
Back to top
View user's profile Send private message
BlackB1rd
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2003
Posts: 131
Location: /Europe/Netherlands/Haarlem

PostPosted: Fri Mar 31, 2006 8:35 am    Post subject: Reply with quote

Well, because I couldn't get it working I decided to install a new clean x86 vserver dedicated to work with freenx. Downloaded the overlays and unmasked them. They all installed successfully, but I still get an error with the nxagent:

Code:

localhost / # nxagent
nxagent: symbol lookup error: /usr/NX/lib/libXcompext.so.1: undefined symbol: _NXContinueOnDisplayError


I get exactly the same error after installing it on my private (athlon xp 1700) server. So, are the current ebuilds broken or am I just stupid ;)

btw. I managed to get freenx working before, lets say a year ago or so. Don't understand why this version is such a pain in the ass.
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 548
Location: uk

PostPosted: Fri Mar 31, 2006 10:59 am    Post subject: Reply with quote

BlackB1rd wrote:
Well, because I couldn't get it working I decided to install a new clean x86 vserver dedicated to work with freenx. Downloaded the overlays and unmasked them. They all installed successfully, but I still get an error with the nxagent:

Code:

localhost / # nxagent
nxagent: symbol lookup error: /usr/NX/lib/libXcompext.so.1: undefined symbol: _NXContinueOnDisplayError


I get exactly the same error after installing it on my private (athlon xp 1700) server. So, are the current ebuilds broken or am I just stupid ;)

btw. I managed to get freenx working before, lets say a year ago or so. Don't understand why this version is such a pain in the ass.


I struggled with this last night, StifflerStealth gave the solution on page 18, guess its a bug in the ebuild :(

Quote:
Why is it looking in /usr/lib ? It should be looking in /usr/NX/lib. :S Maybe this has to do with taking LDPATH=/usr/NX/lib out of the 50nxpaths file. -_-'

Can you edit the file /etc/env.d/50nxpaths and make it so it looks like this:
Quote:
PATH=/usr/NX/bin
ROOTPATH=/usr/NX/bin
LDPATH=/usr/NX/lib
CONFIG_PROTECT="/usr/NX/etc /usr/NX/home"
Then type env-update, and see if everything works right? Also you need to add your user to nx. Did you type nxserver --adduser {your_user_name}?
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Fri Mar 31, 2006 11:55 am    Post subject: Reply with quote

So, having LDPATH set in the 50nxpaths file makes a difference? If you try it without LDPATH set, it fails? Also, with AMD64, you should use the bin version of nx-x11. unmerge nx-x11 and type: emerge nx-x11-bin. :) nx-x11-bin is for AMD64 processors whether it's set to 32 biot or not. There have been issues as described here.

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 548
Location: uk

PostPosted: Fri Mar 31, 2006 3:48 pm    Post subject: Reply with quote

StifflerStealth wrote:
So, having LDPATH set in the 50nxpaths file makes a difference? If you try it without LDPATH set, it fails?


Did for me last night, but mine is a 32bit system.

It may be possible that it is my fault. This is the first use of svn, I used "svn collect (files)" to update and I see from this thread that the correct syntax is "svn up" :roll:, although the feedback of files with A, D or U associated indicated that it had worked OK :) . I have also used the /usr/local/portage overlay instead of creating one specifically for NX.

NX is suspending/resuming fine now :D. I haven't been able to get sound working yet, have to spend more time on it. I haven't tried the file/printer sharing yet, because I am only testing on my home network.

Barrie
Back to top
View user's profile Send private message
BlackB1rd
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2003
Posts: 131
Location: /Europe/Netherlands/Haarlem

PostPosted: Fri Mar 31, 2006 7:07 pm    Post subject: Reply with quote

Unfortunately unmerging nx-x11 and then emerging nx-x11-bin doesn't help. I still get the above error message. As you can see it's not a problem with LDPATH, it's able to locate the library. But I can confirm that adding LDPATH to /etc/env.d/50nxpaths at least fixes the "cannot find" error message.

So the nx-x11 binary also doesn't work, is there anything else I can try?

[edit]
Yeeeaaaah, it finally works! Didn't realize it could actually work with a nxclient :D Thought had to fix the nxagent error when launching it from command line first... But I guess the error is normal and it was probably already fixed after adding LDPATH to 50nxpaths. Thanks for the support! (and ofcourse for providing the ebuilds)
[/edit]
Back to top
View user's profile Send private message
GrimSage
n00b
n00b


Joined: 13 Sep 2004
Posts: 42

PostPosted: Sun Apr 02, 2006 9:57 pm    Post subject: Reply with quote

Is there an easy way to suspend a session from the windows nomachine client? Right now I have to go into processes and kill nxssh and cygserver. I am looking for an easier way to make this work.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Sun Apr 02, 2006 10:47 pm    Post subject: Reply with quote

GrimSage wrote:
Is there an easy way to suspend a session from the windows nomachine client? Right now I have to go into processes and kill nxssh and cygserver. I am looking for an easier way to make this work.
make sure you instaleld freenx with the nxclient flag set. When you disconnect on your windows machine, just click the X to close the application and you will be promted with a screen asking you what you want to do: Terminate, suspend, cancel. :)

Cheers
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
GrimSage
n00b
n00b


Joined: 13 Sep 2004
Posts: 42

PostPosted: Mon Apr 03, 2006 4:38 am    Post subject: Reply with quote

what do you mean by with the nxclient flag set?
you mean in packages.use
**EDIT**
Did that it worked Thank you

Also I dont know how hard this would be for you to do but it would make things really nice for development.

Kuroo has a kuroo-svn ebuild. What it does is it actually just has the one ebuild that will do a checkout of their subversion server and then build from that. I think that is just neat. WOuld save me from having to do the checkout before i use yours.

Also is there a way to update all of the components with one ebuild? Not sure how that would work.

Also I dont know if you have an ebuild for the the freenx web component? Cause that would be sweet.

And thank you very much for all your hard work. This has made things extreemly easy for me.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Mon Apr 03, 2006 11:38 pm    Post subject: Reply with quote

I was thinking about doing a FreeNX SVN Ebuild, but the snapshots are close to svn as you can get, though a new snapshot hasn't been released yet. -_-' So, I might have one.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Tue Apr 04, 2006 10:51 am    Post subject: Reply with quote

Snapshots really are okay, thanks for your great work StifflerStealth :)
I will only shout for svn when smb-support is integrated again :D
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
BlackB1rd
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2003
Posts: 131
Location: /Europe/Netherlands/Haarlem

PostPosted: Tue Apr 04, 2006 11:08 am    Post subject: Reply with quote

Does anyone have printer support working yet? Other than that I'm completely satisfied with the current version :)
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Tue Apr 04, 2006 11:14 am    Post subject: Reply with quote

I've been able to print from FreeNX since version 0.4.4. THough, it uses the printer than the NX server is connected to, and it doesn't use the printer than the client is on. I don't think that is enabled right now.

If you check out the newest overlay, and re-merge FreeNX, I have it now so that if you have the cups use flag set, kde_cups support is turned on by default. :) I have no idea what it does yet, though. :S Worth investigating. :)

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 28, 29, 30  Next
Page 19 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum