Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Install freenx
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 28, 29, 30  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
BlackB1rd
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2003
Posts: 131
Location: /Europe/Netherlands/Haarlem

PostPosted: Tue Apr 04, 2006 5:29 pm    Post subject: Reply with quote

I'll try that one out. Sounds interesting.
I've to say that FreeNX rocks, using it all day hosted at one of my servers connected to a 100mbit dedicated internet uplink and goes smoooth... ;) But I'm sure it also works very well on a 2mbit connection, as that's the bandwidth available from client-side 8)

I also know for sure it works with the commercial version of NX, as the testdrive at nomachine.com works well with my printer. Shouldn't be that difficult to get it working with FreeNX... We'll see.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Tue Apr 04, 2006 9:52 pm    Post subject: Reply with quote

FreeNX was designed to work over a dial up connection. ;)

Good luck with your printer. :)
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Riplix
n00b
n00b


Joined: 26 Sep 2004
Posts: 33

PostPosted: Wed Apr 12, 2006 2:21 pm    Post subject: Reply with quote

Hi there!
I've successfully installed the overlay version of freenx on amd64. Unfortunately when I try to login on freenx server from WindowsXP with the latest NoMachine client I get the nomachine logo displayed and soon after, the client application is killed. On server side the session seems to be active:
Code:

Pyxis # nxserver --list
NX> 100 NXSERVER - Version 1.5.0-50-SVN OS (GPL)
NX> 127 Sessions list:

Display Username        Remote IP       Session ID
------- --------------- --------------- --------------------------------
1001    alfa    xxx.xxx.xxx.xxx    0308543CC73AE0A71509913AE00AF417
NX> 999 Bye
Pyxis #


Any ideas?
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Wed Apr 12, 2006 6:39 pm    Post subject: Reply with quote

It might be usefull if you post the output of the client-log as well as your nxserver and/or /var/log/messages so that people can analyse your problem :)
I don't know if it is still the case, but i heard that using the freenx server on a amd64 is not yet possible. Please correct me if i am wrong. There are howtos out there describing how to setup a 32-bit chroot for the nxserver. I decided to go for a solution that involves linux-vserver.

have a nice day
Mana
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Apr 13, 2006 9:14 pm    Post subject: Reply with quote

@mana: The overlay contains an ebuild for the binary version of nx-x11. This is designed for users of AMD64. ;) So, Gentoo now has a viable solution for it without having to set up a chroot or do the vserver thing. :)

@Riplix: I can't tell what's wrong. A lot of people have this set up and working. :S So, maybe a dependency was removed since then? I need to look at the ebuilds again. But, having the logs would be helpful. Thanks.

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Sat Apr 15, 2006 3:33 pm    Post subject: Reply with quote

hmm i did svn-up inside net-misc in the overlay as the problem with Alt Gr became to anoying now .. i get this digest error

Code:
ebuild nxserver-freenx-0.5.0* fetch

Traceback (most recent call last):
  File "/usr/bin/ebuild", line 71, in ?
    a = portage.doebuild(ebuild, arg, portage.root, tmpsettings, debug=debug, cleanup=("noauto" not in portage.features), tree=mytree)
  File "/usr/lib/portage/pym/portage.py", line 2722, in doebuild
    if not digestcheck(checkme, mysettings, ("strict" in features)):
  File "/usr/lib/portage/pym/portage.py", line 2264, in digestcheck
    mymdigests=digestParseFile(manifestfn)
  File "/usr/lib/portage/pym/portage.py", line 2192, in digestParseFile
    raise portage_exception.DigestException, "Conflicting sizes in digest: %(filename)s" % {"filename":myfilename}
portage_exception.DigestException: 'Conflicting sizes in digest: /usr/local/overlays/nx/net-misc/nxserver-freenx/Manifest'

_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Sat Apr 15, 2006 11:50 pm    Post subject: Reply with quote

Hmmm ....
Code:
# emerge nxserver-freenx -f
>>> cfg-update-1.8.0-r3 : No new packages have been emerged, checksum index OK...
Calculating dependencies... done!
>>> Emerging (1 of 1) net-misc/nxserver-freenx-0.5.0.20060311-r1 to /
>>> Downloading http://studwww.ira.uka.de/~s_franz2/freenx/freenx-0.5.0-test-2006-03-11-7.tar.gz
--18:46:23--  http://studwww.ira.uka.de/~s_franz2/freenx/freenx-0.5.0-test-2006-03-11-7.tar.gz
           => `/portage/distfiles/freenx-0.5.0-test-2006-03-11-7.tar.gz'
Resolving studwww.ira.uka.de... 141.3.12.8
Connecting to studwww.ira.uka.de|141.3.12.8|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 50,703 (50K) [application/x-gzip]

100%[====================================>] 50,703        78.63K/s

18:46:24 (78.39 KB/s) - `/portage/distfiles/freenx-0.5.0-test-2006-03-11-7.tar.gz' saved [50703/50703]

>>> freenx-0.5.0-test-2006-03-11-7.tar.gz RMD160 ;-)
>>> freenx-0.5.0-test-2006-03-11-7.tar.gz size ;-)
>>> freenx-0.5.0-test-2006-03-11-7.tar.gz SHA256 ;-)
>>> freenx-0.5.0-test-2006-03-11-7.tar.gz MD5 ;-)
>>> checksums files   ;-) nxserver-freenx-0.4.5.20060305.ebuild
>>> checksums files   ;-) nxserver-freenx-0.5.0.20060311-r1.ebuild
>>> checksums files   ;-) nxserver-freenx-0.4.4-r1.ebuild
>>> checksums files   ;-) files/nxserver-freenx-0.4.4-xorg7.patch
>>> checksums files   ;-) files/digest-nxserver-freenx-0.4.4-r1
>>> checksums files   ;-) files/nxserver-freenx-xorg7.patch
>>> checksums files   ;-) files/digest-nxserver-freenx-0.5.0.20060311-r1
>>> checksums files   ;-) files/freenx-0.4.4-adduser-fix.patch
>>> checksums files   ;-) files/digest-nxserver-freenx-0.4.5.20060305
>>> checksums src_uri ;-) freenx-0.5.0-test-2006-03-11-7.tar.gz


I am using the latest overlay too. Why are you using ebuild instead of emerge?
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Sun Apr 16, 2006 10:38 am    Post subject: Reply with quote

eeehm i used ebuild because .. uhm .. i dunno, look at me i am a noob :oops:

deleted all distfiles, but again

Code:
localhost distfiles # emerge nxserver-freenx -f
Calculating dependencies ...done!
>>> emerge (1 of 1) net-misc/nxserver-freenx-0.5.0.20060311-r1 to /
>>> Downloading http://studwww.ira.uka.de/~s_franz2/freenx/freenx-0.5.0-test-2006-03-11-7.tar.gz
--10:29:02--  http://studwww.ira.uka.de/~s_franz2/freenx/freenx-0.5.0-test-2006-03-11-7.tar.gz
           => `/usr/portage/distfiles/freenx-0.5.0-test-2006-03-11-7.tar.gz'
Resolving studwww.ira.uka.de... 141.3.12.8
Connecting to studwww.ira.uka.de|141.3.12.8|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 50,703 (50K) [application/x-gzip]

100%[=====================================================================================================================================================================>] 50,703       184.22K/s

10:29:03 (183.96 KB/s) - `/usr/portage/distfiles/freenx-0.5.0-test-2006-03-11-7.tar.gz' saved [50703/50703]

>>> freenx-0.5.0-test-2006-03-11-7.tar.gz size ;-)
>>> freenx-0.5.0-test-2006-03-11-7.tar.gz MD5 ;-)
Traceback (most recent call last):
  File "/usr/bin/emerge", line 3228, in ?
    mydepgraph.merge(pkglist)
  File "/usr/bin/emerge", line 1859, in merge
    retval=portage.doebuild(y,"fetch",myroot,self.pkgsettings,edebug,("--pretend" in myopts),fetchonly=1,tree="porttree")
  File "/usr/lib/portage/pym/portage.py", line 2722, in doebuild
    if not digestcheck(checkme, mysettings, ("strict" in features)):
  File "/usr/lib/portage/pym/portage.py", line 2264, in digestcheck
    mymdigests=digestParseFile(manifestfn)
  File "/usr/lib/portage/pym/portage.py", line 2192, in digestParseFile
    raise portage_exception.DigestException, "Conflicting sizes in digest: %(filename)s" % {"filename":myfilename}
portage_exception.DigestException: 'Conflicting sizes in digest: /usr/local/overlays/nx/net-misc/nxserver-freenx/Manifest

_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 548
Location: uk

PostPosted: Sun Apr 16, 2006 12:54 pm    Post subject: Reply with quote

Just updated overlay to rev 63, via svn up. Emerge -puD world gives the following output.

Code:
sempron2600 net-misc # emerge -puD world

These are the packages that I would merge, in order:

Calculating world dependencies \/usr/lib/portage/bin/ebuild.sh: line 1524: /usr/portage/eclass/debian.eclass: No such file or directory

!!! ERROR: net-misc/nxclient-1.5.0-r4 failed.
!!! Function inherit, Line 1525, Exitcode 1
!!! died sourcing /usr/portage/eclass/debian.eclass in inherit()
!!! If you need support, post the topmost build error, NOT this status message.


aux_get(): (0) Error in net-misc/nxclient-1.5.0-r4 ebuild. (1)
               Check for syntax error or corruption in the ebuild. (--debug)

 ...done!
[ebuild     UD] net-misc/nxclient-1.5.0-r2 [1.5.0-r4]


arch=x86

Any ideas?
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Sun Apr 16, 2006 3:17 pm    Post subject: Reply with quote

exact the same for me when I do emerge -puD world
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Sun Apr 16, 2006 11:40 pm    Post subject: Reply with quote

You need to do two commands now. ;) I updated the howto on how to do this here:
https://bugs.gentoo.org/attachment.cgi?id=84778

Basically, in the same directory that you ran:
svn co http://svn.gnqs.org/svn/gentoo-nx-overlay/testing/net-misc
You need to run this command:
svn co http://svn.gnqs.org/svn/gentoo-nx-overlay/testing/eclass

There are now two eclasses to DL. :) And I just updated the net-misc overlay as well, so you need to resync with that. :)

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Mon Apr 17, 2006 9:00 am    Post subject: Reply with quote

thanks for that massive update :))
Both checkouts are rev 67 now. But what next? cleaning distfiles and doing "emerge nxserver-freenx" still gives me the same checksum error ....
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Mon Apr 17, 2006 10:46 am    Post subject: Reply with quote

I just redigested everything and subversion shows no changes.

Can you remove all FreeNX packages from your distfiles dir?
# rm /usr/portage/distfiles/freenx-0.*

Then type:
emerge nxserver-freenx

Does this work? Also, what version of portage are you using?

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Mon Apr 17, 2006 11:14 am    Post subject: Reply with quote

I removed everything in distfiles and tried to emerge once more still the same. Damn there seems to be something wrong in my system as it works for everybody else? I have the newest portage (sys-apps/portage-2.0.54) ...

i will update world now anyway .. sorry for bothering with my buggy sys ..
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
Husky
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2003
Posts: 77

PostPosted: Mon Apr 17, 2006 4:27 pm    Post subject: Reply with quote

i think the font problem isn't fixed in the bin package. it still tries to find the fonts in /usr/X11R6/lib/X11/font.

doing "ln -s /usr/share/fonts /usr/X11R6/lib/X11/font" seems to fix it.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Mon Apr 17, 2006 10:21 pm    Post subject: Reply with quote

Husky wrote:
i think the font problem isn't fixed in the bin package. it still tries to find the fonts in /usr/X11R6/lib/X11/font.

doing "ln -s /usr/share/fonts /usr/X11R6/lib/X11/font" seems to fix it.


That's odd. It was compiled with the patch. Actually, when it was compiled, it was a sed line. But it still should have that fix. :S I will need to investigate this.

@mana: I don't know what to suggest. I re-digested it and all so, unless my portage is messed up, then it should work. :S This is very odd.

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Tue Apr 18, 2006 7:50 am    Post subject: Reply with quote

Its okay stiffler, bleeding edge sometimes has to be odd :) I will try it again when a new revision, with a different digest is available. I can saveley update this system anyway only during the weekends as it is a semi-productive one. Damn if only freenx wasn't so freakin cool :D

Mana
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Tue Apr 18, 2006 10:22 am    Post subject: Reply with quote

Mana, can you delete the manifest and digest files and digest it yourself?
ebuild /path/to/nxsserver-freenx-0.5.0.20060311-r1.ebuild digest
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Tue Apr 18, 2006 3:15 pm    Post subject: Reply with quote

hola! .. i did what you told me and see it works now what didn't work before .. the digest was correctly calculated and i emerge the package now .. damn i don't understand that ...
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Tue Apr 18, 2006 9:36 pm    Post subject: Reply with quote

Can you paste the contents of your new digest and manifest file here? I want to compare the numbers to mine. :S Maybe there is a something with the portage version I use?

Thanks
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Tue Apr 18, 2006 9:53 pm    Post subject: Reply with quote

of course :)

MD5 b627433904cd6eed38b14524d3b45cbd freenx-0.5.0-test-2006-03-11-7.tar.gz 50703

content of Manifest shows the answer as i see clear now (i hope)

MD5 f26f598610cb4b43e1d931dea2f58cce Manifest.mine 776
MD5 2d73ae9975d161f3493c1d8bac288e24 Manifest.r47 2791
MD5 8b92459ec3cb0959f184eceb22e2f2e4 Manifest.r62 2791
MD5 dfb3c66aa16b74ac4f38083a81d5e605 files/digest-nxserver-freenx-0.4.4-r1 235
MD5 9630b2316545cdb60a1a900a1db5baf8 files/digest-nxserver-freenx-0.4.5.20060305 262
MD5 19bb7ae9f3a37a3e034a5dfb99de610d files/digest-nxserver-freenx-0.5.0.20060311-r1 81
MD5 925fd2cad3adceb556bf1de6cf866ed0 files/freenx-0.4.4-adduser-fix.patch 562
MD5 0fcfdb1adc7a94eece68cfd65a522b7f files/nxserver-freenx-0.4.4-xorg7.patch 569
MD5 2a253055c0eef647a0a8b922f321842d files/nxserver-freenx-xorg7.patch 590
MD5 77fd36d93b0a1b9f35abbe6a1c146561 metadata.xml 482
MD5 139fa534c1644914b01f437bdf83940e nxserver-freenx-0.4.4-r1.ebuild 4297
MD5 4097ce887d06d256cc43807857188878 nxserver-freenx-0.4.5.20060305.ebuild 4247
MD5 b9d0398c4fbeb6c249b248793f22bf56 nxserver-freenx-0.5.0.20060311-r1.ebuild 3981

there was a conflict during svn up that i did not see. And therefore the digest is different. But if so i wonder what could have created the conflict without me making changes to the files (which i didn't). Or did you put those different versions of Manifest into the repository for purpose?

Good night :)
Mana
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
DreadPirate
n00b
n00b


Joined: 13 Apr 2002
Posts: 10
Location: Boston, MA

PostPosted: Wed Apr 19, 2006 9:18 pm    Post subject: Permission Denied (Publickey, keyboard-interactive) Reply with quote

I have the latest version of freenx installed on my server, but when trying to connect with the 1.5 client from my windows XP machine, I get the error message "Server not installed or NX access disabled". I believe I have the public key correct, as I get past the initial login prompt without any errors. The full text of the detailed error log is below:

Code:
NX> 203 NXSSH running with pid: 1288
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: 192.168.1.75 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.5.0-50-SVN OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: wes
NX> 102 Password:
NX> 103 Welcome to: gentoo user: xxxx
NX> 105 listsession --user="xxxx" --status="suspended,running" --geometry="1280x1024x32+render" --type="unix-gnome"
NX> 127 Sessions list of user 'xxxx' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: xxxx
NX> 105 startsession --session="test" --type="unix-gnome" --cache="8M" --images="32M" --link="lan" --kbtype="pc102/en_US" --nodelay="1" --encryption="1" --backingstore="never" --geometry="1280x960" --media="0" --agent_server="" --agent_user="" agent_password="******""  --screeninfo="1280x960x32+render"

Permission denied (publickey,keyboard-interactive).
Killed by signal 15.


Any ideas on this error would be appreciated!
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 548
Location: uk

PostPosted: Wed Apr 19, 2006 10:02 pm    Post subject: Reply with quote

Quote:
I have the latest version of freenx installed on my server, but when trying to connect with the 1.5 client from my windows XP machine, I get the error message "Server not installed or NX access disabled". I believe I have the public key correct, as I get past the initial login prompt without any errors. The full text of the detailed error log is below:



Do you have the latest Windows client from Nomachine? Can you connect via localhost using the client on the server? IIRC I had a similar issue, which was solved by installing the latest client.

Barrie
Back to top
View user's profile Send private message
DreadPirate
n00b
n00b


Joined: 13 Apr 2002
Posts: 10
Location: Boston, MA

PostPosted: Wed Apr 19, 2006 10:19 pm    Post subject: Reply with quote

Baaann,

I downloaded the latest version of the NX client from the nomachine website yesterday. How would I go about testing using the client on the server? This server is headless and sitting in a corner of my apartment - I don't have a keyboard or monitor connected to it currently. I can however remote into the server through SSH without any problem at all using password authentication.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Apr 20, 2006 12:08 am    Post subject: Reply with quote

When you installed freenx on the server, did you do:
nxserver --adduser {your user name}

baaann was asking if you installed the latest nxclient on your Windows machine to connet to the server with. ;)

@Mana: Thanks for posting that. I don't know why it's different for you. Maybe removing the nxserver-freenx directory and doing a checkout will produce different results? I am lost on this.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 28, 29, 30  Next
Page 20 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum