Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Install freenx
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 27, 28, 29, 30  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Tue Dec 12, 2006 12:55 pm    Post subject: Reply with quote

net-misc/nx-x11-1.4.0-r4 is a pretty old package, maybe try a newer version of freenx? Please be sure to unmerge all remaining packages before.

The backend-string may be needed to be fixed in the scripts of you verison or you could try to add "ENABLE_1_5_0_BACKEND" in your node.conf .. if i remember the attribute correctly.
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
pops45042
Apprentice
Apprentice


Joined: 07 Jan 2004
Posts: 278
Location: Cincinnati, Ohio

PostPosted: Tue Dec 12, 2006 2:14 pm    Post subject: Reply with quote

Thats what I also get, well got.
Quote:
Error: Could not find 1.5.0 version string in nxagent. NX 1.5.0 backend is needed for this version of FreeNX.

Errors occured during config check.
Please correct the configuration file.

I just ignored it and went on. I tried to connect with the client and It gives me some authentication error.

Paul
_________________
"That which does not kill me only postpones the inevitable"

Laugh at my old system!
AMD Opteron 165@ 2750Mhz, 2gig 400mhz Cas2 Crucial Ballistix, Abit NF8 Ultra MB, WD 80gig (system), WD 120gig (storage), Geforce 8800GTS 320MB, Mushkin 550W PS
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Dec 12, 2006 2:54 pm    Post subject: Reply with quote

For me it is working. Even with this error.

I did not need to install a new user. Just used the normal user.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
pops45042
Apprentice
Apprentice


Joined: 07 Jan 2004
Posts: 278
Location: Cincinnati, Ohio

PostPosted: Thu Dec 14, 2006 12:42 am    Post subject: Reply with quote

Wow, so I ended up re-doing my linuxbox yesterday and I decided to try freenx again. I followed those last three commands posted above and it just works. Awsome.

Paul
_________________
"That which does not kill me only postpones the inevitable"

Laugh at my old system!
AMD Opteron 165@ 2750Mhz, 2gig 400mhz Cas2 Crucial Ballistix, Abit NF8 Ultra MB, WD 80gig (system), WD 120gig (storage), Geforce 8800GTS 320MB, Mushkin 550W PS
Back to top
View user's profile Send private message
nahpets
Veteran
Veteran


Joined: 05 Oct 2003
Posts: 1178
Location: Montreal, Canada

PostPosted: Fri Dec 15, 2006 9:47 am    Post subject: Reply with quote

I'm reposting this post because nobody answered me, so I'm trying this thread out. I just can't solve the problem described below:

Original Post:

I can't run any tcl/tk applications in NX anymore. I'm getting this error:
Code:

Application initialization failed: this isn't a Tk applicationunknown color name "Black"


I had this problem about a month ago and I fixed it by making a symlink to rgb.txt and by adding an entry for 'Black' to it. The following shows that everything looks as it should:
Code:

# strings /usr/lib/NX/bin/nxagent | grep "X11.*rgb"
/usr/X11R6/lib/X11/rgb
#ls -ll /usr/X11R6/lib/X11/rgb.txt
lrwxrwxrwx 1 root root 22 Sep  6 01:00 /usr/X11R6/lib/X11/rgb.txt -> /usr/share/X11/rgb.txt
# grep Black /usr/share/X11/rgb.txt
  0   0   0     Black


I still can't start any tcl/tk programs... NX probably got broken when I did an upgrade a couple weeks ago... but I'm not sure what to do to fix this. Anyone have a clue?
_________________
Let me guess, you picked out yet another colorful box with a crank that I'm expected to turn and turn until OOP! big shock, a jack pops out and you laugh and the kids laugh and the dog laughs and I die a little inside.
Back to top
View user's profile Send private message
imanassypov
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2005
Posts: 118
Location: Toronto, Canada

PostPosted: Mon Dec 18, 2006 4:30 pm    Post subject: Error: Could not find 1.5.0 version string in nxagent Reply with quote

I am trying to get nxserver running on amd64, and no matter what i try I stumble across the above error.
I unmasked the x86 version, and using the nx-x11-bin package.

has anybody resolved this?

Thx!


equery list nx
[ Searching for package 'nx' in all categories among: ]
* installed packages
[I--] [ ] net-misc/nx-1.5.0 (0)
[I--] [ ~] net-misc/nx-x11-bin-1.5.0 (0)
[I--] [ ] net-misc/nxclient-2.1.0 (0)
[I--] [ ~] net-misc/nxcomp-1.5.0-r2 (0)
[I--] [ ~] net-misc/nxproxy-1.5.0-r2 (0)
[I--] [ ] net-misc/nxserver-freenx-0.5.0-r1 (0)
[I--] [ ~] net-misc/nxssh-1.5.0-r2 (0)
_________________
I.M.
Back to top
View user's profile Send private message
pops45042
Apprentice
Apprentice


Joined: 07 Jan 2004
Posts: 278
Location: Cincinnati, Ohio

PostPosted: Mon Dec 18, 2006 5:46 pm    Post subject: Reply with quote

From what I've read, the 64-bit ebuilds aren't ready yet. The ones for this 1.5 version with the overlay are only 32-bit.

Paul
_________________
"That which does not kill me only postpones the inevitable"

Laugh at my old system!
AMD Opteron 165@ 2750Mhz, 2gig 400mhz Cas2 Crucial Ballistix, Abit NF8 Ultra MB, WD 80gig (system), WD 120gig (storage), Geforce 8800GTS 320MB, Mushkin 550W PS
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Tue Dec 19, 2006 12:20 pm    Post subject: Reply with quote

They are only x86 now since Stuart mostly worked on this platform (and had problems with amd64 too). The ebuilds had some amd64 support a few months ago (when I managed to get it working ;) ), but there were many problems.

Here are the versions I used:
nxclient-1.5.0-r4.tbz2
nxcomp-1.5.0-r2.tbz2
nxesd-1.5.0.tbz2
nxserver-freenx-0.5.0.20060311-r1.tbz2
nxssh-1.5.0-r2.tbz2
nx-x11-bin-1.5.0.tbz2

I still have the binary packages, and a tarball of /usr/NX if you want to give a try! I switched to nx freeedition now (as I am the only one using NX, the 2 concurrent connections are enough, and it has even better performance)
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
nahpets
Veteran
Veteran


Joined: 05 Oct 2003
Posts: 1178
Location: Montreal, Canada

PostPosted: Thu Dec 21, 2006 6:44 am    Post subject: Reply with quote

As posted here, there solution to the tcl/tk color problem is adding the following to your '/etc/nxserver/node.conf' file:
Code:

AGENT_EXTRA_OPTIONS_X="-co /usr/share/X11/rgb"

_________________
Let me guess, you picked out yet another colorful box with a crank that I'm expected to turn and turn until OOP! big shock, a jack pops out and you laugh and the kids laugh and the dog laughs and I die a little inside.
Back to top
View user's profile Send private message
imanassypov
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2005
Posts: 118
Location: Toronto, Canada

PostPosted: Fri Jan 12, 2007 4:52 pm    Post subject: Reply with quote

Voyager,

Thanks for your offer.
-yea, i'd be interested to give 'em a shot. Up to this point, the amd64 is still not there and i get

- net-misc/nxserver-freenx-0.5.0-r1 (masked by: missing keyword)

when emerging...

Can you post the tarball on ftp somewhere?


Thx!


-igor
_________________
I.M.
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Fri Jan 12, 2007 5:39 pm    Post subject: Reply with quote

imanassypov, all the tarballs are on my server here:
http://cafarelli.fr/gentoo/

http://cafarelli.fr/gentoo/old-freenx.tgz is the whole /usr/NX tarball, the other nx* are binary packages created with quickpkg

If you get the matching ebuilds from gentoo CVS (as they were removed from portage a few months ago), you can try a binary emerge, or directly unpack the tarball and see what it gives ;) (note that I was using specific SSH keys, you will need to use or change them back to default on your install)

Good luck!
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Mon Jan 29, 2007 12:00 pm    Post subject: Freenx 0.6 -WE WANT AN EBUILD :D Reply with quote

http://mail.kde.org/pipermail/freenx-knx/2007-January/004535.html

[choire]ebuild ebuild ebuild[/choire] :D
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Mon Jan 29, 2007 7:19 pm    Post subject: Reply with quote

FreeNX 0.6 release is great news! I have bumped ebuilds in my overlay for the adventurous to try.

For now I have tested it on a x86 server (both with USE=-nxclient and nxclient), with a remote nxclient 2.1, so far so good, but feedback is welcome ;) (I have a few things to tidy up in the ebuilds before passing them on to bugzilla)
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
mana
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 75
Location: Berlin

PostPosted: Mon Feb 05, 2007 4:44 pm    Post subject: Reply with quote

Sorry did not find any time to test your ebuild. Maybe you guys in the thread here take the lead and post feedback :)

greets
Mana
_________________
Mein Freund, der Baum, ist tot. Er starb im frühen Morgenrot.
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Tue Feb 06, 2007 9:55 am    Post subject: Reply with quote

I made some fixes to the ebuilds (including amd64 support), also they can now be found directly in the Gentoo NX overlay
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
stockton
n00b
n00b


Joined: 21 Mar 2005
Posts: 2
Location: Bulgaria

PostPosted: Tue Feb 06, 2007 1:59 pm    Post subject: net-misc/nx-2.1.0 compilation issue Reply with quote

Voyageur wrote:
I made some fixes to the ebuilds (including amd64 support), also they can now be found directly in the Gentoo NX overlay


Great news! Well,almost ;) I get the following when upgrading to net-misc/nx-2.1.0 :
(No time to investigate right now(probably tomorrow), but it looks like it has something to do with USE="rdesktop")


âò ôåâ 6 15:30:08 EET 2007

./config/util/printver.c: In function ‘main’:
./config/util/printver.c:25: warning: incompatible implicit declaration of built-in function ‘exit’
Full build of XFree86 version 4.3.0 (27 February 2003) complete.

* econf: updating nx-X11/lib/Xft/config/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/lib/Xft/config/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/lib/fontconfig/config/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/lib/fontconfig/config/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/extras/expat/conftools/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/extras/expat/conftools/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/extras/FreeType/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/extras/FreeType/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/extras/freetype2/builds/unix/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/extras/freetype2/builds/unix/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/programs/xterm/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/programs/xterm/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu
checking for i686-pc-linux-gnu-g++... i686-pc-linux-gnu-g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether i686-pc-linux-gnu-g++ accepts -g... yes
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ANSI C... none needed
checking for a BSD-compatible install... /bin/install -c
checking how to run the C++ preprocessor... i686-pc-linux-gnu-g++ -E
checking for X... libraries , headers
checking for dnet_ntoa in -ldnet... no
checking for dnet_ntoa in -ldnet_stub... no
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for Cygwin32 environment... no
checking for Amd64 environment... no
checking for SunOS environment... no
checking for FreeBSD environment... no
enabling dynamic linking of PNG library
enabling dynamic linking of JPEG library
disabling production of debug symbols
disabling info output in the log file
disabling valgrind memory checker workarounds
compiling version 2.1.0
configure: creating ./config.status
config.status: creating Makefile
make: Nothing to be done for `all'.
* econf: updating nx-X11/lib/Xft/config/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/lib/Xft/config/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/lib/fontconfig/config/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/lib/fontconfig/config/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/extras/expat/conftools/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/extras/expat/conftools/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/extras/FreeType/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/extras/FreeType/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/extras/freetype2/builds/unix/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/extras/freetype2/builds/unix/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating nx-X11/programs/xterm/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating nx-X11/programs/xterm/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu
nxdesktop build configuration script

Target directories:
--prefix=PREFIX location for architecture-independent files
--exec-prefix=EPREFIX location for architecture-dependent files
--bindir=BINDIR location for program binaries [EPREFIX/bin]
--mandir=MANDIR location for man pages [PREFIX/man]
--sharedir=SHAREDIR location for architecture-independent shared files [PREFIX/share/rdesktop]

Build configuration:
--with-x=DIR look for X Window System at DIR/include, DIR/lib
--with-openssl=DIR look for OpenSSL at DIR/include, DIR/lib
--with-egd-socket=PATH look for Entropy Gathering Daemon socket at PATH
--with-libvncserver make rdp2vnc
--with-libvncserver-config=CMD
use CMD as libvncserver-config
--with-debug enable protocol debugging output
--with-debug-kbd enable debugging of keyboard handling
--with-debug-rdp5 enable debugging of RDP5 code
--with-debug-clipboard enable debugging of clipboard code
--with-debug-channel enable debugging of channel code
--with-ipv6 enable support for IPv6
--without-sound disable support for sound redirection
--with-sound=ARG only detect sound-support for "oss" or "esd" or "sun" (and BSD)
--with-openssl-static compiles OpenSSL staticly


!!! ERROR: net-misc/nx-2.1.0 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_compile
ebuild.sh, line 937: Called src_compile
nx-2.1.0.ebuild, line 103: Called econf
ebuild.sh, line 540: Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! This ebuild is from an overlay: '/usr/portage/local/layman/nx'
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Tue Feb 06, 2007 4:43 pm    Post subject: Reply with quote

Definitely a problem in the configure step for rdesktop, thanks for the feedback!

Could you try again after updating the overlay? I just added a fix for this
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
stockton
n00b
n00b


Joined: 21 Mar 2005
Posts: 2
Location: Bulgaria

PostPosted: Wed Feb 07, 2007 3:02 pm    Post subject: Reply with quote

Voyageur wrote:
Could you try again after updating the overlay? I just added a fix for this


Yes,that's it! :) The following ebuilds from the layman's NX overlay compile correctly:

net-misc/nx-2.1.0 USE="rdesktop vnc"
net-misc/nxclient-2.1.0
net-misc/nxserver-freenx-0.6.0 USE="cups nxclient -arts -esd"

I didn't have the time (yet) to perform a more complete functionality test, but at least the basic stuff works (and it works nicely), i.e.:
login/logout, setting compression and SSL encryption,display size. The only glitch so far - resuming suspended sessions,when using nomachine's precompiled client (tested only the windows version). When trying to resume, I am able to do so,the desktop appears, but the information window stays open at "Negotiating link parameters" and after a minute or so the desktop window closes and I get a "Connection timeout".

More reports to follow. I am looking forward to using CUPS printing via NX,and more testing with different clients.

Cheers!

P.S. Oh my, I forgot to thank you for the ebuilds! How rude of me! :) So - thanks a lot,mate! Hope my limited feedback helps.
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Wed Feb 07, 2007 9:01 pm    Post subject: Reply with quote

You're welcome, thank you for the feedback (I'll be very interested in CUPS feedback, as my printer bit the dust a few months ago). By the way are you on x86 on amd64?

With a linux client, I do not have any problem resuming a suspended session, I'll try with the windows client when possible (may be a client bug too, what is your version? Current nomachine's windows binary is 2.1.0-16).
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
Fabianx
n00b
n00b


Joined: 06 Sep 2004
Posts: 5

PostPosted: Thu Feb 15, 2007 2:48 pm    Post subject: 64 bit clean Reply with quote

Hi,

I saw that you added my 64 bit clean patch to the experimental branch of the NX overlay.

Has anyone tested this yet. Are there any issues?

I would really like some feedback :-).

You can also answer to:

http://mail.kde.org/pipermail/freenx-knx/2007-February/004659.html

cu

Fabian (upstream FreeNX)
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Fri Feb 16, 2007 11:32 pm    Post subject: Reply with quote

For people who want to try these native-compilation ebuilds, the NX overlay howto has some infos on how to use it (basically add the ebuilds to your local overlay, try it, give feedback/thanks to Fabian ;) )

I'll test them "for real" in a week (holidays for now!), native amd64 without waiting for NX 3.0 release is great news!
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
mastersd
n00b
n00b


Joined: 08 Mar 2007
Posts: 6

PostPosted: Thu Mar 08, 2007 9:48 pm    Post subject: AMD64 cannot open unix:1000 display Reply with quote

I think my native 64-bit AMD overlay install is fine, and but my client fails due to a display connection problem. The log from my client is below. I can't seem to find any solutions posted about not connecting to the unix socket. (I was able to connect successfully to nomachine's test server, so it's my server setup.)

Any help???

--
NXAGENT - Version 2.1.0

Copyright (C) 2001, 2006 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Agent running with pid '15596'.
Session: Starting session at 'Thu Mar 8 13:43:13 2007'.
Info: Proxy running in server mode with pid '15596'.
Info: Waiting for connection from '127.0.0.1' on port '5001'.
Info: Accepted connection from '127.0.0.1' with port '47739'.
Info: Connection with remote proxy established.
Info: Synchronizing local and remote caches.
Info: Handshaking with remote proxy completed.
Info: Using adsl link parameters 512/24/1/0.
Info: Using agent parameters 5000/50/0/0.
Info: Using cache parameters 4/4194304/8192KB/8192KB.
Info: Using image streaming parameters 50/128/1024KB/2048/256.
Info: Using image cache parameters 1/1/32768KB.
Info: Using pack method '16m-jpeg-7' with session 'unix-kde'.
Info: Using ZLIB data compression 3/3/32.
Info: Using ZLIB stream compression 6/6.
Info: No suitable cache file found.
Info: Established X client connection.
Info: Using shared memory parameters 1/1/1/2048K.
Info: Detected window manager running.
Info: Not using local device configuration changes.
Info: Using alpha channel in render extension.
xsetroot: unable to open display 'unix:1001'
xset: unable to open display "unix:1001"
xset: unable to open display "unix:1001"
xset: unable to open display "unix:1001"
xsetroot: unable to open display 'unix:1001'
...
Back to top
View user's profile Send private message
ydleiF
Apprentice
Apprentice


Joined: 15 Nov 2002
Posts: 170
Location: Southeast Michigan, USA

PostPosted: Thu Mar 08, 2007 10:34 pm    Post subject: debug1: Received SIGCHLD. Reply with quote

I installed nxserver-freeedition on one system and it works out great.

Move over to a remote server, and when i try to log in I get authentication failure. Enabling debug on sshd spews out this:

debug1: sshd version OpenSSH_4.5p1
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-D'
debug1: rexec_argv[2]='-d'
debug1: rexec_argv[3]='-e'
debug1: Bind to port 30303 on 0.0.0.0.
Server listening on 0.0.0.0 port 30303.
debug1: Bind to port 22 on 0.0.0.0.
Server listening on 0.0.0.0 port 22.
debug1: Server will not fork when running in debugging mode.
debug1: rexec start in 5 out 5 newsock 5 pipe -1 sock 8
debug1: sshd version OpenSSH_4.5p1
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: inetd sockets after dupping: 3, 3
Connection from 69.212.26.236 port 43267
debug1: Client protocol version 2.0; client software version OpenSSH_3.9p1
debug1: match: OpenSSH_3.9p1 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.5
debug1: permanently_set_uid: 22/22
debug1: list_hostkey_types: ssh-rsa,ssh-dss
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST received
debug1: SSH2_MSG_KEX_DH_GEX_GROUP sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_INIT
debug1: SSH2_MSG_KEX_DH_GEX_REPLY sent
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: KEX done
debug1: userauth-request for user nx service ssh-connection method none
debug1: attempt 0 failures 0
debug1: PAM: initializing for "nx"
debug1: PAM: setting PAM_RHOST to "adsl-69-212-26-236.dsl.sfldmi.ameritech.net"
debug1: PAM: setting PAM_TTY to "ssh"
debug1: userauth-request for user nx service ssh-connection method publickey
debug1: attempt 1 failures 1
debug1: test whether pkalg/pkblob are acceptable
debug1: temporarily_use_uid: 106/410 (e=0/0)
debug1: trying public key file /usr/NX/home/nx/.ssh/authorized_keys
debug1: restore_uid: 0/0
debug1: temporarily_use_uid: 106/410 (e=0/0)
debug1: trying public key file /usr/NX/home/nx/.ssh/authorized_keys2
debug1: matching key found: file /usr/NX/home/nx/.ssh/authorized_keys2, line 3
Found matching RSA key: 85:b6:54:0d:4c:82:d4:c3:62:d4:f0:da:a3:f3:bc:16
debug1: restore_uid: 0/0
Postponed publickey for nx from 69.212.26.236 port 43267 ssh2
debug1: userauth-request for user nx service ssh-connection method publickey
debug1: attempt 2 failures 1
debug1: temporarily_use_uid: 106/410 (e=0/0)
debug1: trying public key file /usr/NX/home/nx/.ssh/authorized_keys
debug1: restore_uid: 0/0
debug1: temporarily_use_uid: 106/410 (e=0/0)
debug1: trying public key file /usr/NX/home/nx/.ssh/authorized_keys2
debug1: matching key found: file /usr/NX/home/nx/.ssh/authorized_keys2, line 3
Found matching RSA key: 85:b6:54:0d:4c:82:d4:c3:62:d4:f0:da:a3:f3:bc:16
debug1: restore_uid: 0/0
debug1: ssh_rsa_verify: signature correct
debug1: do_pam_account: called
Accepted publickey for nx from 69.212.26.236 port 43267 ssh2
debug1: monitor_child_preauth: nx has been authenticated by privileged process
debug1: PAM: reinitializing credentials
debug1: permanently_set_uid: 106/410
debug1: Entering interactive session for SSH2.
debug1: server_init_dispatch_20
debug1: server_input_channel_open: ctype session rchan 0 win 131072 max 32768
debug1: input_session_request
debug1: channel 0: new [server-session]
debug1: session_new: init
debug1: session_new: session 0
debug1: session_open: channel 0
debug1: session_open: session 0: link with channel 0
debug1: server_input_channel_open: confirm session
debug1: server_input_channel_req: channel 0 request x11-req reply 0
debug1: session_by_channel: session 0 channel 0
debug1: session_input_channel_req: session 0 req x11-req
debug1: channel 1: new [X11 inet listener]
debug1: server_input_channel_req: channel 0 request shell reply 0
debug1: session_by_channel: session 0 channel 0
debug1: session_input_channel_req: session 0 req shell

(following emphasis by me)
**
debug1: Received SIGCHLD.
**
debug1: session_by_pid: pid 24882
debug1: session_exit_message: session 0 channel 0 pid 24882
debug1: session_exit_message: release channel 0
Connection closed by 69.212.26.236
debug1: channel 0: free: server-session, nchannels 2
debug1: channel 1: free: X11 inet listener, nchannels 1
debug1: session_close: session 0 pid 0
debug1: do_cleanup
debug1: PAM: cleanup
Closing connection to 69.212.26.236
debug1: PAM: cleanup


I've spent hours on this but i'm wholly stumped. Any hints would be greeeat. I'm VERY tired so I may have missed some important info to provide, so just speak up if you need something.
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Thu Mar 08, 2007 11:22 pm    Post subject: Reply with quote

ydleiF, does `nxloadconfig --check` report any problems (apart from "Users will not be able to request a XXX session")? Can you ssh without a problem to that box? Also, can you paste the uncommented lines from /etc/ssh/sshd_config (to check the server conf)

Also what do nxclient and freenx report ? (you can change NX_LOG_LEVEL=7 in /etc/nxserver/node.conf to make the server more verbose)

EDIT: just realized you are using free edition server, let's continue on this thread. This one is for GPL FreeNX edition
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages


Last edited by Voyageur on Mon Mar 12, 2007 10:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
v912485
n00b
n00b


Joined: 05 Feb 2004
Posts: 26
Location: London, UK

PostPosted: Mon Mar 12, 2007 9:39 pm    Post subject: Reply with quote

Hi,

I have emerged freenx from the overlay. And the server seems to be working fine since I can connect from a Windows machine using the Windows version of nxclient. However when I try to connect from another Gentoo box the client either exits immediately after authentication or shows a black/blank screen when I select XDM.

nxload --check shows no errors
XDMCP is properly configured since I can log in remotely using XDMCP without a problem.
Connecting using the Windows nxclient works fine.

Any one any suggestions on why nxclient from Gentoo does not work? I have tried all available version.

Tnx,
Al
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 27, 28, 29, 30  Next
Page 28 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum