Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IPW2200 & WiFi problemen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
M@rijn
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2004
Posts: 145
Location: Zierikzee (The Netherlands)

PostPosted: Wed Sep 01, 2004 2:31 pm    Post subject: IPW2200 & WiFi problemen Reply with quote

Voordat ik dit in 1 van de algemenere subforums gooi, eerst hier maar eens vragen. Ik heb sinds een week een nieuwe laptop en probeer nu mijn WLAN kaartje aan de gang te krijgen. De laptop betreft een Mitac MTC 8089 en hoort een WLAN kaartje te hebben wat b/g ondersteund.

Ik dus vol goede moed IPW2200 emergen en booten maar, maar dat ging niet echt, ik heb het daarna handmatig geprobeerd maar krijg als nog het volgende bij modprobe:

Code:

bash-2.05b# modprobe ipw2200
WARNING: Error inserting ieee80211_crypt (/lib/modules/2.6.9-rc1/net/ieee80211_crypt.ko): Invalid module format
WARNING: Error inserting ieee80211 (/lib/modules/2.6.9-rc1/net/ieee80211.ko): Invalid module format
FATAL: Error inserting ipw2200 (/lib/modules/2.6.9-rc1/net/ipw2200.ko): Invalid module format


En ja ik ben root. Als ik doe booten en mijn dmesg bekijk zie ik het volgende:

Code:


.....
VFS: Mounted root (reiserfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 132k freed
Adding 498004k swap on /dev/hda3.  Priority:-1 extents:1
hdd: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
hdd: drive_cmd: error=0x04Aborted Command
ieee80211_crypt: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' sho                  uld be '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'
ieee80211: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' should be                   '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'
ipw2200: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' should be '                  2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
ieee80211_crypt: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' sho                  uld be '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'
ieee80211: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' should be                   '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'
ipw2200: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' should be '                  2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'
ieee80211_crypt: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' sho                  uld be '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'
ieee80211: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' should be                   '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'
ipw2200: version magic '2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.4' should be '                  2.6.9-rc1 preempt PENTIUMM 4KSTACKS gcc-3.3'


Ik heb 2 GCC profielen en heb zowel alles gedaan(emergen van de hele boel voor IPW2200, handmatig installeren, en kernel opnieuw compileren) onder het 1ste als onder het 2de profiel. Maar het helpt niets. Wat is het probleem? En klopt het dat ik in mijn kernel config geen IPW2200 zie? Wat volgens sommige howto's wel moet.

GCC-config
Code:
bash-2.05b# gcc-config -l
[1] i386-pc-linux-gnu-3.3.3
[2] i686-pc-linux-gnu-3.4.1
bash-2.05b#


cat /proc/pci
Code:

Bus  1, device   1, function  0:
    Network controller: Intel Corp. PRO/Wireless 2200BG (rev 5).
      IRQ 11.
      Master Capable.  Latency=64.  Min Gnt=3.Max Lat=24.
      Non-prefetchable 32 bit memory at 0xe0001000 [0xe0001fff].

_________________
Gentoo is just an Aston Martin, "Power, beauty and soul"
Back to top
View user's profile Send private message
rockfly
Apprentice
Apprentice


Joined: 27 Apr 2003
Posts: 179

PostPosted: Wed Sep 01, 2004 8:02 pm    Post subject: Reply with quote

probeer de kernel opnieuw te compileren en module-init-tools
Back to top
View user's profile Send private message
eikketk
Apprentice
Apprentice


Joined: 03 Jun 2003
Posts: 270
Location: Belgium

PostPosted: Tue Sep 07, 2004 3:28 pm    Post subject: Reply with quote

Kernel en module zijn met andere compiler gebouwd , vandaar andere magic -> kiezen, en met zelfde compiler beiden compileren.
_________________
Working day and night to enhance the Linux Desktop Experience :)

Homepage
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum