Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IPW2200 Centrino B/G wireless card native drivers
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Thu Sep 02, 2004 9:59 am    Post subject: IPW2200 Centrino B/G wireless card native drivers Reply with quote

Edit 0.16 drivers have been released.

Edit 0.14 and 0.15 drivers are out. My laptop is now deborked, and the 0.15 ebuild works perfectly with the 802.11g AP I'm now using.

Edit 0.13 drivers are out.

Edit 0.12 drivers are out.

Edit 0.11, 0.10 and 0.9 drivers are now on the website as well. These claim to have some support for Adhoc networks and G data rates. I'm having problems with the 0.11 drivers (see post at 18:20 02/10/04 BST), but 0.10 drivers seem to be working.

Edit 0.8 drivers are now on the http://ipw2200.sf.net site, and in portage.

Edit The 0.7 drivers are in portage (howto edited accordingly). They support 802.11g transfer rates, as well as the new IPW2915 a/b/g cards that will begin appearing in Centrino systems soon Also, Uberlord has released a new version 0.61 of the wireless-config scripts that do away with need for the hacked scripts mentioned below. I'm moving the hack to a new post in the thread, with appropriate notes about what it is.

I just got version 0.5 and 0.7 of the Intel native linux drivers (http://ipw2200.sf.net/) to work with my Vaio. I have 128 bit WEP working, can associate to my 802.11b access point and have done an emerge -uDf world over the connection (including downloading the 220 MB of OOo source code). My kernel is 2.6.8-gentoo-r1, but according to the project site, it should work with all 2.6 kernels >2.6.5

The 0.5 and 0.7 drivers are in portage and can be installed that way, although I haven't tried that yet.

Before you start) Note that they drivers may fail to load the firmware correctly if you have loaded the ndiswrapper module and the windows drivers since you last rebooted. Make sure that ndiswrapper is not set to autoload (comment it out in /etc/modules.autoload.d/kernel-2.6, run modules-update and reboot if it is loading automatically at boot).

1) download drivers and firmware packages from the project site

2) unpack firmware package, and copy contents to /usr/lib/hotplug/firmware/

(3+4 may not be required if you have already set these items up)
3) compile the following options into your kernel (I used modules where possible):
a)
Code:
Device Drivers ->
                Generic Driver Options ->
                        <M> Hotplug firmware loading support

b)
Code:
Device Drivers ->
                Networking support ->
                        Wireless LAN (non-hamradio) ->
                               [*] Wireless LAN drivers (non-hamradio) & Wireless Extensions

c)
Code:
Cryptographic options  ->
  <M> ARC4 cipher algorithm
  <M> Michael MIC keyed digest algorithm
  <M> CRC32c CRC algorithm


4) Reboot into your new kernel

5) unpack and make; make install the ipw2200 driver package

6) modprobe ipw2200

7) modprobe ieee80211_crypt_wep (this module is required for WEP encryption, but doesn't currently get loaded automatically)

8) iwconfig should now show the card as eth1 (assuming you have an eth0 configured). The driver does not support interface naming, so it won't appear as wlan0. Configure your wireless settings with
a) iwconfig eth1 essid <YOUR ESSID>
b) iwconfig eth1 key open <YOUR WEP KEY>

9) make sure that eth1 is correctly configured for your network in /etc/conf.d/net

10) /etc/init.d/net.eth1 start (if this reports net.eth1 not found, ln -s /etc/init.d/net.eth0 /etc/init.d/net.eth1)

11) Use wireless networking...

Automatic module loading on boot
(with thanks to Insanity5902 for pointing out what should have been obvious)

First of all we need to make sure the required modules get autoloaded on boot. Add the following to /etc/modules.autoload.d/kernel-2.6.
Code:
ipw2200
ieee80211_crypt_wep

and then run modules-update (i'm not sure this is required, but it can't hurt).

I found that when I added these lines my wired ethernet card became eth1 and the wireless card eth0 on the next boot. You can switch it back around by adding the driver for the wired ethernet card to /etc/modules.autoload.d/kernel-2.6 above the ipw2200 line.

Automatic Wireless Configuration
Uberlord has posted a wireless-config script that can automatically configure you wireless networking. As of version 0.61, this script works with the ipw2200 0.5 and 0.7 drivers. The thread is at https://forums.gentoo.org/viewtopic.php?t=122435

Issues and required work
At the time of updating (2nd Sept 2004), the ipw2200 drivers currently only support Infrastructure mode, not Ad-Hoc mode.

See http://ipw2200.sf.net/ for current driver issues, and for the project mailing lists that may be able to give more detailed help with more difficult problems.


Last edited by dyqik on Mon Dec 06, 2004 10:38 pm; edited 28 times in total
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Thu Sep 02, 2004 12:17 pm    Post subject: Reply with quote

Quote:
6) modprobe ipw2200

7) modprobe ieee80211_crypto_wep (this module is required for WEP encryption, but doesn't currently get loaded automatically)

easy
Code:
echo ipw2200 >> /etc/modules.autoload/kernel-2.6
echo ieee80211_crypto_wep >> /etc/modules.autoload/kernel-2.6

Obvisously if you are using 2.4 kenrnel replace 2.6 with 2.4

Quote:
8 ) iwconfig should now show the card as eth1 (assuming you have an eth0 configured). The driver does not support interface naming, so it won't appear as wlan0. Configure your wireless settings with
a) iwconfig eth1 essid <YOUR ESSID>
b) iwconfig eth1 key open <YOUR WEP KEY>

You should be able to add this into your /etc/init.d/net.eth1, if you are going to be using the same esside adn key every time. What a few of my friends do is make a small script and name it the name of the location (or ssid) so
Code:
#!/bin/bash
iwconfig eth1 essid <LOCATIONS ESSID>
iwconfig eth1 key open <LOCATIONS WEP KEY>

then set it to execute by
Code:
chmod +x <ESSID>.setup

Personally I would create a folder in /etc/ name something like wlan or something similiar and put them all in there, then you just need to execute whichever one you want depending on where you are at.

Quote:
10) /etc/init.d/net.eth1 start (if this reports net.eth1 not found, ln -s /etc/init.d/net.eth0 /etc/init.d/net.eth1)

this one is easy also (if you know all you can connect to when booting up is wirless)
Code:
rc-update add default

Personally what I would do is add it to the bottom of the script we created above, so it will set your ssid , wep key and then start the service. so the file would look like this
Code:
#!/bin/bash
iwconfig eth1 essid <LOCATIONS ESSID>
iwconfig eth1 key open <LOCATIONS WEP KEY>
/etc/init.d/net.eth1 start

_________________
Join the adopt an unanswered post initiative today


Last edited by Insanity5902 on Thu Sep 02, 2004 1:55 pm; edited 2 times in total
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Thu Sep 02, 2004 12:56 pm    Post subject: Reply with quote

These sound like the obvious way to set things up. I like the collection of iwconfig scripts idea.

I'll try them out later, and add them as an "automating the setup" section later.

I don't believe the drivers work with 2.4 kernels yet, but I might be wrong.

BTW I prefer to start the net.ethX scritps by hand, as I use my laptop on a purely wired network at work (wireless would be bad, as we develop radio telescope detectors), as well as on a wireless network at home and other places.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6759
Location: Blighty

PostPosted: Thu Sep 02, 2004 1:11 pm    Post subject: Re: IPW2200 Centrino B/G wireless card native drivers Reply with quote

dyqik wrote:
Some init script guru is required to tell me how to automate steps 6, 7, 8 and 10 on boot.


Step 8 is easy - click my siggy! 8)
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Thu Sep 02, 2004 1:44 pm    Post subject: Reply with quote

dyqik, by putting the init.d command in the script it is started up when you run the ssid script, so it is only started when you want to connect to a wireless network :P


Also it might be interesting to create a <ssid>-up and a <ssid>-down, one that runs /etc/init.d/net.eth* stop and rmmod the mods.


I will also test all this out when i get my laptop in the next week or so. Hopefully I can order it tonight.
_________________
Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Thu Sep 02, 2004 1:53 pm    Post subject: Re: IPW2200 Centrino B/G wireless card native drivers Reply with quote

UberLord wrote:
dyqik wrote:
Some init script guru is required to tell me how to automate steps 6, 7, 8 and 10 on boot.


Step 8 is easy - click my siggy! 8)


There are a lot of pages in that post, so I will ask you a quick questions, if we are running a ~x86 system, your script won't work b/c we have baselayout-1.10.4? or just part of your script won't work.
_________________
Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6759
Location: Blighty

PostPosted: Thu Sep 02, 2004 6:05 pm    Post subject: Re: IPW2200 Centrino B/G wireless card native drivers Reply with quote

Insanity5902 wrote:
There are a lot of pages in that post, so I will ask you a quick questions, if we are running a ~x86 system, your script won't work b/c we have baselayout-1.10.4? or just part of your script won't work.


My script works with all baselayout versions >= 1.8 on on platforms which support wireless-tools (only x86 based atm)
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Thu Sep 02, 2004 6:22 pm    Post subject: Reply with quote

In fact it's working on my system now, with a few tweaks (pm'd to UberLord). Once I've eaten dinner, I'm going to try rebooting and bringing everything up automatically.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6759
Location: Blighty

PostPosted: Thu Sep 02, 2004 6:46 pm    Post subject: Reply with quote

dyqik wrote:
In fact it's working on my system now, with a few tweaks (pm'd to UberLord). Once I've eaten dinner, I'm going to try rebooting and bringing everything up automatically.


I've PM'ed you with a download location for a beta version that fixes your issues.

PM me back if it works :)
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
dbasinge
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jul 2002
Posts: 86
Location: Salt Lake City, UT

PostPosted: Thu Sep 02, 2004 8:09 pm    Post subject: Re: IPW2200 Centrino B/G wireless card native drivers Reply with quote

dyqik wrote:

The 0.5 version of the drivers are not yet in portage, so I downloaded them from the project site (there is a bug reported requesting that the emerge scripts be updated). Here is how I got them to work:

ipw2200 0.5 drivers are now in portage, and work well for me.

Mike
_________________
D. Michael Basinger, RHCE
If at first you don't succeed, skydiving is not for you. - Anonymous
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Thu Sep 02, 2004 8:23 pm    Post subject: Reply with quote

How much configuration do you have to do compared to my original post? or does the ebuild just replace the make; make install and firmware copying parts?
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Thu Sep 02, 2004 9:06 pm    Post subject: Reply with quote

Also version 0.6 of the drivers have been released on the http://ipw2200.sf.net/ site. Includes support for 802.11g and partial support for 802.11a, as well as card id's for the new 802.11a/b/g cards and new firmware. The above instructions should work for 0.6 as long as you get the correct firmware (version 2 instead of version 1).

I don't have access to an 802.11g AP, so if anyone gets these 0.6 drivers to work on an 802.11g network, can they let everyone now if 802.11g transfer rates work. I'm not going to be able to play with the new stuff until the weekend now (I've got a thesis to write).

Things are moving quite fast at the moment...
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Thu Sep 02, 2004 9:24 pm    Post subject: Re: IPW2200 Centrino B/G wireless card native drivers Reply with quote

UberLord wrote:
My script works with all baselayout versions >= 1.8 on on platforms which support wireless-tools (only x86 based atm)


I was just asking b/c of this in the bottom of your post.
Code:
NOTE: Currently cannot detect if /etc/conf.d/net has been patched when >=sys-apps/baselayout-1.10 is installed


But i got bored at school and read a bit and found my answer (i think)
_________________
Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Sat Sep 04, 2004 12:32 pm    Post subject: Reply with quote

I've added a couple of edits to the original post. The 0.6 drivers in portage didn't work with WEP, apparently due to the problems in that driver release. The 0.7 drivers work using the manual installation procedure, and hopefully will work from within portage.

This post is just to bump the thread so others can see what's going on.
Back to top
View user's profile Send private message
Ecco
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2004
Posts: 80
Location: the Netherlands

PostPosted: Sun Sep 05, 2004 5:20 pm    Post subject: Reply with quote

I'll quote myself from another topic:

Ecco wrote:
Weird, I seem to be unable to load the driver properly. I haven't tried the pervious ones since they're not really usable anyway.

I certainly do have an Intel 2200 BG, and it works with ndiswrapper:

Code:
vaio linux # lspci | grep Network
0000:02:02.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev 05)


After I do "modprobe ipw2200" the kernel tells me this:

Code:
ieee80211_crypt: registered algorithm 'NULL'
ipw2200: Intel(R) PRO/Wireless 2200 Network Driver, 0.4
ipw2200: Copyright(c) 2003-2004 Intel Corporation
PCI: Enabling device 0000:02:02.0 (0000 -> 0002)
ACPI: PCI interrupt 0000:02:02.0[A] -> GSI 7 (level, low) -> IRQ 7
PCI: Setting latency timer of device 0000:02:02.0 to 64
ipw2200: Unable to load ucode
ipw2200: Unable to load firmware: 0xFFFFFFFF
ipw2200: failed to register network device


So firmware_class is certainly loaded.
"lsmod" shows me that (amongst others) the following modules are loaded:

Code:
Module                  Size  Used by
ipw2200                93028  0
firmware_class          7488  1 ipw2200
ieee80211              12100  1 ipw2200
ieee80211_crypt         4356  1 ieee80211


I use mm-sources 2.6.8.1-r3 and gcc3.4, could it have to to with either of those?

I have a Sony VAIO A115S and I have this problem with all versions of ipw2200; I tried upto 0.7. Does anyone have any idea?
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Mon Sep 06, 2004 10:55 am    Post subject: Reply with quote

Hmm, my best guess is that the firmware isn't being loaded correctly. The firmware_class module may be loaded, but the firmware itself might be rejected. Can you post all the messages from dmesg after doing modprobe ipw2200? It should start with ipw2200 module loaded or somesuch, and then load the crypt and wep modules. The bit you posted is from just a bit after it tries to load the firmware. BTW, uninstalling the ebuild of the 0.6 drivers deletes any firmware you've put in place (and on my system, deleted the hotplug directory as well).
Back to top
View user's profile Send private message
Ecco
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2004
Posts: 80
Location: the Netherlands

PostPosted: Mon Sep 06, 2004 5:58 pm    Post subject: Reply with quote

Nope, all the firmware files are in place, and this is all I get in dmesg:

Code:
ndiswrapper (iw_set_tx_power:363): setting tx_power failed (C00000BB)
ndiswrapper (free_timers:299): Fixing an active timer left  by buggy windows driver
ieee80211_crypt: registered algorithm 'NULL'
ipw2200: Intel(R) PRO/Wireless 2200 Network Driver, 0.7
ipw2200: Copyright(c) 2003-2004 Intel Corporation
PCI: Enabling device 0000:02:02.0 (0000 -> 0002)
ACPI: PCI interrupt 0000:02:02.0[A] -> GSI 7 (level, low) -> IRQ 7
PCI: Setting latency timer of device 0000:02:02.0 to 64
ipw2200: Unable to load ucode
ipw2200: Unable to load firmware: 0xFFFFFFEA
ipw2200: failed to register network device
ipw2200: probe of 0000:02:02.0 failed with error -5


Where the top two lines are caused by unloading the ndiswrapper before loading ipw2200. I agree it seems to be the firmware, but I don't know what's going wrong. Thanks for your time anyway :)
Back to top
View user's profile Send private message
lpetersen
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 76
Location: Germany

PostPosted: Mon Sep 06, 2004 6:14 pm    Post subject: Reply with quote

Ecco, I had the same problem as you and I noticed that it was related to experimenting with both ndiswrapper and ipw2200 at the same time (or, to be precise, without rebooting in between).

Try rebooting, with autoloading of ndiswrapper disabled (eg, comment out the alias line in /etc/modules.d/ndiswrapper). Then you can cleanly modprobe ipw2200. Once I rmmod ipw2200 && modprobe ndiswrapper, I can no longer rmmod ndiswrapper && modprobe ipw2200 without getting those firmware load errors.

Hope this helps you,
Lars
Back to top
View user's profile Send private message
Ecco
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2004
Posts: 80
Location: the Netherlands

PostPosted: Mon Sep 06, 2004 7:35 pm    Post subject: Reply with quote

Thank you lpetersen!!!

That was it! ipw2200 doesn't load when ndiswrapper has been loaded. It loads now. Now to get is to associate properly and such...
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Tue Sep 07, 2004 4:00 pm    Post subject: Reply with quote

For historical reference, here is the hack required to get Uberlord's wireless-config version 0.55 script to work with ipw2200 version 0.5 and 0.7. I've now removed from the main post, as the new versions work correctly.

Quote:
I managed to get UberLord's wireless-config script (version 0.5.5) to work by making a few hacks. UberLord is working on fixing the problems properly for the latest wireless-config scripts, so hopefully this section won't be here for long.

DO NOT ASK FOR SUPPORT IN THE WIRELESS-CONFIG THREAD BELOW IF YOU USE THESE HACKS

Install the wireless-config scripts following the directions on the first post of https://forums.gentoo.org/viewtopic.php?t=122435.

The wireless config file in /etc/conf.d/wireless is pretty daunting, but most of the options in the examples in that file don't yet work on the ipw2200 drivers. The only options I've had to set to get it to work with WEP on my home wireless network are
Code:
key_<YOUR ESSID>=" open <YOUR WEP KEY>"
preferred_aps=( "<YOUR_ESSID>", "<NEXT_ESSID>" )


Edit the wireless.sh script in /etc/init.d/ (keeping a backup copy), replacing any instances of the command error with eerror ( the one that must be fixed is at line 759), and commenting out the return 1 command on line 760. These two lines are involved in error checking for setting the mode to Managed. since the ipw2200 drivers only support Managed modes, the iwconfig commands to set the mode all fail with an operation unsupported error, exiting the script. We just want to ignore that, as the mode will be managed anyway.
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Tue Sep 07, 2004 4:07 pm    Post subject: Reply with quote

Ecco, I'm including your experiences in the main post. Thinking about it, I had the same problem as well, but forgot to include it.
Back to top
View user's profile Send private message
Ecco
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2004
Posts: 80
Location: the Netherlands

PostPosted: Tue Sep 07, 2004 7:24 pm    Post subject: Reply with quote

dyqik wrote:
Ecco, I'm including your experiences in the main post. Thinking about it, I had the same problem as well, but forgot to include it.

Great guide so far :)
I guess the firmware doesn't unload properly when unloading ndiswrapper...
Back to top
View user's profile Send private message
Ecco
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2004
Posts: 80
Location: the Netherlands

PostPosted: Sat Sep 11, 2004 4:48 pm    Post subject: Reply with quote

Spotted an error though. In step 7, ieee80211_crypto_wep should be ieee80211_crypt_wep (it's crypt and not crypto).
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Sat Sep 11, 2004 6:34 pm    Post subject: Reply with quote

Ta, fixed it
Back to top
View user's profile Send private message
Antioch
n00b
n00b


Joined: 09 Feb 2004
Posts: 25

PostPosted: Sun Sep 19, 2004 10:52 pm    Post subject: Reply with quote

v0.8 out... Not in portage yet....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7  Next
Page 1 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum