Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IPW2200 Centrino B/G wireless card native drivers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Kestrell Kestrell
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2004
Posts: 115
Location: Moscow

PostPosted: Fri Oct 01, 2004 2:41 pm    Post subject: Reply with quote

øxygen wrote:
0.11 is out, Ad-Hoc Mode and Power-Control seems to work now. Still waiting for rfmon Mode. Latest Version in the Portage Tree is still .8. Renaming the ebuild to reflect 0.11 works....


When you say Renaming the ebuild to reflect 0.11 works, I have a vague idea of what you are talking about, but no idea how to do it.

If you can rename the ebuild to 0.11, that means that when you emerge it, it will grab the 0.11 version? Shouldn't 0.11 be older than 0.8? Assuming it is newer, how is it possible that it will grab a driver that is not in portage yet?

Thanks!
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Fri Oct 01, 2004 2:56 pm    Post subject: Reply with quote

K-K The firmware is the issue. It will fail to install if you have loaded before since last rebooting (by using ndiswrapper, or by trying to modprobe ipw2200), or if hotplug isn't working (hotplug loads the firmware).

You also may need to manually load the ieee80211_crypt_wep module before modprobing the ipw2200 module.

Try starting from scratch with the drivers from the ipw2200.sf.net

Download the 0.11 (latest as 0.11 (zero point eleven) > 0.9 ) drivers and the version 2.0 firmware.

Start by removing any of ndiswrapper, iee80211_crypt_wep or ipw2200 from /etc/modules.auotload.d/kernel-2.6 (they may not be there).

Make sure that /usr/src/linux points to the kernel you want to use the modules with.

Install hotplug as described in the gentoo install documentation.

Untar (tar -zxvf file) the firmware files and copy the *.fw files to to /usr/lib/hotplug/firmware/ .

Untar the driver package (as for the firmware) and enter the directory.
Do a make clean, make, make install.

Reboot. (You must do this step)

Make sure that any switch for the wireless card is set to on

modprobe ieee80211_crypt_wep
modprobe ipw2200

run iwconfig and see if you get any results. If not, post a full dmesg output and I'll run through the whole thing.
Back to top
View user's profile Send private message
Kestrell Kestrell
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2004
Posts: 115
Location: Moscow

PostPosted: Fri Oct 01, 2004 3:05 pm    Post subject: Reply with quote

Awesome! Thanks for the detailed response. I've got a few more questions though.

I don't remember anything about hotplug in the handbook, do you remember what section it is in?

Oh, eleven, I was thinking 0.1.1, that makes more sense.

Does it matter where I have the .11 driver installed, I currently have the .9 driver in /tmp/ipw2200.9 or something like that, will the /tmp directory work for .11 or is there a place these are supposed to go?

That is all the questions for now, I appreciate your help, thanks a lot!
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Fri Oct 01, 2004 3:40 pm    Post subject: Reply with quote

Just do the driver make stuff in your home directory, make install takes care of actually putting the drivers in place.

The hotplug stuff is in the genkernel part of the kernel set up in the installation guide. For reference, the actual instructions are:

Code:

# emerge hotplug
# rc-update add hotplug default
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Fri Oct 01, 2004 4:08 pm    Post subject: Reply with quote

Kestrell Kestrell

What if you want to emerge the drivers, what you are going to do is set the build up in your portage overlay directory.

By default this is /usr/local/portage. You can change this in make.conf if you want it somewhere else.

All of this should been ran as root
First we need to create the directory structure in your overlay directory for the ipw2200 drviers. Make sure /usr/local/portage exist adn then run this ommand
Code:
mkdir /usr/local/portage/net-wireless && mkdir /usr/local/portage/net-wireless/ipw2200


then we are going to copy over the old ebuild and rename it to .10
Code:
cp /usr/portage/net-wireless/ipw2200/ipw2200-0.5.ebuild /usr/local/portage/net-wireless/ipw2200/ipw2200-0.10.ebuild

Quote:
If you get an error saying the desitatnio doesn't exits, I had to cd into /usr/local/portage/net-wireless/ipw2200 first for some reason



After this we need to make the digest for it so run
Code:
ebuild /usr/local/portage/net-wireless/ipw2200/ipw2200-0.10.ebuild digest


now you should be able to run
Code:
 emerge -vp ipw2200
and see that it wants to emerge the .10 version of the drivers, off to the side you will see a [1] and a note at the bottom saying [1] /usr/local/portage

You are done, and if people says this works, then you are set.

Just so you know, the reason you put it in an overlay dir and not the main, is b/c the next time you were to emerge sync, it would delete b/c it isn't in the rsync mirror. And then if you ran emerge -vauD world, it woudl want to downgroud your .10 drivers, to whatever is default in portage.

so basically you can do this then follow the directions above except where it talks about d/l the ipw2200 drivers and run configure, make, install.
_________________
Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Fri Oct 01, 2004 5:31 pm    Post subject: Reply with quote

Make sure that CONFIG_HOTPLUG=y is set in the kernel, otherwise the firmware is not loaded on ipw2200 module startup
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
kf_man
n00b
n00b


Joined: 20 Feb 2004
Posts: 21

PostPosted: Fri Oct 01, 2004 7:47 pm    Post subject: Reply with quote

Code:

ieee80211_crypt: registered algorithm 'NULL'
ieee80211_crypt: registered algorithm 'WEP'
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 0.11
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI interrupt 0000:02:02.0[A] -> GSI 5 (level, low) -> IRQ 5
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw2200_boot.fw load failed
ipw2200: Unable to load firmware: 0xFFFFFFFE
ipw2200: failed to register network device
ipw2200: probe of 0000:02:02.0 failed with error -5


This is the problem I'm having...the firmware won't load. I have hotplug installed and I have hotplug enabled in the kernel.

Any help would be appreciated.
_________________
-Kyle
Linux n00b

System:
HP zt3000
Pentium M 1.6 GHz
1GB PC2700 DDR SDRAM
100GB 5400RPM
Intel audio
ATI Radeon 9000
Realtek 8139
IPW2200
Agere Modem
Back to top
View user's profile Send private message
pangloss
n00b
n00b


Joined: 02 Aug 2002
Posts: 46
Location: Ithaca, NY

PostPosted: Fri Oct 01, 2004 9:04 pm    Post subject: Reply with quote

Insanity, I'll buy you a drink anytime =) Thanks for the mini howto.

I just upgraded to the .11 drivers and I can now associate with the access point that was giving me problems (ssid is hidden/not broadcast). Jay you might try the new driver as well--associating without having to use the MAC.

I can't actually seem to route any traffic though. Works fine when I associate with any other (ssid broadcast) ap, though. It might be that this particular ap doesn't have my MAC address listed correctly in its list of allowed nics. Waiting to hear back on that--don't see how the driver could be at fault now that I'm associated to the ap.
Back to top
View user's profile Send private message
Kestrell Kestrell
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2004
Posts: 115
Location: Moscow

PostPosted: Fri Oct 01, 2004 11:37 pm    Post subject: Reply with quote

dyqik wrote:
K-K
run iwconfig and see if you get any results. If not, post a full dmesg output and I'll run through the whole thing.


I did all of the steps that you listed, with V2.0 firmware and .11 driver. I rebooted and when I run iwconfig I get the same no wireless extensions message.

Dmesg is still outputting that it can't load the firmware, I also noticed that in my menuconfig under Device Drivers -> Generic Driver Options I have "Prevent firmware from being built" as a yes. Is this bad?
Here is my dmesg:

NTFS volume version 3.1.
b44: eth0: Link is down.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: excluding 0x8c0-0x8e7
cs: IO port probe 0x0100-0x04ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
ieee80211_crypt: registered algorithm 'NULL'
ieee80211_crypt: registered algorithm 'WEP'
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 0.11
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI interrupt 0000:02:03.0[A] -> GSI 7 (level, low) -> IRQ 7
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw2200_boot.fw load failed
ipw2200: Unable to load firmware: 0xFFFFFFFE
ipw2200: failed to register network device
ipw2200: probe of 0000:02:03.0 failed with error -5

Thanks!
Back to top
View user's profile Send private message
kf_man
n00b
n00b


Joined: 20 Feb 2004
Posts: 21

PostPosted: Sat Oct 02, 2004 12:28 am    Post subject: Reply with quote

I finally got it to work! If you have the latest hotplug (I can't remember which), the firmware is stored in "/lib/firmware". As soon as I moved it, I was online! Good luck.
_________________
-Kyle
Linux n00b

System:
HP zt3000
Pentium M 1.6 GHz
1GB PC2700 DDR SDRAM
100GB 5400RPM
Intel audio
ATI Radeon 9000
Realtek 8139
IPW2200
Agere Modem
Back to top
View user's profile Send private message
Kestrell Kestrell
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2004
Posts: 115
Location: Moscow

PostPosted: Sat Oct 02, 2004 12:56 am    Post subject: Reply with quote

kf_man wrote:
I finally got it to work! If you have the latest hotplug (I can't remember which), the firmware is stored in "/lib/firmware". As soon as I moved it, I was online! Good luck.


Hey, this is what is in my /usr/lib/hotplug/firmware

LICENSE ipw2200_boot.fw ipw2200_bss.fw ipw2200_ibss.fw ipw2200_ucode.fw

In your kernel do you have
Device Drivers -> Generic Driver Options -> "Prevent firmware from being built" as a yes, or a no?
Back to top
View user's profile Send private message
kf_man
n00b
n00b


Joined: 20 Feb 2004
Posts: 21

PostPosted: Sat Oct 02, 2004 5:31 am    Post subject: Reply with quote

You need to move all of the firmware files to the directory "/lib/firmware" if you have the latest hotplug. I have that option set to yes, but I don't think it affects this at all.
_________________
-Kyle
Linux n00b

System:
HP zt3000
Pentium M 1.6 GHz
1GB PC2700 DDR SDRAM
100GB 5400RPM
Intel audio
ATI Radeon 9000
Realtek 8139
IPW2200
Agere Modem
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Sat Oct 02, 2004 5:22 pm    Post subject: Reply with quote

I'm having association problems with the 0.11 drivers. I can sometimes get them to associate with my AP, but the association fails after a while. The 0.10 drivers seem to work ok at the moment, although I haven't extensively tested them. There is no sign of errors in any log with the 0.11 drivers.

This problem has also been reported on the ipw2100 mailing list.
Back to top
View user's profile Send private message
Kestrell Kestrell
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2004
Posts: 115
Location: Moscow

PostPosted: Sat Oct 02, 2004 9:50 pm    Post subject: Reply with quote

I moved the firmware to /lib/firmware and that brought it up so that iwconfig recognized it.
Nowwhen I started it, I got this:

acorn ~ # /etc/init.d/net.eth1 start
* For iproute2 support, emerge sys-apps/iproute2
* Falling back to ifconfig configuration
* Bringing eth1 up...
* eth1 dhcp
[ !! ]

acorn ~ #

so I am assuming that it came up ok. I unplugged my network cable and tried to use it, the internet didn't work so I ran a dmesg and got this:

eth1: decryption failed (SA=00:0d:88:1e:bc:de) res=-2
eth1: WEP decryption failed ICV mismatch

about 50 times.

Does anyone know what it means and how to fix it?
Back to top
View user's profile Send private message
Kestrell Kestrell
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2004
Posts: 115
Location: Moscow

PostPosted: Sat Oct 02, 2004 10:15 pm    Post subject: Reply with quote

So, I'm a pretty big jackass. I typed the key in wrong, anyways, I got it working now.

One question left, how can I have more than 1 wireless network? I want to be able to connect at work and at home.

One more question:
When I reboot, my eth1 loses the essid name and WEN key, so I have to do the
iwconfig eth1 essid ...
iwconfig eth1 key open ...
commands again. Is there a way to have it store them permanently?
Back to top
View user's profile Send private message
kf_man
n00b
n00b


Joined: 20 Feb 2004
Posts: 21

PostPosted: Sun Oct 03, 2004 4:31 am    Post subject: Reply with quote

Well, I got it working two ways. The better of which is using the latest version of "baselayout" as described here: https://forums.gentoo.org/viewtopic.php?t=122435

Another alternative is to use "WiFi Radar" which is a graphical program, but I didn't find that one to work as well. I would suggest that you try the methods above first.

The forum can be a bit long, so you should try to read as much as you can. There are actually two threads for this, you can get to the second by the link on the last post. Near the end of the second post is a new package of scripts and configs as well.
_________________
-Kyle
Linux n00b

System:
HP zt3000
Pentium M 1.6 GHz
1GB PC2700 DDR SDRAM
100GB 5400RPM
Intel audio
ATI Radeon 9000
Realtek 8139
IPW2200
Agere Modem
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Sun Oct 03, 2004 10:40 am    Post subject: Reply with quote

Uberlord's wireless config scripts are what you want for configuration. These are in the bleeding edge baselayout package.
Back to top
View user's profile Send private message
pangloss
n00b
n00b


Joined: 02 Aug 2002
Posts: 46
Location: Ithaca, NY

PostPosted: Tue Oct 05, 2004 3:20 am    Post subject: Reply with quote

kestrell,

also take a look at netapplet. you could probably use netapplet in conjunction with the new baselayout stuff too.
Back to top
View user's profile Send private message
drklabuse
n00b
n00b


Joined: 27 Apr 2004
Posts: 9

PostPosted: Wed Oct 06, 2004 12:22 pm    Post subject: Reply with quote

Hi,

i have a problem with my Intel Pro 2200. After loading the ipw2200
module, i get this from "dmesg | grep ipw2200" :

Code:

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 0.11
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Radio Frequency Kill Switch is On:
ipw2200: No space for Tx
ipw2200: failed to send POWER_MODE command


The problem is, that i dont have access to an AP or another wireless card
at the moment, so i tried to configure my i card in ad-hoc mode(dont know
if this should work, im a noob to wireless stuff). I just wanted to configure
it so far as i can without makeing a connection.

Some more info:

installed packages:
net-wireless/ipw2200-0.11
net-wireless/wireless-tools-27_pre26-r1
sys-apps/baselayout-1.11.1


my configuration so far:

/etc/conf.d/wireless
Code:

essid_eth1="any"
mode_eth1="ad-hoc"
channel_eth1="3"
key_any="off"


kernel options are all set as mentioned in this thread. Another problem
could be my notebook itself. It has a function key to start and stop
wireless, wich i havent configured yet under linux. I tried to do it with the
iwpriv tool, but without success.

So has someone any ideas whats going on, or does it have to look like this?
Back to top
View user's profile Send private message
dyqik
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2003
Posts: 120
Location: Oxford, UK

PostPosted: Wed Oct 06, 2004 12:40 pm    Post subject: Reply with quote

That's the same output I got with ipw2200 v0.11. I couldn't associate properly with it, but I don't know that the error reported by dmesg is the source of the problem.
Back to top
View user's profile Send private message
drklabuse
n00b
n00b


Joined: 27 Apr 2004
Posts: 9

PostPosted: Wed Oct 06, 2004 2:35 pm    Post subject: Reply with quote

should not hav greped the dmesg output:

Code:

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 0.11
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI interrupt 0000:02:06.0[A] -> GSI 10 (level, low) -> IRQ 10
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.
ipw2200: No space for Tx
ipw2200: failed to send POWER_MODE command
ipw2200: Already sending a command
ipw2200: failed to send POWER_MODE command


the last two lines appear if i try to use iwpriv to turn on the power.
So i think i have to turn off the Kill switch. But how do i do that?
Back to top
View user's profile Send private message
drklabuse
n00b
n00b


Joined: 27 Apr 2004
Posts: 9

PostPosted: Wed Oct 06, 2004 3:06 pm    Post subject: Reply with quote

i think i have found the solution. i had to load a module for the hotkeys of
my notebook called acerhk(doesnt only work with acer notebooks, mines a
fujitsu)
then i just have to turn the card on by:

echo "1" > /proc/driver/acerhk/wirelessled

well the led isnt on now, but i dont get the error because of the kill switch.
make sure that you first do the echo command and then load the module.

hope that helps others.

My next problem now is that if i start the eth1 device with the init script, it
complaines that there was a problem loading the firmeware.
But i have the firmware files in /usr/lib/hotplug/firmware and symlinks in
/lib/firmware pointing to /usr/lib/hotplug/firmware

whats wrong now?
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Wed Oct 06, 2004 6:27 pm    Post subject: Reply with quote

Install hotplug with "emerge hotplug" and add it to the init script. "rc-update add hotplug default"
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
drklabuse
n00b
n00b


Joined: 27 Apr 2004
Posts: 9

PostPosted: Wed Oct 06, 2004 9:39 pm    Post subject: Reply with quote

i already had hotplug emerged and added to the default runlevel.

any other ideas?
Back to top
View user's profile Send private message
drklabuse
n00b
n00b


Joined: 27 Apr 2004
Posts: 9

PostPosted: Thu Oct 07, 2004 10:54 am    Post subject: Reply with quote

i looked into the wireless script(/etc/net.modules.d/wireless) to find out what
is causing this error message. Its because of the iwconfig output which looks
like this:


Code:

eth1      unassociated  ESSID:off/any  Nickname:"any"
          Mode:Ad-Hoc  Frequency=2.422 GHz  Cell: 00:00:00:00:00:00
          Bit Rate=0 kb/s   Tx-Power=255 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on


this script looks for an ieee number, which should stand next to the
interfacename(instead of "unassociated"). So how do i associate my card?
Strange also is that if I call
Code:

iwpriv eth1 get_mode


i get the ieee number. Is it just a bug that its not mentioned by iwconfig?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 3 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum