Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas para instalar o Alsa
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
alex-gurgel
n00b
n00b


Joined: 06 Sep 2004
Posts: 13
Location: Brasil - Rio de Janeiro

PostPosted: Mon Sep 06, 2004 4:37 am    Post subject: Problemas para instalar o Alsa Reply with quote

Instalei o Gentoo muito recente ( Vida Linux Gentoo ) e estou com problemas para usar o comando emerge alsa-driver. Quando eu tento, vem a seguinte mensagem:
Code:
Calculating dependencies ...done!
 
!!! Error: the virtual/modutils package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.
.

Se eu uso emerge --pretend alsa-drivers a mensagem é a seguinte:
Code:
These are the packages that I would merge, in order:
 
Calculating dependencies ...done!
[blocks B     ] sys-apps/modutils ("virtual/modutils" from pkg sys-apps/module-init-tools-3.0-r2)
[ebuild  N    ] sys-apps/module-init-tools-3.0-r2
[ebuild  N    ] sys-kernel/gentoo-sources-2.4.26-r9
[ebuild  N    ] media-sound/alsa-headers-1.0.5a
[ebuild  N    ] media-sound/alsa-driver-1.0.5a


Alguma dica de como resolver ?
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2741
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Mon Sep 06, 2004 5:58 am    Post subject: Reply with quote

Con el kernel-2.6.x no se instala emerge alsa-drivers!
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Mon Sep 06, 2004 2:05 pm    Post subject: Re: Problemas para instalar o Alsa Reply with quote

alex-gurgel wrote:
Instalei o Gentoo muito recente ( Vida Linux Gentoo )

Desculpe, mas AFAIK questões técnicas sobre o VidaLinux não podem ser respondidas aqui. O VidaLinux é um projeto comercial, baseado no Linux mas que não está sob responsabilidade da distro. Você pode se utilizar dos recursos da própria distro ou no fórum Off-The-Wall.
Back to top
View user's profile Send private message
alex-gurgel
n00b
n00b


Joined: 06 Sep 2004
Posts: 13
Location: Brasil - Rio de Janeiro

PostPosted: Mon Sep 06, 2004 3:40 pm    Post subject: Re: Problemas para instalar o Alsa Reply with quote

fernandotcl wrote:

Desculpe, mas AFAIK questões técnicas sobre o VidaLinux não podem ser respondidas aqui. O VidaLinux é um projeto comercial, baseado no Linux mas que não está sob responsabilidade da distro. Você pode se utilizar dos recursos da própria distro ou no fórum Off-The-Wall.


Nesse caso me desculpe, mas obtive esse linux na revista PCMaster deste mes, aonde o mesmo é apresentado apenas como Gentoo. Ao se abrir a revista ( e instalar o mesmo ) é que se percebe ser nomeado VidaLinux Desktop OS, não sendo informado ser um sistema comercial e, mesmo no site da distro existe a informação de duas versões, sendo que uma ( a mais completa ) é paga. Bem, não creio que isso caracterize uma distro como comercial mas, em todo o caso....

Sendo uma distro que segue a filosofia do Gentoo ( acho eu ), achei que aqui seria o local certo para postar uma dúvida.

Assim sendo, fica aqui o meu pedido de desculpas e informo que estarei neste fórum apenas como espectador, não mais perguntando nada.


E, pablo_supertux, apenas para não deixar sua colocação sem resposta, meu kernel é o 2.4.20-gentoo-r6.
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Tue Sep 07, 2004 5:18 am    Post subject: Reply with quote

Bem, vamos com calma. Sempre houve um grande espirito de entre-ajuda ente a comunidade de Gentoo não vamos modificar essa imagem.

Se já demos ajuda em tópicos que não têm nada a ver com Gentoo (hardware por exemplo), qual é o problema de prestar uma ajuda básica a um utilizador do portage? Se ainda fosse um problema específico de outra distribuição, talvez se compreendesse. E mesmo assim acho que uma ajudazita no que fosse possível era bem vinda. Mas é uma questão simples ainda por cima. Vamos lá malta, um bocado mais de camaradagem e menos elitismo.

Alex, podes colocar as tuas questões à vontade. Se forem questões cujo problema ou resolução seja específico da tua distribuição a ajuda pode não ser boa, mas pelo menos tentamos né?

O teu problema é simples, tu tens instalado o modutils, pacote que te fornece o modprobe, insmod entre outros. Esse pacote não serve para os kerneis 2.6, para esses kerneis existe o module-init-tools que para além de funcionar nos kerneis 2.6 é perfeitamente compatível com os kerneis 2.4. Agora, o alsa quer o module-init-tools mas tu tens instalado o modutils. Podes com segurança desinstalar o modutils e instalar o module-init-tools e tens o teu problema resolvido.

Espero que resolva. Se não resolver diz qual é o problema.
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Tue Sep 07, 2004 6:41 pm    Post subject: Reply with quote

Ok, por mim tudo bem responder aqui. Eu sinceramente acho um tiro no pé, afinal de contas já nos bastam nossos problemas, se começarem a surgir problemas de outras distros aqui vai ser difícil manter a fama da comunidade Gentoo (mesmo porque o Gentoo do nome vai pro espaço). Mas quem sou eu pra dizer o que é certo ou errado...
Back to top
View user's profile Send private message
Mythos
l33t
l33t


Joined: 02 May 2004
Posts: 953
Location: Portugal

PostPosted: Tue Sep 07, 2004 11:19 pm    Post subject: Que grande trapalhada! Reply with quote

eu faço emerge alsa-driver, alsatools etc etc.

prefiro usar o som dessa maneira, não meto pleo kernel, contudo é sempre necessário tornar modules os OSS da placa.
_________________
Best Regards,
Sérgio Henrique
Linux dune 3.0.6-gentoo #1 SMP Thu Oct 27 16:47:29 WEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
alex-gurgel
n00b
n00b


Joined: 06 Sep 2004
Posts: 13
Location: Brasil - Rio de Janeiro

PostPosted: Tue Sep 07, 2004 11:23 pm    Post subject: Reply with quote

Fernandotcl, acho apenas, nesse caso, que estamos falando do mesmo estilo de distro. Afinal, até onde vai meu parco conhecimento do Gentoo, o Vidalinux nada mais é do que o Gentoo com uma instalação a base do Anaconda ( instalador do Red Hat ) e com alguns pacotes prontos para a instalação ( Xfree, Open Office e Gnome ). Acho que existe um processo de instalação do Gentoo em que eu baixo os cds e instalo através dele, sem internet. Mas deixemos isso para lá.

O importante é que eu consegui instalar o Alsa, a partir das dicas daqui. Certo que precisei instalar mais alguns pacotes e recompilar o kernel ( usei o genkernel, excelente !! ) já que as fontes do kernel necessárias não eram as que eu tinha instalado. Mas continuo sem som.....

Faltam os /dev/dsp, /dev/mixer e outros. Nao consigo rodar o MAKEDEV audio pois o devfsd não deixa e não consigo dar boot sem ele instalado. Mas um dia eu acerto !!!

Até lá eu vou aprendendo sobre o Gentoo ( que é o que eu prefiro acreditar que meu sistema seja ) !!!

Abraços e obrigado.
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Sep 08, 2004 12:16 am    Post subject: Reply with quote

alex-gurgel wrote:
Fernandotcl, acho apenas, nesse caso, que estamos falando do mesmo estilo de distro. Afinal, até onde vai meu parco conhecimento do Gentoo, o Vidalinux nada mais é do que o Gentoo com uma instalação a base do Anaconda ( instalador do Red Hat ) e com alguns pacotes prontos para a instalação ( Xfree, Open Office e Gnome ). Acho que existe um processo de instalação do Gentoo em que eu baixo os cds e instalo através dele, sem internet. Mas deixemos isso para lá.

Sim, mas é como se um usuário do Kurumin postasse um problema nos fórums do Debian, ou no canal de IRC. Mas, como já disse, sem problemas, não sou o dono do fórum. :)

alex-gurgel wrote:
O importante é que eu consegui instalar o Alsa, a partir das dicas daqui. Certo que precisei instalar mais alguns pacotes e recompilar o kernel ( usei o genkernel, excelente !! ) já que as fontes do kernel necessárias não eram as que eu tinha instalado. Mas continuo sem som.....

Tente:
Code:
# amixer set Master 100 unmute
# amixer set PCM 100 unmute
# alsactl store
# rc-update add alsasound default (se já não tiver feito)


alex-gurgel wrote:
Faltam os /dev/dsp, /dev/mixer e outros. Nao consigo rodar o MAKEDEV audio pois o devfsd não deixa e não consigo dar boot sem ele instalado. Mas um dia eu acerto !!!

Você tem que ter emulação de OSS no kernel.

alex-gurgel wrote:
Até lá eu vou aprendendo sobre o Gentoo ( que é o que eu prefiro acreditar que meu sistema seja ) !!!

É por isso que se lê um manual gigante antes de instalar Gentoo, e é isso que eu te aconselharia. Lá tem um capítulo inteiro só sobre som.
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Wed Sep 08, 2004 12:40 am    Post subject: Reply with quote

fernandotcl wrote:
Ok, por mim tudo bem responder aqui. Eu sinceramente acho um tiro no pé, afinal de contas já nos bastam nossos problemas, se começarem a surgir problemas de outras distros aqui vai ser difícil manter a fama da comunidade Gentoo (mesmo porque o Gentoo do nome vai pro espaço). Mas quem sou eu pra dizer o que é certo ou errado...


Tu és um utilizador de Gentoo e destes forum, logo és tão pessoa para dizer o que é certo ou errado como eu ou outro utilizador qq do forum. eu apenas tenho é permissões para moderar a secção de Português, isso não faz de mim mais do que tu ou outro utilizador, faz é com que eu tenha mais trabalho às vezes =) Para além disso cada um tem a sua opinião que não tem que ser igual à de todos, daí que és livre de dizer a tua assim como eu sou livre de dizer a minha.

Sinceramente não considero um tiro no pé ajudar um utilizador com uma dúvida comum, afinal de contas não há um forum para os utilizadores do Portage em Mac OS X? Aqui ainda é mais simples.

Alex:
Segue as instruções do fernando mas altera só um pequeno detalhe. Onde está:
Code:

# rc-update add alsasound default (se já não tiver feito)


Devia estar:
Code:

# rc-update add alsasound boot (se já não tiver feito)


Porque o alsasound deve ser adicionado ao runlevel Boot.

Se mesmo assim não der, verifica se o teu utilizador pertence ao grupo Audio. Se nada disso funcionar lê de novo o Alsa Guide que pode ser encontrado aqui.
Back to top
View user's profile Send private message
anunakin
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 101

PostPosted: Fri Sep 10, 2004 12:15 pm    Post subject: Reply with quote

Se estiveres usando o kernel 2.6.x, coloque os modulos de son do ALSA do kernel como <M> módulos, só assim vais conseguir instalar o Alsa.... separado! Mas pra q? :?
_________________
Anunakin (Marcus Fazzi)
PHP/Java/C++ Developer
Sony PS3 JPN 60GB, with Gentoo Linux + HDD 160GB
Sony PS2 50001, with PS2Linux, HDD 80GB
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Fri Sep 10, 2004 5:44 pm    Post subject: Reply with quote

RoadRunner wrote:
eu apenas tenho é permissões para moderar a secção de Português, isso não faz de mim mais do que tu ou outro utilizador, faz é com que eu tenha mais trabalho às vezes =) Para além disso cada um tem a sua opinião que não tem que ser igual à de todos, daí que és livre de dizer a tua assim como eu sou livre de dizer a minha.

Nunca quis dizer o contrário disso, na verdade... :D

RoadRunner wrote:
Porque o alsasound deve ser adicionado ao runlevel Boot.

Exato, falha minha. É por isso que eu tive que colocar o snd-via82xx no /etc/modules.autoload.d/. Bem notado.

anunakin wrote:
Se estiveres usando o kernel 2.6.x, coloque os modulos de son do ALSA do kernel como <M> módulos, só assim vais conseguir instalar o Alsa.... separado! Mas pra q?

Ter os drivers de som como módulos é uma recomendação da equipe do Alsa. Certamente não teria problema, mas talvez haja alguma configuração a ser feita antes de carregar os módulos, então o ideal é não fugir desse padrão.
Back to top
View user's profile Send private message
alex-gurgel
n00b
n00b


Joined: 06 Sep 2004
Posts: 13
Location: Brasil - Rio de Janeiro

PostPosted: Fri Sep 10, 2004 6:44 pm    Post subject: Reply with quote

Senhores, para informar: o problema foi resolvido. Ao que me parece a situação é causada por um problema nesta versão específica. Ontem eu baixei a versão mais atualizada ( Vidalinux Desktop OS Beta 2 ) e instalei hoje. A mesma vem com o kernel 2.6.7 e os módulos alsa, além de suporte a reiserfs, coisas que não tinham na versão que adquiri com a revista PCMaster ( era a versão Beta 1 ). Pois bem, instalei e fiz o emerge do source do kernel ( estava no CD ) e o som está funcionando.

Sendo assim o problema era a versão. Faltam apenas alguns retoques de configuração para que a distro fique com a cara que eu desejo.

Muitos agradecimentos e abraços.

P.S.: Postei uma outra dúvida em outro post.
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Sun Sep 12, 2004 8:46 am    Post subject: Reply with quote

Problemas com ALSA e kernel 2.6.x onde é que eu já vi isso? :lol: :lol: :lol: :lol: :lol:


_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
Stranger_in_the_night
n00b
n00b


Joined: 18 Oct 2004
Posts: 13

PostPosted: Wed Oct 20, 2004 2:11 pm    Post subject: Re: Problemas para instalar o Alsa Reply with quote

Hello guis,

I am faceing just the same problem as I guess form this posting.
Unfortunately I don´t speak your language so I am not quite sure, how you solved it (if so).

Would one of you kindly just post an english conclution of it?

Thanks a lot

Stranger

PS: My kernel is 2.4.25 with epia patch

Quote:

emerge alsa-driver.
Calculating dependencies ...done!

!!! Error: the virtual/modutils package conflicts with another package.
!!! both can't be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.


emerge --pretend alsa-drivers
These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B ] sys-apps/modutils ("virtual/modutils" from pkg sys-apps/module-init-tools-3.0-r2)
[ebuild N ] sys-apps/module-init-tools-3.0-r2
[ebuild N ] sys-kernel/gentoo-sources-2.4.27-r1
[ebuild N ] media-sound/alsa-headers-1.0.5a
[ebuild N ] media-sound/alsa-driver-1.0.6a[/code]
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Wed Oct 20, 2004 2:41 pm    Post subject: Reply with quote

Quanto ao vidalinux, parece-me um pouco desleal criar uma nova "distro" que não é mais que um installer grafico do gentoo que utiliza os proprios mirrors e outros recursos de gentoo, principalmente quando uma das versões até é paga. (corrijam-me se estou errado)

Na realidade é que os users depois dessa instalação estão a usar Gentoo, por isso é normal que venham aqui. Sempre é sinal que estão a usar Gentoo, desde que não sejam o tipo de user preguiçoso que deixa questões vagas sem dar grande informação à espera de uma reposta mágica, considero-o como um utilizador normal de gentoo.


Agora uma questão sobre o tema... Como é que voces fazem quando tem alsa no kernel e o portage ateima em tentar instalar o alsa-driver? Eu fiz um emerge inject, mas deve haver uma forma mais limpa e definitiva de o fazer ;)
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Wed Oct 20, 2004 2:50 pm    Post subject: Reply with quote

alex-gurgel wrote:
Senhores, para informar: o problema foi resolvido. Ao que me parece a situação é causada por um problema nesta versão específica. Ontem eu baixei a versão mais atualizada ( Vidalinux Desktop OS Beta 2 ) e instalei hoje. A mesma vem com o kernel 2.6.7 e os módulos alsa, além de suporte a reiserfs, coisas que não tinham na versão que adquiri com a revista PCMaster ( era a versão Beta 1 ). Pois bem, instalei e fiz o emerge do source do kernel ( estava no CD ) e o som está funcionando.

Sendo assim o problema era a versão. Faltam apenas alguns retoques de configuração para que a distro fique com a cara que eu desejo.

Muitos agradecimentos e abraços.

P.S.: Postei uma outra dúvida em outro post.


hehe, resolveste o problema à lá window$

Já que estás a usar gentoo habitua-te que o conceito de versão apenas existe para o meio que utilizaste para instalar, a partir daí basta ir fazendo os updates atraves do portage para ficar com a ultima "versão". Provavelmente esse problema resolvia-se com um
Code:
emerge unmerge modutils
emerge module-init-tools
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum