Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
A grey screen instead of linux?? (yaboot static problem?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
nesnimda
n00b
n00b


Joined: 05 Sep 2004
Posts: 33
Location: my own little world ^^

PostPosted: Wed Sep 08, 2004 2:26 am    Post subject: A grey screen instead of linux?? (yaboot static problem?) Reply with quote

Ok... I've tried installing gentoo on my G5 desktop, and it seemed that everything went on w/o a hitch... exxxcceeeept...
when I load computer, and select "l" in yaboot-static, I get the "files missing" icon flashing for a few seconds and then a grey screen pops up. What does this mean and how would I fix it? *sigh* Gentoo is so cool, but so hard to set up sometimes -_-
1 thing that might be related that REALLY caught my eye was that yabootconfig wouldn't work because it couldn't find my bootstrap partition. I found this incredibly strange.. considering I know I added it.. I tried to use mac-fdisk, but it also stopped working, citing that my partition map entry (944) is not equal to block size (512).

Some printouts (copied by hand, in case there's sp errros)
ls /boot
Code:
System.map-2.6.8 boot config-2.6.8 kernel-2.6.8


/etc/fstab
Code:

/dev/sda3     /                ext2      noatime             1 2
/dev/sda4     none          hfs       sw                     0 0
/dev/sda9     /home        hfs       noatime,defaults 1 2
/dev/sda5     /var/mail     hfs       noatime,defaults 1 2

dev/cdroms/cdrom0 /mnt/cdrom auto noauto,ro,users 0 0

none            /proc          proc     defaults                0 0
none             /dev/shm   tmpfs   defaults                0 0


/etc/yaboot.conf:
Code:

boot=/dev/sda2
device=hd:
ofboot=hd:1
partition=3
delay=10
timeout=40
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot
image=/boot/kernel-2.6.8
            label=Linux
            root=/dev/sda3
            sysmap=/boot/Sysmap-2.6.8
             read-only

macosx=hd:7
enablecdboot
enableofboot


if there's anything else u need for a diagnosis please ask, and thanks very much for the help!
_________________
an apple a day keeps the blue screen away ^_^
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum