Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Eclipse SDK un-emergable?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
servobf
Apprentice
Apprentice


Joined: 03 Jun 2004
Posts: 160

PostPosted: Wed Sep 08, 2004 5:21 am    Post subject: Eclipse SDK un-emergable? Reply with quote

I want to use the Eclipse IDE. I believe I should be emerging the package eclipse-sdk. This package is marked ~ppc. However, when I try to emerge it, it says:
Code:
Calculating dependencies |
!!! all ebuilds that could satisfy ">=virtual/jdk-1.4" have been masked.
!!! possible candidates are:
- dev-java/blackdown-jdk-1.4.2_rc1 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.4.2_rc1-r1 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.4.1 (masked by: -keyword)
!!!    (dependency required by "dev-java/ant-1.6.2-r5" [ebuild])

!!! Error calculating dependencies. Please correct.
 


First, am I trying to emerge the right package to just use the IDE - I plan on compiling separately anyways.
Second, how can it be marked ppc unstable, if it's required packages are marked -*, ~x86 and alpha? (Is there a way arround these packages?)

Thanks!

Michael[/code]
Back to top
View user's profile Send private message
SeJo
Retired Dev
Retired Dev


Joined: 08 Oct 2002
Posts: 298
Location: Belgium

PostPosted: Thu Sep 09, 2004 7:51 am    Post subject: Reply with quote

hey,


you can merge it, but you need to update your profile and your virtuals file.

i emerged it without problems and so have others, i do have to say you need a lot of memory (i think you need about 1 gig).

greetings


SeJo
_________________
"I am not bound to please thee with my answers."
Back to top
View user's profile Send private message
servobf
Apprentice
Apprentice


Joined: 03 Jun 2004
Posts: 160

PostPosted: Thu Sep 09, 2004 2:51 pm    Post subject: Reply with quote

By virtuals, I'm guessing you mean the file /usr/portage/profiles/default-ppc-2004.1/virtuals ? I installed off a 2004.1 cd, is there something I should change to be working with the 2004.2 files? The jdk is listed as ibm-jdk in both. What do I change this to?

What file to I edit for my profile? /etc/profile.env? What values do I change?

Thanks

Michael Moore
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum