Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge problems with everything
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Rawn027
Apprentice
Apprentice


Joined: 01 Mar 2004
Posts: 286

PostPosted: Wed Sep 08, 2004 5:59 pm    Post subject: emerge problems with everything Reply with quote

I set my CHOST flags to
-O3 -mtune=g5 -mabi=altivec -maltivec -fno-strict-aliasing -pipes
i left my CXXFLAGS to powerpc-unkown-linux...etc etc
can i use powerpc64-unkown-blah blah blah if im install a 32 bit version?
well anyways i go through the whole emerge sync and everything and chroot into my system but then i tried to emerge gcc and emerge ufed for the use flags and it said emake error and i could not emerge a thing. the only thing i did differently was make my filesystem xfs so this stinks...help please :)
_________________
AMD Athlon 64 1.8
1GB DDR 400 RAM
Nvidia 6600 GT

MacBook Pro Duo 1.67
1GB DDR2 667 RAM
ATI x1600 Mobility
Back to top
View user's profile Send private message
DiskBreaker
Apprentice
Apprentice


Joined: 07 Oct 2003
Posts: 224

PostPosted: Wed Sep 08, 2004 7:23 pm    Post subject: Reply with quote

Please post the actual error message.
Back to top
View user's profile Send private message
nesnimda
n00b
n00b


Joined: 05 Sep 2004
Posts: 33
Location: my own little world ^^

PostPosted: Wed Sep 08, 2004 8:16 pm    Post subject: G5 Problems Reply with quote

Hey, I guess I can help since I'm currently going through G5 hell right now too -_-
1. you're switcing up your flags a LOT. what you have for your CHOST flag should be your CFLAGS. What you have for your CXXFLAGS should be your CHOSTFLAGS. CXXFLAGS is what you want C++ code optimized for as opposed to straight C code. It's generally good to have it be ${CFLAGS}, which sets the values of the two flags to the same thing.

My problem with the 2004.1 32bit cd is that the old version of GCC doesn't seem to know what G5 means (and the 2004.2 cd doesn't seem to boot correctly) so your mtune flag would have to be powerpc or something less optimized for your computer

I imagine the error your getting is that the c compiler cannot make executeables? That means that your flags in make.conf are wrong.

I'll post a tutorial on 64bit w/ 2004.2 when I finally get it working since I really could have used one, but until then I'm still fighting weird problems (i.e. 2004.1 disk's mac-fdisk works fine, but 2004.2's 64 bit cd gives me an error that my partition map is a bad size =/ )
_________________
an apple a day keeps the blue screen away ^_^
Back to top
View user's profile Send private message
Rawn027
Apprentice
Apprentice


Joined: 01 Mar 2004
Posts: 286

PostPosted: Wed Sep 08, 2004 10:00 pm    Post subject: Reply with quote

yeah thats what the problem is and i dont want to do a stage 1 with ppc optimization flag so im going to wait for either ppc64 or ppc 32 with 2004.2 cd's ...the beta 5 on the ppc64 gentoo site is not working for me, doesnt boot, beta 4 booted but asked for a password so lets see
_________________
AMD Athlon 64 1.8
1GB DDR 400 RAM
Nvidia 6600 GT

MacBook Pro Duo 1.67
1GB DDR2 667 RAM
ATI x1600 Mobility
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum