Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
lilo kan niet schrijven
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
BartNL
n00b
n00b


Joined: 29 Aug 2004
Posts: 65

PostPosted: Thu Sep 09, 2004 10:54 am    Post subject: lilo kan niet schrijven Reply with quote

Beste mensen,

Ik heb een eigen kernel gebakken naast de kernel van de installatie (genkernel). Dit is allemaal vlekkeloos verlopen. Echter wil ik nu van deze kernel opstarten maar de entry komt niet eens in de bootloader (lilo). Als ik ga schrijven blijft deze gewoon "hangen". Lilo is geinstalleerd precies zoals de originele handleiding me instrueert. Hieronder volgt mijn partitietabel en de lilo.conf.

Lilo.conf:

Code:


boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=100
lba32
default=Gentoo

image=/boot/kernel-2.6.8-gentoo-r3
   label=Gentoo
   root=/dev/hda3
   initrd=/boot/initrd-2.6.8-gentoo-r3
   append="root=/dev/hda3 init=/linuxrc"

image=/boot/LinuxBart
   label=LinuxBart
   root=/dev/hda3

other=/dev/hda4
   label=WindowsXP



fdisk:

Code:


Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1           9       72261   83  Linux
/dev/hda2              10          72      506047+  82  Linux swap
/dev/hda3              73        2383    18563107+  83  Linux
/dev/hda4            2384        4865    19936665    7  HPFS/NTFS

Disk /dev/hdb: 80.0 GB, 80060424192 bytes
16 heads, 63 sectors/track, 155127 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1      132059    66557263+   7  HPFS/NTFS
/dev/hdb2          132059      155104    11614995    f  W95 Ext'd (LBA)
/dev/hdb5          132059      155104    11614963+   7  HPFS/NTFS



Als er verder nog meer informatie ter beschikking moet worden gesteld, hoor ik het graag!
[/code]
Back to top
View user's profile Send private message
Traffixxx
n00b
n00b


Joined: 27 Mar 2004
Posts: 46

PostPosted: Thu Sep 09, 2004 11:31 am    Post subject: Reply with quote

wa bedoel je eigelijk met hangen?? na lilo of tijdens lilo?
Back to top
View user's profile Send private message
GuidoJ
Guru
Guru


Joined: 24 Dec 2002
Posts: 444
Location: Netherlands

PostPosted: Thu Sep 09, 2004 3:28 pm    Post subject: Reply with quote

Wat er precies mis gaat is mij ook niet duidelijk, maar na wijziging van de lilo.conf file moet je deze activeren (dit in tegenstelling tot grub). Uit mijn hoofd gewoon met het commando 'lilo', maar sla voor de zekerheid de handleidingen erop na.
Back to top
View user's profile Send private message
BartNL
n00b
n00b


Joined: 29 Aug 2004
Posts: 65

PostPosted: Thu Sep 09, 2004 10:25 pm    Post subject: Reply with quote

Als ik lilo.conf heb gewijzigd, slaat hij deze wel op in lilo.conf, maar de uiteindelijke configuratie wordt niet "echt" opgeslagen (op de bootpartitie). Ook als ik /sbin/lilo doe "hangt" dit commando. uiteraard heb ik de documentatie nagelezen, maar dit resulteerde in noppes. Ik heb alles uitgevoert onder gebruiker root (su) en ook de permissies op de schijf zijn in orde volgens mij. Ik heb alles via de originele documentatie gedaan en heb me daar strikt aan gehouden, ook het bootloader gedeelte. Ik heb ook genkernel gebruikt om mijn eerste kernel te compileren en installeren (tijdens de installatie van Gentoo 2004.2). Maar nu wilde ik een eigen kernel compileren voor extra functies en dit is wel allemaal goed gegaan. Vervolgens heb ik lilo.conf aangepast en opgeslagen, dit ging ook perfect, maar zodra ik /sbin/lilo of lilo uitvoerde bleef het proces "hangen" en moest ik de console afsluiten. Verder is er dus geen echte configuratie weggeschreven, maar als ik lilo.conf open (met nano) staat er alles wel in zoals ik het heb ingevoerd. Als ik de PC boot, en hij komt in lilo, staat de nieuwe entry er niet in.
Back to top
View user's profile Send private message
polle
Veteran
Veteran


Joined: 28 Feb 2003
Posts: 1498
Location: Belgium

PostPosted: Thu Sep 09, 2004 10:47 pm    Post subject: Reply with quote

je hebt je bootpartitie toch gemount voordatje
-je kernel naar daar gecopieerd hebt
-je lilo aangepast hebt
Standaard wordt de bootpartitie in gentoo niet gemounted.
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Fri Sep 10, 2004 1:36 am    Post subject: Reply with quote

ik denk idd dat je boot bent vergeten te mounten.

nadat je /etc/lilo.conf heb aangepast moet je inderdaad lilo draaien om de wijzigingen door te voeren.

Zou ook nog aan het filesystem kunnen liggen. Keer fschk'en misschien (die van je boot partitie)
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
LukeLemmings
n00b
n00b


Joined: 25 Feb 2004
Posts: 25

PostPosted: Thu Sep 16, 2004 11:56 am    Post subject: Reply with quote

Bart,

Wat is precies het lilo commando dat je grdraaid hebt?

Voor het testen van je lilo config kun je een boot floppy maken.

zo:

lilo -b /dev/fd0

Wellicht moet je vervolgens bij het opstarten van je pc in Bios het booten van floppy enabelen.

Bij mij ziet dit er zo uit:
Code:
> lilo -b /dev/fd0
Ignoring entry 'boot'
Warning: boot record relocation beyond BPB is necessary: /dev/fd0
Warning: The boot sector and map file are on different disks.
Added GenKernel
Added Modular *
Added OldLinux


Lucas.
Back to top
View user's profile Send private message
BartNL
n00b
n00b


Joined: 29 Aug 2004
Posts: 65

PostPosted: Fri Sep 17, 2004 12:28 pm    Post subject: Reply with quote

Beste mensen,

Inmiddels is alles opgelost. Ik heb de boot partitie gemount met de juiste rechten en heb daar lilo naar toe geschreven.

Groeten,

Bart
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum