Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
12" powerbook kernel config
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
rlpt
n00b
n00b


Joined: 12 Sep 2004
Posts: 7

PostPosted: Sun Sep 12, 2004 8:10 pm    Post subject: 12" powerbook kernel config Reply with quote

I have compiled a kernel using the config http://ppcconfdb.sourceforge.net/conf/PowerBook_G4_867MHz-12/kernel/2.6_15-Nov-2003/2.6_modules_15-Nov-2003
it compiles fine but when i try to boot it i get the error message "VFS: Cannot open root device hda4 ...." and it halts before it gets to init. The contents of my fstab are:

Code:

/dev/hda4      /      ext3      noatime         0 0
/dev/hda3      none      swap      sw         0 0
/dev/cdroms/cdrom0   /mnt/cdrom   iso9660      auto,ro,users      0 0
#/dev/fd0      /mnt/floppy   auto      noauto         0 0

# NOTE: The next line is critical for boot!
none         /proc      proc      defaults      0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
# Adding the following line to /etc/fstab should take care of this:

none         /dev/shm   tmpfs      defaults      0 0



the kernel source i am using is 2.6.8 vanilla from kernel.org

thanks
rlpt
Back to top
View user's profile Send private message
rlpt
n00b
n00b


Joined: 12 Sep 2004
Posts: 7

PostPosted: Mon Sep 13, 2004 11:42 am    Post subject: Reply with quote

if some has a 12" powerbook could you please post your .config if you are using a 2.6 kernel
Back to top
View user's profile Send private message
fridgemagnet
n00b
n00b


Joined: 15 Aug 2004
Posts: 13

PostPosted: Mon Sep 13, 2004 3:40 pm    Post subject: re: Reply with quote

hi,

i dont have a powerbook, but i got this error when my grub conf was incorrectly setting the root partition.

either
1) your grub config is wrong or
2) you dont have reiserfs compiled in your kernel.
3) something i dont know :?

I have had the same error before. Are you sure that your grub.conf is correct?

Andy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum