Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HFS volulme not unmounted cleanly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
linuxopjemac
n00b
n00b


Joined: 23 Aug 2004
Posts: 35
Location: The Hague, The Netherlands

PostPosted: Tue Sep 14, 2004 6:28 am    Post subject: HFS volulme not unmounted cleanly Reply with quote

I found myself in trouble with a hfs volume. I can only mount it read only as it was not cleanly unmounted (dmesg). The thing is that I don't know how to clean it. fsck.hfs command can't be found (I thought it was in hfsutils). hfsck doesn't do anything. I tried from within OSX with the disk utility but it says that there is nothing wrong with the hfs partition. Anyone else an idea?
Back to top
View user's profile Send private message
rickb
n00b
n00b


Joined: 04 Dec 2002
Posts: 31
Location: The Hague, Netherlands

PostPosted: Tue Sep 14, 2004 1:27 pm    Post subject: Re: HFS volulme not unmounted cleanly Reply with quote

Just quoting myself from https://forums.gentoo.org/viewtopic.php?p=809436#809436 :

Quote:
Use hpmount from the hfsplusutils package to mount the partition. It fails, but it does something magical to the partition after which you can mount it normally again with mount -t hfsplus.


Don't ever use hfsck. Or any other tool from hfsplusutils.

P.s.
Is it just me or does HFS+ support in the latest kernels no longer have a problem dealing with very large files?
Back to top
View user's profile Send private message
DiskBreaker
Apprentice
Apprentice


Joined: 07 Oct 2003
Posts: 224

PostPosted: Tue Sep 14, 2004 4:39 pm    Post subject: Re: HFS volulme not unmounted cleanly Reply with quote

rickb wrote:
Is it just me or does HFS+ support in the latest kernels no longer have a problem dealing with very large files?

Yeah, I think it was fixed in 2.6.7 :)
Back to top
View user's profile Send private message
linuxopjemac
n00b
n00b


Joined: 23 Aug 2004
Posts: 35
Location: The Hague, The Netherlands

PostPosted: Wed Sep 15, 2004 6:55 am    Post subject: Reply with quote

I ended up in hformat the partition. Now it works...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum