Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: get spellchecking working in Ximian Openoffice
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
asiobob
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1375
Location: Bamboo Creek

PostPosted: Tue Sep 14, 2004 9:49 am    Post subject: HOWTO: get spellchecking working in Ximian Openoffice Reply with quote

Ages ago I installed ximian openoffice-bin and noticed it didn't spell check at all. After some searching a forum member pointed to a script which after I ran partially fixed the problem (I could spell check using certain fonts).

More recently I emerged the latest ~ ximian-openoffice from source, and noticed the same problem, the previous fix did not work.

Here;s how I did get it to work.

1. Visit, http://lingucomponent.openoffice.org/dictpack.html
2. Download DicOOo macro.sxw (yes an fear macro)
3. Run this as a USER probably for every user.
4. Openoffice may warn macros are dangerous ;)
5. Follow the instructions in the document, ie, a button appears in the document, click it, it installs dictionarys from the net of your choosing but more importantly does something to get the spell checking working (eg I had the dictionaries before but they never worked)

6. close all openoffice programs.
7 restart, Tools, options. Lanuage aids, make sure your dictionaries are selected (if they are not).
8. spell checking will work (hopefully)

note: previously, it just said every thing was correct when there were clearly incorrect words
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Tue Sep 14, 2004 10:45 am    Post subject: Reply with quote

Or simply adjust two lines in the install-dict file in /opt/Ximian-OpenOffice so they are as follows:
Code:
my $Debug = $ENV{'OOO_DEBUG'};
my $OOO_DIR = '/opt/Ximian-OpenOffice/';

if ($Debug && $OOO_DIR =~ /^\@/) {
    $OOO_DIR = '/opt/Ximian-OpenOffice/';

They need adjusting as they point to wrong directory.

Then run install-dict (from the /opt dir) and the dictionary works.

Note: I have no idea if this works for anything other than english, you may need to download the relevent language dictionary, but I had it set up with UK-english perfectly within 30 seconds of installing Ximian.

Hopefully between the two posts spelling will be sorted out :D
_________________
usefuljaja.com - VPS Tutorials
Back to top
View user's profile Send private message
DiskDoc
Apprentice
Apprentice


Joined: 25 Apr 2002
Posts: 196
Location: Finland

PostPosted: Wed Sep 14, 2005 8:02 am    Post subject: Dictionaries in Ximian OpenOffice 1.3.9-r1 Reply with quote

Is ASIO_BOBs method still the way to go? I've installed openoffice-ximian-1.3.9 from source for a non-geek friend, partly to get a swedish interface and because I thought it'd be better than the standard OOo ebuild.

But dictionaries..dear, dear.. Maybe I'm wrong in wanting it simpler since this IS Gentoo after all. Other distros probably have dictionaries all wrapped up and ready to go.

OOodi didn't work for me here. It used to work with the standard OOo but as I recall it stopped doing that for some unknown reason.

[later]

Ok.. Seems by running this macro-script (newer than the one I found included with XOOo):

http://lingucomponent.openoffice.org/dictpack.html

..I was able to install some dictionaries for a specific user at least. It's probably possible to do that for the entire system as well by running the macro as root or by copying in the dictionaries to /opt/Ximian-OpenOffice/share/dict/ooo by hand and modifying dictionary.lst.

On OOodi, I think my troubles might be due to its ebuild not depending on Gnome. Running it on the KDE-centered system I mentioned produced a lot of complaints about missing libgnome.so. It worked better on a Gnome-based system.
_________________
"So slay me now! I have little magic left."
- Kallak, leader of the royal mystics
Back to top
View user's profile Send private message
Jim6
Tux's lil' helper
Tux's lil' helper


Joined: 08 Apr 2005
Posts: 102

PostPosted: Thu Sep 22, 2005 2:37 pm    Post subject: Reply with quote

You legend! That's been annoying me for a while; and the minute I go to look for a solution this was here! Thanks!

- Didn't need the fix in the second post
- Using Ximian-Openoffice 1.1.1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum