Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Working xorg.confs for xorg 6.8 thread
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Wed Sep 15, 2004 12:34 am    Post subject: Working xorg.confs for xorg 6.8 thread Reply with quote

This one works on a TiBook 867mhz w/ radeon 9000 mobility (M9):
Code:
# Copyright 2004 The X.Org Foundation
# Refer to the xorg.conf(5x) man page for details about the format of
# this file.

Section "Module"
        Load     "dbe"
#       Load    "type1"
#       Load    "speedo"
        Load    "freetype"
#       Load    "xtt"
        Load    "glx"
        Load    "dri"

        SubSection "extmod"
                Option          "omit xfree86-dga"
        EndSubSection

EndSection

Section "Files"
        RgbPath         "/usr/X11R6/lib/X11/rgb"
        FontPath        "/usr/share/fonts/artwiz-aleczapka-en"
        FontPath        "/usr/share/fonts/misc/"
        FontPath        "/usr/share/fonts/TTF/"
#       FontPath        "/usr/share/fonts/Type1/"
#       FontPath        "/usr/share/fonts/CID/"
        FontPath        "/usr/share/fonts/75dpi/"
        FontPath        "/usr/share/fonts/100dpi/"
#       FontPath        "/usr/share/fonts/local/"
#       FontPath        "/usr/share/fonts/Speedo/"
#       FontPath        "/usr/share/fonts/TrueType/"
#       FontPath        "/usr/share/fonts/freefont/"
        ModulePath      "/usr/X11R6/lib/modules"
EndSection

Section "ServerFlags"
        Option          "OffTime"       "10"
EndSection

Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "kbd"
        Option          "AutoRepeat"    "500 30"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc101"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
        Option          "Protocol"      "Auto"
        Option          "Device"        "/dev/input/mice"
EndSection

Section "Monitor"
        Identifier      "Flatpanel"
        HorizSync       31.5 - 48.5
        VertRefresh     50-70
        Option          "DPMS"
EndSection

Section "Device"
        Identifier      "Card0"
        Driver          "radeon"
        Option          "UseFBDev"
        Option          "AGPMode"               "4"
        Option          "EnablePageFlip"        "1"
        Option          "DynamicClocks"         "1"
EndSection

Section "Screen"
        Identifier      "Screen0"
        Device          "Card0"
        Monitor         "Flatpanel"
        DefaultDepth    24

        Subsection "Display"
                Depth           8
                Modes "1280x854" "640x480" "800x600" "1024x768" "1152x768"
                ViewPort        0 0
        EndSubsection

        Subsection "Display"
                Depth           16
                Modes "1280x854" "640x480" "800x600" "1024x768" "1152x768"
                ViewPort        0 0
        EndSubsection

        Subsection "Display"
                Depth           24
                Modes "1280x854" "640x480" "800x600" "1024x768" "1152x768"
                ViewPort        0 0
        EndSubsection

EndSection

Section "ServerLayout"
        Identifier      "Simple Layout"
        Screen          "Screen0"
        InputDevice     "Mouse0"        "CorePointer"
        InputDevice     "Keyboard0"     "CoreKeyboard"
EndSection

Section "DRI"
        Mode    0666
EndSection

Section "Modes"
        Identifier      "Modes0"
        Modeline "1280x854" 79.815 1280 1296 1408 1536 854 855 858 866 -HSync -VSync
EndSection


http://stimuli.ca/linux/files/xorg.conf
Back to top
View user's profile Send private message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Thu Sep 16, 2004 8:03 am    Post subject: Reply with quote

Uh, feel free to add your working xorg-x11-6.8 xorg.confs to this thread to help out your fellow man. It took me a while to get mine working.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum