Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Open Firmware Error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
autumn_star
n00b
n00b


Joined: 16 Sep 2004
Posts: 28

PostPosted: Sat Sep 18, 2004 7:44 pm    Post subject: Open Firmware Error Reply with quote

Hi.
I've just installed Gentoo-ppc-2004.1 with gentoo-dev-sources kernel in my Quicksilver 2002.
I have dual-boot, osx and linux. I select linux and then press enter.
Instead of loading my kernel 2.6.5-gentoo-G4, it shows the open firmware white screen with the following error:

"DEFAULT CATCH! code=300 at %SRR0:0140390 %SRR1:00083030"

and I have to reboot manually.

Is it a problem with my kernel or with yaboot?

Anybody knows how to fix it?

There's someone in debian lists with the same problem
Debian lists
Back to top
View user's profile Send private message
servobf
Apprentice
Apprentice


Joined: 03 Jun 2004
Posts: 160

PostPosted: Sun Sep 19, 2004 1:59 am    Post subject: Reply with quote

Have you already reset pram?

At boot time, before the chime, hold down ctrl-option-p-r untill the machine chimes 3 times (two restarts, plus the thrid chime, when you let it start all the way)

Can you boot to the OS chooser by holding down option during chime-time? If you can, can you select linux, and then run ybin -v?

~Michael
Back to top
View user's profile Send private message
autumn_star
n00b
n00b


Joined: 16 Sep 2004
Posts: 28

PostPosted: Sun Sep 19, 2004 2:12 am    Post subject: Reply with quote

No, I haven't reset PRAM.
I think it's a kernel problem, as I downloaded ppc-sources (kernel 2.4.24-ppc-r2) and it boots.
_________________
Quicksilver 2002
kernel 2.4.24-ppc-r2
Back to top
View user's profile Send private message
servobf
Apprentice
Apprentice


Joined: 03 Jun 2004
Posts: 160

PostPosted: Sun Sep 19, 2004 5:51 am    Post subject: Reply with quote

I'm confused than. Can you boot, or no?

Are you saying you can boot to one kernel, but not the other? Or is the error not at boot time?

Thanks,

Michael
Back to top
View user's profile Send private message
Paladine01
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2003
Posts: 131
Location: Phoenix AZ

PostPosted: Mon Sep 20, 2004 2:00 am    Post subject: Reply with quote

I'm kind of having the same problem ;-)

When I boot kernel 2.6.8.1 on my Gamecube, sometimes it works and other times it just hangs. It's very random. I heard today that I should stick to 2.6.7 but I havn't tested it out yet? Maybe 2.6.8.1 has some boot bugs?
Back to top
View user's profile Send private message
autumn_star
n00b
n00b


Joined: 16 Sep 2004
Posts: 28

PostPosted: Mon Sep 20, 2004 11:47 pm    Post subject: Reply with quote

When I tried to boot using kernel 2.6.5 the OF error showed up.
Now I've installed kernel 2.4 and it boots ok.
_________________
Quicksilver 2002
kernel 2.4.24-ppc-r2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum