Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gtk-qt-engine not for PPC anymore ? [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
jerry arns
Tux's lil' helper
Tux's lil' helper


Joined: 13 Dec 2003
Posts: 95
Location: France

PostPosted: Wed Sep 22, 2004 6:45 pm    Post subject: gtk-qt-engine not for PPC anymore ? [solved] Reply with quote

As I could see in another post :

https://forums.gentoo.org/viewtopic.php?t=121007&postdays=0&postorder=asc&highlight=gtk+qt&start=25

gtk-qt-engine-0.2 was available as ~ppc.

But now with version 0.5, it is not available for ppc anymore.

If I want to try it anyway, is it sufficient to manually add the "~ppc" keyword to the ebuild ?
_________________
Left handed, right minded.


Last edited by jerry arns on Sun Oct 17, 2004 1:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
DiskBreaker
Apprentice
Apprentice


Joined: 07 Oct 2003
Posts: 224

PostPosted: Wed Sep 22, 2004 9:51 pm    Post subject: Re: gtk-qt-engine not for PPC anymore ? Reply with quote

jerry arns wrote:
If I want to try it anyway, is it sufficient to manually add the "~ppc" keyword to the ebuild ?

This would work, but the next time you sync your portage tree these changes will be gone. Instead, the recommended way is to add the following line to the file /etc/portage/package.keywords (create the file if it does not exist):
Code:
x11-themes/gtk-qt-engine    ~x86


(for more info man portage)

Gtk-Qt-Engine 0.5 works quite well with my qt 3.3.2 and gtk+ 2.4.4.
Back to top
View user's profile Send private message
codergeek42
Bodhisattva
Bodhisattva


Joined: 05 Apr 2004
Posts: 5142
Location: Anaheim, CA (USA)

PostPosted: Wed Sep 22, 2004 9:58 pm    Post subject: Reply with quote

You should add
Code:
x11-themes/gtk-qt-engine ~ppc
to your /etc/portage/package.keywords. (You may need to create that directory and file if either/both of them do not yet exist.)
_________________
~~ Peter: Programmer, Mathematician, STEM & Free Software Advocate, Enlightened Agent, Transhumanist, Fedora contributor
Who am I? :: EFF & FSF
Back to top
View user's profile Send private message
jerry arns
Tux's lil' helper
Tux's lil' helper


Joined: 13 Dec 2003
Posts: 95
Location: France

PostPosted: Thu Sep 23, 2004 7:56 pm    Post subject: Re: gtk-qt-engine not for PPC anymore ? Reply with quote

Quote:
Instead, the recommended way is to add the following line to the file /etc/portage/package.keywords (create the file if it does not exist):
Code:
x11-themes/gtk-qt-engine    ~x86


(for more info man portage)

Gtk-Qt-Engine 0.5 works quite well with my qt 3.3.2 and gtk+ 2.4.4.


Yep, that did the trick. Xchat now looks like Plastik.

Thank you.
_________________
Left handed, right minded.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum