Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] Logitech DiNovo under Linux Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
javac16
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 111

PostPosted: Wed Feb 15, 2006 10:39 pm    Post subject: Reply with quote

:cry: Man...I'll try upgrading to 2.6.15 (plus patch) and let you know if I have any luck.
Back to top
View user's profile Send private message
sibov
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2004
Posts: 147
Location: Germany

PostPosted: Thu Feb 16, 2006 9:20 am    Post subject: Reply with quote

:P NEW bluez-patch patch-2.6.15-mh2.gz available for download at http://www.bluez.org/patches.html

maybe this will fix the kernel panic :wink:
_________________
Gentoo 2.6.17-gentoo-r5 with dmraid Raid0 Dualboot
AMD64 X2 3800+, 4x512MB DDR PC3200Pro Corsair Geforce EN6600GT silencer @ 256MB
4x250GB SATAII Samsung SP120, Asus A8N Premium, Plextor PX712SA DVDRW
Logitech Dinovo, SB Audigy4
Back to top
View user's profile Send private message
javac16
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 111

PostPosted: Thu Feb 16, 2006 3:03 pm    Post subject: Reply with quote

I nevered tried p1, but I patched 2.6.15-r1 with p2 and am having no problems (no panics and dinovo is working).

Code:

$ uname -a
Linux morpheus 2.6.15-gentoo-r1 #1 SMP PREEMPT Thu Feb 16 09:47:56 EST 2006 i686 Intel(R) Xeon(TM) CPU 2.00GHz GenuineIntel GNU/Linux
$ hidd
00:07:61:23:CE:A7 Logitech Bluetooth Mouse [046d:b001] connected
00:07:61:24:0B:EC Logitech Bluetooth Keyboard [046d:b303] connected


Hope you have similar luck with p2.
Back to top
View user's profile Send private message
sibov
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2004
Posts: 147
Location: Germany

PostPosted: Thu Feb 16, 2006 7:21 pm    Post subject: Reply with quote

:P :P I'm lucky too. The new bluez.org patch-2.6.15-mh2.gz fixed it :wink:

Code:
hidd --show
00:07:61:24:5A:7D Logitech Bluetooth Mouse [046d:b001] connected
00:07:61:23:E4:2E Logitech Bluetooth Keyboard [046d:b303] connected

_________________
Gentoo 2.6.17-gentoo-r5 with dmraid Raid0 Dualboot
AMD64 X2 3800+, 4x512MB DDR PC3200Pro Corsair Geforce EN6600GT silencer @ 256MB
4x250GB SATAII Samsung SP120, Asus A8N Premium, Plextor PX712SA DVDRW
Logitech Dinovo, SB Audigy4
Back to top
View user's profile Send private message
javac16
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 111

PostPosted: Thu Feb 16, 2006 8:58 pm    Post subject: Reply with quote

That is great :D

Thanks for giving me the kick to take the time to upgrade to 2.6.15.
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Sat Mar 04, 2006 11:26 am    Post subject: Reply with quote

Ho-hum... I've got a problem with my diNovo. It will connect using bluetooth, I'm typing on it right now, but for the love of God won't do so upon boot and in the GDM login screen. I actually have to connect a regular Keyboard and fiddle about, work a little voodoo and restart bluetooth to make it connect...

Anyone got a clue? Here's my relevant data:
rc-update -s:
Code:
               acpid |      default
           alsasound | boot
                apmd |
  bittorrent-tracker |
           bluetooth |      default
               boinc |
            bootmisc | boot
             bttrack |
             checkfs | boot
           checkroot | boot
               clock | boot
            coldplug | boot
         consolefont |
         crypto-loop |
               cupsd |      default
                dbus |      default
          domainname |      default
              esound |      default
                famd |      default
                 gpm |
                hald |      default
              hdparm | boot
            hostname | boot
             hotplug | boot
             keymaps | boot
          lm_sensors |      default
               local |      default nonetwork
          localmount | boot
             modules | boot
            net.eth0 |      default
              net.lo | boot
            netmount |      default
            net.ppp0 |
                nscd |
          ntp-client |
                ntpd |      default
             numlock |      default
             portmap |
           rmnologin | boot
              rsyncd |
               samba |      default
              serial | boot
               slapd |
              slurpd |
               spamd |
                sshd |      default
           syslog-ng |      default
            timidity |
             urandom | boot
          vixie-cron |      default
                 xdm |      default

/etc/bluetooth/hcid.conf:
Code:
#
# HCI daemon configuration file.
#

# HCId options
options {
        # Automatically initialize new devices
        autoinit yes;

        # Security Manager mode
        #   none - Security manager disabled
        #   auto - Use local PIN for incoming connections
        #   user - Always ask user for a PIN
        #
        security user;

        # Pairing mode
        #   none  - Pairing disabled
        #   multi - Allow pairing with already paired devices
        #   once  - Pair once and deny successive attempts
        pairing multi;

        # PIN helper
        #pin_helper /usr/bin/bluepin;

        # D-Bus PIN helper
        dbus_pin_helper;
}

# Default settings for HCI devices
device {
        # Local device name
        #   %d - device id
        #   %h - host name
        name "BlueZ at %h (%d)";

        # Local device class
        class 0x3e0100;

        # Default packet type
        #pkt_type DH1,DM1,HV1;

        # Inquiry and Page scan
        iscan enable; pscan enable;

        # Default link mode
        #   none   - no specific policy
        #   accept - always accept incoming connections
        #   master - become master on incoming connections,
        #            deny role switch on outgoing connections
        #
        #lm accept,master;
        #
        lm accept;

        # Default link policy
        #   none    - no specific policy
        #   rswitch - allow role switch
        #   hold    - allow hold mode
        #   sniff   - allow sniff mode
        #   park    - allow park mode
        lp rswitch,hold,sniff,park;

        # Authentication and Encryption (Security Mode 3)
        #auth enable;
        #auth disable;
        #encrypt enable;
}

/etc/conf.d/bluetooth:
Code:
# Bluetooth configuraton file

# Start of hcid (allowed values are "true" and "false")
HCID_ENABLE=true

# Config file for hcid
HCID_CONFIG="/etc/bluetooth/hcid.conf"

# Start sdpd (allowed values are "true" and "false")
SDPD_ENABLE=true

# Start hidd (allowed values are "true" and "false")
HIDD_ENABLE=true

# Arguments to hidd
HIDD_OPTIONS=""

# Run hid2hci (allowed values are "true" and "false")
HID2HCI_ENABLE=true

# Bind rfcomm devices (allowed values are "true" and "false")
RFCOMM_ENABLE=true

# Config file for rfcomm
RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"

# Start dund (allowed values are "true" and "false")
DUND_ENABLE=true

# Arguments to dund
DUND_OPTIONS="--listen --persist"

# Start pand (allowed values are "true" and "false")
PAND_ENABLE=true

# Arguments to pand
PAND_OPTIONS="--listen --role NAP"

_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
sibov
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2004
Posts: 147
Location: Germany

PostPosted: Sat Mar 04, 2006 3:06 pm    Post subject: Reply with quote

Hi red-wolf76,

have you already edit the /etc/init.d/bluetooth init-script ?

Do you have dual boot with MiCro$oft OS?

Does it only fails with gdm? Then give kdm a try!


Kind regards,
Sibov
_________________
Gentoo 2.6.17-gentoo-r5 with dmraid Raid0 Dualboot
AMD64 X2 3800+, 4x512MB DDR PC3200Pro Corsair Geforce EN6600GT silencer @ 256MB
4x250GB SATAII Samsung SP120, Asus A8N Premium, Plextor PX712SA DVDRW
Logitech Dinovo, SB Audigy4
Back to top
View user's profile Send private message
javac16
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 111

PostPosted: Sat Mar 04, 2006 5:46 pm    Post subject: Reply with quote

Quote:
I actually have to connect a regular Keyboard and fiddle about, work a little voodoo and restart bluetooth to make it connect...


What's the vodoo you have to perform?
Back to top
View user's profile Send private message
javac16
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 111

PostPosted: Sat Mar 04, 2006 8:35 pm    Post subject: Reply with quote

Not sure when this occured but I have noticed the following issues lately:
F1-F12 - not working
suspend, home, email, finder, volume-up, volume-down, mute - not working

media key - works
play/pause, skip, back, stop - work

Anyone else seeing this problem?

Edit: Okay, I figured out that the F-Lock key is now working so I can switch between F1-F12 and the New-My Music functionality. However, the other keys mentioned abover are still not working. Although they do appear properly in Gnome Keyboard Shortcuts -- pressing the Email key when setting a shortcut brings up XF86Mail. This makes me think I broke something somewhere, but I am having some difficulty figuring out where to look.

Edit #2: It seems this isn't a problem with the keyboard. I assigned other keys to volume up/down, etc. actions in Gnome and they are not able to control the settings either. Also setting mute button to "Open Panel" works fine...
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Sun Mar 05, 2006 12:03 am    Post subject: Reply with quote

javac16 wrote:
Quote:
I actually have to connect a regular Keyboard and fiddle about, work a little voodoo and restart bluetooth to make it connect...


What's the vodoo you have to perform?
The usual chicken-waving. Restarting bluetooth and performing a hid2hci and hidd --search does things it should have already done. :roll:

And technically I dual boot with Win2K, but I haven't done so for rather a longish time. No need to :lol: Besides, it doesn't work either. :oops:

It doesn't matter whether it's GDM or not. I've tried booting into console only - no dice. There was something in this thread about making some udev rules that I haven't looked into yet. But I think it has something to do with the recent update I ran. Something changed in the bluetooth stuff, I think and it worked before...
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
javac16
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 111

PostPosted: Mon Mar 06, 2006 3:08 am    Post subject: Reply with quote

I am not seeing the issues you are having - here is what I am running for comparison:
Code:

net-wireless/bluez-libs-2.25
net-wireless/bluez-utils-2.25
sys-kernel/gentoo-sources-2.6.15-r1 (with the second 2.6.15 patch from the bluez website)
sys-fs/udev-079-r1


Did you recently turn encryption or authentication on? Any issues with the PIN (do you have to enter it)?
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Mon Mar 06, 2006 8:35 am    Post subject: Reply with quote

javac16 wrote:
I am not seeing the issues you are having - here is what I am running for comparison:
Did you recently turn encryption or authentication on? Any issues with the PIN (do you have to enter it)?

That's another thing, I've not quite fathomed. I dont have to fiddle with the PIN. Never did have to. I'm not at my box and it's not running (damn you, Swine German Energy Companies! :x) but I'll let you know which versions I'm running.

What I know I have, is the device tarball turned on and no special udev-rule. Do you have one of those? That might explain why I have to do a search before the Receiver will pick up stuff (devnode not created on boot).

I think I'll try that first thing this evening. Turning off the tarball!
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
javac16
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2003
Posts: 111

PostPosted: Mon Mar 06, 2006 12:54 pm    Post subject: Reply with quote

I don't have any special udev rules for the dinovo setup. Customation that I have done:
Using meeuw's modified bluepinstub (for PIN -- see page 3)...although I currently don't have auth or encryption turned on.

Whenever I modify items with the keyboard I tend to get it messed up for a couple reboots, but I usually reread this thread and follow this procedure to get it working where it autoconnects:
- reboot and ssh into my workstation
- click the connect button on the mouse
- run hidd --search
-- the mouse starts working
- repeat this process for the keyboard and media pad

if things get really whacky I delete the following files (you may just want to mv the files just in case):
/var/lib/bluetooth/<your-hub's-bluetooth-address>/*

I then repeat the procedure outlined above.
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Mon Mar 06, 2006 1:05 pm    Post subject: Reply with quote

I'll look into that tonight. Interestingly, I think I don't even have to press any buttons on the devices themselves, I just do a hidd --search and they're all there, waving at me! :lol:
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Mon Mar 06, 2006 9:20 pm    Post subject: Reply with quote

Ho hum. I thought wrongly, it appears.
Voodoo consists of:
  • running hid2hci
  • hidd --search
  • pressing the buttons
After that, the keyboard works - and keeps working. :?
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
sibov
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2004
Posts: 147
Location: Germany

PostPosted: Tue Mar 07, 2006 9:20 am    Post subject: Reply with quote

red-wolf76 wrote:
Ho hum. I thought wrongly, it appears.
Voodoo consists of:
  • running hid2hci
  • hidd --search
  • pressing the buttons
After that, the keyboard works - and keeps working. :?


Hi Red-Wolf76,

please double check your /etc/init.d/bluetooth script it must have the line

Code:
--exec /usr/bin/hidd -- ${HIDD_OPTIONS} --server


maybe there 's a typo within the line or above ;-)

regards,
Sibov
_________________
Gentoo 2.6.17-gentoo-r5 with dmraid Raid0 Dualboot
AMD64 X2 3800+, 4x512MB DDR PC3200Pro Corsair Geforce EN6600GT silencer @ 256MB
4x250GB SATAII Samsung SP120, Asus A8N Premium, Plextor PX712SA DVDRW
Logitech Dinovo, SB Audigy4
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Tue Mar 07, 2006 10:33 pm    Post subject: Reply with quote

sibov wrote:
please double check your /etc/init.d/bluetooth script it must have the line
Code:
--exec /usr/bin/hidd -- ${HIDD_OPTIONS} --server

maybe there 's a typo within the line or above ;-)
Hey, Sibov. Just went to check and it's in there, as required.

I think I fixed it, however. I changed to
Code:
# Security Manager mode
#   none - Security manager disabled
#   auto - Use local PIN for incoming connections
#   user - Always ask user for a PIN
#
security auto;
in /etc/bluetooth/hcid.conf and surely enough after an /etc/init.d/bluetooth restart keyboard and mouse came to life. The MediaPad will go to sleep, but automatically connect, when prodded with a pointy stick.

Now, I'll check whether that solved the boot-up problem as well...
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Fri Mar 10, 2006 11:18 pm    Post subject: Reply with quote

Bloody 'Ell!

I have to boot with an extra keyboard and restart bluetooth from the console before everything will work. :x I'm stumped...
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
derelm
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2002
Posts: 95

PostPosted: Mon Mar 13, 2006 2:00 am    Post subject: Reply with quote

hi, i fixed these problems be deactivating dbus pin helper.

i noticed that when setting dbus pin helper the hcid won't get started by the init script. commenting the line it started without a problem.

hope that helps

edit:
just noticed that the problem with dbus is, that dbus is started *after* bluetooth is started because it doesn't depend on dbus. so maybe the easy fix is to edit /etc/init.d/bluetooth like so:
Code:

depend() {
        after coldplug dbus
}


edit2:
removed need dbus in favour of after dbus


Last edited by derelm on Mon Mar 13, 2006 8:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Mon Mar 13, 2006 6:47 am    Post subject: Reply with quote

Hey, that could explain it. I think I'll try that tonight at the box.

I'll let you know.

EDIT: Duh... Didn't do anything but now it works. Didn't even update the script like you said... :roll: Help! My Gentoo is Windowsifying itself! 8O
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
freeman01
n00b
n00b


Joined: 21 Mar 2006
Posts: 1

PostPosted: Tue Mar 21, 2006 7:05 pm    Post subject: dinovo bluetooth works after individual change Reply with quote

for me it was necessary to set the sleep-time in the bluetooth init-script from 1 to 2 seconds....
with the defaultsetting (sleep 1 second after hid2hci command) the hidd and the sdpd fails.

----------------------------
i use kernel 2.6.15 with newest bluetoothpatch
_________________
thank's to the gentoo-community for the great job.
Back to top
View user's profile Send private message
chojin
n00b
n00b


Joined: 26 Jun 2005
Posts: 42

PostPosted: Wed Mar 22, 2006 7:16 pm    Post subject: Reply with quote

I finaly have hid2hci find my dongle and it seems the bluetooth functionality works.. Thanks to an update on linux.yes.nu containing a patch for hid2hci for dinovo laser support.
But I now can't get my keyboard, -pad nor mouse connected.
I followed al instructions on linux.yes.nu and on this forum, including the 2.6.15-mh2 patch.
But now when I try to use my keyboard, every key I pres I get this error in my /var/log/messages:
hidd: HID create error 2 (No such file or directory)

since I have no Idea what file or directory isn't found, I ran
# strace hidd -n -server
which showed me this at the time of the error:
open("/var/lib/bluetooth/00:07:61:41:F5:80/hidd", O_RDONLY) = -1 ENOENT (No such file or directory)

I checked and indeed there is no /var/lib/bluetooth directory, so I created it, but still no difference.

Does anyone know what this means? why it isn't working and how I have to get it working?
Back to top
View user's profile Send private message
Diavolo
Apprentice
Apprentice


Joined: 09 Jan 2005
Posts: 151

PostPosted: Sun Mar 26, 2006 12:54 pm    Post subject: Reply with quote

I installed my diNovo Media Desktop using this Tutorial: http://linux.yes.nu/diNovo/

Now with x11 7.0, the special keys don't seem to work. Any idea? :(
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Mon Mar 27, 2006 11:39 am    Post subject: Reply with quote

Chances are, you overwrote your X keyboard config files when you upgraded, or they may alternatvely have moved.

There's a section here on including the diNovo amongst the keyboards you can pick. Try re-doing that.
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
Diavolo
Apprentice
Apprentice


Joined: 09 Jan 2005
Posts: 151

PostPosted: Mon Mar 27, 2006 6:23 pm    Post subject: Reply with quote

No, the edited files have not been overwritten...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Page 4 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum