Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
jkomar
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 192
Location: Calgary, Canada

PostPosted: Fri Nov 12, 2004 6:38 pm    Post subject: Reply with quote

I must have some kind of problem in my cyrus-sasl setup because when I try to start saslauthd, I get saslauthd[process number] :set_auth_mech : unknown authentication mechanism: pam...

Could this have something to do with -pam in my USE Flags?

Thanks,

Jason
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Fri Nov 12, 2004 7:06 pm    Post subject: Reply with quote

set you auth mech to use ldap.


/etc/conf.d/saslauthd

Code:
SASL_AUTHMECH=ldap
SASLAUTHD_OPTS="-a ${SASL_AUTHMECH}"


That is what you want
_________________
write quit bang
Back to top
View user's profile Send private message
jkomar
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 192
Location: Calgary, Canada

PostPosted: Fri Nov 12, 2004 7:45 pm    Post subject: Reply with quote

That eliminated the pam error, but produced the same error with ldap. I ended up re-emerging openldap and it saslauthd starts properly now.

Thanks for your help.

Jason
Back to top
View user's profile Send private message
teldap
n00b
n00b


Joined: 12 Nov 2004
Posts: 1

PostPosted: Fri Nov 12, 2004 7:56 pm    Post subject: Reply with quote

Hallo,
I have a little problem:

foobar ~ # nano –w ldap.ldif

dn: dc=ox-domain,dc=tld
objectclass: dcObject
objectclass: organization
o: OXDomain
dc: ox-domain
dn: cn=Manager,dc=ox-domain,dc=tld
objectclass: organizationalRole
cn: Manager

Code:
 foobar ~ # slapadd -l ldap.ldif
   slapadd: could not parse entry (line=9)


line 9 is the end of the file. Mast I change "o: OXDomain" ? Or what is wrong ? Thank you
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Fri Nov 12, 2004 8:17 pm    Post subject: Reply with quote

Minimally Get rid of line 9 or any blank lines..

Make sure it is running
Code:
ps -ef | grep slapd


Confirm your BASE URI and HOST is set in /etc/openldap/ldap.conf also make sure your /etc/openldap/slapd.conf is set up exactly like the how to describes (of course use your tld)

If you have to edit any of the files make sure you restart slapd.

Try again.. see if slapcat shows anything maybe it has been added already ..

Like i said some posts above I am a ldap n00b so if none of this solves your issue i do not know what to tell ya.

However if you find you answer somewhere else be sure to post back what it was.. This thread is a good resource..

Welcome to gentoo forums...
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Nov 12, 2004 9:20 pm    Post subject: Reply with quote

Ok, init-zero, you're getting some kind of "promotion" here. How about something like "Official Gentoo OX Forum Guru"? :)

I really appreciate all the help you're giving as well as your experimentation and feedback. It's really great! Thanks!
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Fri Nov 12, 2004 9:37 pm    Post subject: Reply with quote

bitwh0re wrote:
Ok, init-zero, you're getting some kind of "promotion" here. How about something like "Official Gentoo OX Forum Guru"? :)

I really appreciate all the help you're giving as well as your experimentation and feedback. It's really great! Thanks!


Hey no problem! I am on this OX thing like flies on shit :D

I have got konqueror / nautilus / cadaver all working with webdav.documents .. webdav rocks ! I am having some auth issues with windows xp but so far so good..
_________________
write quit bang
Back to top
View user's profile Send private message
DoDaT69
n00b
n00b


Joined: 09 Apr 2004
Posts: 11

PostPosted: Sat Nov 13, 2004 5:38 am    Post subject: its gone! Reply with quote

where did the how to move to?
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Sat Nov 13, 2004 3:30 pm    Post subject: Re: its gone! Reply with quote

DoDaT69 wrote:
where did the how to move to?


http://www.mikefetherston.ca/OX/
Back to top
View user's profile Send private message
DoDaT69
n00b
n00b


Joined: 09 Apr 2004
Posts: 11

PostPosted: Sat Nov 13, 2004 3:38 pm    Post subject: Reply with quote

much appreciated.. I am going through it atm... ;)

Thanks again man!
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Sat Nov 13, 2004 4:58 pm    Post subject: Reply with quote

DoDaT69 wrote:
much appreciated.. I am going through it atm... ;)

Thanks again man!


Good luck, and you're welcome! Any feedback or tips are welcomed and appreciated!!!
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Mon Nov 15, 2004 2:25 pm    Post subject: Reply with quote

init-zero wrote:

Code:
<servlet>
        <servlet-name>webdav.documents</servlet-name>
        <servlet-class>com.openexchange.webdav.documents</servlet-class>
        <display-name>webdav.documents</display-name>
        <description>webdav.documents</description>
    </servlet>

<servlet-mapping>
        <servlet-name>webdav.documents</servlet-name>
        <url-pattern>/webdav.documents/*</url-pattern>
    </servlet-mapping>




So the only thing that needed to be changed was the <url-pattern>? I.E. the "/*" needed to be added to the end of webdav.documents? I guess I should change that for ical, contacts, etc, huh?
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Mon Nov 15, 2004 2:28 pm    Post subject: Reply with quote

init-zero wrote:
I figured out how to set up virtual domains..

In you /etc/postfix/main.cf add the following.

Code:
virtual_alias_domains = example.com
         virtual_alias_maps = hash:/etc/postfix/virtual


Than create /etc/postfix/virtual and add

Code:
postmaster@example.com postmaster


Than "Execute the command "postmap /etc/postfix/virtual" after changing the virtual
file, and execute the command "postfix reload" after changing the main.cf file"

works just like your alias file and newalises.

Taken from the VIRTUAL_README :D


Wouldn't something have to be added to the LDAP tree as well?
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Mon Nov 15, 2004 3:03 pm    Post subject: Reply with quote

bitwh0re wrote:
init-zero wrote:

Code:
<servlet>
        <servlet-name>webdav.documents</servlet-name>
        <servlet-class>com.openexchange.webdav.documents</servlet-class>
        <display-name>webdav.documents</display-name>
        <description>webdav.documents</description>
    </servlet>

<servlet-mapping>
        <servlet-name>webdav.documents</servlet-name>
        <url-pattern>/webdav.documents/*</url-pattern>
    </servlet-mapping>




So the only thing that needed to be changed was the <url-pattern>? I.E. the "/*" needed to be added to the end of webdav.documents? I guess I should change that for ical, contacts, etc, huh?


yes to " /* " that will allow you to travel into the directories. Also your filespool must be accesable by the user running you tomcat instance. As far as ical and such go I would say no this would only apply for the documents.
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Mon Nov 15, 2004 3:31 pm    Post subject: Reply with quote

bitwh0re wrote:
init-zero wrote:
I figured out how to set up virtual domains..

In you /etc/postfix/main.cf add the following.

Code:
virtual_alias_domains = example.com
         virtual_alias_maps = hash:/etc/postfix/virtual


Than create /etc/postfix/virtual and add

Code:
postmaster@example.com postmaster


Than "Execute the command "postmap /etc/postfix/virtual" after changing the virtual
file, and execute the command "postfix reload" after changing the main.cf file"

works just like your alias file and newalises.

Taken from the VIRTUAL_README :D


Wouldn't something have to be added to the LDAP tree as well?


Again this will only allow you to send an email to user1@mydomain1.com and have it send to your "real" user at user1@mydomain.com .. It is like a virtual host alias thing. Not a true virtual domain..
_________________
write quit bang
Back to top
View user's profile Send private message
parnasus
n00b
n00b


Joined: 20 Mar 2003
Posts: 7

PostPosted: Tue Nov 16, 2004 7:59 pm    Post subject: Unable to add documents Reply with quote

First of all, thank you all. If one reads the HOWTO carefully, it is possible to set this up on the first try. :oops:

On to the problem:
I am unable to save documents through openXchange. When I try to upload the file, I get:
Quote:
- An error ocurred saving the documents to the database


The only thing I see in the log files are:
Quote:
Nov 16 14:49:57 localhost slapd[13266]: conn=3 op=435 BIND anonymous mech=implicit ssf=0
Nov 16 14:49:57 localhost slapd[13266]: conn=3 op=435 BIND dn="cn=Manager,dc=dyndns-ise,dc=dyndns,dc=org" method=128
Nov 16 14:49:57 localhost slapd[13266]: conn=3 op=435 BIND dn="cn=Manager,dc=dyndns-ise,dc=dyndns,dc=org" mech=SIMPLE ssf=0
Nov 16 14:49:57 localhost slapd[6561]: deferring operation
Nov 16 14:49:57 localhost slapd[13266]: conn=3 op=435 RESULT tag=97 err=0 text=
Nov 16 14:49:57 localhost slapd[6883]: conn=3 op=436 SRCH base="dc=dyndns-ise,dc=dyndns,dc=org" scope=2 filter="(uid=sam)"
Nov 16 14:49:57 localhost slapd[6883]: conn=3 op=436 SRCH attr=dn
Nov 16 14:49:57 localhost slapd[6883]: conn=3 op=436 SEARCH RESULT tag=101 err=0 nentries=1 text=
Nov 16 14:49:57 localhost slapd[6882]: conn=3 op=437 BIND anonymous mech=implicit ssf=0
Nov 16 14:49:57 localhost slapd[6882]: conn=3 op=437 BIND dn="uid=sam,ou=Users,ou=OxObjects,dc=dyndns-ise,dc=dyndns,dc=org" method=128
Nov 16 14:49:57 localhost slapd[6882]: conn=3 op=437 BIND dn="uid=sam,ou=Users,ou=OxObjects,dc=dyndns-ise,dc=dyndns,dc=org" mech=SIMPLE ssf=0
Nov 16 14:49:57 localhost slapd[6882]: conn=3 op=437 RESULT tag=97 err=0 text=


Any ideas?
_________________
"If you design for the exceptions, the rules fall into place."
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Tue Nov 16, 2004 9:42 pm    Post subject: Reply with quote

Looking at you post I am not to sure what to tell you.. Your log shows that the ldap requests are going through fine so the only thing I think it could be is database grants / permissions.

How are you starting OX... I would reccomend starting each server in a differnt term and watch the logs..
/usr/local/open-xchange/bin/openexchange-sessiond
/usr/local/open-xchange/bin/openexchange-groupware
/usr/local/open-xchange/bin/openexchange-webmail

than also tail -f /var/log/messages
(for testing a have /var/log/messages as a catch all log file)
this will give you "real time error reporting" so to speak.. I think you will find an error in your groupware log if so post that..
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Nov 16, 2004 10:09 pm    Post subject: Reply with quote

Those are LDAP log entries, you'll want to post your other logs as init-zero says. The documents are stored in your local filesystem under a (pretty whacky) file system layout in the /usr/local/open-xchange directory. The entries, not the file itself, are stored in the database. All that LDAP is used for is for authentication.

You may want to look in your auth.log file as well and maybe check the permissions on your filespool. I've read in some of the other howto's that you have to do this, although I've never noticed it with mine.
Back to top
View user's profile Send private message
parnasus
n00b
n00b


Joined: 20 Mar 2003
Posts: 7

PostPosted: Tue Nov 16, 2004 11:11 pm    Post subject: Reply with quote

init-zero wrote:
Looking at you post I am not to sure what to tell you.. Your log shows that the ldap requests are going through fine so the only thing I think it could be is database grants / permissions.

How are you starting OX... I would reccomend starting each server in a differnt term and watch the logs..
/usr/local/open-xchange/bin/openexchange-sessiond
/usr/local/open-xchange/bin/openexchange-groupware
/usr/local/open-xchange/bin/openexchange-webmail

than also tail -f /var/log/messages
(for testing a have /var/log/messages as a catch all log file)
this will give you "real time error reporting" so to speak.. I think you will find an error in your groupware log if so post that..


The sessiond and webmail log files had nothing helpful in them. The only thing reported in the groupware log was:
Code:
Nov 16 17:59 localhost openexchange: Netline Application Server [NAS 5.0]
Nov 16 17:59 localhost openexchange: (c) Netline Internet Service GmbH
Nov 16 17:59 oxchange openexchange: Linux i386 2.4.26-gentoo-r9
Nov 16 17:59 oxchange openexchange: 1.4.2-gentoo-1098991002
Nov 16 17:59 oxchange openexchange: VM Total Memory       : 20,288 KB
Nov 16 17:59 oxchange openexchange: VM Free Memory        : 19,791 KB
Nov 16 17:59 oxchange openexchange: VM Used Memory        : 497 KB
Nov 16 17:59 oxchange openexchange: system version : [0.7.4] initializing ...
Nov 16 17:59 oxchange openexchange: Using path: /usr/local/open-xchange/
Nov 16 17:59 oxchange openexchange: Loglevel set to: 5
Nov 16 17:59 oxchange openexchange: Setting timeout           : 60000
Nov 16 17:59 oxchange openexchange: Setting start_server      : 1
Nov 16 17:59 oxchange openexchange: Setting thread_pool       : 0
Nov 16 17:59 oxchange openexchange: Setting db_pool           : 5
Nov 16 17:59 oxchange openexchange: Allow non pooled threads  : true
Nov 16 17:59 oxchange openexchange: Setting upload directory  : /tmp/
Nov 16 17:59 oxchange openexchange: Application-Build: 0
Nov 16 17:59 oxchange openexchange: Application-Build: 0
Nov 16 17:59 oxchange openexchange: bind to port 6661
Nov 16 17:59 oxchange openexchange: upload bind to port 6663
 done
Error while saving uploaded document.


Per bitwh0re's clue, I tried:
Code:
chmod -R 777 /usr/local/open-xchange/var
Unfortunately, I get the same errors again. The only thing that seems unusual in the LDAP entries is it is trying to log in anonymously (?).

I'll take a look at the SQL permissions and see what turns up.[/code]
_________________
"If you design for the exceptions, the rules fall into place."
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Nov 16, 2004 11:25 pm    Post subject: Reply with quote

Is this a clean install or an upgrade?
Back to top
View user's profile Send private message
parnasus
n00b
n00b


Joined: 20 Mar 2003
Posts: 7

PostPosted: Tue Nov 16, 2004 11:36 pm    Post subject: Reply with quote

bitwh0re wrote:
Is this a clean install or an upgrade?


This is a clean install.

I tried running the PostgreSQL postmaster in terminal mode (logged in as postgres and ran 'postmaster -i -D /var/lib/postgresql/data/') but got no joy. Also looked at the prg_documents_* tables but didn't see anything particularly out of place with them.

I've taken a close look at /usr/local/open-xchange/var/filespool. The directory is completely empty, and according to SuSE, it should be populated. I've made modifications to their script to populate the directory and I'll see if that remedies the problem.
_________________
"If you design for the exceptions, the rules fall into place."
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Nov 17, 2004 12:08 am    Post subject: Reply with quote

you did run the "correctfilespool" shell file right?
Back to top
View user's profile Send private message
parnasus
n00b
n00b


Joined: 20 Mar 2003
Posts: 7

PostPosted: Wed Nov 17, 2004 12:17 am    Post subject: Reply with quote

bitwh0re wrote:
you did run the "correctfilespool" shell file right?


I checked command history and there was a typo when I entered it. I'm re-running (actually running for the first time) it now. This will most likely take care of it.

<bonk self>
_________________
"If you design for the exceptions, the rules fall into place."
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 17, 2004 12:48 am    Post subject: Reply with quote

dohhh :D

One thing to note if your are going to be using webdav stuff the filespool must also be accesible by the user running your tomcat instance. And I do suggest you mess with that I am super impressed. Works just like a local file system just with versioning :P
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Nov 17, 2004 12:33 pm    Post subject: Reply with quote

init-zero wrote:
dohhh :D

One thing to note if your are going to be using webdav stuff the filespool must also be accesible by the user running your tomcat instance. And I do suggest you mess with that I am super impressed. Works just like a local file system just with versioning :P


There's also talk on the General mailinglist about possibly integrating SAMBA with LDAP and the filespool. Would be done through what's called an OXtension. Sounds very promising.

On another note, there's talk on the OX forum about integrating an IM server (Jabber) into the mix as well. There are java clients that could be docked on the (right-side) panel.

Things are going to get even more interesting!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 37, 38, 39  Next
Page 7 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum