Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
playworker
n00b
n00b


Joined: 28 Jul 2004
Posts: 21
Location: UK

PostPosted: Tue Oct 12, 2004 3:50 pm    Post subject: Reply with quote

Okay, sorted the Cyrus-IMAP issues, for anyone interested the mailbox needs to be user.oxusername, so if you add a user to OX with the username jimbob you need a mailbox called user.jimbob.

You may want to update your HOWTO with this as at the moment it is a little misleading - you are adding a user to OX with username "john" and then creating a mailbox called "user.jsmith" :P

If anyone else is getting "Login only under a layer" this is because you have the option "allowplaintext" set to "no" in imapd.conf, this needs setting to "yes" for the OX webmail to work properly! (Again this is missing from the HOWTO :D )

Right, now that is out of the way OX appears to be working fine and I've even downloaded your cool icons 8)

Only thing is my Postfix server isn't delivering it's mail properly, anybody any ideas? I've got it configured exactly as in the HOWTO and mail clients can connect to the server and believe they've sent mail but it's not getting to the users :cry:
Back to top
View user's profile Send private message
playworker
n00b
n00b


Joined: 28 Jul 2004
Posts: 21
Location: UK

PostPosted: Tue Oct 12, 2004 4:25 pm    Post subject: Reply with quote

I've done a bit of digging and it turns out the mail is being received but Postfix is just putting it into queues because it can't access the lmtp socket/dir supplied in main.cf...

The line in main.cf reads:
Code:
mailbox_transport = lmtp:unix:/var/imap/socket/lmtp


This dir/socket or whatever it is does exist but the messages are sitting in queues waiting to be delivered with the message:
Code:
connect to /var/imap/socket/lmtp[/var/imap/socket/lmtp]: Permission Denied


Do I perhaps need to change the permissions on this object or is it something else causing this problem?

Any help appreciated!

Thanks, Matt :)
Back to top
View user's profile Send private message
phil
n00b
n00b


Joined: 05 May 2003
Posts: 62
Location: Saint Louis, MO

PostPosted: Tue Oct 12, 2004 9:13 pm    Post subject: Thanks bitwh0re Reply with quote

Thanks bitwh0re for this document. I had 0.7.0 working, but it was rough, and I quickly lost interest. The improvements on 0.7.3 made me want to try again, so I'd making a HOWTO Open-Xchange, using the ebuild that's currently in bugs.gentoo.org, on the Gentoo Wiki. Here's my page so far:

http://gentoo-wiki.com/HOWTO_Open-Xchange

I just want to get the OX part down, since I have most of the backend working, save for Openldap now for some reason, and then expand the document to cover all of your steps. Take a look, let me know what you think. I'd like this to become the dumping ground for all OX knowledge on Gentoo so that eventually anyone can install it.

P
_________________
Left To Chance - apathy is no longer an option
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Oct 12, 2004 10:37 pm    Post subject: Gentoo / OX Wiki Reply with quote

Looks good so far phil! I think what OX needs now is admin, maintenance, and configuration/customisation docs. I have a section for that in my HOWTO but haven't been able to find the time to work on that yet. I want to get the base of this HOWTO working good.

I've made some icons for the top menu and am working on some other icons for the rest of OX. You can view them at my page for OX at:

http://www.mikefetherston.ca/OX/
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Oct 12, 2004 10:43 pm    Post subject: Reply with quote

playworker wrote:
I've done a bit of digging and it turns out the mail is being received but Postfix is just putting it into queues because it can't access the lmtp socket/dir supplied in main.cf...

The line in main.cf reads:
Code:
mailbox_transport = lmtp:unix:/var/imap/socket/lmtp


This dir/socket or whatever it is does exist but the messages are sitting in queues waiting to be delivered with the message:
Code:
connect to /var/imap/socket/lmtp[/var/imap/socket/lmtp]: Permission Denied


Do I perhaps need to change the permissions on this object or is it something else causing this problem?


I had that issue the first time around with Postfix.. right now I can't recall what it was... all I know is that I played with it long enough to get it working. :) I know the second time doing this install, I didn't run into it. Try these resources and see if any can help:

http://www.comedia.it/~bluca/postfix/CYRUS_README

http://www.cise.ufl.edu/depot/doc/postfix/LMTP_README

http://www.faqs.org/docs/Linux-HOWTO/Postfix-Cyrus-Web-cyradm-HOWTO.html
Back to top
View user's profile Send private message
playworker
n00b
n00b


Joined: 28 Jul 2004
Posts: 21
Location: UK

PostPosted: Wed Oct 13, 2004 7:35 am    Post subject: Reply with quote

Cheers for the links!

Haven't tried it yet because I'm at home but the first link contains this line:
Code:
mailbox_transport=cyrus:unix:/var/imap/socket/lmtp

which is slightly different to the line in your HOWTO...
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Oct 13, 2004 1:58 pm    Post subject: Reply with quote

That line was copied from my config file, so it should work. Maybe check the permissions on lmtpd. Mine are:

-rwxr-xr-x 1 root root 799668 Sep 10 09:13 /usr/cyrus/bin/lmtpd

and these are my permissions on the socket:

srwxrwxrwx 1 root root 0 Oct 13 07:53 /var/imap/socket/lmtp

You can try manually running the lmtpd daemon and see if that does anything. On my other box.. the first OX config.. I have this in my main.cf:

lmtp_cache_connection = NO

As well, make sure that the 'local_recipient_maps = ' parameter is uncommented.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Oct 13, 2004 2:37 pm    Post subject: HOWTO v0.12 Reply with quote

Ok, all corrections from this topic have been added to the HOWTO. I've republished the .pdf at:

http://www.mikefetherston.ca/OX

A note about the icons, they're not mine. I've borrowed them from the Crystal theme for Gnome so the credit should go there. I've just reworked them a bit so that they fit with the OX layout. I've also added a new set that uses index transparency which plays better with IE at my OX page above.
Back to top
View user's profile Send private message
lkraav
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2004
Posts: 125
Location: Estonia

PostPosted: Wed Oct 13, 2004 9:48 pm    Post subject: cyrus-sasl + ldap Reply with quote

playworker wrote:
Alrighty, here's a quick rundown of my progress so far:

o Setup SASL as per HOWTO but it won't start - message "Unknown Authentication Mechanism: ldap" :?: FIXED: Re-emerged cyrus-sasl and it included the ldap stuff this time :roll: :)


I been messing with this all day. When you don't have cyrus-sasl installed and emerge it for the first time, then ldap doesn't get included no matter what you do. Then I noticed that after doing emerge cyrus-sasl and trying to compile the source myself while cyrus-sasl is installed gets ldap included just fine in the self made binary. After Matt's progress, I also just did a re-emerge, while another copy of cyrus-sasl was installed and now it finds the ldap stuff it needs, compiles saslauthd with ldap and replaces the previous emerge. What's up with that?

Also, I would like to add that it is preferred to emerge the 7.4.5 masked version of jdbc3-postgresql package, if you are having problems with groupware not acting right on data occasionaly and getting SET AUTOCOMMIT TO OFF not supported errors in groupware.log.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Oct 14, 2004 12:22 am    Post subject: Re: cyrus-sasl + ldap Reply with quote

lkraav wrote:

I been messing with this all day. When you don't have cyrus-sasl installed and emerge it for the first time, then ldap doesn't get included no matter what you do. Then I noticed that after doing emerge cyrus-sasl and trying to compile the source myself while cyrus-sasl is installed gets ldap included just fine in the self made binary. After Matt's progress, I also just did a re-emerge, while another copy of cyrus-sasl was installed and now it finds the ldap stuff it needs, compiles saslauthd with ldap and replaces the previous emerge. What's up with that?

Also, I would like to add that it is preferred to emerge the 7.4.5 masked version of jdbc3-postgresql package, if you are having problems with groupware not acting right on data occasionaly and getting SET AUTOCOMMIT TO OFF not supported errors in groupware.log.


So is it the order in which cyrus-sasl and ldap are emerge that's giving the problem?

Did you link against /usr/share/jdbc3-postgresql-1/lib/pg74jdbc3.jar instead of /usr/share/postgresql/lib/postgresql.jar? That's what I did the first time around. The second time around, when I was writing the HOWTO, i noticed the postgresql.jar file and used that instead. It seemed to have worked ok.
Back to top
View user's profile Send private message
janh
n00b
n00b


Joined: 20 Dec 2003
Posts: 31

PostPosted: Thu Oct 14, 2004 4:22 pm    Post subject: Reply with quote

have followed the doc into extreme detail:

these are the software versions I have emerged:
[ebuild R ] dev-java/jikes-1.21
[ebuild R ] dev-libs/openssl-0.9.7d-r1
[ebuild R ] net-nds/openldap-2.1.30-r2
[ebuild R ] dev-libs/cyrus-sasl-2.1.19-r1
[ebuild R ] mail-mta/postfix-2.1.3
[ebuild R ] net-mail/cyrus-imapd-2.2.8
[ebuild R ] net-mail/cyrus-imap-admin-2.2.8
[ebuild R ] dev-db/postgresql-7.4.5-r2
[ebuild R ] dev-java/ant-1.6.2-r6
[ebuild R ] net-www/apache-2.0.52
[ebuild R ] www-servers/tomcat-5.0.27-r4
[ebuild R ] dev-java/jdom-1.0_beta10
[ebuild R ] dev-java/xerces-2.6.2-r1
[ebuild R ] app-admin/sudo-1.6.7_p5
[ebuild R ] app-text/ispell-3.2.06-r6
[ebuild R ] net-misc/netkit-telnetd-0.17-r4
[ebuild R ] net-nds/gq-0.6.0

when I do the command:
/etc/init.d/cyrus start
I get the results:

* Starting Cyrus imapd...
start-stop-daemon: stat /usr/cyrus/bin/cyrusmaster: No such file or directory [ !! ]

Anybody has got any ideas what is happening ??
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Oct 14, 2004 5:50 pm    Post subject: Reply with quote

Sounds to me like /usr/cyrus/bin/cyrusmaster doesn't exist at that location. Have you tried looking for 'cyrusmaster'?

Code:
find / -name "cyrusmaster" -print


If cyrusmaster exists but not in /usr/cyrus/bin you can create a symlink to it. If it doesn't exist, try re-emerging it cyrus-imapd.
Back to top
View user's profile Send private message
janh
n00b
n00b


Joined: 20 Dec 2003
Posts: 31

PostPosted: Thu Oct 14, 2004 8:14 pm    Post subject: Reply with quote

This did the trick to get things up and running

Code:

mkdir /usr/cyrus/
mkdir /usr/cyrus/bin/
ln -sf /usr/lib/cyrus/master /usr/cyrus/bin/cyrusmaster
/etc/init.d/cyrus start
 * Starting Cyrus imapd...    [ OK ]


but this does not give me a warm feeling (although at least that works now)
Back to top
View user's profile Send private message
janh
n00b
n00b


Joined: 20 Dec 2003
Posts: 31

PostPosted: Thu Oct 14, 2004 8:31 pm    Post subject: Reply with quote

progressed further but got stuck with this now:

Code:

/usr/sbin/saslpasswd2 -c cyrus
Password:
Again (for verification):
saslpasswd2: generic failure


The message inside /var/log/messages is below

Code:

Oct 14 22:27:13 tux saslpasswd2: unable to open Berkeley db /etc/sasl2/sasldb2: Invalid argument
Oct 14 22:27:13 tux saslpasswd2: setpass failed for cyrus: generic failure


searched everywhere but getting stuck on this
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Oct 15, 2004 12:15 am    Post subject: Reply with quote

Have a look in /var/log/auth.log. Does /etc/sasl2/sasldb2 exist? Have you confirmed that the Berkeley DB libraries exist on your computer and that directory is listed in ld.so.conf? You could also possibly run 'ldconfig'....
Back to top
View user's profile Send private message
janh
n00b
n00b


Joined: 20 Dec 2003
Posts: 31

PostPosted: Fri Oct 15, 2004 9:25 am    Post subject: Reply with quote

Still stuck on the same,
have gone in detail through everything:

the file /var/log/auth.log does not exist (this might point to something I am missing)
Code:
   
ls -l /var/log | grep aut

results in nothing
the file /etc/sasl2/sasldb2 exists and is owned by root:
Code:

ls -l /etc/sasl2/sasldb2
-rw-r-----  1 root mail 12311 Sep 10 15:54 /etc/sasl2/sasldb2


As far as I can tell Berkeley DB is installed on this system (maybe the doc could be slightly more detailed on that front), what I found is the following:
Code:

ls -l /usr/lib/libdb*.a
-rw-r--r--  1 root root  736450 Sep 10 12:08 /usr/lib/libdb-3.2.a
-rw-r--r--  1 root root 1073900 Apr 13  2004 /usr/lib/libdb-4.1.a
lrwxr-xr-x  1 root root      11 Sep 10 12:08 /usr/lib/libdb.a -> libdb-4.1.a
-rw-r--r--  1 root root  883438 Jun 20 23:27 /usr/lib/libdb1.a
-rw-r--r--  1 root root  799338 Sep 10 12:08 /usr/lib/libdb_cxx-3.2.a
-rw-r--r--  1 root root 1168986 Apr 13  2004 /usr/lib/libdb_cxx-4.1.a
lrwxr-xr-x  1 root root      15 Sep 10 12:08 /usr/lib/libdb_cxx.a -> libdb_cxx-4.1.a

Have download Berkeley DB in a seperate directoy as well, to make sure this gets found I have done the below:
Code:

echo /usr/lib/sasl2 >> /etc/ld.so.conf
echo /usr/local/BerkeleyDB.4.2/lib >> /etc/ld.so.conf
ldconfig


Instead of installing manually, should the Berkeley DB-stuff not be covered by this ebuild ?
[url]
http://packages.gentoo.org/ebuilds/?db-4.2.52_p2
[/url]


Code:

emerge --pretend sys-libs/db

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sys-libs/db-4.1.25_p1-r3
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Oct 15, 2004 10:42 pm    Post subject: Reply with quote

Try adding:

auth.debug,authpriv.* /var/log/auth.log

to your /etc/syslog.conf file and restarting sysklogd. Also make sure you have an entry for your hostname in /etc/hosts. These results from Google may help you as well:

http://www.google.ca/search?hl=en&q=saslpasswd2+unable+to+open+Berkeley+db++Invalid+argument&btnG=Search&meta=

I will change that section about Berkeley DB to show the proper emerge statement, thanks for catching that!
Back to top
View user's profile Send private message
janh
n00b
n00b


Joined: 20 Dec 2003
Posts: 31

PostPosted: Sat Oct 16, 2004 12:48 pm    Post subject: Reply with quote

have gone through google and various usergroups, still stuck.
Appear to be hitting a problem encountered on other user groups,
but I could not find anybody that came up with a solution.

This is the entry in the auth log:

Code:


 saslpasswd2: auxpropfunc error no mechanism available
 saslpasswd2: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
 saslpasswd2: setpass succeeded for login
 saslpasswd2: error deleting entry from sasldb: DB_NOTFOUND: No matching key/data pair found last message repeated 2 times
 saslpasswd2: sql_select option missing

 saslpasswd2: auxpropfunc error no mechanism available
 saslpasswd2: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
 saslpasswd2: setpass succeeded for login
 saslpasswd2: error deleting entry from sasldb: DB_NOTFOUND: No matching key/data pair found



any suggestions
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Sat Oct 16, 2004 2:03 pm    Post subject: Reply with quote

Seems your saslauthd is not configured. Make sure your /etc/conf.d/saslauthd reads like this:

# Initial (empty) options.
SASLAUTHD_OPTS=""

# Specify the authentications mechanism.
# *NOTE* For list see: saslauthd -v
# From 2.1.19, add "-r" to options for old behavior
# ie. reassemble user and realm to user@realm form.
# SASLAUTHD_OPTS="${SASLAUTH_MECH} -a pam -r"
#SASLAUTHD_OPTS="${SASLAUTH_MECH} -a pam"
#SASLAUTHD_OPTS="-a shadow"

SASL_AUTHMECH=ldap
SASLAUTHD_OPTS="-a ${SASL_AUTHMECH}"


Good Luck!!
Back to top
View user's profile Send private message
playworker
n00b
n00b


Joined: 28 Jul 2004
Posts: 21
Location: UK

PostPosted: Sat Oct 16, 2004 9:02 pm    Post subject: Reply with quote

Sorry for not posting earlier!

All working now, it was just the permissions on the lmtp socket :roll:
The socket is owned by the "cyrus" user which is a member of the "mail" group, all I had to do was add the postfix user to the "mail" group so that Postfix could also access the socket - no good just changing the perms so that postfix is the owner because then Cyrus can't see it! :)

Many thanks for everyone's assistance and thanks again for the HOWTO 8)
Back to top
View user's profile Send private message
janh
n00b
n00b


Joined: 20 Dec 2003
Posts: 31

PostPosted: Tue Oct 19, 2004 12:31 pm    Post subject: Reply with quote

have searched over the whole document step by step,
in the end I was missing one of the PERL modules.

After that I found out stuff was not talking through to imap,
fixed that and yes hit another problem I cannot explain:
Code:


Oct 19 14:20:35  saslauthd[27010]: set_auth_mech   : unknown authentication mechanism: ldap



Have searched the whole document for the word ldap and verified my setup against that, could not find any differences.
These are my entries for /etc/conf.d/saslauthd

Code:

more /etc/conf.d/saslauthd
SASLAUTHD_OPTS=""
#SASLAUTHD_OPTS="${SASLAUTH_MECH} -a pam"
SASL_AUTHMECH=ldap
SASLAUTHD_OPTS="-a ${SASL_AUTHMECH}"



where else might it loose the link to ldap ??
not in perl (verified that)
not in portage (verified that as well)
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Oct 19, 2004 1:28 pm    Post subject: Reply with quote

Ensure that ldap and -pam are in your USE flags and check what authentication method your saslauthd supports:

Code:
ox ~ # saslauthd -v
saslauthd 2.1.19
authentication mechanisms: getpwent rimap shadow ldap


Hope that helps!
Back to top
View user's profile Send private message
janh
n00b
n00b


Joined: 20 Dec 2003
Posts: 31

PostPosted: Tue Oct 19, 2004 2:43 pm    Post subject: Reply with quote

Think you hit the problem spot on with this, ldap is not supported inside saslauthd:
Code:


saslauthd -v
saslauthd 2.1.19
authentication mechanisms: getpwent rimap shadow



have tried to unmerge cyrus-sasle,
verify the USE statement in /etc/make.conf
then merged it again.
no change.

Then I tried to set it explicit with the following commands:

Code:

emerge --unmerge cyrus-sasl
USE="ldap -pam" emerge cyrus-sasl


the result remains:
Code:

saslauthd -v
saslauthd 2.1.19
authentication mechanisms: getpwent rimap shadow


have started to feel pretty stupid about this all,
doing nothing but reading manuals all the time.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Oct 19, 2004 3:04 pm    Post subject: Reply with quote

I would ensure that after you unmerge cyrus-sasl that indeed the saslauthd file disappears and that when you re-emerge it that the date and time matches your new emerge.

You may also want to 'source /etc/profile' and 'env-update' before and/or after the emerge.

Don't feel stupid, it took me over two weeks the first time around to get OX working. I read *a lot* of manuals, HOWTO's, documentation, problem reports, and mailing lists before I got everything going. It's even tougher if you've never touched this stuff (mail, ldap, etc.) before because you have to learn that as well.

The learning curve is very steep.
Back to top
View user's profile Send private message
janh
n00b
n00b


Joined: 20 Dec 2003
Posts: 31

PostPosted: Tue Oct 19, 2004 4:28 pm    Post subject: Reply with quote

Have tried several times to update all environment variables and unmerge and emerge the cyrus-sasl software. During the compilation it reports the following error in the auth.log file

Code:

Oct 19 18:16:23 tux last message repeated 2 times
Oct 19 18:19:52 tux saslpasswd2: sql_select option missing
Oct 19 18:19:52 tux saslpasswd2: auxpropfunc error no mechanism available
Oct 19 18:19:52 tux saslpasswd2: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Oct 19 18:19:52 tux saslpasswd2: setpass succeeded for login
Oct 19 18:19:52 tux saslpasswd2: error deleting entry from sasldb: DB_NOTFOUND: No matching key/data pair found
Oct 19 18:19:52 tux last message repeated 2 times
Oct 19 18:19:52 tux saslpasswd2: sql_select option missing
Oct 19 18:19:52 tux saslpasswd2: auxpropfunc error no mechanism available
Oct 19 18:19:52 tux saslpasswd2: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Oct 19 18:19:52 tux saslpasswd2: setpass succeeded for login
Oct 19 18:19:52 tux saslpasswd2: error deleting entry from sasldb: DB_NOTFOUND: No matching key/data pair found

On the other hand the emerge log does not report any problems during that same compile:
Code:

1098202681: Started emerge on: Oct 19, 2004 18:18:01
1098202681:  *** emerge  cyrus-sasl
1098202681:  >>> emerge (1 of 1) dev-libs/cyrus-sasl-2.1.19-r1 to /
1098202681:  === (1 of 1) Cleaning (dev-libs/cyrus-sasl-2.1.19-r1::/usr/portage/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild)
1098202682:  === (1 of 1) Compiling/Merging (dev-libs/cyrus-sasl-2.1.19-r1::/usr/portage/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild)
1098202795:  === (1 of 1) Updating world file (dev-libs/cyrus-sasl-2.1.19-r1)
1098202795:  === (1 of 1) Post-Build Cleaning (dev-libs/cyrus-sasl-2.1.19-r1::/usr/portage/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19-r1.ebuild)
1098202796:  >>> AUTOCLEAN: dev-libs/cyrus-sasl
1098202796:  --- AUTOCLEAN: Nothing unmerged.
1098202796:  ::: completed emerge (1 of 1) dev-libs/cyrus-sasl-2.1.19-r1 to /
1098202796:  *** Finished. Cleaning up...
1098202796:  *** exiting successfully.
1098202796:  *** terminating.


Have done a google for the above error, there appear to be other people with the same error, but nobody with a solution
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, ... 37, 38, 39  Next
Page 2 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum