Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 10, 11, 12 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
pneum0nia
n00b
n00b


Joined: 24 Sep 2004
Posts: 37

PostPosted: Sun Nov 28, 2004 2:48 am    Post subject: Reply with quote

Yeah I guess I am just confused as to why the application is looking for '/servlet/intranet' when that directory doesn't exist.
_________________
#define CLEVER_SIGNATURE 1
Back to top
View user's profile Send private message
Primera
n00b
n00b


Joined: 05 Nov 2003
Posts: 22
Location: New Orleans, LA

PostPosted: Sun Nov 28, 2004 3:09 am    Post subject: cyradm -user cyrus domain.tld Reply with quote

I have re-emerged all cyrus packages as well as used your (bitwh0re) configs modified only with my information. Unfortunately the command
Code:
cyradm -user cyrus domain.tld
still hangs. I have tried domain.tld, computer.domain.tld, and localhost in this command without success. Any more ideas?
_________________
All it takes for evil to triumph is for good men to do nothing.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Sun Nov 28, 2004 10:50 am    Post subject: Reply with quote

pneum0nia wrote:
Yeah I guess I am just confused as to why the application is looking for '/servlet/intranet' when that directory doesn't exist.


it's a virtual mapping that's created by mod_jk2 in workers2.properties and in the web.xml file:

Code:
web.xml:

<servlet>
<servlet-name>intranet</servlet-name>
<servlet-class>intranet</servlet-class>
</servlet>

<servlet-mapping>
<servlet-name>intranet</servlet-name>
<url-pattern>/intranet</url-pattern>
</servlet-mapping>


Code:
workers2.properties:

# Example socket channel, override port and host.
[channel.socket:ox-domain.tld:8009]
port=8009
host=ox-domain.tld

# define the worker
[ajp13:ox-domain.tld:8009]
channel=channel.socket:ox-domain.tld:8009
group=lb

# Map the Tomcat examples webapp to the Web server uri space
[uri:/examples/*]
group=lb

[status:]
info=Status worker, displays runtime information

[uri:/jkstatus/*]
info=The Tomcat /jkstatus handler
group=status:

[uri:/servlet/*]
worker=ajp13:ox-domain.tld:8009


I hope that helps to clear it up as to how the mapping is created.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Sun Nov 28, 2004 10:53 am    Post subject: Re: cyradm -user cyrus domain.tld Reply with quote

Primera wrote:
I have re-emerged all cyrus packages as well as used your (bitwh0re) configs modified only with my information. Unfortunately the command
Code:
cyradm -user cyrus domain.tld
still hangs. I have tried domain.tld, computer.domain.tld, and localhost in this command without success. Any more ideas?


can you verify that imap is indeed listening on port 143 by telnetting to your host (to port 143)?
Back to top
View user's profile Send private message
pneum0nia
n00b
n00b


Joined: 24 Sep 2004
Posts: 37

PostPosted: Sun Nov 28, 2004 10:54 am    Post subject: Reply with quote

Yeah it does...it actually made more sense when I viewed things via the tomcat administration panel.
_________________
#define CLEVER_SIGNATURE 1
Back to top
View user's profile Send private message
Primera
n00b
n00b


Joined: 05 Nov 2003
Posts: 22
Location: New Orleans, LA

PostPosted: Mon Nov 29, 2004 5:13 am    Post subject: Re: cyradm -user cyrus domain.tld Reply with quote

Quote:
can you verify that imap is indeed listening on port 143 by telnetting to your host (to port 143)?

Yes, telnet to imap port was working great...I've started over from the beginning with a fresh install...I'll report if I get the same problem.
_________________
All it takes for evil to triumph is for good men to do nothing.
Back to top
View user's profile Send private message
killercow
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2004
Posts: 86
Location: Netherlands

PostPosted: Thu Dec 02, 2004 11:00 am    Post subject: can't get tomcat to start the /servlet dir. Reply with quote

I have configured tomcat to start the /servlet app, but when i start it trough the manager at :8080, it says:

FAIL - Application at context path /servlet could not be started

what could be wrong? i know i did some things a bit different to get everything installed, i checked to see if the .class and .jar files are in the tomcat/*/servlet dir

When i continue with the guide, and later on start OX, it all works as expected, i can see the login screen, and it logs me in, but as soon as it redirects me to http://10.0.0.150/servlet/groupware.......

i get a 404 error,
Apache's error_log says it can't find the dir servlet in /var/www/localhost/htdocs/servlet
So im guessing the mod_jk2 thing isn't working as expected, which probably depends on tomcat to get the /servlet application started.

Any clues?

FIXED:
while searhing for answers i found out that /opt/tomcat5/logs/catalina.out contains the errors that the manager doesn't display, it said the xml of my web.xml was not correct, i have corrected it and now it works, at least, the servlet starts.


Not so fixed after all,
after restarting tomcat i see that the servet has been loaded as openExchange.
And after reloading apache,tomcat and all of the OX daemons i can login to the perl script without getting the 500 error.
But when i get redirect apache still looks for /servlet in its localhost/htdocs dir.

Im getting lost in the config scripts here, :/ Were to look for typo's?

My tomcat manager doens't seem to get any connections on jk-8009, which i persume would be the proces apache should be talking to?
Back to top
View user's profile Send private message
sardiskan
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 115
Location: Montgomery

PostPosted: Thu Dec 02, 2004 4:13 pm    Post subject: will open-xchange work with a different email server Reply with quote

I would like to use open-xchange but I already have a mail server running that I would like open-xchange to connect to. Will it do that?
_________________
Unless a grain of wheat falls to the ground and dies, it remains only a single seed.
Back to top
View user's profile Send private message
sardiskan
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 115
Location: Montgomery

PostPosted: Thu Dec 02, 2004 4:14 pm    Post subject: postfix will send to other domain, but not mine. Reply with quote

My postfix install sends email to outside domains but not to my own domain. THe client sides shows that the message has been sent, but the other user never gets it and I guess the timeout on postfix is long because I haven't recieved a bounce yet.

Jason
_________________
Unless a grain of wheat falls to the ground and dies, it remains only a single seed.
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Dec 02, 2004 4:35 pm    Post subject: Reply with quote

@ killercow It sound as if it has something to do with mod_jk. I would also look at your apache logs to see what mod_jk is doing..

@ sardiskan I think we would need more info on your mail server to give you any answers. Do you use ldap to authenticate to your mail server? .. cryus-imapd ? sasl ?
_________________
write quit bang
Back to top
View user's profile Send private message
killercow
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2004
Posts: 86
Location: Netherlands

PostPosted: Fri Dec 03, 2004 8:55 am    Post subject: fixed! Reply with quote

for some reason stupid litle bugs seem to persist more easily when the workday is getting at the end.

just booted the server and all was solved within 15 minutes. guess i was getting tired and overlooked some things.

(it was just a typo in the modules conf part of apache.)

allmost everything works now,

deleting contacts gives me an sql error, which says autocomming=off is no longer supported.

isn't that a bug which emerged when i guess postgresql dropped support for that?

Does anyone have any luck reaching the ldap server from within thunderbird? i add it to the ldap servers list like the OX wiki says, but it won't give me any of my contacts, or an error.
Back to top
View user's profile Send private message
sardiskan
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 115
Location: Montgomery

PostPosted: Fri Dec 03, 2004 4:28 pm    Post subject: Reply with quote

if I login with an incorrectly user/pass it gives me an
authentication error (which is good), but if I give the correct
user/pass information, it goes and logs me in but it bring up a black webpage. What's up with that. any ideas.
_________________
Unless a grain of wheat falls to the ground and dies, it remains only a single seed.


Last edited by sardiskan on Fri Dec 03, 2004 8:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
sardiskan
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 115
Location: Montgomery

PostPosted: Fri Dec 03, 2004 4:30 pm    Post subject: Reply with quote

init-zero wrote:
@ killercow It sound as if it has something to do with mod_jk. I would also look at your apache logs to see what mod_jk is doing..

@ sardiskan I think we would need more info on your mail server to give you any answers. Do you use ldap to authenticate to your mail server? .. cryus-imapd ? sasl ?


init-zero I use qmail and vpopmail as my email services. Qmail is used to send, and vpopmail is used to capture. Does that help?
_________________
Unless a grain of wheat falls to the ground and dies, it remains only a single seed.
Back to top
View user's profile Send private message
sardiskan
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 115
Location: Montgomery

PostPosted: Fri Dec 03, 2004 8:22 pm    Post subject: Reply with quote

Ok, I appear to be getting logged into the server, I don't get any error message when I logon with my "john" user, but I get a black website. There is literally nothing in it. Any ideas?
_________________
Unless a grain of wheat falls to the ground and dies, it remains only a single seed.
Back to top
View user's profile Send private message
Swell°
n00b
n00b


Joined: 01 Dec 2003
Posts: 69

PostPosted: Sat Dec 04, 2004 5:19 pm    Post subject: Reply with quote

Hi,

First thanks for this great howto! Great job

But, i have a problem when i want to start slapd, I have this error:

Code:

Dec  5 02:06:50 [slapd] SQL engine 'mysql' not supported
Dec  5 02:06:50 [slapd] auxpropfunc error no mechanism available_


I don't know what's wrong...
Back to top
View user's profile Send private message
drakkan
Apprentice
Apprentice


Joined: 21 Jun 2004
Posts: 232

PostPosted: Sat Dec 04, 2004 7:07 pm    Post subject: Reply with quote

Hi, I'm following your howto but I'm having some trouble configuring ldap (this is the first time I configure ldap):

my sldap.conf has the following entries, as howto suggests:

include /etc/openldap/schema/cosine.schema
include /etc/openldap/schema/inetorgperson.schema
include /etc/openldap/schema/openldap.schema
include /etc/openldap/schema/misc.schema
include /etc/openldap/schema/nis.schema
#include /etc/openldap/schema/openxchange.schema

allow bind_v2
suffix "dc=homenetwork,dc=it"
rootdn "cn=Manager,dc=homenetwork,dc=it"
index objectClass pres,eq
#index cn,sn,uid eq
index gidNumber,memberUid eq
#index uid,mailEnabled,cn,sn,givenname,lnetMailAccess,alias,loginDestination eq,sub


but when I start ldap with /etc/init.d/slapd start , I have the following error:

* Starting ldap-server...
/etc/openldap/schema/cosine.schema: line 1071: ObjectClass not found: "person [ !! ]


how I can fix this?

thanks

drakkan
Back to top
View user's profile Send private message
Swell°
n00b
n00b


Joined: 01 Dec 2003
Posts: 69

PostPosted: Sat Dec 04, 2004 9:28 pm    Post subject: Reply with quote

drakkan wrote:
Hi, I'm following your howto but I'm having some trouble configuring ldap (this is the first time I configure ldap):


Same as me...
Back to top
View user's profile Send private message
drakkan
Apprentice
Apprentice


Joined: 21 Jun 2004
Posts: 232

PostPosted: Sat Dec 04, 2004 9:41 pm    Post subject: Reply with quote

Swell° wrote:
drakkan wrote:
Hi, I'm following your howto but I'm having some trouble configuring ldap (this is the first time I configure ldap):


Same as me...


I have solved the slapd start problem a good slapd.conf is the following:

# $OpenLDAP: pkg/ldap/servers/slapd/slapd.conf,v 1.23.2.8 2003/05/24 23:19:14 kurt Exp $
#
# See slapd.conf(5) for details on configuration options.
# This file should NOT be world readable.
#
include /etc/openldap/schema/core.schema
include /etc/openldap/schema/cosine.schema
include /etc/openldap/schema/inetorgperson.schema
include /etc/openldap/schema/openldap.schema
include /etc/openldap/schema/misc.schema
include /etc/openldap/schema/nis.schema
#include /etc/openldap/schema/openxchange.schema

allow bind_v2

# Define global ACLs to disable default read access.

# Do not enable referrals until AFTER you have a working directory
# service AND an understanding of referrals.
#referral ldap://root.openldap.org

pidfile /var/run/openldap/slapd.pid
argsfile /var/run/openldap/slapd.args

# Load dynamic backend modules:
# modulepath /usr/lib/openldap/openldap
# moduleload back_bdb.la
# moduleload back_ldap.la
# moduleload back_ldbm.la
# moduleload back_passwd.la
# moduleload back_shell.la

# Sample security restrictions
# Require integrity protection (prevent hijacking)
# Require 112-bit (3DES or better) encryption for updates
# Require 63-bit encryption for simple bind
# security ssf=1 update_ssf=112 simple_bind=64

# Sample access control policy:
# Root DSE: allow anyone to read it
# Subschema (sub)entry DSE: allow anyone to read it
# Other DSEs:
# Allow self write access
# Allow authenticated users read access
# Allow anonymous users to authenticate
# Directives needed to implement policy:
# access to dn.base="" by * read
# access to dn.base="cn=Subschema" by * read
# access to *
# by self write
# by users read
# by anonymous auth
#
# if no access controls are present, the default policy is:
# Allow read by all
#
# rootdn can always write!

#######################################################################
# ldbm database definitions
#######################################################################

database bdb
suffix "dc=homenetwork,dc=it"
rootdn "cn=Manager,dc=homenetwork,dc=it"
# Cleartext passwords, especially for the rootdn, should
# be avoid. See slappasswd(8) and slapd.conf(5) for details.
# Use of strong authentication encouraged.
rootpw secret
# The database directory MUST exist prior to running slapd AND
# should only be accessible by the slapd and slap tools.
# Mode 700 recommended.
directory /var/lib/openldap-data
# Indices to maintain
index objectClass pres,eq
#index cn,sn,uid eq
index gidNumber,memberUid eq
#index uid,mailEnabled,cn,sn,givenname,lnetMailAccess,alias,loginDestination eq,sub



now I have another problem:

I create the following ldap.ldif file:

dn: dc=homenetwork,dc=it
objectclass: dcObject
objectclass: organization
o: HOMENETWORK
dc: homenetwork



dn: cn=Manager,dc=homenetwork,dc=it
objectclass: organizationalRole
cn: Manager


but when I issue the command :

slapadd -l ldap.ldif

I have the error:

slapadd: could not parse entry (line=6)
Back to top
View user's profile Send private message
Swell°
n00b
n00b


Joined: 01 Dec 2003
Posts: 69

PostPosted: Sat Dec 04, 2004 9:59 pm    Post subject: Reply with quote

@drakkan: thanks but my problem is not coming from the slapd.conf, I don't understand why it tells me SQL engine 'mysql' not supported

I hope someone can help...

Thanks anyway
Back to top
View user's profile Send private message
Rosjahh
Apprentice
Apprentice


Joined: 16 Jan 2003
Posts: 182
Location: Below sealevel

PostPosted: Sat Dec 04, 2004 10:39 pm    Post subject: Reply with quote

Hi, I've been busy trying to get OX working with help of Mike's guide. Exellent guide. Thank you!

However, I'm having trouble to log in. I just get "Authentication failed!" above the login box. I've looked in all the logs that I thought are relevant, inside /var/open-xchange/log, messages, auth, slapd etc. and also tried to watch output when i start the openexchange starting scripts in a terminal. There I do get some output, but no error messages. sessiond.log shows me:
Code:

Creating directory '/home/httpd'.
Creating directory '/home/httpd/.maildir'.
Creating directory '/home/httpd/.maildir/cur'.
Creating directory '/home/httpd/.maildir/new'.
Creating directory '/home/httpd/.maildir/tmp'.


webmail.log and groupware.log are empty. slap doesn't give me any indication that open-xchange is contacting ldap.

Apache confirms that it has started the mod_jk2/2.0.4 module. No errors.

I'm doind two things a little different from the guide: I'm trying to use courier instead of cyrus, and I configured the ldap differently so that the Open-xchange setup just merges with my samba configuration. But I guess that this should not be a problem. I should at least be able to see some errors, right?

What should I double check? Any suggestions?

Thanks


Last edited by Rosjahh on Sun Dec 05, 2004 12:20 am; edited 1 time in total
Back to top
View user's profile Send private message
drakkan
Apprentice
Apprentice


Joined: 21 Jun 2004
Posts: 232

PostPosted: Sat Dec 04, 2004 10:48 pm    Post subject: Reply with quote

Rosjahh wrote:
Hi, I've come to page Mike's guide. Exellent guide. Thank you!


can you post your ldap.ldif, please? I'm having trouble with slapadd (the previous post),

thanks
drakkan
Back to top
View user's profile Send private message
drakkan
Apprentice
Apprentice


Joined: 21 Jun 2004
Posts: 232

PostPosted: Sat Dec 04, 2004 11:32 pm    Post subject: Reply with quote

bitwh0re wrote:
sardiskan wrote:
I was following the install guide and I have come to a stopping point. During the "Initialize LDAP tree" phase I have a create a file called ldap.diff and configure it. Then I have to add this tree configuration to ldap by running:

Code:
slapadd -l ldap.ldif


After I try that I get the following error:

Code:
slapadd: cound not parse entry (line=9)


I'm not sure what to do next. Any ideas?


You know, I thought everyone that was getting this error was doing it wrong until I got that error just the other day. I've changed the HOWTO around to show a working way of initially populating the LDAP tree. Here's the command until I publish the next HOWTO:

Code:
ldapadd �x �D �cn=Manager,dc=ox-domain,dc=tld� �W �f ldap.ldif


Of course, change dc=ox-domain,dc=tld to suit your environment.



I have the same problem:


gentoo openldap # ldapadd -x -D "cn=Manager,dc=homenetwork,dc=it" -W -f ldap.ldif
Enter LDAP Password:
adding new entry "dc=homenetwork,dc=it "
ldapadd: update failed: dc=homenetwork,dc=it
ldap_add: Invalid syntax (21)
additional info: objectclass: value #0 invalid per syntax


ldap.conf:

gentoo openldap # cat ldap.conf
# $OpenLDAP: pkg/ldap/libraries/libldap/ldap.conf,v 1.9 2000/09/04 19:57:01 kurt Exp$
#
# LDAP Defaults
#

# See ldap.conf(5) for details
# This file should be world readable but not world writable.

#BASE dc=example, dc=com
#URI ldap://ldap.example.com ldap://ldap-master.example.com:666

#SIZELIMIT 12
#TIMELIMIT 15
#DEREF never
BASE dc=homenetwork, dc=it
URI ldap://homenetwork.it
HOST homenetwork.it
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Sat Dec 04, 2004 11:51 pm    Post subject: Reply with quote

@Swell : recompile ldap with -mysql in your use flag. Or do an equery uses openldap and see if mysql support is compiled in. I have no idea why you would be pulling this from slapd..

@sardiskan : I could be wrong but I do not think that mail server will work well with OX.

@the other people: I am not at work but I will be able to look at your problems more on monday if they have not been resolved.

bitwh0re get in here !! :D
_________________
write quit bang
Back to top
View user's profile Send private message
Rosjahh
Apprentice
Apprentice


Joined: 16 Jan 2003
Posts: 182
Location: Below sealevel

PostPosted: Sun Dec 05, 2004 12:29 am    Post subject: Reply with quote

drakkan wrote:
Rosjahh wrote:
Hi, I've come to page Mike's guide. Exellent guide. Thank you!


can you post your ldap.ldif, please? I'm having trouble with slapadd (the previous post),

thanks
drakkan


drakkan, I don't see anything wrong with your ldif file. It's the same as mine except that I have a different domain ofcourse. The errors you get are also not familiar to me. Personnaly I had to mess a little with my schema's in /etc/openldap/slapd.conf to get it working. I really don't know if this is the case with you to. My schemas are now;

Code:

include         /etc/openldap/schema/core.schema
include         /etc/openldap/schema/cosine.schema
include         /etc/openldap/schema/nis.schema
include         /etc/openldap/schema/inetorgperson.schema
include         /etc/openldap/schema/samba.schema
include         /etc/openldap/schema/qmail.schema
include        /etc/openldap/schema/openxchange.schema


At least i can restart openldap with this configuration, I can add the ldif file, and my previous postfix configuration still works (I need qmail.schema for that). I don't know if this will cause me problems later on.

At the moment open-xchange doesn't even talk to openldap.
Back to top
View user's profile Send private message
Swell°
n00b
n00b


Joined: 01 Dec 2003
Posts: 69

PostPosted: Sun Dec 05, 2004 8:56 am    Post subject: Reply with quote

@Everybody here: My ldap works
I'AM VERY STUPID... there was a stupid mistake in my slapd.conf...

What can be good to had in the doc is:

Code:

This command test the config file!
/usr/lib/slapd -t
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 10, 11, 12 ... 37, 38, 39  Next
Page 11 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum