Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 14, 15, 16 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Dec 30, 2004 2:25 pm    Post subject: Reply with quote

Did you make sure you enabled aci in you ebuild for ldap?
Code:
foobar openldap # nano -w openldap-2.1.xx-ry.ebuild
 myconf=”$(myconf) --enable-aci”


Also I am having issues with the encrypted password.

The adduser_ox uses your etc/admintools.conf for many variables. May want to look at that.

In admintools.conf I can not use my encrypted {CRYPT} pass and in saslauthd.conf I can not use my encrypted passwd.. I do not know why but I _must_ store them in plain text.. This I do not like and will look into figuring out why this is the case.
_________________
write quit bang
Back to top
View user's profile Send private message
jorgeantonio
n00b
n00b


Joined: 28 Dec 2004
Posts: 5

PostPosted: Thu Dec 30, 2004 2:44 pm    Post subject: Reply with quote

You are right can be the error on that part because the code to add was in other .ebuild :) now can I edit and nothing more at my step on The how to or is needed re-emerge other apps???

ANd in your case if you test with

Quote:
/usr/lib/openldap/slapd -t
it is sucess ?
Men I'm newbee here but i know that the ldap authentication is not my issue, so if you want to see any of my files or code let me know. :roll:

Thanx!
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Dec 30, 2004 2:51 pm    Post subject: Reply with quote

do a..
Code:
emerge -p openldap

to see what version you are running then edit the ebuild of that version.

yes I can test fine.
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Dec 30, 2004 2:53 pm    Post subject: Reply with quote

changed your post :p you will need to emerge ldap again after of course.
_________________
write quit bang
Back to top
View user's profile Send private message
jorgeantonio
n00b
n00b


Joined: 28 Dec 2004
Posts: 5

PostPosted: Thu Dec 30, 2004 2:56 pm    Post subject: Reply with quote

:D Sorry!

Ok emerge ldap but is needed set again all passwords and all the settings following the HOW TO or only emerge ldap and done?
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Dec 30, 2004 3:08 pm    Post subject: Reply with quote

should be able to just emerge ldap again
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Dec 30, 2004 3:58 pm    Post subject: Reply with quote

Another thing to update in the how-to is in the smtp section... You do not need to create a new /etc/sasl2/smtp file just edit the current /etc/sasl2/smtp.conf and add
Code:
 pwcheck_method: saslauthd
mech_list: LOGIN PLAIN


working on ssl will keep ya posted..

Also in the virus section amavisd.conf if you add a " \ " before the @$mydomain you will not get that error..

Code:
$mailfrom_notify_admin     = "virus-admin\@$mydomain";
$mailfrom_notify_recip     = "virus-admin\@$mydomain";


It is defaulted like that i think.
_________________
write quit bang
Back to top
View user's profile Send private message
parnasus
n00b
n00b


Joined: 20 Mar 2003
Posts: 7

PostPosted: Thu Dec 30, 2004 4:14 pm    Post subject: Reminders not being sent. Reply with quote

I'm back, guys.

I've checked through the HOWTO as well as the body of this thread and have found no indiciation of what may be happening to my reminders. Whenever an appointment has a reminder attached, the reminder is never sent. I've verified the system date is set correctly, as well as the appointment date.

I've done some investigating, and have found if I do not click on ADD on the participant screen, I am not notified of the appointment, even though I'm already assigned. I realize as the appointment creator, I may not necessarily need to be notified. But it also makes a good trail of bread crumbs when appointments are made and cancelled, etc.

Is there a CRON job which needs to be running? A daemon forgotten? I really haven't a clue.
_________________
"If you design for the exceptions, the rules fall into place."
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Dec 31, 2004 1:12 pm    Post subject: Re: Reminders not being sent. Reply with quote

parnasus wrote:
I'm back, guys.

I've checked through the HOWTO as well as the body of this thread and have found no indiciation of what may be happening to my reminders. Whenever an appointment has a reminder attached, the reminder is never sent. I've verified the system date is set correctly, as well as the appointment date.

I've done some investigating, and have found if I do not click on ADD on the participant screen, I am not notified of the appointment, even though I'm already assigned. I realize as the appointment creator, I may not necessarily need to be notified. But it also makes a good trail of bread crumbs when appointments are made and cancelled, etc.

Is there a CRON job which needs to be running? A daemon forgotten? I really haven't a clue.


I would file this as a reproducable bug at the open-xchange website.
Back to top
View user's profile Send private message
mxc
Guru
Guru


Joined: 05 Mar 2003
Posts: 442
Location: South Africa

PostPosted: Sat Jan 01, 2005 8:42 am    Post subject: Has anyone setup oxpenxchange with ldap using kerberos? Reply with quote

Hi all,


I have an exisitng ldap server which keep centralised user info. I use kerberos to handle authentication. The particular version I use is Heimdal which stores teh passwords in ldap.

My question is as follows:

1) Are there any known issue with openxchange and kerberos authentication?

2) When I run the init.d script from openxchange I keep getting prompted for passwords when the scripts tries to su to apache. Its weird as my server attempts to use kerbeos to login but the server itself is setup to use only local account for login. I.e. the client machine use kerberos and the server just uses unix accounts. I am not sure why the su command is attempting to do kerbeos authentication especially since the pam modules tell it only to use unix authentication?

3) I keep getting ldap connection errors when trying to add a user

Quote:
ldap_sasl_interactive_bind_s: Can't contact LDAP server (-1)
LDAP Success
SQL Success


Any help appreciated
Back to top
View user's profile Send private message
steffen79
n00b
n00b


Joined: 03 Dec 2004
Posts: 48
Location: germany / hannover

PostPosted: Sat Jan 01, 2005 9:26 pm    Post subject: Reply with quote

i have still a little problem... i can't delete anything in the groupware frontend.
i cant delete contacts or files.
I always get if i try to delete a file:
Can't delete file in filestorage.
Can't delete file in filestorage.
Can't delete file in filestorage.
Error while deleting folder from database.

if i try to delete a contact:

The contact wasn't deleted from the database: SQL err in Contact java.sql.SQLException: ERROR: SET AUTOCOMMIT TO OFF is no longer supported

im using these libs in WEB-INF/libs:

activation.jar
comfiretools.jar
intranet.jar
jdom.jar
mail.jar
nas.jar
pg73jdbc3.jar
postgresql.jar -> /usr/share/jdbc3-postgresql-1/lib/pg73jdbc3.jar
servlet-api.jar
webdav.jar
xercesImpl.jar

are these correct?
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Sun Jan 02, 2005 12:40 am    Post subject: Reply with quote

steffen79 wrote:

The contact wasn't deleted from the database: SQL err in Contact java.sql.SQLException: ERROR: SET AUTOCOMMIT TO OFF is no longer supported


That is because of the jdbc connector. In this huge thread I explain how to fix this by downloading a new jdbc jar.. You should be able to find it.
_________________
write quit bang
Back to top
View user's profile Send private message
steffen79
n00b
n00b


Joined: 03 Dec 2004
Posts: 48
Location: germany / hannover

PostPosted: Mon Jan 03, 2005 7:48 am    Post subject: Reply with quote

thx. it worked. emerged the masked jdbc driver, compiled ox again und now everythings works! thanks a lot for this great how-to, too!
Back to top
View user's profile Send private message
ferp2
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2002
Posts: 104

PostPosted: Mon Jan 03, 2005 7:31 pm    Post subject: Top Menu Icons Reply with quote

Hi everyone,

Although I've installed the top menu icons in /var/www/localhost/htdocs/cfintranet/images/icons/top/EN, I'm still getting the colored squares. Only when I mouse over them do they change to the icons. I've tried different things, including rebooting but so far nothing works.

Any suggestions on this?

Thanks
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Mon Jan 03, 2005 8:00 pm    Post subject: Reply with quote

clean out you web-browser cache and temp files.....
_________________
write quit bang
Back to top
View user's profile Send private message
ferp2
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2002
Posts: 104

PostPosted: Mon Jan 03, 2005 8:55 pm    Post subject: Reply with quote

Thanks, init... should have known better.

I'd also like to make a small contribution with regards to setting up OX. I had some trouble getting past ./adduser_ox ... which kept on giving me the "inappropriate authentication" message, and thus prevented me from successfully logging into Open-xchange. If you're having a similar problem, this is how I entered the LDAP secretpassword into all the pertinent documents:

Let's say you decide upon a secretpassword of "123551234".

1. /etc/saslauthd.conf
...
ldap_bind_pw: 123551234
...

2. slappasswd -h {CRYPT} -s 123551234
{CRYPT}abcXXabcd

3. /etc/openldap/slapd.conf
...
password-hash {CRYPT}

rootpw abcXXabcd
...

4. /usr/local/open-xchange/etc/admintools.conf
...
# LDAP Admin Passwd
BINDPW="abcXXabcd"
...

Apparently, you don't include the {CRYPT} portion when you insert your encrypted password into admintools.conf.

Good luck...
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Mon Jan 03, 2005 9:24 pm    Post subject: Reply with quote

good tip. I was wondering about that. I have my passwd stored in plain text and sure as heck didnt like it. I will try to change that in my admintools.. We still need to store it in plain text as far a saslauthd goes :( it looks like...
_________________
write quit bang
Back to top
View user's profile Send private message
ferp2
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2002
Posts: 104

PostPosted: Thu Jan 06, 2005 12:07 am    Post subject: Reply with quote

OK, I sent in a post detailing how I got LDAP to work. Everything seemed alright, meaning I was able to successfully login to open-exchange, but that was until I clicked on the email icon and got that familiar "!!!System Error!!!" message. After taking a careful look in my log files, I realized that entering the secretpassword before I encrypted it is WRONG.

Here's what I wrote:

Quote:
Let's say you decide upon a secretpassword of "123551234".

1. /etc/saslauthd.conf
...
ldap_bind_pw: 123551234
...


Here's what I should have written:

Quote:
Let's say you decide upon a secretpassword of "123551234".

1. slappasswd -h {CRYPT} -s 123551234
{CRYPT}abcXXabcd

2. /etc/saslauthd.conf
...
ldap_bind_pw: abcXXabcd
...


If you don't enter the encrypted secretpassword in saslauthd.conf, you will not be able to use the email portion of open-xchange.

To Mike Fetherston:

First, thanks for the excellent howto which, as far as I'm concerned, outclasses the other howtos I've seen out there by a long shot. Second, when you get a chance to update your howto, I'd recommend that you put the "slappasswd -h {CRYPT} -s secretpassword" step before entering the secretpassword info into /etc/saslauthd.conf. The way things are now in your howto, one might get the impression that you decide upon your secretpassword first when entering it into /etc/saslauthd.conf, and then encrypt it for /etc/slapd.conf and /usr/local/open-xchange/etc/admintools.conf.

Anyway, that's it.
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Jan 06, 2005 2:56 pm    Post subject: Reply with quote

tls on SMTP

/etc/postfix/main.cf

Code:
smtpd_use_tls = yes
smtpd_tls_auth_only = yes
smtpd_tls_key_file = /etc/ssl/postfix/server.key
smtpd_tls_cert_file = /etc/ssl/postfix/server.crt
smtpd_tls_CAfile = /etc/ssl/postfix/server.pem
smtpd_tls_loglevel = 3
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom


Posfix now comes with it own certs so creating them is not need anymore. To confirm check /etc/ssl/postfix for server.key server.crt server.pem.

Than do a postfix reload and you should be good to go.
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Jan 06, 2005 3:14 pm    Post subject: Reply with quote

How do we add access to only e-mail and not OX? I am going to be looking into this if anyone has any ideas let me know. Our mail setup is authing against a uname and password on ldap but so is OX so I am not even sure if it can be done.
_________________
write quit bang
Back to top
View user's profile Send private message
ferp2
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2002
Posts: 104

PostPosted: Fri Jan 07, 2005 3:10 am    Post subject: Reply with quote

Could someone post their web.xml file with the WebDAV stuff included. I can access http://myserv.dom/servlet/webdav.documents in my browser but I get a 404 if I try http://myserv.dom/servlet/webdav.documents/dir/test.txt.

I read that some other people were having problems. Has any one figured out how to get this working?
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Fri Jan 07, 2005 2:42 pm    Post subject: Reply with quote

your servlet section ..

Code:
<servlet>
<servlet-name>webdav.documents</servlet-name>
<servlet-class>com.openexchange.webdav.documents</servlet-class>
<display-name>webdav.documents</display-name>
<description>webdav.documents</description>
</servlet>


Than your mapping section ..

Code:
<servlet-mapping>
<servlet-name>webdav.documents</servlet-name>
<url-pattern>/webdav.documents/*</url-pattern>
</servlet-mapping>
</web-app>


The " /* " is the key
_________________
write quit bang
Back to top
View user's profile Send private message
ferp2
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2002
Posts: 104

PostPosted: Fri Jan 07, 2005 10:19 pm    Post subject: Reply with quote

Hi init_zero,

When I originally created the web.xml file, I put in a bunch of tags, allowing open-xchange to be deployed in the Tomcat server container. These original tags were surrounded by these two tags:

Quote:
<web-app></web-app>


When I originally added the WebDAV stuff to the web.xml file, I added it below the closing </web-app> tag. When I tried to access open-xchange, however, it couldn't find the files, so I took a chance and surround ALL the tags, including the WebDAV tags, with <web-app></web-app>. Now this worked, but to be honest I'm not sure if this is right. That's why I wanted to see a complete web.xml file, so I can see how the original info and the new WebDAV info is put together. By the way I have the correct syntax as in:

Quote:
<url-pattern>/webdav.documents/*</url-pattern>


Thanks
Back to top
View user's profile Send private message
conloos
n00b
n00b


Joined: 23 Feb 2004
Posts: 54

PostPosted: Sat Jan 08, 2005 12:18 am    Post subject: next tripwire Reply with quote

Hi,

i tried to setup 'init_ldap.ldif' on a openldap-2.1.30-r4 and had several times an error in line 101 (the problem is the line 69: OpenLDAPaci: etc.)
I had to edit my ebuild script (for openldap-2.1.30-r4) and add --enable-aci (e.g. myconf_berkdb='--enable-bdb --with-ldbm-api=berkeley --enable-aci').

con

RFM@me: page 5 on the pdf :(


Last edited by conloos on Sat Jan 08, 2005 1:02 am; edited 2 times in total
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Sat Jan 08, 2005 1:00 am    Post subject: Reply with quote

ferp2 wrote:
Hi init_zero,

When I originally created the web.xml file, I put in a bunch of tags, allowing open-xchange to be deployed in the Tomcat server container. These original tags were surrounded by these two tags:

Quote:
<web-app></web-app>


When I originally added the WebDAV stuff to the web.xml file, I added it below the closing </web-app> tag. When I tried to access open-xchange, however, it couldn't find the files, so I took a chance and surround ALL the tags, including the WebDAV tags, with <web-app></web-app>. Now this worked, but to be honest I'm not sure if this is right. That's why I wanted to see a complete web.xml file, so I can see how the original info and the new WebDAV info is put together. By the way I have the correct syntax as in:

Quote:
<url-pattern>/webdav.documents/*</url-pattern>


Thanks


Ahh I see yea that will work but you want one <web-app> at the begining and one at the end.

Code:
<web-app>
<display-name>Servlet OpenXchange</display-name>
<description>
Servlet OpenXchange 0.7.5
</description>
<servlet>
<servlet-name>intranet</servlet-name>
<servlet-class>intranet</servlet-class>
</servlet>
<servlet>
<servlet-name>webmail</servlet-name>
<servlet-class>webmail</servlet-class>
</servlet>

<servlet-mapping>
<servlet-name>intranet</servlet-name>
<url-pattern>/intranet</url-pattern>
</servlet-mapping>
<servlet-mapping>
<servlet-name>webmail</servlet-name>
<url-pattern>/webmail</url-pattern>
</servlet-mapping>

<servlet>
<servlet-name>webdav.con</servlet-name>
<servlet-class>com.openexchange.webdav.contacts</servlet-class>
<display-name>webdav.con</display-name>
<description>webdav.con</description>
</servlet>

<servlet>
<servlet-name>webdav.calendar</servlet-name>
<servlet-class>com.openexchange.webdav.calendar</servlet-class>
<display-name>webdav.calendar</display-name>
<description>webdav.calendar</description>
</servlet>

<servlet>
<servlet-name>webdav.ical</servlet-name>
<servlet-class>com.openexchange.webdav.ical</servlet-class>
<display-name>webdav.ical</display-name>
<description>webdav.ical</description>
</servlet>

<servlet>
<servlet-name>webdav.documents</servlet-name>
<servlet-class>com.openexchange.webdav.documents</servlet-class>
<display-name>webdav.documents</display-name>
<description>webdav.documents</description>
</servlet>

<servlet-mapping>
<servlet-name>webdav.con</servlet-name>
<url-pattern>/webdav.contacts</url-pattern>
</servlet-mapping>

<servlet-mapping>
<servlet-name>webdav.calendar</servlet-name>
<url-pattern>/webdav.calendar</url-pattern>
</servlet-mapping>

<servlet-mapping>
<servlet-name>webdav.ical</servlet-name>
<url-pattern>/webdav.ical</url-pattern>
</servlet-mapping>

<servlet-mapping>
<servlet-name>webdav.documents</servlet-name>
<url-pattern>/webdav.documents/*</url-pattern>
</servlet-mapping>
</web-app>

_________________
write quit bang
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 14, 15, 16 ... 37, 38, 39  Next
Page 15 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum