Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 23, 24, 25 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
dans1234
n00b
n00b


Joined: 05 Apr 2005
Posts: 1

PostPosted: Tue Apr 05, 2005 8:50 pm    Post subject: OXLook Reply with quote

I have open-xchange beta 5 up and running with relatively few problems following Mike's How-to (Thanks Mike). However, I just can't get OXlook to work. It's not a top priority for me because my users are used to using a webmail interface and they don't seem to care... I was just wondering if anyone has gotten OXLook to work properly. I'm using SSL according to Mike's guide so I use https://mail.oxdomain.tld

Thanks
Back to top
View user's profile Send private message
Hibbelharry
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 88
Location: Bremen, Northern Germany

PostPosted: Wed Apr 06, 2005 12:04 am    Post subject: Reply with quote

hello guys,
i'm currently running rc1 and web guis and tools ork flawlessly so far using ~x86 apache/tomcat. since mod_jk2 gave me major headaches with apache seg'faulting all the time i tried to set up mod_jk instead of mod_jk2. since i reworked the whole setup to clean up somethings i'm currently running in a problem: webdav doesn't work as it should. webdav.documents works flawlessly, rss feeding of bookamrks to browser also works. i can import calendars via webdav.ical but i can't write anything into the calendar. i don't find any error messages in the logs. so my question:

has anyone a working ox setup using mod_jk and can post his configuration files for mod_jk ?

i strongly believe this is the issue of my problems.
any help or suggestions are really appreciated.

Greetz
Hibbelharry
Back to top
View user's profile Send private message
Cuchulainn
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2003
Posts: 107

PostPosted: Wed Apr 06, 2005 11:52 am    Post subject: Reply with quote

Okay, I've got groupware up and running. When I try the webmail though, it says:
Quote:
WebMail - OPEN-XCHANGE 0.8.0-beta4
!!! SYSTEM - ERROR !!!

What is going wrong here?

Cheers, Cuchu
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Apr 06, 2005 1:05 pm    Post subject: Reply with quote

hybrid256 wrote:

I followed the howto until the part where I change the default icons by the one provided by bitwhore and didn't go further since for instance, I want a working solution before adding some other stuff such as Clam or Spam Assassin.


I'm currently trying to get DSPAM integrated into my OX install.. DSPAM is supposed to be more accurate than SA. But I think you're going in the right direction -- get the base going, test, *then* extend. :)

hybrid256 wrote:

Here is my goal : I have 100 users currently using Outlook as a Microsoft Exchange client and of course, the Exchange that goes with it.
Part of my users have adresses in @clubaventure.fr, some in @sport-away.com and I want to add a @tourisport.fr which means that I'll have to deal with 3 domains and to make thing a bit more complicated, I want to be able to have at mximum, the 3 domains for one single user (ie aliases)
What I want from OX is to be able to do all this as much alike as possible.


I know init-zero showed you how to do this with /etc/postfix/virtual and will probably want my head on a silver platter for mentioning this, but this could probably be done in LDAP as well. IMO, LDAP would be the way to go (more centralized administration).. if you try this method and get it working, I'd be very interested in seeing how you did it.

Good Luck!
Back to top
View user's profile Send private message
Cuchulainn
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2003
Posts: 107

PostPosted: Wed Apr 06, 2005 1:21 pm    Post subject: Reply with quote

I am logged in to the groupware section, but I am not able to make an appointment or task. It seems to work, but the task/appointment is not made. What could be wrong here?

Cheers, Cuchu
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Apr 06, 2005 1:24 pm    Post subject: Reply with quote

init-zero wrote:

Then run..
Code:

postmap /etc/postfix/virtual ; postfix reload

That will give you a /etc/postfix/virtual.db that postfix can read and understand.

This all can be done via ldap to but i like the good ol way ;)



Jesus bitwh0re do you read before you type :twisted: :twisted: :twisted:
_________________
write quit bang
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Apr 06, 2005 8:39 pm    Post subject: Reply with quote

Wow RC-1 is out.


Will try this version and write success or not ;)

Edit:

It functions perfectly =)

i just downloaded the source compiled it like in the tutorial - but something doesn't function, i added following lines:

Code:

 --with-dbhost=127.0.0.1 \
 --with-rootpw="ldapsecretpassword"


now it functions perfectly. Give it a try *YES*
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Thu Apr 07, 2005 5:38 am    Post subject: Reply with quote

@bitwh0re:
Could you please change in WebmailSpellChecking the line:

Code:
<execute cmd="ispell -ddeutsch -a -P -H -Tlatin1"/>


to
Quote:
<execute cmd="ispell -dgerman -a -P -H -Tlatin1"/>


Could be, that you mean the original content of the file.
But with 'german' it works like it should.

Thank You =)
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Apr 07, 2005 1:05 pm    Post subject: Reply with quote

Boef wrote:

Could you please change in WebmailSpellChecking the line:

Code:
<execute cmd="ispell -ddeutsch -a -P -H -Tlatin1"/>


to
Quote:
<execute cmd="ispell -dgerman -a -P -H -Tlatin1"/>


Could be, that you mean the original content of the file.
But with 'german' it works like it should.


Are you saying that -ddeutsch doesn't work? Could it be that you don't have the deutsch dictionary installed? From the ispell man page it states that:

Code:
-d file    Specify  an  alternate dictionary file.  For example, use -d deutsch to choose a German dictionary in a German installation.


If it isn't working for you, could it be that you don't have a "German installation"? You can find your installed dictionaries here:

Code:
/usr/lib/ispell
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Thu Apr 07, 2005 2:44 pm    Post subject: Reply with quote

bitwh0re wrote:

Are you saying that -ddeutsch doesn't work? Could it be that you don't have the deutsch dictionary installed? From the ispell man page it states that:

Yes, i mean. I installed the german package (app-dicts/ispell-de).

bitwh0re wrote:

Code:
-d file    Specify  an  alternate dictionary file.  For example, use -d deutsch to choose a German dictionary in a German installation.


I read that too and wondered, i don't know why - but the dictionary is saved as /usr/lib/ispell/german.[hash/aff].
Thats why I change the option and now it is functioning. =)
Back to top
View user's profile Send private message
gschinkel
n00b
n00b


Joined: 08 Apr 2005
Posts: 14

PostPosted: Fri Apr 08, 2005 12:05 pm    Post subject: Reply with quote

Hi people,

Can anyone of you guys help me out with the following problem:

Apr 8 13:46:27 groupware slapd[22713]: conn=3 fd=10 ACCEPT from IP=81.173.4.90:50643 (IP=0.0.0.0:389)
Apr 8 13:46:27 groupware slapd[22754]: conn=3 op=0 BIND dn="cn=Manager,dc=example,dc=nl" method=128
Apr 8 13:46:27 groupware slapd[22754]: conn=3 op=0 BIND dn="cn=Manager,dc=example,dc=nl" mech=SIMPLE ssf=0
Apr 8 13:46:27 groupware slapd[22754]: conn=3 op=0 RESULT tag=97 err=0 text=
Apr 8 13:46:27 groupware slapd[22754]: conn=3 op=1 MOD dn="cn=AddressAdmins,o=AddressBook,ou=OxObjects,dc=example,dc=nl"
Apr 8 13:46:27 groupware slapd[22754]: conn=3 op=1 MOD attr=member
Apr 8 13:46:27 groupware slapd[22754]: conn=3 op=1 RESULT tag=103 err=20 text=modify/add: member: value #0 already exists
Apr 8 13:46:27 groupware slapd[22754]: conn=3 op=1 RESULT tag=103 err=20 text=modify/add: member: value #0 already exists
Apr 8 13:46:27 groupware slapd[22754]: conn=3 op=2 UNBIND
Apr 8 13:46:27 groupware slapd[22754]: conn=3 fd=10 closed

This happens when I try to add a user with the following command:
/usr/local/open-xchange/sbin/adduser_ox --username="gschinkel" --passwd="test123" --name="schinkel" --sname="g" --maildomain="example.nl" --ox_timezone="GMT"

What might be wrong? The command output says it's first error is an SQL error, but I doubt that because all previous ldap (and SQL) statements seem to have gone well.
Back to top
View user's profile Send private message
kblack
n00b
n00b


Joined: 12 Nov 2004
Posts: 9

PostPosted: Sun Apr 10, 2005 7:09 am    Post subject: Reply with quote

Need postfix help:

Got everything up and running but postfix stoped delivering to cyrus. Every message I sedn gets bounced because postfix detects it as a loop. Do I need to do anything in main.cf to tell postfix to deliver to cyrus?
Back to top
View user's profile Send private message
)(MarksTheSpot
n00b
n00b


Joined: 20 Jan 2005
Posts: 16
Location: Bristol, UK

PostPosted: Sun Apr 10, 2005 7:55 am    Post subject: /usr/local/open-xchange/etc/groupware/ldap.conf No such file Reply with quote

Hi,

I've been away sorting out a different machine, and now it's going great, I'm just trying to add a ox-user but it keeps saying that it can't find ldap.conf in my ox directory.

Can anyone post an example of a ldap.conf so I can add it to the dir and get going again? or is this s deeper problem that it appears?

Cheers,

Matt

[edit]

OK, since posting this, I've got the ldap.conf isue sorted, but I'm ow getting ldap error 89.

I can't find any reference to this in the log files, so I'm not sure what's going on...

Help!


[/edit]
_________________
---------------------------------------
"Quis custodiet ipsos custodes?"
---------------------------------------
Back to top
View user's profile Send private message
)(MarksTheSpot
n00b
n00b


Joined: 20 Jan 2005
Posts: 16
Location: Bristol, UK

PostPosted: Sun Apr 10, 2005 10:10 am    Post subject: Re: /usr/local/open-xchange/etc/groupware/ldap.conf No such Reply with quote

)(MarksTheSpot wrote:

OK, since posting this, I've got the ldap.conf isue sorted, but I'm ow getting ldap error 89.

I can't find any reference to this in the log files, so I'm not sure what's going on...

Help!


Boy do I feel stupid, it was because I'd put whitespace in the ldap.conf file between the dc="" tags...

:oops:

Ah well, Now I can login, just get a blank page though with a session id in the URL.

On to tracking that down... :)

)(marks
_________________
---------------------------------------
"Quis custodiet ipsos custodes?"
---------------------------------------
Back to top
View user's profile Send private message
)(MarksTheSpot
n00b
n00b


Joined: 20 Jan 2005
Posts: 16
Location: Bristol, UK

PostPosted: Sun Apr 10, 2005 10:25 am    Post subject: Reply with quote

OK,

I rebooted and it's all good! :)

Thanks for a great tuorial, now to just change the icons... :)


)(marks
_________________
---------------------------------------
"Quis custodiet ipsos custodes?"
---------------------------------------
Back to top
View user's profile Send private message
KirinSan
n00b
n00b


Joined: 06 Aug 2003
Posts: 22
Location: NRW

PostPosted: Thu Apr 14, 2005 7:40 am    Post subject: Reply with quote

Hi All,

great tutorial. Certainly it's a lot of work and time in it.

I followed the tutorial, emerge software, configured it, and so on. So far I did not have any problems.
But when I typed the following command:
Code:
slapadd -l /usr/local/open-xchange/share/init_ldap.ldif


I'm getting this error:
Code:
slapadd: could not parse entry (line=146)


At first I thought, I had made a typo, but when I edited this file, Line 146 was a blank one. When I removed this line, and ran the command again, he could not parse the next blank line.:?:


Code:

111: dn: uid=mailadmin,ou=Users,ou=OxObjects,dc=wiwi-gentoo,dc=testserver,dc=de
112: objectClass: top
113: objectClass: shadowAccount
114: objectClass: posixAccount
115: objectClass: person
116: objectClass: inetOrgPerson
117: objectClass: OXUserObject
118: OpenLDAPaci: 1#entry#grant;r,w,s,c;cn,initials,mail,title,ou,l,birthday,description,street,
  postalcode,st,c,oxtimezone,homephone,mobile,pager,facsimiletelephonenumber,
  telephonenumber,labeleduri,jpegphoto,loginDestination,sn,givenname,;r,s,c;[all]#self#
119: uidNumber: 501
120: homeDirectory: /home/mailadmin/
121: loginShell: /bin/bash
122: mailEnabled: OK
123: gidNumber: 500
124: mailDomain: wiwi-gentoo.testserver.de
125: ou: Administration
126: uid: mailadmin
127: sn: Admin
128: preferredLanguage: EN
129: mail: mailadmin@wiwi-gentoo.testserver.de
130: o: BDV
131: smtpServer: localhost
132: imapServer: localhost
133: alias: postmaster@wiwi-gentoo.testserver.de
134: alias: root@wiwi-gentoo.testserver.de
135: givenName: Admin
136: cn: Admin Admin
137: shadowMin: 0
138: shadowMax: 9999
139: shadowWarning: 7
140: shadowExpire: 0
141: userPassword: {crypt}TYVrC4Dwsnp8o
142: OXAppointmentDays: 5
143: OXGroupID: 500
144: OXTaskDays: 5
145: OXTimeZone: EST
146:


Line 118 is one line in the config-file

Anyone any idea?

Thanks for helping me!

KirinSan
_________________
"Ihr kriegt mich niemals! Niemand kriegt Homer Simpson ... ähh ...
ich meine, den Kuchenmann! Ich bin nämlich nicht Homer Simpson,
sondern der Kuchenmann, Homer Simpson ist garnicht hier! HAHAHA!"
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Apr 14, 2005 2:14 pm    Post subject: Reply with quote

KirinSan wrote:
Hi All,
Code:

118: OpenLDAPaci: 1#entry#grant;r,w,s,c;cn,initials,mail,title,ou,l,birthday,description,street,
  postalcode,st,c,oxtimezone,homephone,mobile,pager,facsimiletelephonenumber,
  telephonenumber,labeleduri,jpegphoto,loginDestination,sn,givenname,;r,s,c;[all]#self#



Line 118 is one line in the config-file

Anyone any idea?

Thanks for helping me!

KirinSan


It looks like OpenLDAP doesn't have ACI enabled. If you were following the older howto (index.html) the edits you make to the OpenLDAP ebuild will get erased when you perform an emerge sync. I have a more active HOWTO that you can follow here:

http://www.mikefetherston.ca/OX/html/index-new.html
Back to top
View user's profile Send private message
les.piggot
n00b
n00b


Joined: 15 Oct 2003
Posts: 15

PostPosted: Fri Apr 15, 2005 7:23 am    Post subject: Reply with quote

Hi guys,

I've just followed Mikes Howto but for ox 0.8 rc1 release (& postgress 8.01). when I try to add a user to OX using adduser_ox, it fails, on the SQL addition (addusersql_ox script) with the following error:

java.sql.SQLException: ERROR: column "creating_date" is of type timestamp with time zone but expression is of type character varying
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1471)
at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1256)
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:175)
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:389)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:330)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeUpdate(AbstractJdbc2Statement.java:282)
at com.openexchange.tools.oxfolder.OXFolderAction.createFolder(OXFolderAction.java:194)
at com.openexchange.tools.oxfolder.OXFolderAction.addUsersStandardFolder(OXFolderAction.java:730)
at com.openexchange.tools.oxfolder.OXFolderAction.addUserToOXFolders(OXFolderAction.java:608)
at com.openexchange.tools.oxfolder.OXFolderAction.main(OXFolderAction.java:107)
java.sql.SQLException: ERROR: column "creating_date" is of type timestamp with time zone but expression is of type character varying
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1471)
at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1256)
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:175)
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:389)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:330)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeUpdate(AbstractJdbc2Statement.java:282)
at com.openexchange.tools.oxfolder.OXFolderAction.createFolder(OXFolderAction.java:194)
at com.openexchange.tools.oxfolder.OXFolderAction.addUsersStandardFolder(OXFolderAction.java:730)
at com.openexchange.tools.oxfolder.OXFolderAction.addUserToOXFolders(OXFolderAction.java:614)
at com.openexchange.tools.oxfolder.OXFolderAction.main(OXFolderAction.java:107)
java.sql.SQLException: ERROR: column "creating_date" is of type timestamp with time zone but expression is of type character varying
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1471)
at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1256)
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:175)
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:389)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:330)
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeUpdate(AbstractJdbc2Statement.java:282)
at com.openexchange.tools.oxfolder.OXFolderAction.createFolder(OXFolderAction.java:194)
at com.openexchange.tools.oxfolder.OXFolderAction.addUsersStandardFolder(OXFolderAction.java:730)
at com.openexchange.tools.oxfolder.OXFolderAction.addUserToOXFolders(OXFolderAction.java:620)
at com.openexchange.tools.oxfolder.OXFolderAction.main(OXFolderAction.java:107)
INSERT


Any else found this error, or any ideas how to solve it?

Cheers

Les
Back to top
View user's profile Send private message
les.piggot
n00b
n00b


Joined: 15 Oct 2003
Posts: 15

PostPosted: Fri Apr 15, 2005 8:37 am    Post subject: Reply with quote

OK, seemed to be a issue with postgres 8.01, downgrades to 7.437. and SQL statemtn works correctly.

Cheers

Les
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Fri Apr 15, 2005 11:52 am    Post subject: Reply with quote

les.piggot wrote:
OK, seemed to be a issue with postgres 8.01, downgrades to 7.437. and SQL statemtn works correctly.

Cheers

Les


Good to know, I was going to upgrade to postgresql 8x this weekend. Thanks for the heads up.
_________________
write quit bang
Back to top
View user's profile Send private message
KirinSan
n00b
n00b


Joined: 06 Aug 2003
Posts: 22
Location: NRW

PostPosted: Fri Apr 15, 2005 12:56 pm    Post subject: Reply with quote

Hello again,

thx for your help. You were right, it was a missing --enable-aci statement. I forgot that I compiled openldap long time ago on my machine.

But now I got an error again. When I try to add a user via adduser_ox I get a LDAP Success and a SQL Error Deleting User from LDAP.

/var/log/messages gives nothing but when I start slapd I get these strange messages:
Code:

lapd[28673]: daemon: socket() failed errno=97 (Address family not supported by protocol)
sql_select option missing
auxpropfunc error no mechanism available
_sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
bdb_initialize: Sleepycat Software: Berkeley DB 4.1.25: (December 19, 2002)
bdb_db_init: Initializing BDB database
slapd starting


Is it possible thats something wrong with my postgresql...I use postgresql 7.4.7-r1


As I had enough time I printed the tutorial and found a slight error in the "Configuring Postfix" section. There seems to be an overlapping table in the config section. :-)


Thank you for this great documentation

Greetz

Kirin
_________________
"Ihr kriegt mich niemals! Niemand kriegt Homer Simpson ... ähh ...
ich meine, den Kuchenmann! Ich bin nämlich nicht Homer Simpson,
sondern der Kuchenmann, Homer Simpson ist garnicht hier! HAHAHA!"
Back to top
View user's profile Send private message
les.piggot
n00b
n00b


Joined: 15 Oct 2003
Posts: 15

PostPosted: Fri Apr 15, 2005 1:24 pm    Post subject: Reply with quote

Guys,

Everything seems to be working but I'm not able to log into ox :(

After loging on to the system I get redirected to

http://172.16.2.111/servlet/intranet?SITE=beforeAuth&sessionID=3a43c09cbc5f029a96a79076fe878e64:

Not Found

The requested URL /servlet/intranet was not found on this server.
Apache/2.0.52 (Gentoo/Linux) mod_jk2/2.0.4 Server at domain.ltd Port 80

Any thoughts,
Cheers

Les
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Fri Apr 15, 2005 1:32 pm    Post subject: Reply with quote

Code:
 auxpropfunc error no mechanism available
_sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
this is comming from a mail daemon correct?

Bitwh0re and I tried to figure this error out.. And had no luck yet. I think it may be a bug in gentoo somewhere.

Code:
lapd[28673]: daemon: socket() failed errno=97 (Address family not supported by protocol)


This is the error you should be looking into. I can not tell you off the top of my head what it is.

also this may be fishy too.
Code:
sql_select option missing


I would confirm use flags and such in your packages. 'equery uses ldap'
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Fri Apr 15, 2005 1:34 pm    Post subject: Reply with quote

les.piggot wrote:
Guys,

Everything seems to be working but I'm not able to log into ox :(

After loging on to the system I get redirected to

http://172.16.2.111/servlet/intranet?SITE=beforeAuth&sessionID=3a43c09cbc5f029a96a79076fe878e64:

Not Found

The requested URL /servlet/intranet was not found on this server.
Apache/2.0.52 (Gentoo/Linux) mod_jk2/2.0.4 Server at domain.ltd Port 80

Any thoughts,
Cheers

Les


I would check over your mod_jk2 configs also make sure tomcat is running. You could look into your apache logs a bit more to see what is going on.
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Apr 15, 2005 5:53 pm    Post subject: Reply with quote

init-zero wrote:
Code:
 auxpropfunc error no mechanism available
_sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
this is comming from a mail daemon correct?

Bitwh0re and I tried to figure this error out.. And had no luck yet. I think it may be a bug in gentoo somewhere.

Code:
lapd[28673]: daemon: socket() failed errno=97 (Address family not supported by protocol)


This is the error you should be looking into. I can not tell you off the top of my head what it is.

also this may be fishy too.
Code:
sql_select option missing


I would confirm use flags and such in your packages. 'equery uses ldap'


This sounds more like PostgreSQL is not accepting TCP/IP connections. What makes me think it's Postgre and *not* OpenLDAP is the 'sql_select option missing'. Enabling TCP/IP connections in Postgres is covered in this section:

http://www.mikefetherston.ca/OX/html/index-new.html#22

If this error is indeed being thrown by OpenLDAP and not Postgres then make sure that you have 'allow bind_v2' in your slapd.conf file. It's order of placement matters, but slapd will tell you where to put it when you restart it.

WRT to the Postgres 8.x problems.. it could be that the 7.4 JDBC drivers were emerged which are probably not entirely compatible with Postgres 8.0. It seems now that 8.0_p311 of the Postgres JDBC3 drivers have been released (unstable) as of April 12th. You may want to try again as it seems Postgres 8.0 has been marked stable (April 4th) on x86.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 23, 24, 25 ... 37, 38, 39  Next
Page 24 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum