Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 25, 26, 27 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
pneum0nia
n00b
n00b


Joined: 24 Sep 2004
Posts: 37

PostPosted: Fri Apr 22, 2005 7:45 pm    Post subject: Reply with quote

I am having emerge failures of mod_jk2-2.0.4 on apache-2.0.54 and noticed this on bugfix that noted that mod_jk2 is no longer supported and mod_jk is being backported and supported. Is there any reason why I wouln't be able to implement mod_jk instead of mod_jk2 in my OX installation?
_________________
#define CLEVER_SIGNATURE 1
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Apr 22, 2005 8:01 pm    Post subject: Reply with quote

pneum0nia wrote:
I am having emerge failures of mod_jk2-2.0.4 on apache-2.0.54 and noticed this on bugfix that noted that mod_jk2 is no longer supported and mod_jk is being backported and supported. Is there any reason why I wouln't be able to implement mod_jk instead of mod_jk2 in my OX installation?


I think that mod_jk is for Apache 1.3 and mod_jk2 is for Apache 2.0. JK2 will be integrated as of Apache 2.1 which is currenly in Alpha. You can reference the older instructions which used a JK2 binary here:

http://www.mikefetherston.ca/OX/html/index.html

Look in the section titled "Configure Apache for Tomcat"
Back to top
View user's profile Send private message
ferp2
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2002
Posts: 104

PostPosted: Fri Apr 22, 2005 8:05 pm    Post subject: Reply with quote

I recently setup OX and had everything working fine. Then I decided to change the domainname, so I went through all the config files and reentered the new domain name. I also did a rm /var/lib/openldap-data/* and rebuilt OX. You'd think that would have been enough for ldap to forget that the old domain ever existed, but when I created a new user and logged in as that user under the new domainname and then clicked the Setup link to make changes to the user information I got:

Quote:
Sorry,

Details:
Access Denied!


Taking a look at the ldap log, I see:

Code:
Apr 22 15:51:32 max slapd[5835]: conn=37 fd=12 ACCEPT from IP=127.0.0.1:1254 (IP=0.0.0.0:389)
Apr 22 15:51:32 max slapd[6165]: conn=37 op=0 BIND dn="uid=xxxxx,ou=Users,ou=OxObjects,dc=olddomainname,dc=com" method=128
Apr 22 15:51:32 max slapd[6165]: conn=37 op=0 RESULT tag=97 err=49 text=
Apr 22 15:51:32 max slapd[5835]: conn=37 fd=12 closed


So, although I basically purged the olddomainname from ldap, it's still appearing in the logs and preventing me from accessing the user's info in OX.

I'm hoping someone might have a suggestions in this matter.
Back to top
View user's profile Send private message
feliperal
Apprentice
Apprentice


Joined: 09 Mar 2003
Posts: 168

PostPosted: Sat Apr 23, 2005 4:08 am    Post subject: Reply with quote

bitwh0re wrote:
pneum0nia wrote:
I am having emerge failures of mod_jk2-2.0.4 on apache-2.0.54 and noticed this on bugfix that noted that mod_jk2 is no longer supported and mod_jk is being backported and supported. Is there any reason why I wouln't be able to implement mod_jk instead of mod_jk2 in my OX installation?


I think that mod_jk is for Apache 1.3 and mod_jk2 is for Apache 2.0. JK2 will be integrated as of Apache 2.1 which is currenly in Alpha. You can reference the older instructions which used a JK2 binary here:

http://www.mikefetherston.ca/OX/html/index.html

Look in the section titled "Configure Apache for Tomcat"


I tried downloading the fedorcore 1 binary. Unfortunately, apache2 is complaining that it cannot load or open shared libary mod_jk2.so from /usr/lib/modules/ .

I'm trying to run the i386 binary on my x86_64 machine. I have multilib in my USE flags, so I do not know why it won't load the module.

Anyways, apache2 functionaly is present in mod_jk and I was able tocompile and install it with no problem. The only thing now is to incorporate the config settings in workers2.properties to their correct equivalents for mod_jk. I'll try to get it running this weekend and post my findings.

Felipe
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Sat Apr 23, 2005 11:37 pm    Post subject: OX 8.0 is released Reply with quote

Works realy fine thanks to the documentation.

Thanks again =)
Back to top
View user's profile Send private message
ferp2
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2002
Posts: 104

PostPosted: Sun Apr 24, 2005 3:27 pm    Post subject: correctfilespool Reply with quote

One of the steps in the howto is to setup directories in the filespool directory using the command:

Quote:
sh /usr/local/open-xchange/sbin/correctfilespool


Now in older versions of OX, you entered the above command and then were told to be patient while the directories were being set up. When I came to doing this step on the latest version (open-xchange-0.8.0-0), instead of the usual message to be patient, I got the following:

Quote:
chmod: cannot access `/usr/local/open-xchange/var/filespool/00': No such file or directory
chmod: cannot access `/usr/local/open-xchange/var/filespool/00/00': No such file or directory
chmod: cannot access `/usr/local/open-xchange/var/filespool/00/01': No such file or directory
chmod: cannot access `/usr/local/open-xchange/var/filespool/00/02': No such file or directory
chmod: cannot access `/usr/local/open-xchange/var/filespool/00/03': No such file or directory
chmod: cannot access `/usr/local/open-xchange/var/filespool/00/04': No such file or directory
etc...


Thinking I had made a mistake, I reinstalled OX only to get the same message. Next I wrote to the OX user group describing the problem. I was told the following by one of the developers:

Quote:
the filespool will be created if needed. You do not need to run
./correctfilespool while the installation ...


So, either this step has become obsolete in the lastest version of OX, or it was never necessary to manually run this bash script in the first place -- I don't know. In any case you don't have to run the correctfilespool script to get a functioning OX system.
Back to top
View user's profile Send private message
)(MarksTheSpot
n00b
n00b


Joined: 20 Jan 2005
Posts: 16
Location: Bristol, UK

PostPosted: Mon Apr 25, 2005 7:20 am    Post subject: Unable to authentificate user at the imap server. Reply with quote

All,

I've got it all up and runnging and when I log into groupware, it looks great but I can't create anything.

I also get the following in webmail.log:

Code:

Unable to authentificate user at the imap server.


Can anyone help with why I might have this error?

I'm gonna try and upgrade to 8.0 final today and see if that works, but if anyone can help in the mean time, that would be great.

Thanks,

)(marks
_________________
---------------------------------------
"Quis custodiet ipsos custodes?"
---------------------------------------
Back to top
View user's profile Send private message
inTIMidate
n00b
n00b


Joined: 25 Apr 2005
Posts: 4

PostPosted: Mon Apr 25, 2005 2:15 pm    Post subject: Reply with quote

when i do the following:
Code:

./configure --enable-webdav \
--with-mailjar=/usr/share/sun-javamail-bin/lib/mail.jar \
--with-activationjar=/usr/share/sun-jaf-bin/lib/activation.jar \
--with-jdomjar=/usr/share/jdom-1.0_beta10/lib/jdom.jar \
--with-xercesjar=/usr/share/xerces-2/lib/xercesImpl.jar \
--with-jsdkjar=/opt/tomcat5/common/lib/servlet-api.jar \
--with-jdbcjar=/usr/share/jdbc3-postgresql-1/lib/pg73jdbc3.jar \
--with-dbname=openexchange \
--with-dbuser=open-xchange \
--with-dbpass=oxen \
--with-runuid=apache \
--with-servletdir=/opt/tomcat5/webapps/servlet/ \
--with-htdocsdir=/var/www/localhost/htdocs/ \
--with-cgibindir=/var/www/localhost/cgi-bin/ \
--with-jni-dir=/opt/sun-jdk-1.4.2.08/include/ \
--with-openssl-dir=/usr/include/


i receive this error:
Code:

configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
/root/open-xchange-0.8.0-0/config/missing: Unknown `--run' option
Try `/root/open-xchange-0.8.0-0/config/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make sets $(MAKE)... (cached) yes
checking for a BSD-compatible install... /bin/install -c
checking for java... /opt/sun-jdk-1.4.2.08/bin/java
checking for jikes... /opt/sun-jdk-1.4.2.08/bin/javac
checking for jar... /opt/sun-jdk-1.4.2.08/bin/jar
checking for ant... /usr/bin/ant
checking for javah... /opt/sun-jdk-1.4.2.08/bin/javah
checking for sudo... /usr/bin/sudo
checking for -gcc... no
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking build system type... config.sub: missing argument
Try `config.sub --help' for more information.
configure: error: /bin/sh config/config.sub failed
./tim: line 2: --with-mailjar=/usr/share/sun-javamail-bin/lib/mail.jar: No such file or directory
./tim: line 3: --with-activationjar=/usr/share/sun-jaf-bin/lib/activation.jar: No such file or directory
./tim: line 4: --with-jdomjar=/usr/share/jdom-1.0_beta10/lib/jdom.jar: No such file or directory
./tim: line 5: --with-xercesjar=/usr/share/xerces-2/lib/xercesImpl.jar: No such file or directory
./tim: line 6: --with-jsdkjar=/opt/tomcat5/common/lib/servlet-api.jar: No such file or directory
./tim: line 7: --with-jdbcjar=/usr/share/jdbc3-postgresql-1/lib/pg73jdbc3.jar: No such file or directory
./tim: line 8: --with-dbname=openexchange: command not found
./tim: line 9: --with-dbuser=open-xchange: command not found
./tim: line 10: --with-dbpass=oxen: command not found
./tim: line 11: --with-runuid=apache: command not found
./tim: line 12: --with-servletdir=/opt/tomcat5/webapps/servlet/: No such file or directory
./tim: line 13: --with-htdocsdir=/var/www/localhost/htdocs/: No such file or directory
./tim: line 14: --with-cgibindir=/var/www/localhost/cgi-bin/: No such file or directory
./tim: line 15: --with-jni-dir=/opt/sun-jdk-1.4.2.08/include/: No such file or directory
./tim: line 16: --with-openssl-dir=/usr/include/: No such file or directory


Anyone know a solution?

Could the mod_jk2 be the problem? because mod_jk2 isnt available anymore only mod_jk which is also masked.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Mon Apr 25, 2005 2:43 pm    Post subject: Reply with quote

inTIMidate wrote:

configure: error: /bin/sh config/config.sub failed
./tim: line 2: --with-mailjar=/usr/share/sun-javamail-bin/lib/mail.jar: No such file or directory
./tim: line 3: --with-activationjar=/usr/share/sun-jaf-bin/lib/activation.jar: No such file or directory
./tim: line 4: --with-jdomjar=/usr/share/jdom-1.0_beta10/lib/jdom.jar: No such file or directory
./tim: line 5: --with-xercesjar=/usr/share/xerces-2/lib/xercesImpl.jar: No such file or directory
./tim: line 6: --with-jsdkjar=/opt/tomcat5/common/lib/servlet-api.jar: No such file or directory
./tim: line 7: --with-jdbcjar=/usr/share/jdbc3-postgresql-1/lib/pg73jdbc3.jar: No such file or directory
./tim: line 8: --with-dbname=openexchange: command not found
./tim: line 9: --with-dbuser=open-xchange: command not found
./tim: line 10: --with-dbpass=oxen: command not found
./tim: line 11: --with-runuid=apache: command not found
./tim: line 12: --with-servletdir=/opt/tomcat5/webapps/servlet/: No such file or directory
./tim: line 13: --with-htdocsdir=/var/www/localhost/htdocs/: No such file or directory
./tim: line 14: --with-cgibindir=/var/www/localhost/cgi-bin/: No such file or directory
./tim: line 15: --with-jni-dir=/opt/sun-jdk-1.4.2.08/include/: No such file or directory
./tim: line 16: --with-openssl-dir=/usr/include/: No such file or directory
[/code]

Could the mod_jk2 be the problem? because mod_jk2 isnt available anymore only mod_jk which is also masked.


No, I don't think that mod_jk2 is the source of the problems here.. it really isn't coming into play for the ./configure for Open-Xchange. It appears to me that the ./configure script cannot find the files in the location that you've specified. Are you possibly doing this as non-root? Can you verify that these files exist in these locations as the user you're performing the ./configure as?

I'll be updating the HOWTO to use mod_jk and 2005.0. It appears I misspoke earlier when I said that mod_jk is for Apache 1.3 and mod_jk2 is for Apache 2.0. mod_jk will work fine for Apache 2.0.. there's even official documentation from the Apache Project covering this and a Gentoo Forums topic as well.
Back to top
View user's profile Send private message
Hibbelharry
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 88
Location: Bremen, Northern Germany

PostPosted: Mon Apr 25, 2005 2:58 pm    Post subject: Re: correctfilespool Reply with quote

[quote="ferp2"]One of the steps in the howto is to setup directories in the filespool directory using the command:

Quote:
sh /usr/local/open-xchange/sbin/correctfilespool


since OX 0.8 this command is obsolete,files and directories are created on the fly with right permissions when needed. if you're upgrading you should just make sure every already existing file should have the right owner.

bitwhore wrote

mod_jk is for apache 1.3 and mod_jk2 is for apache 2.0. this is apparently wrong. both, mod_jk and mod_jk2 work on apache 2.0. mod_jk2 is deprecated and unsupported. mod_jk ist actively maintained and lots of code from mod_jk2 has been backported to mod_jk.
apache 2.1 will have a successor for both beeing built in, which should work nearly similar to mod_jk (not mod_jk2) as far as apache mailinglists predict.

i'm currently using mod_jk successful, just having some webdav issues which i'm currently tracing, think they're not related to mod_jk. web frontends work beautiful and webdav.documents too.

Greetz
Hibbelharry
Back to top
View user's profile Send private message
inTIMidate
n00b
n00b


Joined: 25 Apr 2005
Posts: 4

PostPosted: Tue Apr 26, 2005 8:09 am    Post subject: Reply with quote

Problem is fixed.

The --with-jsdkjar=/ value was wrong.
Back to top
View user's profile Send private message
inTIMidate
n00b
n00b


Joined: 25 Apr 2005
Posts: 4

PostPosted: Tue Apr 26, 2005 11:41 am    Post subject: Reply with quote

Im currently stuck at the point where i have to configure apache2 for tomcat and i want to get apache2 to work with mod_jk not mod_jk2.

There seems to be somthing wrong with the mod_jk file.
Code:
# /etc/init.d/apache2 start     
* Apache2 has detected a syntax error in your configuration files:
Syntax error on line 1 of /usr/lib/apache2/conf/modules.d/mod_jk.conf:
Cannot load /usr/lib/apache2/extramodules/mod_jk.so into server: /usr/lib/apache2/extramodules/mod_jk.so: undefined symbol: ap_null_cleanup


File: /usr/lib/apache2/conf/modules.d/mod_jk.conf
Code:
LoadModule jk2_module extramodules/mod_jk.so
JkSet config.file /etc/apache2/conf/workers2.properties


File: /etc/apache2/conf/workers2.properties
Code:

[logger]
info=Native Logger
level=ERROR

[shm]
info=Scoreboard. Requried for reconfiguration and status with multiprocess servers.
file=anon

# Defines a load balancer named lb. Use even if you only have one machine.
[lb:lb]

[channel.socket:localhost:8009]
port=8009
host=127.0.0.1

# define the worker
[ajp13:localhost:8009]
channel=channel.socket:localhost:8009
group=lb

[status:]
info=Status worker, displays runtime information

[uri:/servlet/*]
worker=ajp13:localhost:8009


Portage doesnt seem to support mo'd_jk2 anymore. So who has the solution for this problem?
Back to top
View user's profile Send private message
les.piggot
n00b
n00b


Joined: 15 Oct 2003
Posts: 15

PostPosted: Tue Apr 26, 2005 1:12 pm    Post subject: Reply with quote

Hi InTIMidate,

Look further up the page, Bitwhore thought that mod_jk is for Apache 1.3 and mod_jk2 is for Apache 2.0. JK2 will be integrated as of Apache 2.1 which is currenly in Alpha. You can reference the older instructions which used a JK2 binary here:

http://www.mikefetherston.ca/OX/html/index.html

Look in the section titled "Configure Apache for Tomcat"

Les
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Apr 26, 2005 1:27 pm    Post subject: Reply with quote

les.piggot wrote:

Look further up the page, Bitwhore thought that mod_jk is for Apache 1.3 and mod_jk2 is for Apache 2.0. JK2 will be integrated as of Apache 2.1 which is currenly in Alpha. You can reference the older instructions which used a JK2 binary here:

http://www.mikefetherston.ca/OX/html/index.html

Look in the section titled "Configure Apache for Tomcat"


I will be reworking the HOWTO for mod_jk, and then again for whatever Apache dreams up with 2.1. For now, yeah, use the old instructions for the binary.
Back to top
View user's profile Send private message
kblack
n00b
n00b


Joined: 12 Nov 2004
Posts: 9

PostPosted: Wed Apr 27, 2005 4:11 am    Post subject: Reply with quote

So what has been the easiest way to get OX to start on boot?
Back to top
View user's profile Send private message
les.piggot
n00b
n00b


Joined: 15 Oct 2003
Posts: 15

PostPosted: Wed Apr 27, 2005 7:09 am    Post subject: Reply with quote

kblack:

Copy the openxchange startup script from /usr/local/open-xchange/etc/init.d/openexchange to /etc/init.d

then to automatically start openexchange during the boot process run: rc-update add openexchange default

Les
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Apr 27, 2005 1:13 pm    Post subject: Reply with quote

bitwh0re wrote:
KirinSan wrote:
Hey again,

well...i tried to add different folders..even with ox, but i can't.

When I create a user for cyrus with cm user.Test the only folder, which is created is the inbox.

Normally it should create folders like drafts, sent and so on, or?


Yes, 0.7.5 *used* to do this upon first logon but it doesn't appear that OX 0.8 does. Here is a script you can use:

http://www.open-xchange.org/cgi-bin/simpleforum.cgi?fid=01&topic_id=1097702474

Mike


Forget that.. use this instead:

http://www.open-xchange.org/cgi-bin/simpleforum.cgi?fid=01&topic_id=1114003156

Quote:
since OX 0.8-x it's configureable and disabled by default. check the webmail.properties for the option: user.default.folder.autocreate=false
Back to top
View user's profile Send private message
killercow
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2004
Posts: 86
Location: Netherlands

PostPosted: Wed Apr 27, 2005 2:04 pm    Post subject: Reply with quote

Hmfgz,

Since my last atempt to get Ox working as it should (including webmail) didn;t work as expected i tried to redo the entire install with 0.8 final.

I reran all of the steps, and removed the databases where needed,. but not i get an error on make for openexchange.

./configure works perfectly.
make gives me a lot of this java error's and then:
Code:

............essfully compile.


    [javac]    393.                         descr = new Element("responsedescription", "D", "DAV:");
    [javac]                                             ^-----^
    [javac] *** Semantic Error: A candidate for type "Element" was found, but it is invalid and needs to be fixed before this type will successfully compile.

    [javac] Issued 1 semantic warning compiling "/root/open-xchange-0.8.0-0/src/com/openexchange/webdav/vcard.java":

    [javac]    159.                 String user = null;
    [javac]                                ^--^
    [javac] *** Semantic Warning: Local "user" shadows a field of the same name in "com.openexchange.tools.webdav.OXServlet".

BUILD FAILED
/root/open-xchange-0.8.0-0/build.xml:57: Compile failed; see the compiler error output for details.

Total time: 11 seconds
make[1]: *** [java] Error 1
make[1]: Leaving directory `/root/open-xchange-0.8.0-0/javabuild'
make: *** [all-recursive] Error 1


Any clues?

my configure command is as follows:
Code:

./configure --enable-webdav --with-mailjar=/usr/share/sun-javamail-bin/lib/mail.jar --with-activationjar=/usr/share/sun-jaf-bin/lib/activation.jar --with-jdomjar=/usr/share/jdom/lib/jdom.jar --with-xercesjar=/usr/share/xerces-2/lib/xercesImpl.jar --with-jsdkjar=/opt/tomcat5/common/lib/servlet-api.jar --with-jdbcjar=/usr/share/jdbc3-postgresql/lib/jdbc3-postgresql.jar --with-dbname=openexchange --with-dbuser=open-xchange --with-dbpass=oxen --with-runuid=apache --with-servletdir=/opt/tomcat5/webapps/servlet/ --with-htdocsdir=/var/www/localhost/htdocs/ --with-cgibindir=/var/www/localhost/cgi-bin/ --with-jni-dir=/opt/sun-jdk-1.4.2.08/include/ --with-openssl-dir=/usr/include/
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Apr 27, 2005 3:01 pm    Post subject: Reply with quote

Latest HOWTO (v0.23) released. Major change this time is the move from mod_jk2 to mod_jk.

http://www.mikefetherston.ca/OX/html/index.html

This HOWTO has been based on a completely fresh install of 2005.0 from Stage 1 using "x86" using Open-Xchange 0.8. The system you choose to install Open-Xchange on should match this as closely as possible, if not there may be some breakage or "things just don't work" type of situations.

Let me know how things go and, good luck to all!!

Mike.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Apr 27, 2005 3:09 pm    Post subject: Reply with quote

killercow wrote:

/root/open-xchange-0.8.0-0/build.xml:57: Compile failed; see the compiler error output for details.

Total time: 11 seconds
make[1]: *** [java] Error 1
make[1]: Leaving directory `/root/open-xchange-0.8.0-0/javabuild'
make: *** [all-recursive] Error 1
[/code]

Any clues?

my configure command is as follows:
Code:

./configure --enable-webdav --with-mailjar=/usr/share/sun-javamail-bin/lib/mail.jar --with-activationjar=/usr/share/sun-jaf-bin/lib/activation.jar --with-jdomjar=/usr/share/jdom/lib/jdom.jar --with-xercesjar=/usr/share/xerces-2/lib/xercesImpl.jar --with-jsdkjar=/opt/tomcat5/common/lib/servlet-api.jar --with-jdbcjar=/usr/share/jdbc3-postgresql/lib/jdbc3-postgresql.jar --with-dbname=openexchange --with-dbuser=open-xchange --with-dbpass=oxen --with-runuid=apache --with-servletdir=/opt/tomcat5/webapps/servlet/ --with-htdocsdir=/var/www/localhost/htdocs/ --with-cgibindir=/var/www/localhost/cgi-bin/ --with-jni-dir=/opt/sun-jdk-1.4.2.08/include/ --with-openssl-dir=/usr/include/


It appears that it's failing on the webdav compile section:

Code:
file:  build.xml

56:        <target name="compilewebdav" depends="init">
57:                <javac srcdir="${srcdir}" destdir="${builddir}" debug="on" optimize="off" encoding="ISO8859-1">
58:                        <classpath>
59:                                <pathelement location="/opt/tomcat5/common/lib/servlet-api.jar"/>
60:                                <pathelement location="/usr/share/jdbc3-postgresql/lib/jdbc3-postgresql.jar"/>
61:                                <pathelement location="/usr/share/sun-javamail-bin/lib/mail.jar"/>
62:                                <pathelement location="/usr/share/sun-jaf-bin/lib/activation.jar"/>
63:                                <pathelement location="/usr/share/jdom-1.0_beta10/lib/jdom.jar"/>
64:                        </classpath>
65:                </javac>
66:        </target>


You can try temporarily disabling webdav, or verify the locations of the files in the <pathelement> lines above (those are mine). I noticed that your jdom directory is a bit different than what portage installs.
Back to top
View user's profile Send private message
killercow
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2004
Posts: 86
Location: Netherlands

PostPosted: Thu Apr 28, 2005 8:01 am    Post subject: Reply with quote

BitW0re,

Thanks!
That did the trick, i copied your configure statement (as stated in the manual) as i hought you used the default settings.
Maybe you should use the default options everywhere so people can indeed blindly copy the commands from the manual. (i did so becuase i had some trouble with typo's while reading them from the PDF the last time.)
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Apr 28, 2005 12:24 pm    Post subject: Reply with quote

killercow wrote:
Thanks!
That did the trick, i copied your configure statement (as stated in the manual) as i hought you used the default settings.
Maybe you should use the default options everywhere so people can indeed blindly copy the commands from the manual. (i did so becuase i had some trouble with typo's while reading them from the PDF the last time.)

You're welcome killercow!

That was the default location for JDOM when v0.20 of the HOWTO was out. Since then the latest stable version of JDOM was bumped and there were some path changes from /usr/share/jdom to /usr/share/jdom-1.0_beta10. When 5.0.28 of Tomcat hits x86 I'm expecting it's path to change as well.

Check out the latest HOWTO, I just finished it and it works well with OX v0.8!
Back to top
View user's profile Send private message
feliperal
Apprentice
Apprentice


Joined: 09 Mar 2003
Posts: 168

PostPosted: Thu Apr 28, 2005 2:04 pm    Post subject: Reply with quote

bitwh0re wrote:
killercow wrote:
Thanks!
That did the trick, i copied your configure statement (as stated in the manual) as i hought you used the default settings.
Maybe you should use the default options everywhere so people can indeed blindly copy the commands from the manual. (i did so becuase i had some trouble with typo's while reading them from the PDF the last time.)

You're welcome killercow!

That was the default location for JDOM when v0.20 of the HOWTO was out. Since then the latest stable version of JDOM was bumped and there were some path changes from /usr/share/jdom to /usr/share/jdom-1.0_beta10. When 5.0.28 of Tomcat hits x86 I'm expecting it's path to change as well.

Check out the latest HOWTO, I just finished it and it works well with OX v0.8!


Yes the path moved from /opt/tomcat5 to /usr/share/tomcat-5. I tried running open-xchange with the newest tomcat and I get a sessionID error that complains about no socet being available. :( Also, you will get a log4j error when starting the newest tomcat in portage.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Apr 28, 2005 2:40 pm    Post subject: Reply with quote

feliperal wrote:
bitwh0re wrote:

That was the default location for JDOM when v0.20 of the HOWTO was out. Since then the latest stable version of JDOM was bumped and there were some path changes from /usr/share/jdom to /usr/share/jdom-1.0_beta10. When 5.0.28 of Tomcat hits x86 I'm expecting it's path to change as well.


Yes the path moved from /opt/tomcat5 to /usr/share/tomcat-5. I tried running open-xchange with the newest tomcat and I get a sessionID error that complains about no socet being available. :( Also, you will get a log4j error when starting the newest tomcat in portage.


Yup, you're right! And the last time I tried Tomcat 5.0.28 out of ~x86 it really did not work at all.
Back to top
View user's profile Send private message
lxnay
Retired Dev
Retired Dev


Joined: 09 Apr 2004
Posts: 661
Location: Italy

PostPosted: Thu Apr 28, 2005 9:33 pm    Post subject: Reply with quote

I've some problems. I've updated OX to 0.8.0 and I'd like to use Calendar via Kontact using WebDAV. I can read the file http://localhost/servlet/webdav.ical but I can't write back the changes:

here's some logs:

catalina:
Code:
ERROR: ICalWriter.build: java.lang.NullPointerException
java.lang.NullPointerException
   at com.openexchange.tools.ical.ICalWriter.output(ICalWriter.java:89)
   at com.openexchange.tools.ical.ICalWriter.output(ICalWriter.java:82)
   at com.openexchange.webdav.ical.doGet(ical.java:140)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
   at com.openexchange.tools.webdav.WebDavServlet.service(WebDavServlet.java:150)
   at com.openexchange.tools.webdav.OXServlet.service(OXServlet.java:330)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
   at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
   at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
   at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
   at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
   at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
   at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
   at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
   at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
   at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
   at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
   at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
   at java.lang.Thread.run(Thread.java:534)
org.postgresql.util.PSQLException: ERROR: la colonna "fid" non esiste

   at org.postgresql.util.PSQLException.parseServerError(PSQLException.java:139)
   at org.postgresql.core.QueryExecutor.executeV3(QueryExecutor.java:152)
   at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java:100)
   at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java:43)
   at org.postgresql.jdbc1.AbstractJdbc1Statement.execute(AbstractJdbc1Statement.java:517)
   at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:50)
   at org.postgresql.jdbc1.AbstractJdbc1Statement.executeQuery(AbstractJdbc1Statement.java:233)
   at com.openexchange.api.OXSqlObject.getNext(OXSqlObject.java:231)
   at com.openexchange.webdav.ical.createVEVENT(ical.java:289)
   at com.openexchange.webdav.ical.doGet(ical.java:132)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
   at com.openexchange.tools.webdav.WebDavServlet.service(WebDavServlet.java:150)
   at com.openexchange.tools.webdav.OXServlet.service(OXServlet.java:330)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
   at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
   at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
   at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
   at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
   at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
   at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
   at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
   at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
   at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
   at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
   at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
   at java.lang.Thread.run(Thread.java:534)
org.postgresql.util.PSQLException: ERROR: la colonna "fid" non esiste

   at org.postgresql.util.PSQLException.parseServerError(PSQLException.java:139)
   at org.postgresql.core.QueryExecutor.executeV3(QueryExecutor.java:152)
   at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java:100)
   at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java:43)
   at org.postgresql.jdbc1.AbstractJdbc1Statement.execute(AbstractJdbc1Statement.java:517)
   at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:50)
   at org.postgresql.jdbc1.AbstractJdbc1Statement.executeQuery(AbstractJdbc1Statement.java:233)
   at com.openexchange.api.OXSqlObject.getNext(OXSqlObject.java:231)
   at com.openexchange.webdav.ical.createVTODO(ical.java:306)
   at com.openexchange.webdav.ical.doGet(ical.java:136)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
   at com.openexchange.tools.webdav.WebDavServlet.service(WebDavServlet.java:150)
   at com.openexchange.tools.webdav.OXServlet.service(OXServlet.java:330)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
   at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
   at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
   at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
   at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
   at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
   at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
   at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
   at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
   at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
   at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
   at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
   at java.lang.Thread.run(Thread.java:534)
ERROR: ICalWriter.build: java.lang.NullPointerException
java.lang.NullPointerException
   at com.openexchange.tools.ical.ICalWriter.output(ICalWriter.java:89)
   at com.openexchange.tools.ical.ICalWriter.output(ICalWriter.java:82)
   at com.openexchange.webdav.ical.doGet(ical.java:140)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
   at com.openexchange.tools.webdav.WebDavServlet.service(WebDavServlet.java:150)
   at com.openexchange.tools.webdav.OXServlet.service(OXServlet.java:330)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
   at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
   at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
   at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
   at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
   at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
   at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
   at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
   at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
   at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
   at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
   at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
   at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
   at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
   at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
   at java.lang.Thread.run(Thread.java:534)


There's "fid" column problem and wedav write file problem.
_________________
http://www.sabayon.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 25, 26, 27 ... 37, 38, 39  Next
Page 26 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum