Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 26, 27, 28 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
killercow
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2004
Posts: 86
Location: Netherlands

PostPosted: Fri Apr 29, 2005 9:47 am    Post subject: Reply with quote

I managed to get everything up and running, but there are two last problems.

My webdav doesn't do much. webdav.ical gives me a prompt and when i enter my data i get an error stating that my user doesn't belong to any groups.
If i connect to webdav.documents i get the following error:

Code:

javax.servlet.ServletException: Can't access the filespool: Permission denied
   com.openexchange.webdav.documents.oxinit(documents.java:122)
   com.openexchange.tools.webdav.OXServlet.init(OXServlet.java:136)
   org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
   org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
   org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
   org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
   org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
   org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
   org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
   org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
   java.lang.Thread.run(Thread.java:534)


Could this be because the shellscript creating the filespool didn't do anything? (all the chmod's gave me file not found errors)

And there's a last question:
How can i share my contacts database with my co-workers?
Have they disabled this in 0.8? (as we would like to share "parts" of our contacts databases with each other.)
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Apr 29, 2005 1:25 pm    Post subject: Reply with quote

lxnay wrote:
I've some problems. I've updated OX to 0.8.0 and I'd like to use Calendar via Kontact using WebDAV. I can read the file http://localhost/servlet/webdav.ical but I can't write back the changes:

There's "fid" column problem and wedav write file problem.


What version are you upgrading from?
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Apr 29, 2005 1:26 pm    Post subject: Reply with quote

killercow wrote:
I managed to get everything up and running, but there are two last problems.

My webdav doesn't do much. webdav.ical gives me a prompt and when i enter my data i get an error stating that my user doesn't belong to any groups.
If i connect to webdav.documents i get the following error:

Code:

javax.servlet.ServletException: Can't access the filespool: Permission denied
   com.openexchange.webdav.documents.oxinit(documents.java:122)
   com.openexchange.tools.webdav.OXServlet.init(OXServlet.java:136)
   org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
   org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
   org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
   org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
   org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
   org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
   org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
   org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
   java.lang.Thread.run(Thread.java:534)


Could this be because the shellscript creating the filespool didn't do anything? (all the chmod's gave me file not found errors)

And there's a last question:
How can i share my contacts database with my co-workers?
Have they disabled this in 0.8? (as we would like to share "parts" of our contacts databases with each other.)


Can you access your documents from the web interface, or does that fail as well?

For your contacts, I'm sure you can by connecting to the LDAP server to access your contacts. You may have to tinker with the ACL's on your LDAP tree.
Back to top
View user's profile Send private message
killercow
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2004
Posts: 86
Location: Netherlands

PostPosted: Fri Apr 29, 2005 2:25 pm    Post subject: Reply with quote

bitwh0re wrote:

Can you access your documents from the web interface, or does that fail as well?

For your contacts, I'm sure you can by connecting to the LDAP server to access your contacts. You may have to tinker with the ACL's on your LDAP tree.


Nope, even uploading a files gives me problems.
- An error ocurred saving the documents to the database
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Fri Apr 29, 2005 3:38 pm    Post subject: Reply with quote

killercow wrote:
bitwh0re wrote:

Can you access your documents from the web interface, or does that fail as well?

For your contacts, I'm sure you can by connecting to the LDAP server to access your contacts. You may have to tinker with the ACL's on your LDAP tree.


Nope, even uploading a files gives me problems.
- An error ocurred saving the documents to the database


It seems by the above trace that OX is having trouble accessing your filespool due to a permissions problem. Here is what my filespool looks like:

Code:
/usr/local/open-xchange/var

drwxr-xr-x   2 tomcat nogroup  72 Apr 27 08:50 filespool


Code:
/usr/local/open-xchange/var/filespool

ox filespool # ls -al
total 4
drwxr-xr-x  3 tomcat nogroup  96 Apr 29 06:38 .
drwxr-xr-x  8 root   root    216 Apr 27 08:50 ..
drwxr-xr-x  3 tomcat tomcat   72 Apr 29 06:38 00
-rw-r--r--  1 tomcat tomcat   15 Apr 29 06:38 state


HTH,

Mike.
Back to top
View user's profile Send private message
Tanisete
Guru
Guru


Joined: 12 Mar 2004
Posts: 312

PostPosted: Fri Apr 29, 2005 11:07 pm    Post subject: Reply with quote

Hi to all!!

I've spent hours with the tutorials, forums, and all, and i'm unable to make this work... I have a few problems right now:

- First, i can't connect with cyrus imap server. I only have imapd server (no port 143, and 993 is ok). So that, i cannot add a user with cyrusadmin. My cyrus.conf is:

Code:
SERVICES {
  # Add or remove based on preferences.
  imap          cmd="imapd" listen="imap2" prefork=0
  pop3          cmd="pop3d" listen="pop-3" prefork=0

  imaps         cmd="imapd -s" listen="imaps" prefork=0
  pop3s         cmd="pop3d -s" listen="pop3s" prefork=0

  # Don't forget to generate the needed keys for SSL or TLS
  # (see doc/html/install-configure.html).
  #imaps                cmd="imapd -s" listen="imaps" prefork=0
  #pop3s                cmd="pop3d -s" listen="pop3s" prefork=0

  sieve         cmd="timsieved" listen="sieve" prefork=0
 


EDIT: OK, Forget this one... i think i'm a bit obscure right now... The important one is the ldap one.

- Second, i had a strange error with LDAP,
[/code]
Apr 29 22:06:18 krynn slapd[17789]: conn=5 op=0 RESULT tag=97 err=0 text=
Apr 29 22:06:18 krynn slapd[17789]: conn=5 op=1 ADD dn="uid=inmi,ou=Users,ou=OxObjects,dc=ox-domain,dc=tld"
Apr 29 22:06:18 krynn slapd[17789]: conn=5 op=1 RESULT tag=105 err=80 text=entry store failed
Apr 29 22:06:18 krynn slapd[17789]: conn=5 op=1 RESULT tag=105 err=80 text=entry store failed
Code:


so i had to follow some instructions i found in the german forum of open-xchange (with altavista :D ):

Code:
/etc/init.d/slapd stop
rm /var/lib/openldap-data/*
slapadd –l /usr/local/open-xchange/share/init_ldap.ldif
/etc/init.d/slapd start


But now, i can only start the ldap daemon manually!!! The daemon doesn't start with the default gentoo script...

Can anyone give me a clue or help me?

Thanks a lot!!!!
Back to top
View user's profile Send private message
Tanisete
Guru
Guru


Joined: 12 Mar 2004
Posts: 312

PostPosted: Sat Apr 30, 2005 12:00 pm    Post subject: Reply with quote

Ok, i got it running after all...

But i'm having strange problems ritgh now.
I also have kde installed, but when i start all the services that run with openxchange, kde failts with rpc timeout... is something interferring? do they share any kind of socket? I can't understand why this happens...

Thanks in advance!!!
Back to top
View user's profile Send private message
feliperal
Apprentice
Apprentice


Joined: 09 Mar 2003
Posts: 168

PostPosted: Sun May 01, 2005 3:35 pm    Post subject: Reply with quote

Bitwhore, your guide is well written, and a pleasure to read. Just a few suggestions.

In the first part, where you are configuring the /etc/hosts file, I would set it like this:
Code:

12.34.56.78 ox-domain.tld ox-domain


I had to do it this way in order to properly resolve when running hostname -f or starting the /etc/init.d/postfix service. Postfix will not start without doing the above.

Second, you should give execute permissions to the openexchange init.d file we created init /etc/init.d/
Code:

chmod u+x /etc/init.d/openexchange
env-update
rc-update add openexchange default
/etc/init.d/openexchange start


Now, to my problem. I was able to create a user using the open-xchange adduser utility. Unfortunately, when I try to login, I'm getting a Authentication Failed error:
Code:

May 01 08:00:33 localhost openexchange: oxsessiond init (localhost:33333)
May 01 08:00:33 localhost openexchange: INTERNAL TLS Support: OFF
May 01 08:02:41 localhost openexchange: ERROR: Authentification failed
May 01 08:04:57 localhost openexchange: ERROR: Authentification failed
May 01 08:05:09 localhost openexchange: ERROR: Authentification failed
May 01 08:19:36 localhost openexchange: ERROR: Authentification failed       


I have checked my saslauthd.conf file and changed the
Code:
ldap_servers: ldap://ox-domain.tld:389/


to:
Code:

ldap_servers: ldap://localhost:389/


also, I made sure that the ldapsecret password was the same as in slapd.conf and in the /usr/local/open-xchange/share/admintools.conf.

Any help would be greately appreciated. I've been scratching my head and banging it against the wall for hours :(

Thanks,
Felipe
Back to top
View user's profile Send private message
Tanisete
Guru
Guru


Joined: 12 Mar 2004
Posts: 312

PostPosted: Sun May 01, 2005 9:42 pm    Post subject: Reply with quote

Hi again!!

Finally i got it working... thanks for the great tutorial mike! I would like also to add that, the package.use you provide is wrong in some package's name, like "oro", that is "jakarta-oro". Anyway, great!! I will read more to finish ssl support.
Back to top
View user's profile Send private message
inTIMidate
n00b
n00b


Joined: 25 Apr 2005
Posts: 4

PostPosted: Mon May 02, 2005 11:16 am    Post subject: Reply with quote

I think i almost got everything up and running, only groupware isn't functioning...

I can succesfully login to webmail and everything works.

I can succesfully login to groupware BUT i get a blank page

What could cause this problem?

groupware.log
Code:
May 02 17:06:11 localhost openexchange: getSession <c1e798295dc40ca159cacb8459ecf4d8>
May 02 17:06:11 localhost openexchange: dGltAXRlc3QBRU4BMTkyLjE2OC4wLjI3ATE5Mi4xNjguMC4yMQ==
May 02 17:06:11 linux_PC openexchange: Attribute "imapServer" not set in "uid=mailadmin,ou=Users,ou=OxObjects", using localhost!
May 02 17:06:11 linux_PC openexchange: Attribute "smtpServer" not set in "uid=mailadmin,ou=Users,ou=OxObjects", using localhost!
java.lang.NullPointerException
        at com.openexchange.groupware.ldap.DefaultUserGroupHandle.getForeSureName(DefaultUserGroupHandle.java:562)
        at com.openexchange.groupware.Management.onCheckUserAuth(Management.java:491)
        at com.openexchange.thread.ComfireThread.validateSession(ComfireThread.java:386)
        at com.openexchange.thread.ComfireThread.run(ComfireThread.java:158)
        at java.lang.Thread.run(Thread.java:534)
Back to top
View user's profile Send private message
Tanisete
Guru
Guru


Joined: 12 Mar 2004
Posts: 312

PostPosted: Mon May 02, 2005 2:58 pm    Post subject: Reply with quote

have you inited the ldap server? It seems that you missed something in the ldap config...
Revise this section in the tutorial:

http://www.mikefetherston.ca/OX/html/index.html#33

It may be related to a bad dc in slapd.conf...

I hope it helps!
Back to top
View user's profile Send private message
ferp2
Tux's lil' helper
Tux's lil' helper


Joined: 13 Aug 2002
Posts: 104

PostPosted: Mon May 02, 2005 8:34 pm    Post subject: Redirect to https Reply with quote

Hello,

I've set up OX on Gentoo using Mike's 0.22 howto and 2005.0. Everything is working except I can't get the mod_rewrite to work. In Mike's howtos he says the following about redirects:

Quote:
You may want to create a 302 or an HTML file with a META REFRESH to redirect the user to the HTTPS server.


Now I've done that by putting a file called index.html (containing a META REFRESH) in the DocumentRoot, which is /var/www/localhost/htdocs. As a result, now if you explicitly enter https://sub.domain.tld, Apache will redirect you to https://sub.domain.tld/cgi-bin/login.pl.

Most users, however, will not enter https://sub.domain.tld. They will enter sub.domain.tld. By default, the browser client will attach http://sub.domain.tld and then fetch the URL. In my case I get a 400 Bad Request Error, telling me the Apache server is not setup to serve pages on port 80, and that instead you'll have to go to port 443, since Apache has been set up with SSL. The 400 Bad Request Error page also conveniently provides a link to the https port, but since DNS is pointing to sub.domain.tld while server knows itself as domain.tld, the link leads to a dead end. Regardless, the way I would like things to be set up is as follows:

A user enters sub.domain.tld, which becomes http://sub.domain.tld. The Apache server, using mod_rewrite, redirects the user to https://sub.domain.tld/cgi-bin/login.pl, the OX login page.

Easy enough, you might say, but when I create the mod_rewrite code, either in commonapache.conf or a .htaccess file, it is ignored and I once again find myself on the 400 Bad Request Error page.

I have searched high and low for a solution. Init_zero has offered a solution using a virtual host, but the domain I've setup is not being virtually hosted, so this is not a solution for me. Since sub.domain.tld is the only domain hosted on the system, I should be able to put a .htaccess file in DocumentRoot, which is /var/www/localhost/htdocs, or I should be able to put the mod_rewrite code in commonapache.conf or one of the SSL conf files. Alas, no matter where I have put this code, the result is always for Apache to send me a 400 Bad Request Error page.

I would be ecstatic if someone could reproduce this persistent error. If you are so inclined, here's the mod_rewrite code for entering into a .htaccess or commonapache.conf

Code:
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^/(.*)$ https://ox.dfsarchitects.com/cgi-bin/login.pl/ [R]


Or some such variation.

Thanks
Back to top
View user's profile Send private message
carpman
Advocate
Advocate


Joined: 20 Jun 2002
Posts: 2202
Location: London - UK

PostPosted: Mon May 02, 2005 9:54 pm    Post subject: Reply with quote

hello, i have a problem configuring OX, during install i get:

Code:

jc_options: java not found at /opt/sun-jdk-1.4.2.07/bin/java or /opt/sun-jdk-1.4.2.07/jre/bin/java
Error: JAVA_HOME is not defined correctly.



I have updated from 07 to 08, if i run java-config -f i get:

Code:

smaart open-xchange-0.8.0-0 # java-config -f
smaart open-xchange-0.8.0-0 #


This does not change even if i do:

Code:

smaart open-xchange-0.8.0-0 # java-config -S sun-jdk-1.4.2.08
System Virtual Machine set
You may want to update your enviroment by running:
        "/usr/sbin/env-update && source /etc/profile"



Code:

smaart open-xchange-0.8.0-0 # java-config -L
[sun-jdk-1.4.2.08] "Sun JDK 1.4.2.08" (/etc/env.d/java/20sun-jdk-1.4.2.08)



Any ideas?

cheers
_________________
Work Station - 64bit
Gigabyte GA X48-DQ6 Core2duo E8400
8GB GSkill DDR2-1066
SATA Areca 1210 Raid
BFG OC2 8800 GTS 640mb
--------------------------------
Notebook
Samsung Q45 7100 4gb
Back to top
View user's profile Send private message
carpman
Advocate
Advocate


Joined: 20 Jun 2002
Posts: 2202
Location: London - UK

PostPosted: Tue May 03, 2005 8:15 am    Post subject: Reply with quote

Hello, ok run:

Code:

source /etc/profile


Now i get:

Code:

java-config -L
[sun-jdk-1.4.2.08] "Sun JDK 1.4.2.08" (/etc/env.d/java/20sun-jdk-1.4.2.08)



but still fails on compile, in compile config i have:

Code:

--with-jni-dir=/opt/sun-jdk-1.4.2.08/include/ \

_________________
Work Station - 64bit
Gigabyte GA X48-DQ6 Core2duo E8400
8GB GSkill DDR2-1066
SATA Areca 1210 Raid
BFG OC2 8800 GTS 640mb
--------------------------------
Notebook
Samsung Q45 7100 4gb
Back to top
View user's profile Send private message
killercow
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2004
Posts: 86
Location: Netherlands

PostPosted: Tue May 03, 2005 11:36 am    Post subject: Reply with quote

Changing the permissions to tomcat, changed some things.

I now get:
An error ocurred saving the documents to the database.

Any clues?
Back to top
View user's profile Send private message
Grokinator
n00b
n00b


Joined: 28 Apr 2005
Posts: 11

PostPosted: Tue May 03, 2005 7:12 pm    Post subject: Postfix Address Extensions w/Cyrus Fix Reply with quote

Hello Everyone.

I have been using Mike's HOWTO and reading from this thread, and I've managed to get pretty far in the setup of OX. I just wanted to add this bit of info to the thread:

I've been using the address extension delimiter through postfix. That is, when anyone sends an email to greg-<whatever> at mydomain_com, it goes to the email inbox of "greg". However, following this HOWTO, cyrus didn't recognize the <account>-<whatever> format. I changed the mailbox_transport setting in Postfix's main.cf and the cyrus setting in Postfix's master.cf as follows:

Changes to main.cf:
Code:

#mailbox_transport = lmtp:unix:/var/imap/socket/lmtp
mailbox_transport = cyrus


Fix the path to "deliver" in master.cf as follows:
Code:

  user=cyrus argv=/usr/lib/cyrus/deliver -e -r ${sender} -m ${extension} ${user}


Oh, I had to make sure I added "local_recipient_maps =" to main.cf. I'm not sure that was specified in the HOWTO or if I just missed it in there. That lets lookups work for users who only exist in LDAP (i.e. not local accounts).

Well, good luck to everyone.

Oh, if anyone reads this and happens to know of a way to export my maildir to the cyrus db, please PM me.

Thanks!

G
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu May 05, 2005 1:24 pm    Post subject: Reply with quote

New release of OX today. v0.80-1 is out!!
Back to top
View user's profile Send private message
rickvernam
Guru
Guru


Joined: 09 Jul 2004
Posts: 310

PostPosted: Thu May 05, 2005 5:17 pm    Post subject: Reply with quote

Okay, bare with me as I have never setup a mail server in my life.
I have been following the How-To religiously, but cannot get past the first functionality check: using postfix to send an email.
here is the log after I try to send an email:
Quote:

May 5 11:23:35 oxdomain postfix/smtpd[15324]: connect from unknown[192.168.2.120]
May 5 11:23:35 oxdomain postfix/smtpd[15324]: 7349357A60: client=unknown[192.168.2.120]
May 5 11:23:35 oxdomain postfix/cleanup[15326]: 7349357A60: message-id=<427A48BD.4060804@oxdomain.tld>
May 5 11:23:35 oxdomain postfix/qmgr[15226]: 7349357A60: from=<rickv@oxdomain.tld>, size=534, nrcpt=1 (queue active)
May 5 11:23:35 oxdomain postfix/local[15327]: warning: dict_ldap_connect: Unable to bind to server ldap://oxdomain.tld:389 as : 81 (Can't contact LDAP server)
May 5 11:23:35 oxdomain postfix/smtpd[15324]: disconnect from unknown[192.168.2.120]
May 5 11:23:35 oxdomain postfix/local[15327]: 7349357A60: to=<rickv@hobi.com>, relay=local, delay=0, status=deferred (alias database unavailable)

I have been searching for the problem for about a day or so. Perhaps if I new the problem, I could find a solution...or the solution.
So, perhaps this is some trivial thing, but having absolutely no experience, I don't know where to turn...
Any direction would be greatly appreciated.

TIA
-Rick
Back to top
View user's profile Send private message
Grokinator
n00b
n00b


Joined: 28 Apr 2005
Posts: 11

PostPosted: Thu May 05, 2005 5:43 pm    Post subject: Rick's Postfix Probs Reply with quote

Rick,

Sounds like the problem is in your LDAP configuration. Either the LDAP server itself or the configuration of Postfix to communicate with it.

You can verify openLDAP is listening by using nmap (emerge nmap) and scanning your local host. "nmap localhost" will do it. Then it will tell you all the ports your local machine has open. 389 should be there. If you see a 636, but no 389 then your server is configured for secure LDAP, but not normal LDAP.

Post your postfix main.cf file if you want, and possibly your /etc/openldap/ldap.conf.

Do a "grep -v "#" /etc/postfix/main.cf" to output your main.cf file w/o all the commented stuff.

Regards,

Greg
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu May 05, 2005 5:43 pm    Post subject: Reply with quote

rickvernam wrote:
Okay, bare with me as I have never setup a mail server in my life.
I have been following the How-To religiously, but cannot get past the first functionality check: using postfix to send an email.
here is the log after I try to send an email:
Quote:

May 5 11:23:35 oxdomain postfix/smtpd[15324]: connect from unknown[192.168.2.120]
May 5 11:23:35 oxdomain postfix/smtpd[15324]: 7349357A60: client=unknown[192.168.2.120]
May 5 11:23:35 oxdomain postfix/cleanup[15326]: 7349357A60: message-id=<427A48BD.4060804@oxdomain.tld>
May 5 11:23:35 oxdomain postfix/qmgr[15226]: 7349357A60: from=<rickv@oxdomain.tld>, size=534, nrcpt=1 (queue active)
May 5 11:23:35 oxdomain postfix/local[15327]: warning: dict_ldap_connect: Unable to bind to server ldap://oxdomain.tld:389 as : 81 (Can't contact LDAP server)
May 5 11:23:35 oxdomain postfix/smtpd[15324]: disconnect from unknown[192.168.2.120]
May 5 11:23:35 oxdomain postfix/local[15327]: 7349357A60: to=<rickv@hobi.com>, relay=local, delay=0, status=deferred (alias database unavailable)

I have been searching for the problem for about a day or so. Perhaps if I new the problem, I could find a solution...or the solution.
So, perhaps this is some trivial thing, but having absolutely no experience, I don't know where to turn...
Any direction would be greatly appreciated.

TIA
-Rick


It could be that postfix is using dns to find out what the ip address is for oxdomain.tld and not consulting your /etc/hosts file. Try setting entries in your hosts file, or use localhost instead of ox-domain.tld for your postfix/ldap configuration.
Back to top
View user's profile Send private message
Grokinator
n00b
n00b


Joined: 28 Apr 2005
Posts: 11

PostPosted: Thu May 05, 2005 5:47 pm    Post subject: Re: bitwh0re Reply with quote

Excellent point! The hosts file could be the prob, too.

Bit, do you know what's significant about the 0.8.0-1 release? I have been having problems with windows webdav clients not being able to save to a webdav folder. It's really weird. I can copy things there, but not save directly.

Greg
Back to top
View user's profile Send private message
ptparif
n00b
n00b


Joined: 05 May 2005
Posts: 3

PostPosted: Thu May 05, 2005 5:53 pm    Post subject: slapadd segmentation fault Reply with quote

i've been trying to get OX running here, and have been following through the how-to.

I'm up to the point where I do slapadd -l /usr/local/openxchange/share/init_ldap.ldif and I get a segmentation fault.

Interestingly, when I do a slapcat, I also get a segmentation fault.

Any ideas on what I can do to get this working?

thanks
Back to top
View user's profile Send private message
Grokinator
n00b
n00b


Joined: 28 Apr 2005
Posts: 11

PostPosted: Thu May 05, 2005 5:55 pm    Post subject: Reply with quote

Are you running a hardened kernel?

Greg
Back to top
View user's profile Send private message
ptparif
n00b
n00b


Joined: 05 May 2005
Posts: 3

PostPosted: Thu May 05, 2005 5:58 pm    Post subject: nope, no hardened kernel Reply with quote

Grokinator wrote:
Are you running a hardened kernel?

Greg


Nope, at least I don't think so - I ran through a fresh install really quickly and used genkernel with gentoo-sources. From what I remember, that's not a hardened kernel.
Back to top
View user's profile Send private message
Grokinator
n00b
n00b


Joined: 28 Apr 2005
Posts: 11

PostPosted: Thu May 05, 2005 6:01 pm    Post subject: Reply with quote

No, I don't think that has any PAX features in it. Is there anything interesting in your logs when things segfault?

I might try rebuilding openLDAP, but it's up to you.

Greg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 26, 27, 28 ... 37, 38, 39  Next
Page 27 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum