Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 3:15 pm    Post subject: Reply with quote

I did that this morning... no luck Still all I see is the portal icon no cal no forums no tasks....
And webmail still seems to be an issue..

I am re-reading you how to and will post anything that I had issues with...

To Start

Section 3:
Code:
cp /root/.cpan/build/perl-ldap-0.3202/lib/Net/LDAP.pm /usr/lib/perl5/site_perl


I did not have that directory in roots home.. I had a .cpan dir but it did not go that far.

So I used find / -name LDAP.pm and found one in
Code:
/usr/lib/perl5/vendor_perl/5.8.4/Net/LDAP.pm
/usr/lib/perl5/vendor_perl/5.8.4/Bundle/Net/LDAP.pm


I used one of those.. do you think this will be an issue ?

**edit if you help me get this going today I will mail you a check ;)
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 3:20 pm    Post subject: Reply with quote

Also... Section 3 postgress..

That big huge postgres insert with all the 'y','y','y','y', I was not sure if I put the correct number of 'y' in so I ran it again.. Not sure If that caused something to bork up.. I am not to hot with postgres either..
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Nov 03, 2004 3:37 pm    Post subject: Reply with quote

init-zero wrote:
Also... Section 3 postgress..

That big huge postgres insert with all the 'y','y','y','y', I was not sure if I put the correct number of 'y' in so I ran it again.. Not sure If that caused something to bork up.. I am not to hot with postgres either..


Get the latest HOWTO, I've done some updates, and try using Portage to emerge your PERL CPAN modules. You can copy the Postgre INSERT statement from the OX INSTALL file or from their website.
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 4:01 pm    Post subject: Reply with quote

I am using v0.13... Is that the newest ? That is the only one I see on the site
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 4:42 pm    Post subject: Reply with quote

Ok it stems out to the 'usr_general_rights' table ..

I did in fact have the system_general_right table incorrect. So creating a new user with adduser_ox works..

I do a query with
Code:
elect * from usr_general_rights where login like '[a_valid_user]';


and get several 'y' like we want...

But still get the same issues.
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 4:55 pm    Post subject: Reply with quote

God damn it... Users can not have upper case letters.. 8O

Created a new user 'testme' All data base perms were correct and I am up and running..

Yeeeefsckinhawwww :D
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 5:04 pm    Post subject: Reply with quote

Ok I am now junning into errors with pg73jdbc3.jar..
Code:
java.sql.SQLException: ERROR:  SET AUTOCOMMIT TO OFF is no longer supported

        at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java:131)
        at org.postgresql.jdbc1.AbstractJdbc1Connection.ExecSQL(AbstractJdbc1Connection.java:482)
        at org.postgresql.jdbc1.AbstractJdbc1Connection.ExecSQL(AbstractJdbc1Connection.java:461)
        at org.postgresql.jdbc1.AbstractJdbc1Connection.setAutoCommit(AbstractJdbc1Connection.java:957)
        at com.openexchange.tools.RightsHandle.insertMembers(RightsHandle.java:357)


I am using the dev-java/jdbc3-postgresql ebuild.. Maybe I will try 2 and see what happens.

I will continue to post here in hopes my trail and error is helping anyone.
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Nov 03, 2004 5:07 pm    Post subject: Reply with quote

Code:

ox sbin # ./adduser_ox --username="MikeDonaldson" --passwd="xxxxxx" --name="Mike" --sname="Donaldson" --maildomain="hozer.ca" --lang="EN" --mail_enabled=OK --inetmail=TRUE --ox_timezone=EST

LDAP Success
SQL Success


I just tried adding a user with caps and it seems to work (see above). What's the error that you get when trying to add a user with caps?
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 5:13 pm    Post subject: Reply with quote

That part works but when I log in I see no icons except for 'portal'

Question..

What postgresql version are you using and what jdbc connector ?

edit ** and will I have to re-configure the source to build with a different jdbc driver if I change

Quote:
--with-jdbcjar=/usr/share/my/new/jdbc.jar

_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 5:28 pm    Post subject: Reply with quote

ok fixed that ..

I went to http://jdbc.postgresql.org/download.html#jars and downloaded pg74.215.jdbc3.jar than moved it to /usr/share/jdbc3-postgresql-1/lib than I renamed it to match the original one in that directory.

Im sure this is not the best thing to do but it works.
_________________
write quit bang
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 5:53 pm    Post subject: Reply with quote

New issue :P

This is an ldap error.

When I create an appoinment and send out e-mails when a pop-up window appears asking me to 'accept' of 'decline' It fails with "Your options couldn't be saved."

My log output..
Code:
ERROR: uid=myuser: SloxWorker/storeConfirmation: Unable to store confirmation status to groupware DB: javax.naming.AuthenticationException: [LDAP: error code 49 - Invalid Credentials]

_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Nov 03, 2004 6:02 pm    Post subject: Reply with quote

init-zero wrote:
ok fixed that ..

I went to http://jdbc.postgresql.org/download.html#jars and downloaded pg74.215.jdbc3.jar than moved it to /usr/share/jdbc3-postgresql-1/lib than I renamed it to match the original one in that directory.

Im sure this is not the best thing to do but it works.


You can just emerge jdbc3-postgresql http://packages.gentoo.org/ebuilds/?jdbc3-postgresql-7.4.5. I would imagine that you'd have to recompile OX with the new JDBC driver. I'll file a bug at OX's website about the capitals in usernames. I just logged in with that user above and saw what you're experiencing.

As for your LDAP issue, make sure you've set the LDAP rootdn and credentials properly in the /usr/local/open-xchange/etc files.
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 6:52 pm    Post subject: Reply with quote

bitwh0re wrote:

As for your LDAP issue, make sure you've set the LDAP rootdn and credentials properly in the /usr/local/open-xchange/etc files.


hrmm I seem to have no rootdn options in any of my etc files except for admintools.conf.

Code:
BINDDN="cn=Manager,dc=ox-mydomain,dc=net"


Should there be any ldap options in server.conf all I have is sql connect stuff....

Wondering if it has something to do with /usr/local/open-xchange/share/init_ldap.ldif

**edit

When trying to add a contact to the Address Book I also get an error. But the address gets added.

Code:
 WARN: CATEGORY: Unable to load user's private categories /usr/local/open-xchange/var/settings/intranet/myuser.cat not found or not readable.
javax.naming.NoPermissionException: [LDAP: error code 50 - no write access to parent]; remaining name 'uid=23,o=AddressBook,ou=OxObjects'
        at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.java:2925)
        at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2863)
        at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2669)
        at com.sun.jndi.ldap.LdapCtx.c_createSubcontext(LdapCtx.java:753)
        at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_createSubcontext(ComponentDirContext.java:319)

_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Nov 03, 2004 7:11 pm    Post subject: Reply with quote

Under /usr/local/open-xchange/groupware and /webmail you should have linked (ln -s) /etc/openldap/ldap.conf. That file should contain your rootdn and ldap admin credentials.

Code:

ox webmail # pwd && ls -al ldap.conf
/usr/local/open-xchange/etc/webmail
lrwxrwxrwx  1 root root 23 Oct 20 08:14 ldap.conf -> /etc/openldap/ldap.conf

ox groupware # pwd && ls -al ldap.conf
/usr/local/open-xchange/etc/groupware
lrwxrwxrwx  1 root root 23 Oct 20 08:14 ldap.conf -> /etc/openldap/ldap.conf
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 7:35 pm    Post subject: Reply with quote

Im sorry, I do have those I did not explain clear enough I guess. My bad.

I am wondering about this mailadmin user.?? The doc does not say anything about that user come to think of it I do not think I created a passwd for him.

When I look at /usr/local/open-xchange/share/init_ldap.ldif

I have this and it cant be correct :p

Code:
uid: mailadmin
userPassword: {CRYPT}newmailadminpass


I did do the crypt setup for something.. Do I use that same password in this area also.. I am getting more confused as I go :D

BTW Thank you so very much for the help... Check is in the mail :P
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Nov 03, 2004 7:45 pm    Post subject: Reply with quote

Yes. It's covered on pages 12 and 13.
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 8:30 pm    Post subject: Reply with quote

Code:
cat 'your-guide' | grep -i mailadmin
:wink:

Hmm I see the crypt section no mailadmin stuff, but anyways I added the crypt password to both places in
Code:
/usr/local/open-xchange/share/init_ldap.ldif


I think my problem is in that file somewhere...

Still stuck with the create contact error and the accept / decline appointment error.

Looking into this further, mailadmin is a different user to run OX on or what ? We are using ldaps default rootdn which is 'Manager' with you guide.. I see entries all over the place for mailadmin in other docs. My admin tool is using BINDDN="cn=Manager....... not mailman.

hrmmmm its been a long day i may give up and look at it with fresh eyes tomorrow.
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Wed Nov 03, 2004 8:55 pm    Post subject: Reply with quote

The mailadmin/crypt section in my HOWTO is listed on Page 13.

Code:
Change the userPassword directive to show:

   userPassword:  {CRYPT}<output from perl command above>

   Browse this file and replace/change any entries that need to be to suit your configuration.



Manager is the 'root' user for your LDAP installation. S/He's the one that does maintenance on the LDAP tree such as creating, deleting, modifying entries. 'mailadmin' is something created by OX which exists in your LDAP tree. I'm not clear as to what the purpose of the 'mailadmin' user is for. You may want to ask on the General mailing list for OX. You may also want to ask them about the specific issues you are having with LDAP and your Address Book. You can find more information about that on their website:

http://mirror.open-xchange.org/ox/EN/community/
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Wed Nov 03, 2004 9:20 pm    Post subject: Reply with quote

One more question before my day is over..

How can I undo the slapadd -l /usr/loca/open-xchange/share/init_ldap.ldif command so I can re run it ?
_________________
write quit bang
Back to top
View user's profile Send private message
cron0
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2004
Posts: 132
Location: Montreal, Quebec

PostPosted: Wed Nov 03, 2004 10:04 pm    Post subject: Problems when adding users with adduser_ox Reply with quote

I can't add users.. Where is what I do and the error:
Code:
/usr/local/open-xchange/sbin/adduser_ox --username="my.email" --passwd="password" --name="firstname" --sname="secondname" --maildomain="mydom.com" --ox_timezone="EST"
ldap_bind: Inappropriate authentication (48)

Then when I try to search the tree:
Code:
ldapsearch -b "cn=Manager,dc=mydom,dc=com"
SASL/DIGEST-MD5 authentication started
Please enter your password:
ldap_sasl_interactive_bind_s: Internal (implementation specific) error (80)
        additional info: SASL(-13): user not found: no secret in database


Each of my files /etc/openldap/slapd.conf and /usr/local/open-xchange/etc/admintools.conf contain the SAME password chain which start with {MD5} because I've used slappasswd -h {MD5} to generate the password as recommended in slapd.conf

The password I used when initializing the database with init_ldap.ldif is different from the one used above... Should it have been the same? If so, what would be the ldap command to modify it in my tree?

Or else, what could be the probleme here?

By the way, thanks for the great How-To! EVERY useful and easy to follow!
JF
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Nov 04, 2004 10:06 am    Post subject: Reply with quote

init-zero wrote:
One more question before my day is over..

How can I undo the slapadd -l /usr/loca/open-xchange/share/init_ldap.ldif command so I can re run it ?


You can use GQ to administer your LDAP tree. The connection details are at the very end of the document. GQ is a GNOME based LDAP directory administrator.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Nov 04, 2004 10:16 am    Post subject: Re: Problems when adding users with adduser_ox Reply with quote

JF_Cron0 wrote:
I can't add users.. Where is what I do and the error:
Code:
/usr/local/open-xchange/sbin/adduser_ox --username="my.email" --passwd="password" --name="firstname" --sname="secondname" --maildomain="mydom.com" --ox_timezone="EST"
ldap_bind: Inappropriate authentication (48)

Then when I try to search the tree:
Code:
ldapsearch -b "cn=Manager,dc=mydom,dc=com"
SASL/DIGEST-MD5 authentication started
Please enter your password:
ldap_sasl_interactive_bind_s: Internal (implementation specific) error (80)
        additional info: SASL(-13): user not found: no secret in database


Each of my files /etc/openldap/slapd.conf and /usr/local/open-xchange/etc/admintools.conf contain the SAME password chain which start with {MD5} because I've used slappasswd -h {MD5} to generate the password as recommended in slapd.conf

The password I used when initializing the database with init_ldap.ldif is different from the one used above... Should it have been the same? If so, what would be the ldap command to modify it in my tree?

Or else, what could be the probleme here?

By the way, thanks for the great How-To! EVERY useful and easy to follow!
JF


What are you typing on the command line when asked for your password? The input key or the encrypted key?

http://www.openldap.org/lists/openldap-software/200201/msg00616.html

You may want to try reverting, temporarily, to a plaintext password for your LDAP config to get the base of OX running and then try adding security. You may also want to check the man page for slapd.conf:

http://www.hmug.org/man/5/slapd.conf.html
Back to top
View user's profile Send private message
cron0
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2004
Posts: 132
Location: Montreal, Quebec

PostPosted: Thu Nov 04, 2004 12:05 pm    Post subject: Re: Problems when adding users with adduser_ox Reply with quote

bitwh0re wrote:

What are you typing on the command line when asked for your password? The input key or the encrypted key?

http://www.openldap.org/lists/openldap-software/200201/msg00616.html

You may want to try reverting, temporarily, to a plaintext password for your LDAP config to get the base of OX running and then try adding security. You may also want to check the man page for slapd.conf:

http://www.hmug.org/man/5/slapd.conf.html


I tried deleting my database /var/lib/openldap-data/ and starting again with simple cleartext passwords. No luck. I still get that error:
Code:
ldap_sasl_interactive_bind_s: Internal (implementation specific) error (80)
        additional info: SASL(-13): [b]user not found: no secret in database[/b]


User not found? No secret in database?
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Thu Nov 04, 2004 2:50 pm    Post subject: Reply with quote

You may want to sign up for the mailing list (users) My question got answered pretty quick.

To me It almost sounds like you default slapd passwd is not set in the slapd.conf.. I also am a ldap n00b. (rootpw)

bitwh0re Do you get an error with accept or deny a meeting request through the web-mail interface. A mailing list user said it was a known bug .. Just wondering if you see it.

My other issues stems out to be from ldap ACL's .. In the how-to It does not look like any ACL's are set in the slapd.conf.. I must dig into this more today and see were I get.
_________________
write quit bang
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Thu Nov 04, 2004 4:22 pm    Post subject: Reply with quote

Yes it sounds like:

Code:
suffix          "dc=hozer,dc=ca"
rootdn          "cn=Manager,dc=hozer,dc=ca"
rootpw          secret


isn't set. If you don't have those entries in your slapd.conf I can't see how OpenLDAP would work. Don't forget you have to restart OpenLDAP after changing it's .conf files (/etc/init.d/slapd restart).

I was not able to accept or deny an appointment request through the webmail interface. I did not see any options allowing me to do that. The only place that I did see that was when I opened the appointment there were Accept and Deny radio buttons which seemed to work. I did this on the online demo for OX on open-xchange.org.

I do not have ACL's for LDAP in the HOWTO (yet). The first few releases of the HOWTO were to make sure that it was the bare minimum you needed to do to get OX up and running. I'm now working, when I have the time, on extending OX. After that I will work on security and maintenance/administrative sections.

If you would like to give me a start with LDAP ACL's that would be great.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 37, 38, 39  Next
Page 4 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum