Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 31, 32, 33 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
bhalter
n00b
n00b


Joined: 26 May 2004
Posts: 18

PostPosted: Sun Jul 31, 2005 5:31 am    Post subject: openxchange and imaps Reply with quote

Has anyone gotten OX working with an IMAPS server? I'd like to only use IMAPS and turn off IMAP. I can't get OX to work with --enable-ssl in the comfigure because sessiond fails to start on an error about oxssl missing.

--Bryan
Back to top
View user's profile Send private message
heinzg
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2004
Posts: 96
Location: In the EU

PostPosted: Mon Aug 08, 2005 5:30 pm    Post subject: Reply with quote

Hi there

I am stuck with the following and I hope that someone can help with it.

After configuring Cyrus and SASL http://www.mikefetherston.ca/OX/html/index.html#24
I tested the configuration with
Quote:
telnet myhost imap

and recieved the following
Quote:
telnet myhost imap
Trying 192.168.0.xx...
telnet: Unable to connect to remote host: Connection refused


I then recycled the cyrus with
Code:
/etc/init.d/cyrus restart

and got the following error
Quote:
* Stopping cyrus imapd ...
start-stop-daemon: warning: failed to kill 7240: No such process [ !! ]


I then checked the with 'ps' if it was running but it was not, but found the following in the logs

Quote:
ctl_cyrusdb[7262]: recovering cyrus databases
Aug 8 18:25:57 myhost ctl_cyrusdb[7262]: skiplist: recovered /var/imap/mailboxes.db (0 records, 144 bytes) in 0 seconds
Aug 8 18:25:57 myhost ctl_cyrusdb[7262]: skiplist: recovered /var/imap/annotations.db (0 records, 144 bytes) in 0 seconds
Aug 8 18:25:57 myhost ctl_cyrusdb[7262]: done recovering cyrus databases
Aug 8 18:25:57 myhost master[7240]: multiple entries for service 'imaps'
Aug 8 18:25:57 myhost master[7240]: exiting


I checked /etc/services for "imaps" and this is all that is in there
Quote:

imaps 993/tcp # imap4 protocol over TLS/SSL
imaps 993/udp


Any ideas?

Thanx in advance
heinzg
Back to top
View user's profile Send private message
heinzg
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2004
Posts: 96
Location: In the EU

PostPosted: Tue Aug 09, 2005 10:18 am    Post subject: Reply with quote

hi there,

I found the problem in /etc/cyrus.conf

I had the line
Quote:
imaps cmd="imapd -s" listen="imaps" prefork=0
twice.

Fixed and working
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Aug 09, 2005 1:47 pm    Post subject: Re: openxchange and imaps Reply with quote

bhalter wrote:
Has anyone gotten OX working with an IMAPS server? I'd like to only use IMAPS and turn off IMAP. I can't get OX to work with --enable-ssl in the comfigure because sessiond fails to start on an error about oxssl missing.

--Bryan


--enable-ssl is only for interprocess communication within the OX daemons (webmail, sessiond, groupware).

IMAPS may not be possible judging by this email from sept 2004:

http://article.gmane.org/gmane.comp.cms.open-xchange.general/234

might be worth asking the OX devs again.
Back to top
View user's profile Send private message
trashcity
Guru
Guru


Joined: 18 Sep 2003
Posts: 343
Location: österreich

PostPosted: Wed Aug 10, 2005 8:51 am    Post subject: Reply with quote

hello

me english is not so good

i have a problem with initializ the postgres db

Code:
postgres@mail ~ $ /usr/local/open-xchange/sbin/dbinit_ox
/usr/local/open-xchange/sbin/dbinit_ox: line 15: /usr/local/open-xchange/etc/admintools.conf: Permission denied
/usr/local/open-xchange/sbin/dbinit_ox: line 27: -h: command not found
postgres@mail ~ $


so wath kan i du?
Back to top
View user's profile Send private message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 202
Location: Germany

PostPosted: Fri Aug 12, 2005 7:47 am    Post subject: Reply with quote

Hello....

Did anyone get webdav completely workling yet?
I can get the webdav.ical with kontact but the descriptiones are not there. I can't write on the webdav.ical too.
As I understood until now, the rights are set in the /opt/tomcat5/webapps/servlet/WEB-INF/web.xml.
I use the file from http://www.mikefetherston.ca/OX/html/.
What do I have to do to change the rights?
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Mon Aug 15, 2005 6:21 pm    Post subject: Reply with quote

trashcity wrote:
hello

me english is not so good

i have a problem with initializ the postgres db

Code:
postgres@mail ~ $ /usr/local/open-xchange/sbin/dbinit_ox
/usr/local/open-xchange/sbin/dbinit_ox: line 15: /usr/local/open-xchange/etc/admintools.conf: Permission denied
/usr/local/open-xchange/sbin/dbinit_ox: line 27: -h: command not found
postgres@mail ~ $


so wath kan i du?


run that command as root.
Back to top
View user's profile Send private message
heinzg
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2004
Posts: 96
Location: In the EU

PostPosted: Wed Aug 17, 2005 8:09 pm    Post subject: Reply with quote

Hi there!

Ok i am still stuck with the section http://www.mikefetherston.ca/OX/html/index.html#36

I run the following
Code:
/usr/local/open-xchange/sbin/adduser_ox --username="heinzg" --passwd="heinzg" --name="heinz" --sname="user" --maildomain="mydomain.de" --ox_timezone="Europe/Berlin"


and get the following return on the prompt
Quote:
Undefined ERROR - LDAP CODE implementation specific
See LDAP Log for Details!


I did see a post earler where "lxnay" had the same / or rather similar error. https://forums.gentoo.org/viewtopic-t-233291-postdays-0-postorder-asc-start-400.html

I then back tracked to and also did as "lxnay"
Quote:
I had to put a clear password in admintools.conf


What i did was I changed all entries of "ldapsecretpassword" that are mentioned in the howto i.e.

Quote:

Code:

/etc/saslauthd.conf
 ldap_bind_pw: ldapsecretpassword

Code:

Configure slapd.conf for your site:
 slappasswd -h {CRYPT} -s ldapsecretpassword

Code:

/etc/openldap/slapd.conf
 rootpw {CRYPT}<encrypted output from command above>

Code:

Ensure admintools.conf is proper:
/usr/local/open-xchange/etc/admintools.conf
 BINDPW="ldapsecretpassword"



in the logs the following is to be found ( i did a reboot ) and re-run the adduser_ox command.
Quote:

Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 fd=9 ACCEPT from IP=192.168.0.10:41287 (IP=0.0.0.0:389)
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" method=128
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" mech=SIMPLE ssf=0
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 op=0 RESULT tag=97 err=0 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 op=1 SRCH base="ou=Users,ou=OxObjects,dc=mydomain.de,dc=de" scope=2 filter="(uid=*)"
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 op=1 SRCH attr=uidNumber
Aug 17 21:31:16 gentoo_host slapd[7737]: bdb_db_cache: db_open(objectClass) failed: Permission denied (13)
Aug 17 21:31:16 gentoo_host slapd[7737]: <= bdb_equality_candidates: (objectClass) index_param failed (13)
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 op=1 SEARCH RESULT tag=101 err=0 nentries=1 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 op=2 UNBIND
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=28 fd=9 closed
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 fd=9 ACCEPT from IP=192.168.0.10:41288 (IP=0.0.0.0:389)
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" method=128
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" mech=SIMPLE ssf=0
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 op=0 RESULT tag=97 err=0 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 op=1 ADD dn="uid=heinz,ou=Users,ou=OxObjects,dc=mydomain.de,dc=de"
Aug 17 21:31:16 gentoo_host slapd[7737]: bdb_db_cache: db_open(objectClass) failed: Permission denied (13)
Aug 17 21:31:16 gentoo_host slapd[7737]: bdb_index_read: Could not open DB objectClass
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 op=1 RESULT tag=105 err=80 text=index generation failed
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 op=1 RESULT tag=105 err=80 text=index generation failed
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 op=2 UNBIND
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=29 fd=9 closed
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 fd=9 ACCEPT from IP=192.168.0.10:41289 (IP=0.0.0.0:389)
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" method=128
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" mech=SIMPLE ssf=0
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 op=0 RESULT tag=97 err=0 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 op=1 ADD dn="ou=addr,uid=heinz,ou=Users,ou=OxObjects,dc=mydomain.de,dc=de"
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 op=1 RESULT tag=105 err=32 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 op=1 RESULT tag=105 err=32 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 fd=12 ACCEPT from IP=192.168.0.10:41290 (IP=0.0.0.0:389)
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 op=2 UNBIND
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=30 fd=9 closed
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" method=128
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" mech=SIMPLE ssf=0
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 op=0 RESULT tag=97 err=0 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 op=1 MOD dn="cn=AddressAdmins,o=AddressBook,ou=OxObjects,dc=mydomain.de,dc=de"
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 op=1 MOD attr=member
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 op=1 RESULT tag=103 err=0 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 op=1 RESULT tag=103 err=0 text=
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 op=2 UNBIND
Aug 17 21:31:16 gentoo_host slapd[7737]: conn=31 fd=12 closed


I then tried to delete the user with
Code:
usr/local/open-xchange/sbin/deluser_ox --username="heinz"
No such User


in the logs at the same time
Quote:

Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 fd=9 ACCEPT from IP=192.168.0.10:60715 (IP=0.0.0.0:389)
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" method=128
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" mech=SIMPLE ssf=0
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=0 RESULT tag=97 err=0 text=
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=1 SRCH base="uid=heinz,ou=Users,ou=OxObjects,dc=mydomain.de,dc=de" scope=1 filter="(objectClass=*)"
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=1 SRCH attr=1.1
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=1 RESULT tag=101 err=32 text=
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=2 DEL dn="uid=heinz,ou=Users,ou=OxObjects,dc=mydomain.de,dc=de"
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=2 RESULT tag=107 err=32 text=
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=2 RESULT tag=107 err=32 text=
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 op=3 UNBIND
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=34 fd=9 closed
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 fd=9 ACCEPT from IP=192.168.0.10:60716 (IP=0.0.0.0:389)
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" method=128
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 op=0 BIND dn="cn=Manager,dc=mydomain.de,dc=de" mech=SIMPLE ssf=0
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 op=0 RESULT tag=97 err=0 text=
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 op=1 MOD dn="cn=AddressAdmins,o=AddressBook,ou=OxObjects,dc=mydomain.de,dc=de "
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 op=1 MOD attr=member
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 op=1 RESULT tag=103 err=16 text=modify/delete: member: no such value
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 op=1 RESULT tag=103 err=16 text=modify/delete: member: no such value
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 op=2 UNBIND
Aug 17 21:34:43 gentoo_host slapd[7737]: conn=35 fd=9 closed


What I did see during the reboot is that the "saslauthd" printed lots of text to the console i.e.
Quote:

option information:
-a <authmech> Selects the authentication mechanism to use.
-c Enable credential caching.
-d Debugging (don't detach from tty, implies -V)
-r Combine the realm with the login before passing to authentication mechanism
Ex. login: "foo" realm: "bar" will get passed as login: "foo@bar"
The realm name is passed untouched.
-O <option> Optional argument to pass to the authentication
mechanism.
-l Disable accept() locking. Increases performance, but
may not be compatible with some operating systems.
-m <path> Alternate path for the saslauthd working directory,
must be absolute.
-n <procs> Number of worker processes to create.
-s <kilobytes> Size of the credential cache (in kilobytes)
-t <seconds> Timeout for items in the credential cache (in seconds)
-v Display version information and available mechs
-V Enable verbose logging
-h Display this message.

saslauthd 2.1.20
authentication mechanisms: getpwent rimap shadow ldap


And it don't seem to be running at all, as i can't find it with
Code:
ps -ef | grep saslauthd


I did the
Code:
saslauthd -v
saslauthd 2.1.20
authentication mechanisms: getpwent rimap shadow ldap


all the steps in the howto worked fine up in till the adduser_ox command.

can someone help with this ??

I will buy the person a real Bavarian beer (or 2 ) who helps me solve this one !! ( i will also post it any where it needs to go)

Cheers
Heinzg
Back to top
View user's profile Send private message
elKano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Feb 2005
Posts: 81
Location: Bilbao, Spain, UE

PostPosted: Thu Aug 18, 2005 11:09 am    Post subject: Reply with quote

Hello.
I have spent some too long time trying to install Open-Xchange on our server. Thanks to this excellent howto, I am almost there.
I just have a couple of problems, which, I think, are related:
Webmail gives only this message:
Code:
WebMail - OPEN-XCHANGE 0.8.0-5
!!! SYSTEM - ERROR !!!


And the following log shows up in the webmail.log:
Quote:

AuthentificationFailedException in FolderSettings/loadFolder
Unable to authentificate user at the imap server.
Please check username and/or password.
Details: javax.mail.AuthentificationFailedException: Login Failed: authentification failure


I know this error has been reported before, but I can not seem to find a working solution...

The other error shows up when trying to save a modified user setup:
Code:

 ERROR!Could not store input to the directory!Details:
javax.naming.NoPermissionException: [LDAP: error code 50 - Insufficient Access Rights]; remaining name 'uid=test,ou=Users,ou=OxObjects,dc=juno,dc=w95'


I think both problems are related to some identification misconfiguration, but I can not find where.

Any help would be much appreciate...
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Sat Aug 20, 2005 2:21 pm    Post subject: Re: openxchange and imaps Reply with quote

bhalter wrote:
Has anyone gotten OX working with an IMAPS server? I'd like to only use IMAPS and turn off IMAP. I can't get OX to work with --enable-ssl in the comfigure because sessiond fails to start on an error about oxssl missing.

--Bryan


the "--enable-ssl"-flag turns on encryptet communication between OX-components.
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Sat Aug 20, 2005 2:22 pm    Post subject: Reply with quote

A new ebuild to bugs.gentoo.org: https://bugs.gentoo.org/show_bug.cgi?id=62197 was added for the new OX-release.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Mon Aug 22, 2005 7:30 pm    Post subject: Reply with quote

heinzg wrote:

What I did see during the reboot is that the "saslauthd" printed lots of text to the console i.e.
Quote:

option information:
-a <authmech> Selects the authentication mechanism to use.
-c Enable credential caching.
-d Debugging (don't detach from tty, implies -V)
-r Combine the realm with the login before passing to authentication mechanism
Ex. login: "foo" realm: "bar" will get passed as login: "foo@bar"
The realm name is passed untouched.
-O <option> Optional argument to pass to the authentication
mechanism.
-l Disable accept() locking. Increases performance, but
may not be compatible with some operating systems.
-m <path> Alternate path for the saslauthd working directory,
must be absolute.
-n <procs> Number of worker processes to create.
-s <kilobytes> Size of the credential cache (in kilobytes)
-t <seconds> Timeout for items in the credential cache (in seconds)
-v Display version information and available mechs
-V Enable verbose logging
-h Display this message.

saslauthd 2.1.20
authentication mechanisms: getpwent rimap shadow ldap



It looks like all is well with your saslauthd except that you may have a typo (more than likely a missing space) in your /etc/conf.d/saslauthd. It should look like this:

Code:

#SASLAUTHD_OPTS="${SASLAUTH_MECH} -a pam"

SASLAUTH_MECH=ldap
SASLAUTHD_OPTS="-a ${SASLAUTH_MECH}"


I've got a feeling that you don't have the space after the -a.
Back to top
View user's profile Send private message
bitwh0re
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 214

PostPosted: Tue Aug 23, 2005 11:54 pm    Post subject: Virtual Domains Reply with quote

Please read here for how to use Virtual Domains with OX:

https://forums.gentoo.org/viewtopic-t-371116-highlight-.html
Back to top
View user's profile Send private message
cpunchin
n00b
n00b


Joined: 18 Feb 2004
Posts: 37

PostPosted: Mon Aug 29, 2005 9:11 pm    Post subject: Reply with quote

Quote:


Code:
WebMail - OPEN-XCHANGE 0.8.0-5
!!! SYSTEM - ERROR !!!


And the following log shows up in the webmail.log:
Quote:

AuthentificationFailedException in FolderSettings/loadFolder
Unable to authentificate user at the imap server.
Please check username and/or password.
Details: javax.mail.AuthentificationFailedException: Login Failed: authentification failure




I had this problem last night due to the power failure thanks to hurricane Katrina :x

It turned out that my ldap db got corrupted. Please make sure that these account(s) have been created into cyrus. If so, then:

1. Stop slapd. If you get errors (!!), then kill the process. that happened to me.
2. Do a db4.2_recover -v from within the /var/lib/openldap-data/ directory.
3. Restart ldap.

In my case, my log.000000001 file was corrupted. I renamed it to log.00000001.bak and ran a db4.2_recover -c

The recover -v was unable to fix it in my case.

Please let us know how you did...
:idea:
Back to top
View user's profile Send private message
elKano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Feb 2005
Posts: 81
Location: Bilbao, Spain, UE

PostPosted: Tue Aug 30, 2005 6:45 am    Post subject: Reply with quote

Actually, I just found the problem. I just feel plain stupid. In one of the config files, there was a missing 'd': ldap_bin_pw instead of ldap_bind_pw.
And my other problem, I have found on the open-xchange official forum, is a problem of permissions set by slapd.conf. I have right now them set a bit too large (all rights to everyone), but it works. I just need to limit them step by step.

My only big problem right now is sending mail. It did work when I set up Postfix, I remember, but now mail just keeps being queued (they all show up in 'mailq' and 'postqueue -f' does nothing) with the following message:
Code:
(connect to /var/imap/socket/lmtp[/var/imap/socket/lmtp]: Permission denied)

However:
Code:
wxrwxrwx  1 root root 0 Aug 29 13:58 /var/imap/socket/lmtp


If, in /etc/postfix/main.cf, I comment line 'mailbox_transport = lmtp:unix:/var/imap/socket/lmtp' and uncomment 'mailbox_transport = cyrus', mails seem to be sent, but they actually just disappear (never received).
However, this is more of a postfix problem, not Open-Xchange. I will see if I manage to correct this today.

Thanks.
Back to top
View user's profile Send private message
cpunchin
n00b
n00b


Joined: 18 Feb 2004
Posts: 37

PostPosted: Wed Aug 31, 2005 5:58 pm    Post subject: Reply with quote

Quote:

If, in /etc/postfix/main.cf, I comment line 'mailbox_transport = lmtp:unix:/var/imap/socket/lmtp' and uncomment 'mailbox_transport = cyrus', mails seem to be sent, but they actually just disappear (never received).
However, this is more of a postfix problem, not Open-Xchange. I will see if I manage to correct this today.



Seems that your ISP blocking port 25. Most residential DSL ISP's have port 25 blocked.
Back to top
View user's profile Send private message
empunkt
n00b
n00b


Joined: 07 Sep 2005
Posts: 8

PostPosted: Wed Sep 07, 2005 4:57 pm    Post subject: tomcat5 troubles Reply with quote

Hello,

i followed mike's guide. Everything worked good so far. Tanks a lot!
OX compiled, Ldap configured an runnig, Postgres, postfix, courier, apache1.
But i got stuck on tomcat.
merged, configured, copied ox .jar files. Tomcat is running. Manager ist working.
When i try to enter http://192.168.22.1:8080/servlet/intranet just nothing happens.. wating for answer... then.. nothing.
An http://192.168.22.1:8080/servlet/ results in Directory Listing For / ... what is empty
In the Tomcat Manager i see
/ Welcome to Tomcat
/admin Tomcat Administration
/balancer
/manager Tomcat Manager Application
/servlet Open-Xchange Servlets and WebDAV
/umin Open-Xchange
/webdav Webdav Content Management
Im not familar with tomcat at all. May anyone give me a hint?

kind regards,

Julian
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 6:03 pm    Post subject: Re: tomcat5 troubles Reply with quote

empunkt wrote:
Hello,

i followed mike's guide. Everything worked good so far. Tanks a lot!
OX compiled, Ldap configured an runnig, Postgres, postfix, courier, apache1.
But i got stuck on tomcat.
merged, configured, copied ox .jar files. Tomcat is running. Manager ist working.
When i try to enter http://192.168.22.1:8080/servlet/intranet just nothing happens.. wating for answer... then.. nothing.
An http://192.168.22.1:8080/servlet/ results in Directory Listing For / ... what is empty
In the Tomcat Manager i see
/ Welcome to Tomcat
/admin Tomcat Administration
/balancer
/manager Tomcat Manager Application
/servlet Open-Xchange Servlets and WebDAV
/umin Open-Xchange
/webdav Webdav Content Management
Im not familar with tomcat at all. May anyone give me a hint?

kind regards,

Julian


I am in much the same state right now :-(
get a 404 error.. blah
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Sep 07, 2005 6:46 pm    Post subject: Reply with quote

Hmm you should just copy the servlet.war (this file has also the webdav in it) and the umin.war in the tomcat5/webapps-path (make sure you've compiled it with webdav-support)

You could also try the ebuild from the bugzilla:

https://bugs.gentoo.org/show_bug.cgi?id=62197&action=View

This should help you and is easy to use. If you encounter any problems please post it here.
Back to top
View user's profile Send private message
empunkt
n00b
n00b


Joined: 07 Sep 2005
Posts: 8

PostPosted: Wed Sep 07, 2005 7:04 pm    Post subject: Reply with quote

Hi,

servlet.war and umin.war, are in the webapp directory as they should.
ox was compiled with webdav support.
I did the make myself with
./configure --enable-webdav --enable-doc --with-mailjar=/usr/share/sun-javamail-bin/lib/mail.jar --with-activationjar=/usr/share/sun-jaf-bin/lib/activation.jar --with-jdomjar=/usr/share/jdom-1.0/lib/jdom.jar --with-xercesjar=/usr/share/xerces-2/lib/xercesImpl.jar --with-jsdkjar=/opt/tomcat5/common/lib/servlet-api.jar --with-jdbcjar=/usr/share/jdbc3-postgresql/lib/jdbc3-postgresql.jar --with-dbname=openexchange --with-dbuser=open-xchange --with-dbpass=xxxx --with-runuid=tomcat --with-tomcatuser=tomcat --with-htdocsdir=/var/www/localhost/htdocs/ --with-cgibindir=/var/www/localhost/cgi-bin/ --with-jni-dir=/opt/sun-jdk-1.4.2.08/include/ --with-openssl-dir=/usr/include --with-domain=ox.asgard.myth --with-organization="eMpunkt" --with-basedn="dc=ox,dc=asgard,dc=myth" --with-rootdn="cn=Manager,dc=ox,dc=asgard,dc=myth"
I really don't have a clou why tomcat is not working correctly. there isn't much to be misconfigured concerning tomcat. is there?
I rember tomcat working at some time but than it stopped. unmerging -> deleting configs -> merging again -> compiling ox again. didn't solve the issue.

maybe i should try the ebuild.

Help appreciated,

Thanks a lot,

Julian
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 7:19 pm    Post subject: Reply with quote

Boef wrote:
Hmm you should just copy the servlet.war (this file has also the webdav in it) and the umin.war in the tomcat5/webapps-path (make sure you've compiled it with webdav-support)

You could also try the ebuild from the bugzilla:

https://bugs.gentoo.org/show_bug.cgi?id=62197&action=View

This should help you and is easy to use. If you encounter any problems please post it here.


I have tried the ebuild. And the war's are in

/usr/share/tomcat-5/server/webapps

Code:
castle webapps # ls -al
total 2647
drwxr-xr-x   4 tomcat tomcat     152 Sep  7 15:10 .
drwxr-xr-x   4 root   root        96 Sep  5 22:24 ..
drwxr-xr-x  15 tomcat tomcat     944 Sep  5 22:24 admin
drwxr-xr-x   4 tomcat tomcat     272 Sep  5 22:24 manager
-rwxr-xr-x   1 tomcat tomcat 2004255 Sep  7 15:10 servlet.war
-rwxr-xr-x   1 tomcat tomcat  698019 Sep  7 15:10 umin.war


I chown'd them to tomcat in the hopes that would work, but nope.

going to localhost:8080/servlet/intranet/
gives me an error reading:

Code:
HTTP Status 404 - /servlet/intranet/


basically I followed the web howto until the installing open-xchange part and then I used the ebuild. The ebuild workd, but tomcat can't seem to run the stuff I need.

also when I try the login @ /cgi-bin/login.pl it complains that
Code:
Can not build up Socket!

SessionD running?


but ps aux shows that it is running

Code:
castle webapps # ps aux | grep sessiond
tomcat   15057  0.0  0.1   4340  1036 pts/1    S    15:05   0:00 /bin/sh /usr/bin/openexchange-sessiond
tomcat   15062  0.1  3.1 1517128 32344 pts/1   Sl   15:05   0:01 /opt/blackdown-jdk-1.4.2.02/bin/java -ms20M -mx280M -Dopenexchange.propfile=/etc/open-xchange/groupware/system.properties -DappName=sessiondApp -Djava.library.path=/usr/lib64/open-xchange -classpath /usr/lib64/open-xchange/nas.jar:/usr/lib64/open-xchange/comfiretools.jar:/usr/lib64/open-xchange/intranet.jar:/usr/lib64/open-xchange/sessiond.jar com.openexchange.sessiond.oxsessiond -P 33333
root     31431  0.0  0.0   2608   520 pts/2    R+   15:18   0:00 grep sessiond


So I have no ideas left what I have done wrong. I really want to get this up and running as it seems like exactly what I need. Can anyone help ?

I am going to put up a $10usd reward for helping me get open-change up and running. Seriously I am tired of looking at this. Thanks gentoo users you are great
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Sep 07, 2005 7:41 pm    Post subject: Reply with quote

nife wrote:

I have tried the ebuild. And the war's are in

/usr/share/tomcat-5/server/webapps

Code:
castle webapps # ls -al
total 2647
drwxr-xr-x   4 tomcat tomcat     152 Sep  7 15:10 .
drwxr-xr-x   4 root   root        96 Sep  5 22:24 ..
drwxr-xr-x  15 tomcat tomcat     944 Sep  5 22:24 admin
drwxr-xr-x   4 tomcat tomcat     272 Sep  5 22:24 manager
-rwxr-xr-x   1 tomcat tomcat 2004255 Sep  7 15:10 servlet.war
-rwxr-xr-x   1 tomcat tomcat  698019 Sep  7 15:10 umin.war

Which version of tomcat you've got?
If you've got a the version greater than 5.0.28-r4, I will check this again.

nife wrote:

Code:
castle webapps # ps aux | grep sessiond
tomcat   15057  0.0  0.1   4340  1036 pts/1    S    15:05   0:00 /bin/sh /usr/bin/openexchange-sessiond
tomcat   15062  0.1  3.1 1517128 32344 pts/1   Sl   15:05   0:01 /opt/blackdown-jdk-1.4.2.02/bin/java -ms20M -mx280M -Dopenexchange.propfile=/etc/open-xchange/groupware/system.properties -DappName=sessiondApp -Djava.library.path=/usr/lib64/open-xchange -classpath /usr/lib64/open-xchange/nas.jar:/usr/lib64/open-xchange/comfiretools.jar:/usr/lib64/open-xchange/intranet.jar:/usr/lib64/open-xchange/sessiond.jar com.openexchange.sessiond.oxsessiond -P 33333
root     31431  0.0  0.0   2608   520 pts/2    R+   15:18   0:00 grep sessiond


So I have no ideas left what I have done wrong. I really want to get this up and running as it seems like exactly what I need. Can anyone help ?


Which useflags have you used?
Code:
emerge open-xchange -pv
.

Try
Code:
USE="webdav postgres -ssl" emerge open-xchange
if all of your ox-components are on the same computer.
Hope that helps.
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 8:06 pm    Post subject: Reply with quote

Code:
[ebuild   R   ] net-mail/open-xchange-0.8.1.2  -doc -mysql +postgres +ssl -vhosts -webdav 0 kB [1]


The new use flags just made it so that I get a 404 error when I try to login instead of complaining that it doesn't have a sessiond running. So that is progress
Looks like I am close. All I need is to get tomcat to run the stuff and then configure mod_jk


I have www-servers/tomcat-5.0.28-r4 -doc +examples +jikes

so looks like that is alright

I haven't changed any config files on my tomcat install so maybe that is something that I have messed up ?

The example files show up fine when I to to localhost:8080 so looks like tomcat is running just not running the .war's

I have tried deploying the .war's through the tomcat manage page and it fails the upload just goes to a blank white screen.
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 8:26 pm    Post subject: Reply with quote

now I'm getting error authentication failed when I try to login... blah
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Sep 07, 2005 8:26 pm    Post subject: Reply with quote

The problem is, they have changed the structure of the directories since tomcat www-servers/tomcat-5.0.28-r4. I'm currently installing that version and will report it and change the ebuild.

ok, now it finished, they changed the structure try to copy the war-files into "/var/lib/tomcat-5/default/webapps".
This should be the right location.

i'll update the ebuild.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 31, 32, 33 ... 37, 38, 39  Next
Page 32 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum